The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

[Cisco] NAT через Loopback (cisco nat loopback)


<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>
Ключевые слова: cisco, nat, loopback,  (найти похожие документы)
Date: Sat, 27 Apr 2002 10:59:37 +0400 From: Vadim Krasikov <Vadim.Krasikov@f5.n5038.z2.fidonet.org> Newsgroups: fido7.ru.cisco Subject: [Cisco] NAT через Loopback >> interface Loopback0 >> ip address 195.xxx.xxx.33 255.255.255.255 >> ip nat outside DS> Вот здесь маска /32, в route-map не пойдет set ip next-hop, нужно set DS> interface loopback0 >> route-map InSide permit 10 >> match ip address 121 >> set ip next-hop 192.168.254.49 >> ! >> route-map InSide permit 11 >> match ip address 122 >> set ip next-hop 10.9.254.1 >> ============== DS> set interface .. DS> Или попробовать поменять, как уже написали, e0/0 - loopback местами, DS> e0/0 - outside, loopback - inside Хотя должно работать в обоих DS> случаях. Уф... после двух часов экспериментов кажется удалось добиться требуемого, использовав оба совета
interface Loopback0 ip nat inside ... interface Ethernet0/0 ip nat outside ... route-map InSide permit 12 match ip address 124 set interface Loopback0 ... access-list 124 permit tcp 192.168.120.0 0.0.0.255 any eq 24554 ... ip nat inside source list 124 interface Loopback0 overload

<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>

Обсуждение [ RSS ]
  • 1, Misha (??), 13:29, 18/10/2006 [ответить]  
  • +/

    interface Loopback1
    ip address 82.208.33.1 255.255.255.255
    ip nat outside
    ip virtual-reassembly
    !
    interface Loopback0
    ip address 82.208.12.25 255.255.255.255
    crypto map *******
    !
    interface Vlan1
    ip address 192.168.29.51 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    hold-queue 32 in
    !
    interface Vlan2
    ip address 172.12.1.1 255.255.255.252
    !
    interface Vlan3
    ip address 10.109.1.233 255.255.255.252
    !
    interface Vlan4
    ip address 219.22.111.130 255.255.255.252
    !
    router ospf 1
    log-adjacency-changes
    passive-interface default
    no passive-interface Tunnel0
    no passive-interface Tunnel1
    network ****** 0.0.0.3 area 2
    network ******** 0.0.0.3 area 2
    network 172.12.1.1  0.0.0.3 area 2
    network 82.208.33.1  0.0.0.0 area 2
    network 82.208.12.25  0.0.0.0 area 2
    default-information originate
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 10.0.0.0 255.255.255.0 Loopback0
    ip route 192.168.1.0 255.255.255.0 192.168.1.13


    ip nat inside source list 124 interface Loopback1 overload
    !
    access-list 124 permit ip 192.168.29.0 0.0.0.255 any
    !
    route-map InSide permit 12
    match ip address 124
    set interface Loopback1

    таже проблема не работает нат
    подскажите де грабли ??

     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:




    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру