The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Error wiht USB printer"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Error wiht USB printer"
Сообщение от saha emailИскать по авторуВ закладки(ok) on 07-Окт-04, 15:27  (MSK)
Вопрос такой:
1) Есть usb принтер, есть Linux (kernel 2.6.7), есть cups и есть foomatic-configure.
2) При подключении принтера в /proc/bus/usb/devices появляется информация о   новом устройстве и драйвере который оно использует (Driver=usblp).
3) Команда "echo "good print" > /dev/usb/lp0" - печатает.
4) "foomatic-configure -s cups -n Brother-HL-1240 -p Brother-HL-1240 -d hl1250 -c file://dev/usb/lp0" - настраивает принтер.

ЕСЛИ ОТПРАВИТЬ НА ПЕЧАТЬ ТЕСТОВУЮ СТРАНИЦУ например "localhost:631 - test page", то видим такое:"Unable to open USB device "usb://dev/usb/lp0": No such device", то же самое и в логах.

ВОПРОС: ПОЧЕМУ?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Error wiht USB printer"
Сообщение от denn emailИскать по авторуВ закладки(??) on 07-Окт-04, 15:31  (MSK)
>4) "foomatic-configure -s cups -n Brother-HL-1240 -p Brother-HL-1240 -d hl1250 -c file://dev/usb/lp0"
>видим такое:"Unable to open USB device "usb://dev/usb/lp0": No such

file://dev/usb/lp0 <> usb://dev/usb/lp0

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Error wiht USB printer"
Сообщение от saha emailИскать по авторуВ закладки(ok) on 07-Окт-04, 17:05  (MSK)
>>4) "foomatic-configure -s cups -n Brother-HL-1240 -p Brother-HL-1240 -d hl1250 -c file://dev/usb/lp0"
>>видим такое:"Unable to open USB device "usb://dev/usb/lp0": No such
>
>file://dev/usb/lp0 <> usb://dev/usb/lp0
>
Попробывать конечно можно:
"foomatic-configure -s cups -n Brother-HL-1240 -p Brother-HL-1240 -d hl1250 -c usb://dev/usb/lp0".

Результат не изменился - "Unable to open USB device "usb://dev/usb/lp0": No such device".

Замечу, что посмотреть через "foomatic-configure -Q", то он как был "<connect>usb://dev/usb/lp0</connect>", так и остался, от сюда вывод - КОМАНДЫ РАВНОЗНАЧНЫ!!
>
Какие еще предложения?

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру