The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"как в FreeBSD собрать PHP5 с поддержкой cio8 ?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от Vetal email(??) on 28-Июл-06, 16:57 
Как собрать PHP 5 с модулем cio8?

Сведения о системе:
FreeBSD 6.1 release;
клиент oracle9 (скопирован с линукса), добавлены группа и пользователь oracle, установлены переменные окружения  ORACLE_HOME=/opt/oracle/product/9ir2/  LD_LIBRARY_PATH=/opt/oracle/product/9ir2/lib ;
поддержка linux установлена и включена в rc.conf linux_enable="YES";
строка конфигурации php 5 configure --with-cio8,/opt/oracle/product/9ir2/instantclient ...др.опции;
В итоге конфиг вылетает с надписью configure: error: Oracle Instant Client SDK header files not found ;
Пробовал указывать путь к /opt/oracle/product/9ir2/lib - не помогает.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от lavr email on 28-Июл-06, 17:36 
>Как собрать PHP 5 с модулем cio8?
>
>Сведения о системе:
>FreeBSD 6.1 release;
>клиент oracle9 (скопирован с линукса), добавлены группа и пользователь oracle, установлены переменные
>окружения  ORACLE_HOME=/opt/oracle/product/9ir2/  LD_LIBRARY_PATH=/opt/oracle/product/9ir2/lib ;
>поддержка linux установлена и включена в rc.conf linux_enable="YES";
>строка конфигурации php 5 configure --with-cio8,/opt/oracle/product/9ir2/instantclient ...др.опции;
>В итоге конфиг вылетает с надписью configure: error: Oracle Instant Client SDK
>header files not found ;
>Пробовал указывать путь к /opt/oracle/product/9ir2/lib - не помогает.

ничего личного, но судя по изложенному вы совсем не в курсах не только как надло делать,
но и даже в названиях: oci8

Все есть в портах

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от Vetal email(??) on 28-Июл-06, 17:55 
>>Как собрать PHP 5 с модулем cio8?
>>
>>Сведения о системе:
>>FreeBSD 6.1 release;
>>клиент oracle9 (скопирован с линукса), добавлены группа и пользователь oracle, установлены переменные
>>окружения  ORACLE_HOME=/opt/oracle/product/9ir2/  LD_LIBRARY_PATH=/opt/oracle/product/9ir2/lib ;
>>поддержка linux установлена и включена в rc.conf linux_enable="YES";
>>строка конфигурации php 5 configure --with-cio8,/opt/oracle/product/9ir2/instantclient ...др.опции;
>>В итоге конфиг вылетает с надписью configure: error: Oracle Instant Client SDK
>>header files not found ;
>>Пробовал указывать путь к /opt/oracle/product/9ir2/lib - не помогает.
>
>ничего личного, но судя по изложенному вы совсем не в курсах не
>только как надло делать,
>но и даже в названиях: oci8
>
>Все есть в портах

Извините - обшибся oci8. Мне нужна поддержка в ПХП5 оракла, я с ним никогда не сталкивался, и поэтому "не в курсах" что надо делать

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от lavr email on 29-Июл-06, 21:01 
>>>Как собрать PHP 5 с модулем cio8?
>>>
>>>Сведения о системе:
>>>FreeBSD 6.1 release;
>>>клиент oracle9 (скопирован с линукса), добавлены группа и пользователь oracle, установлены переменные
>>>окружения  ORACLE_HOME=/opt/oracle/product/9ir2/  LD_LIBRARY_PATH=/opt/oracle/product/9ir2/lib ;
>>>поддержка linux установлена и включена в rc.conf linux_enable="YES";
>>>строка конфигурации php 5 configure --with-cio8,/opt/oracle/product/9ir2/instantclient ...др.опции;
>>>В итоге конфиг вылетает с надписью configure: error: Oracle Instant Client SDK
>>>header files not found ;
>>>Пробовал указывать путь к /opt/oracle/product/9ir2/lib - не помогает.
>>
>>ничего личного, но судя по изложенному вы совсем не в курсах не
>>только как надло делать,
>>но и даже в названиях: oci8
>>
>>Все есть в портах
>
>Извините - обшибся oci8. Мне нужна поддержка в ПХП5 оракла, я с
>ним никогда не сталкивался, и поэтому "не в курсах" что надо
>делать

посмотреть ЧТО и КАК сделано в портах:

клиент есть для oracle8: /usr/ports/databases/oracle8-client/
и под него заточенный /usr/ports/databases/php5-oci8/

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от Vetal email(??) on 31-Июл-06, 09:43 
>>>>Как собрать PHP 5 с модулем cio8?
>>>>
>>>>Сведения о системе:
>>>>FreeBSD 6.1 release;
>>>>клиент oracle9 (скопирован с линукса), добавлены группа и пользователь oracle, установлены переменные
>>>>окружения  ORACLE_HOME=/opt/oracle/product/9ir2/  LD_LIBRARY_PATH=/opt/oracle/product/9ir2/lib ;
>>>>поддержка linux установлена и включена в rc.conf linux_enable="YES";
>>>>строка конфигурации php 5 configure --with-cio8,/opt/oracle/product/9ir2/instantclient ...др.опции;
>>>>В итоге конфиг вылетает с надписью configure: error: Oracle Instant Client SDK
>>>>header files not found ;
>>>>Пробовал указывать путь к /opt/oracle/product/9ir2/lib - не помогает.
>>>
>>>ничего личного, но судя по изложенному вы совсем не в курсах не
>>>только как надло делать,
>>>но и даже в названиях: oci8
>>>
>>>Все есть в портах
>>
>>Извините - обшибся oci8. Мне нужна поддержка в ПХП5 оракла, я с
>>ним никогда не сталкивался, и поэтому "не в курсах" что надо
>>делать
>
>посмотреть ЧТО и КАК сделано в портах:
>
>клиент есть для oracle8: /usr/ports/databases/oracle8-client/
>и под него заточенный /usr/ports/databases/php5-oci8/


В том то и дело, что его я устанавливал. Все равно, при сборке, пхп ругается на отсутствие библиотек. Пути к клиенту указывал /client/path/lib и просто /client/path и /client/path/freebsd
oci8 в php есть в ./ext/oci8 - его обновлял до версии oci8-1.2.1

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от Vetal email(??) on 01-Авг-06, 16:31 
Есть у кого работающий php с включенным оракл-клиентом? Отзовитесь!
Просьба к модераторам - исправьте тему пожалуйста: вместо cio8 на oci8
и в теле --with-cio8 на --with-oci8
писал по памяти - сорри за ошибки.


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от Vetal email(??) on 08-Авг-06, 13:30 
Сам спросил, сам отвечаю.

Я использовал скопированного из linux клиента оракла 9, поместил его в /opt и прописал переменные окружения: ORACLE_HOME и LD_LIBRARY_PATH
сборка PHP:
# ./configure --with-apxs2=/usr/local/sbin/apxs --with-mysql --with-openssl --with-oci8
без указания инсталляции oci8 как shared extension или instantclient
библиотека, которую он требует называется oci.h, на всякий случай я сделал линк к ней в директории ../ext/oci8/
Конфигурация происходит до конца без вылетов.
# make
Выдает следующее сообщение
/usr/bin/ld: cannot find -ldl
*** Error code 1

В файле config.log :

/usr/bin/ls: cannot find -ldl
configure: failed program was
#line 64431 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char OCILobIsTemporary();

Я попробовал следующее:
ldconfig -m /opt/oracle/product/9ir2/lib
ldconfig -m /opt/oracle/product/9ir2/instantclient
ldconfig -m /compat/linux/lib
ldconfig -m /compat/linux/usr/lib

Побороть эту проблему мне не удалось.
Может кто знает как?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "как в FreeBSD собрать PHP5 с поддержкой cio8 ?"  
Сообщение от Vetal email(??) on 09-Авг-06, 12:01 
Я прошу всех извинить меня за непроглядную упорную тупость. Я уперся в клиент, скопированный с Линукса и никак не мог от него отвлечься.
При таких раскладах, мне, вероятно, нужно было скомпилировать apache и php Линуксовым gmake'ом или скопировать уже с готовой системы Линукс весь готовый рабочий набор.
Все оказалось гораздо проще.
Подразумевается, что Apache и по необходимости Mysql, openssl уже установлены.
Ставиться клиент из /usr/ports/database/linux/instantclient-basic-linux32-10.2.0.2-20060331
&& /usr/ports/database/linux/instantclient-sdk-linux32-10.2.0.2-20060331
(дистфайлы нужно скачать непосредственно с сайта оракла, предварительно зарегистрировавшись)
далее ставиться /usr/ports/database/oracle8-client
после чего нужно зайти в директорию /usr/local/oracle8-client/freebsd , запустить redefine-syms.sh и сделать make && make patch
Потом устанавливаем php5 из /usr/ports/lang/php5
+ необходимые екстеншены из /usr/ports/databases. Я ставил ./php5-mysql & ./php5-oci8
Вот и все. Должно работать.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру