The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"ни как не могу справиться"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"ни как не могу справиться"  
Сообщение от Spirit1985 email(ok) on 11-Авг-07, 20:43 
Добрый вечер собственно у меня следующая проблема
установил себе red hat es5 первое что мне нужно это же конечно аська дабы поддерживать связь с внешним миром. выбор пал на sim так нужен еще джабер. так вот возникли у меня слудующие проблемы:

[root@sririt ~]# rpm -ivh sim-0.9.3-2.rh90.i386.rpm
ошибка: Неудовлетворенные зависимости:
libcrypto.so.4 нужен для sim-0.9.3-2.rh90.i386
libssl.so.4 нужен для sim-0.9.3-2.rh90.i386
libstdc++.so.5 нужен для sim-0.9.3-2.rh90.i386
libstdc++.so.5(CXXABI_1.2) нужен для sim-0.9.3-2.rh90.i386
libstdc++.so.5(GLIBCPP_3.2) нужен для sim-0.9.3-2.rh90.i386
libstdc++.so.5(GLIBCPP_3.2.2) нужен для sim-0.9.3-2.rh90.i386

далее понимаем что библиотеки эти уже есть

[root@spirit /]# find -name libstd*.*
./usr/share/apps/kdevdocumentation/tocs/libstdc++.toc
./usr/share/doc/libstdc++-devel-4.1.1
./usr/lib/libstdc++.so.6
./usr/lib/libstdc++.so.6.0.8
./usr/lib/gcc/i386-redhat-linux/4.1.1/libstdc++.so
./usr/lib/gcc/i386-redhat-linux/4.1.1/libstdc++.a
./usr/include/boost/config/stdlib/libstdcpp3.hpp

далее

[root@spirit~]# ln -s /usr/lib/libstdc++.so.6 libstdc++.so.5

запускаю снова установку и опять он мне говорит что нет библиотеки! блин
сделал запуск установи с параметрами --nodeps --force

[root@spirit sim]# sim
sim: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

libstdc++.so.5 и потом с libssl удалось побороться но сейчас не могу решить вот эту проблему

[root@spirit lib]# sim
sim: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found (required by sim)
sim: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2.2' not found (required by /usr/lib/libsimapi.so.0)
sim: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found (required by /usr/lib/libsimapi.so.0)

После отбросил сим и попытался поставить что то другое

скажите где почитать весь день головой об стену бьюсь ни чего не могу установить

[root@spirit Desktop]# rpm -ivh utm-5.1.10-014.i386.rpm
ошибка: Неудовлетворенные зависимости:
libcppunit-1.10.so.2 нужен для utm-5.1.10-014.i386
liblber.so.2 нужен для utm-5.1.10-014.i386
libldap.so.2 нужен для utm-5.1.10-014.i386
libssl.so.4 нужен для utm-5.1.10-014.i386
libstdc++.so.5 нужен для utm-5.1.10-014.i386
libstdc++.so.5(CXXABI_1.2) нужен для utm-5.1.10-014.i386
libstdc++.so.5(GLIBCPP_3.2) нужен для utm-5.1.10-014.i386
libstdc++.so.5(GLIBCPP_3.2.2) нужен для utm-5.1.10-014.i386

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "ни как не могу справиться"  
Сообщение от Romik (??) on 11-Авг-07, 21:59 
забыли
ldd -v
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "ни как не могу справиться"  
Сообщение от anonymous (??) on 12-Авг-07, 00:21 
1. Попробовать поискать в репозитории пакет с libstdc++5
2. /sbin/ldconfig для пересборки кеша динамических библиотек
3. .rh90. в названии пакета случайно не говорит о том, что пакет для red hat 9.0, а не для red hat enterprise 5.0?  откуда пакет взяли?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "ни как не могу справиться"  
Сообщение от spirit (??) on 12-Авг-07, 10:08 
>1. Попробовать поискать в репозитории пакет с libstdc++5
>2. /sbin/ldconfig для пересборки кеша динамических библиотек
>3. .rh90. в названии пакета случайно не говорит о том, что пакет
>для red hat 9.0, а не для red hat enterprise 5.0?
> откуда пакет взяли?

да пакет для red hat 9.0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "ни как не могу справиться"  
Сообщение от anonymous (??) on 12-Авг-07, 16:52 
>>1. Попробовать поискать в репозитории пакет с libstdc++5
>>2. /sbin/ldconfig для пересборки кеша динамических библиотек
>>3. .rh90. в названии пакета случайно не говорит о том, что пакет
>>для red hat 9.0, а не для red hat enterprise 5.0?
>> откуда пакет взяли?
>
>да пакет для red hat 9.0

значит поищите пакет для вашей системы.  посмотрите в репозитарии.

если бесконтрольно ставить "левые" пакеты -- любая, даже самая энтерпрайз система не выдержит.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "ни как не могу справиться"  
Сообщение от Spirit email(??) on 13-Авг-07, 10:18 
>[оверквотинг удален]
>>>3. .rh90. в названии пакета случайно не говорит о том, что пакет
>>>для red hat 9.0, а не для red hat enterprise 5.0?
>>> откуда пакет взяли?
>>
>>да пакет для red hat 9.0
>
>значит поищите пакет для вашей системы.  посмотрите в репозитарии.
>
>если бесконтрольно ставить "левые" пакеты -- любая, даже самая энтерпрайз система не
>выдержит.

Дело уже не в установке сима. Мне в кратчайшие сроки нужно изучить билинг UTM. а с ним проблемы которы я описал выше

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "ни как не могу справиться"  
Сообщение от anonymous (??) on 13-Авг-07, 11:43 
>Дело уже не в установке сима. Мне в кратчайшие сроки нужно изучить
>билинг UTM. а с ним проблемы которы я описал выше

Тогда искать пакет с libstdc++5 для rhel5.

В принципе, трюк ln -s который вы сделали может заработать, но после пересборки кеша библиотек /sbin/ldconfig

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "ни как не могу справиться"  
Сообщение от Spirit email(??) on 13-Авг-07, 12:57 
>>Дело уже не в установке сима. Мне в кратчайшие сроки нужно изучить
>>билинг UTM. а с ним проблемы которы я описал выше
>
>Тогда искать пакет с libstdc++5 для rhel5.
>
>В принципе, трюк ln -s который вы сделали может заработать, но после
>пересборки кеша библиотек /sbin/ldconfig

/sbin/ldconfig уже проделал ошибка осталось такой же. Рекомендовали поставить compat-libstdc++ но там к сожалению я не нашел libstdc++5. А как можно держать две одинаковых библиотеки но разных версий ? как подсунуть именно библиотеку более старой версии определенной программе в конкретном случаем UTM

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "ни как не могу справиться"  
Сообщение от A Clockwork Orange on 13-Авг-07, 13:27 
>[оверквотинг удален]
>>
>>Тогда искать пакет с libstdc++5 для rhel5.
>>
>>В принципе, трюк ln -s который вы сделали может заработать, но после
>>пересборки кеша библиотек /sbin/ldconfig
>
>/sbin/ldconfig уже проделал ошибка осталось такой же. Рекомендовали поставить compat-libstdc++ но там
>к сожалению я не нашел libstdc++5. А как можно держать две
>одинаковых библиотеки но разных версий ? как подсунуть именно библиотеку более
>старой версии определенной программе в конкретном случаем UTM

почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "ни как не могу справиться"  
Сообщение от Spirit email(??) on 13-Авг-07, 13:35 
>[оверквотинг удален]
>>>
>>>В принципе, трюк ln -s который вы сделали может заработать, но после
>>>пересборки кеша библиотек /sbin/ldconfig
>>
>>/sbin/ldconfig уже проделал ошибка осталось такой же. Рекомендовали поставить compat-libstdc++ но там
>>к сожалению я не нашел libstdc++5. А как можно держать две
>>одинаковых библиотеки но разных версий ? как подсунуть именно библиотеку более
>>старой версии определенной программе в конкретном случаем UTM
>
>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?

к сожалению не могу ответить на этот вопрос :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "ни как не могу справиться"  
Сообщение от anonymous (??) on 13-Авг-07, 13:56 
>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?

используйте apt

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "ни как не могу справиться"  
Сообщение от A Clockwork Orange on 13-Авг-07, 13:59 
>>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?
>
>используйте apt

а оно с ред хэт работает? или это вроде как только дебиановская примочка?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "ни как не могу справиться"  
Сообщение от anonymous (??) on 13-Авг-07, 14:02 
>>>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?
>>
>>используйте apt
>
>а оно с ред хэт работает? или это вроде как только дебиановская
>примочка?

Судя по 2,5 миллионам результатов в гугле -- работает.  Но я сам не использовал так что могу только подсказать http://www.google.com/search?q=apt+red+hat

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "ни как не могу справиться"  
Сообщение от Spirit email(??) on 13-Авг-07, 14:00 
>>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?
>
>используйте apt

хм apt-cache search
и apt-get install я встречал в алт линукс. Разве в редхат этот трюк пройдет?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "ни как не могу справиться"  
Сообщение от Imperator (??) on 13-Авг-07, 14:58 
>>>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?
>>
>>используйте apt
>
>хм apt-cache search
>и apt-get install я встречал в алт линукс. Разве в редхат этот
>трюк пройдет?

В RHEL ES5 используется yum & Up2date
Вот ими и ставь.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "ни как не могу справиться"  
Сообщение от Spirit email(??) on 13-Авг-07, 15:20 
>>>>почему в линуксе, не устанавливаются зависимые пакеты самостоятельно?
>>>
>>>используйте apt
>>
>>хм apt-cache search
>>и apt-get install я встречал в алт линукс. Разве в редхат этот
>>трюк пройдет?
>
>В RHEL ES5 используется yum & Up2date
>Вот ими и ставь.

А можно по подробнее пожалуйста

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "ни как не могу справиться"  
Сообщение от anonymous (??) on 13-Авг-07, 13:59 
>/sbin/ldconfig уже проделал ошибка осталось такой же. Рекомендовали поставить compat-libstdc++ но там
>к сожалению я не нашел libstdc++5. А как можно держать две
>одинаковых библиотеки но разных версий ? как подсунуть именно библиотеку более
>старой версии определенной программе в конкретном случаем UTM

проверьте вывод ldd /usr/local/bin/имя_бинарника_программы, там будет написано какие библиотеки найдены и какие нет

полный путь к файлу программы можно узнать командой which

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "ни как не могу справиться"  
Сообщение от anonymous (??) on 13-Авг-07, 16:34 
>проверьте вывод ldd /usr/local/bin/имя_бинарника_программы, там будет написано какие библиотеки найдены и какие нет
>
>полный путь к файлу программы можно узнать командой which

Кстати, вот эту команду вы запустили в домашнем каталоге (~), а нужно в /usr/lib:
[root@spirit~]# ln -s /usr/lib/libstdc++.so.6 libstdc++.so.5

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "ни как не могу справиться"  
Сообщение от Spirit email(??) on 13-Авг-07, 17:05 
>>проверьте вывод ldd /usr/local/bin/имя_бинарника_программы, там будет написано какие библиотеки найдены и какие нет
>>
>>полный путь к файлу программы можно узнать командой which
>
>Кстати, вот эту команду вы запустили в домашнем каталоге (~), а нужно
>в /usr/lib:
>[root@spirit~]# ln -s /usr/lib/libstdc++.so.6 libstdc++.so.5

да я вкурсе это уже давно исправлено и сам сим линк лежит в /usr/lib/ спасибо за замечание !
Впредь буду внимательнее :) но это не меняй начальной ситуации :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "ни как не могу справиться"  
Сообщение от johnjoy (??) on 13-Авг-07, 16:54 
#yum whatprovides libstdc++.so.5
...
compat-libstdc++-33.i386                 3.2.3-61               base
Matched from:
libstdc++.so.5
Importing additional filelist information

compat-libstdc++-33.x86_64               3.2.3-61               base
Matched from:
/usr/lib64/libstdc++.so.5

....

#yum install compat-libstdc++-33

ну и так далее

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру