The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"проблема с httpd"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (Linux привязка / Linux)
Изначальное сообщение [ Отслеживать ]

"проблема с httpd"  +/
Сообщение от dagport (ok) on 09-Июн-10, 20:39 
[root@bill /]# service httpd start
Starting httpd: Syntax error on line 148 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/mod_auth_basic.so into server: /etc/httpd/modules/mod_auth_basic.so: cannot open shared object file: No such file or directory
or directoryles/mod_auth_basic.so: cannot open shared objec[FAILED]No such file o


я ему скармливал этот файл mod_auth_basic.so

после этого он начал выдавать это
[root@bill modules]# service httpd start
Starting httpd: Syntax error on line 148 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/mod_auth_basic.so into server: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /etc/httpd/modules/mod_auth_basic.so)

я думаю все таки не надо было скидывать туда из другой системы.(ну можно и удалить вернуться к началу ))))не могу понять в чем дело

дистриб RHat

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "проблема с httpd"  +1 +/
Сообщение от rovdy on 09-Июн-10, 21:29 
>[оверквотинг удален]
>[root@bill modules]# service httpd start
>Starting httpd: Syntax error on line 148 of /etc/httpd/conf/httpd.conf:
>Cannot load /etc/httpd/modules/mod_auth_basic.so into server: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by
>/etc/httpd/modules/mod_auth_basic.so)
>
>я думаю все таки не надо было скидывать туда из другой системы.(ну
>можно и удалить вернуться к началу ))))не могу понять в чем
>дело
>
>дистриб RHat

а он тебе нужен?
1. закоментируй строчку с включением модуля.
2. бери пакет с репозитария
3. собирай сам
ну и на всякий случай проверь ты версию своей glibc, судя по логам она дружить не хочет с той, которая у тебя стоит.

удачи


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "проблема с httpd"  +/
Сообщение от dagport (ok) on 09-Июн-10, 21:56 
а  нет других вариантов


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "проблема с httpd"  +/
Сообщение от Аноним (??) on 10-Июн-10, 00:35 
>а  нет других вариантов

каких других вариантов? ты издеваешься, да?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "проблема с httpd"  +/
Сообщение от dagport (ok) on 10-Июн-10, 01:29 
>>а  нет других вариантов
>
>каких других вариантов? ты издеваешься, да?

Нет почему сразу издеваешься.. Просто думал есть еще какие варианты

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "проблема с httpd"  +/
Сообщение от dagport (ok) on 10-Июн-10, 09:28 
а где взять репозиторий для этой версии не могу найти
apache-1.3.27-4

RHat 7.3

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "проблема с httpd"  +/
Сообщение от Klong email on 10-Июн-10, 13:46 
>а где взять репозиторий для этой версии не могу найти
>apache-1.3.27-4
>
>RHat 7.3

Эта версия RH имела хождение лет 15 назад. Это так, к слову.
Судя по конфигам у вас стандартная инсталляция из пакетов, а это значит что "ПРОСТО" просимый файл не подсунуть. Необходимо поставить пакет который его содержит. Репозитария для 7.3 нынче можно наверно только на Альфа Центавре найти. Но смотреть так далеко не обязательно, можно поискать необходимый пакет в интернете, либо на установочном компакт диске.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "проблема с httpd"  +/
Сообщение от dagport (ok) on 10-Июн-10, 19:21 
так проблема в следящем разложу по полкам, чтоб было яснее.
стоял изначально apache-1.3.27-4  место нахождения etc/httpd/
случился  кернел паник подняли все кроме выше упомянутого сервера апач
после поставили httpd 2.2.12 но уже в папку var/и там своя папка httpd 2.2.12
теперь так запуская вот так service hhtpd  start  выкидывает выше упомянутую ошибку эту

[root@bill /]# service httpd start
Starting httpd: Syntax error on line 148 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/mod_auth_basic.so into server: /etc/httpd/modules/mod_auth_basic.so: cannot open shared object file: No such file or directory
or directoryles/mod_auth_basic.so: cannot open shared objec[FAILED]No such file o
то есть он пытается запустить старую версию httpd
после захожу в папку var/ httpd 2.2.12 и запускаю так ./httpd -k start
он стартует только уже версия новая .

теперь у меня вопрос .
1, как только установили второй он заменил конфиг первого то есть старого ? хотя они в разных папках .
2. Как удалить теперь ?  второй при попытке сделать так
[root@bill httpd-2.2.15]# rpm -e httpd
error: package httpd is not installed сами видите.
3, после удаления я хочу сделать обновления старой версии я нашел apache-1.3.27-4.src.rpm  и хочу обновить старую или вовсе удалить и поставить по новой только скинуть конфиг старой будет работать ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру