The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Firefox прекращает поддержку плагинов NPAPI, за исключением ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от opennews (??) on 09-Окт-15, 09:57 
Проект Mozilla объявил (https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plu.../) о решении прекратить поддержку плагинов с интерфейсом NPAPI в Firefox до конца 2016 года.
Возможность использования NPAPI будет оставлена только для Adobe Flash, так как данная технология остаётся востребована большим числом пользователей. Остальные NPAPI-плагины, в том числе Silverlight, Java и Unity, невозможно будет использовать в Firefox.


В качестве основных причин прекращения поддержки NPAPI отмечается устаревание данного API и желание избавиться от NPAPI-плагинов как от источников проблем с производительностью, крахов и уязвимостей. Вместо NPAPI предлагается использовать штатный Web API, который уже обладает достаточными возможностями (например, в Web API уже доступны такие возможности, ранее реализуемые через внешние плагины, как средства организации потокового вещания, расширение графические возможности, функциональность для разработки игр и средства (https://hacks.mozilla.org/2015/09/flash-free-clipboard-for-t.../) управлением буфером обмена).


С учётом того, что браузеры Chrome и Microsoft Edge уже не поддерживают NPAPI, удаление NPAPI кардинально не отразится на рыночной доле производителей плагинов. В ответ на заявление о прекращении поддержки NPAPI компания Oracle рекомендовала (https://blogs.oracle.com/java-platform-group/entry/npapi_plu...) разработчикам сайтов  перейти на использование (http://docs.oracle.com/javase/8/docs/technotes/guides/deploy...) не требующей установки плагина технологии запуска аплетов Java Web Start (https://blogs.oracle.com/java-platform-group/entry/java_web_...), вместо встраивания Java-контента в web-страницы, или перейти на использование браузеров, в которых сохранена поддержка NPAPI (Internet Explorer и Safari).


Компания Unity Technologies предложила (http://blogs.unity3d.com/?p=29891) разработчикам игр перейти на WebGL и штатный Web API, объявив требующую плагина технологию Web Player устаревшей и намереваясь прекратить её поддержку начиная с выпуска Unity 5.4, намеченного на март 2016 года. Что касается Silverlight, то данная технология уже давно не развивается компанией Microsoft и объявлена устаревшей.


URL: https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plu.../
Новость: http://www.opennet.ru/opennews/art.shtml?num=43117

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +11 +/
Сообщение от Аноним (??) on 09-Окт-15, 09:57 
Спасибо Mozilla, теперь интернет-банки, в которых последние годы только наладили возможность работы с разными браузерами, опять станут работать только в Internet Explorer.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +20 +/
Сообщение от Наркоман on 09-Окт-15, 10:03 
В нормальных банках интернет-банк уже давно не на жаве.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

12. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от bla (??) on 09-Окт-15, 10:12 
А электронная подпись как организована?
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

19. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –30 +/
Сообщение от qwwe (??) on 09-Окт-15, 10:30 
LOL. Какая электронная подпись? В нормальных банках соединение по https и пользователю выдают логин/пароль, которые больше не знает никто.
Куда вы все там Java пихаете то?
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

25. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +22 +/
Сообщение от zritel on 09-Окт-15, 10:52 
Мда, иногда лучше жевать..
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

44. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –7 +/
Сообщение от Аноним (??) on 09-Окт-15, 12:43 
> Мда, иногда лучше жевать..

вот и жуй молча.

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

71. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –3 +/
Сообщение от www2 (ok) on 09-Окт-15, 18:33 
Жуйте. Могу пример назвать - у Сбербанка всё именно так, как сказал товарищ выше: https, логин и пароль. И никаких яв.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

102. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Vladjmir (ok) on 10-Окт-15, 15:07 
И двухфакторная авторизация.
Ответить | Правка | ^ к родителю #71 | Наверх | Cообщить модератору

31. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 09-Окт-15, 11:26 
> LOL. Какая электронная подпись? В нормальных банках соединение по https и пользователю
> выдают логин/пароль, которые больше не знает никто.
> Куда вы все там Java пихаете то?

Еще otp на мобиьники шлют, ну или заставляют ключи на токенах хранить, но такие банк клиенты требуют своих плагинов или крипто про.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

38. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Евгений (??) on 09-Окт-15, 12:00 
Обычно в таких "нормальных" банках % клиентов жалующихся что у них сперли денювки превалирует.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

52. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +3 +/
Сообщение от anonymous (??) on 09-Окт-15, 13:46 
URL на статистику или Лев Простой.
Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

79. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Anonplus on 09-Окт-15, 19:48 
Там, где двухфакторная авторизация по СМС - действительно крадут. Перевыпускают симку в офисе оператора по доверенности или поддельному паспорту. Полуркайте форумы ("перевыпуск симки мобильный банк"), эта проблема в последние года два очень широко распространилась. Последней каплей стал недавний случай, когда у более-менее известного клиента за месяц четырежды таким образом перевыпускали сим-карту. Только тогда началась шумиха в СМИ и Билайн, ВНЕЗАПНО, обнаружил, что таки да - проблема есть и запретил перевыпускать симки по доверенности.

Но это не спасает в сценариях "у мошенников знакомый человек, работающий в салоне оператора, который за мзду или по старой дружбе таки нарушит регламент". Так что я от Сбера отвязал номер телефона и пользуюсь одноразовыми паролями, распечатываемыми в банкоматах. Потому что у меня там, лежит несколько сотен тысяч и потом год судиться с банком на предмет возвращения денег мне не хочется. Банк в таких случаях сваливает вину на сотового оператора ("это они выдают там ваши симки кому попало"), а оператор - на банк ("это банк у вас фуфло и не проверяет IMSI, который у каждой симки разный").

Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

65. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Челодой моловек on 09-Окт-15, 17:14 
Вы хоть раз создавали платежное поручение? Если пользоваться интернет банкингом как физ. лицо и перекидывать деньги со своей карточки на карточку друга/подруги/сына/отца, то да, для таких операций ничего подписывать не надо.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

103. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Коля on 10-Окт-15, 17:14 
В моем любимом банке Авангард использую джаву для подписи платежных поручений. Флешка с подписью хранится у главного бухгалтера. Вопрос: как организовать этот процесс без джавы?
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

30. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 09-Окт-15, 11:21 
Для чего там подпись? Ну хранится на сервере банка, наверно, раз юзер использует простую 2-х факторную аунтификацию.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

46. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от daemontux on 09-Окт-15, 12:56 
> Для чего там подпись? Ну хранится на сервере банка, наверно, раз юзер
> использует простую 2-х факторную аунтификацию.

Помимо обычных пользователей, банк клиентами пользуются компании. А там без ЭЦП никак.

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

42. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от 123 (??) on 09-Окт-15, 12:36 
Токенизация.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

43. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Аноним (??) on 09-Окт-15, 12:40 
FireFox умел электронную подпись всегда. а вот ты - нет.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

104. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Zulu on 10-Окт-15, 17:50 
OTP в криптованой SMS. Или в некриптованой, тогда еще один пароль. Отличайте ваш геморрой от остального мира.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

8. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +12 +/
Сообщение от eRIC (ok) on 09-Окт-15, 10:04 
пусть немного в банке тоже поработают, а то засиделись там программисты без дела :) это не должна быть головной болью системных администраторов

пусть в банке осваивают новые технологии и все свои корявые интернет-банкинги с времен 2000 и XP под новые требования современных браузеров выпускают :)

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

32. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 11:26 
> пусть немного в банке тоже поработают, а то засиделись там программисты без
> дела :) это не должна быть головной болью системных администраторов
> пусть в банке осваивают новые технологии и все свои корявые интернет-банкинги с
> времен 2000 и XP под новые требования современных браузеров выпускают :)

А пока они это не сделают, ваша организация посидит без расчетного счета?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

59. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +3 +/
Сообщение от Аноним (??) on 09-Окт-15, 15:10 
> А пока они это не сделают, ваша организация посидит без расчетного счета?

Ага, а когда (более-менее серьезные) клиенты начинают массово валить – начинаются вопли про происки конкурентов, черный пиар и злобный картельно-масонские сговор с целью рейдерского захвата и перепродажи в анальное рабство.

В общем, этих ежиков нужно пинать ногами, иначе они не то что не полетят – даже не почешутся.

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

86. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 23:22 
>> А пока они это не сделают, ваша организация посидит без расчетного счета?
> Ага, а когда (более-менее серьезные) клиенты начинают массово валить – начинаются
> вопли про происки конкурентов, черный пиар и злобный картельно-масонские сговор с
> целью рейдерского захвата и перепродажи в анальное рабство.
> В общем, этих ежиков нужно пинать ногами, иначе они не то что
> не полетят – даже не почешутся.

Ну, попробуй. Придешь - расскажешь, как удалось, ога?

Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

93. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Анонми on 10-Окт-15, 04:49 
> Ну, попробуй. Придешь - расскажешь, как удалось, ога?

Попробуй не только отвечать, но и читать, ога?

Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

92. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от mumu (??) on 10-Окт-15, 02:43 
Мечты Мечты. Приходишь ты такой к главбуху, у которого через этот банк уже вся чернуха на офшоры навязана и говоришь что переходим мы на другой потому, что мне мозилла больше ie нравится, а в мозиле нету каких-то плагинов. Котелок чугунный только на голову надеть не забудь.
Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

94. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Анонми on 10-Окт-15, 04:51 
Мечты Мечты. Плюешь ты, такой весь в белом, на нужды клиентов. Чморишь их, а они все равно лезут и лезут, как будто им тут медом намазанно ...


Ответить | Правка | ^ к родителю #92 | Наверх | Cообщить модератору

109. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от mumu (??) on 11-Окт-15, 12:03 
Потому что нужды клиентов это в первую очередь возможность проводить свои махинации, высокие процентные ставки, возможность откатов с зарплатных процентов и все прочие плюшки.

А с клиентбанками пусть сексом бухи и сисадмины занимаются, им для этого зарплату отбашляют. Так то.

Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

113. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Michael Shigorin email(ok) on 12-Окт-15, 17:06 
> Котелок чугунный только на голову надеть не забудь.

Тому, кто до сих пор тупит об офшоры, ничего не поняв из Кипра?

PS: иэхх, ещё один кусочек нетшкафовской эпохи уходит...

Ответить | Правка | ^ к родителю #92 | Наверх | Cообщить модератору

41. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от anon5775 on 09-Окт-15, 12:16 
а кому выпускать, когда все тут сидят?
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

22. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Sadok (ok) on 09-Окт-15, 10:39 
> Спасибо Mozilla, теперь интернет-банки, в которых последние годы только наладили возможность
> работы с разными браузерами, опять станут работать только в Internet Explorer.

Use FireFox ESR, Luke

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

28. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 11:02 
> Use FireFox ESR, Luke

Firefox ESR поддерживается только год. Только один год, Карл!
NPAPI уберут в декабре, а конце 2016 этот истечёт год поддержки ESR.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

51. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –2 +/
Сообщение от Аноним (??) on 09-Окт-15, 13:13 
Ну и? Триал закончится? Исходники протухнут? В чём проблема-то?

Некоторые на икспишечке до сих пор сидят, уже два года без всякой поддержки. А IE6 до сих пор на десятке в режиме совместимости гоняют, ради всякого г-нософта.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

2. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –2 +/
Сообщение от Челодой моловек on 09-Окт-15, 09:59 
В клиент-банке плагин java используется для подписи платежных поручений своим ключом. Интересно, если плагин перестанет поддерживаться, что можно использовать взамен? Можно ли это реализовать через Web API или банкам придется использовать что-то типа Java Web Start?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 09-Окт-15, 10:02 
Скорее второе, то бишь Java Web Start. А пока оно не реализовано, особенно зная всю бюрократию банков, админы буду кушать кактусы :(
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

13. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от конь on 09-Окт-15, 10:14 
Будет десктопная тулза.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

115. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от aim (ok) on 13-Окт-15, 02:05 
там проблема то вся в сертификации "исходных" продуктов.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

14. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от fi (ok) on 09-Окт-15, 10:15 
ну в моем банке java использовалась как Web Start, думаю у других так же - как отдельное приложение. Но на сегодня он перешел на подпись через смс, так что гудбай java.

после ухода хрома с этой темы java пошла на вымирание :(

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

63. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от виндотролль (ok) on 09-Окт-15, 16:05 
какой смс? не путай н-факторную аутентификацию с электронной подписью
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

105. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Zulu on 10-Окт-15, 17:52 
> какой смс? не путай н-факторную аутентификацию с электронной подписью

Верно, это разные вещи. Но зачем именно электронная подпись?

Ответить | Правка | ^ к родителю #63 | Наверх | Cообщить модератору

106. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от виндотролль (ok) on 10-Окт-15, 19:11 
> Верно, это разные вещи. Но зачем именно электронная подпись?

В моем банке тоже аут. по ключу. А вот подпись нужна для сдачи отчетности в налоговую.

Ответить | Правка | ^ к родителю #105 | Наверх | Cообщить модератору

36. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от Аноним (??) on 09-Окт-15, 11:49 
> В клиент-банке плагин java используется для подписи платежных поручений своим ключом. Интересно,
> если плагин перестанет поддерживаться, что можно использовать взамен? Можно ли это
> реализовать через Web API или банкам придется использовать что-то типа Java
> Web Start?

Банк будет писать с покерфейсом: "для работы требуется вин хэпэ с ишаком 8" И ты поставишь себе хэпэ и ишак.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

50. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +3 +/
Сообщение от Аноним (??) on 09-Окт-15, 13:08 
Нет, ты найдешь себе приличный банк.
Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

60. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от тоже Аноним email(ok) on 09-Окт-15, 15:31 
ВТБ, например - неприличный банк? Ишак-онли.
Во всяком случае, техподдержка на что-то другое и не думает распространять свои обязанности...
Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

68. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Ан (??) on 09-Окт-15, 17:38 
Неприличный. Вот когда клиенты начнут посылать банки которые выкидывают пользователям неюзабельные поделия и веб-морды, тогда те зашевелятся.
А то от некоторых поделий можно начать убивать создателей этих поделий. Такое чувство что удобство и аккуратность это не для разработчиков банков.
Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

83. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от тоже Аноним email(ok) on 09-Окт-15, 20:44 
К сожалению, банки в России все больше делятся на те, которые готовы конкурировать за клиента, и те, в которых можно держать счет и не трястись при каждой новости про отзыв лицензий. Работать, к сожалению, в основном приходится со вторыми, а им печали клиентов по барабану - так и так прибегут, никуда не денутся.
Ответить | Правка | ^ к родителю #68 | Наверх | Cообщить модератору

89. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Ан (??) on 09-Окт-15, 23:32 
В Белоруссии вроде как есть несколько банков которые уже лет 20 существуют минимум и благо у некоторых с веб-мордами всё нормально. Хотя есть те которыми пользоваться не матюгаясь нельзя. На счёт подходов с ЭЦП не совсем в курсе потому про это сказать нечего.
Ответить | Правка | ^ к родителю #83 | Наверх | Cообщить модератору

120. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 15-Окт-15, 11:47 
У Белпромстройбанка (ныне БПС-Сбербанка) для интернет-банкинга у юридических лиц отдельное десктопное приложение на базе Eclipse, которое и флэшки с токенами поддерживает, и чёрта в ступе.
Ответить | Правка | ^ к родителю #89 | Наверх | Cообщить модератору

76. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Аникандр on 09-Окт-15, 18:59 
ВТБ - это последняя остановка перед концом. Дальше только Сбербанк России.
Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

82. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от тоже Аноним email(ok) on 09-Окт-15, 20:42 
Вы про очередь на отзыв лицензии? Да, примерно так.
Кстати, этот фактор для бизнеса почему-то важнее, чем поддержка разных браузеров.
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

114. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Michael Shigorin email(ok) on 12-Окт-15, 17:23 
> Кстати, этот фактор для бизнеса почему-то важнее, чем поддержка разных браузеров.

Но как конкурентный Вы его почему-то не рассматриваете ведь?

Ответить | Правка | ^ к родителю #82 | Наверх | Cообщить модератору

4. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –4 +/
Сообщение от Аноним (??) on 09-Окт-15, 10:02 
Господа, анонимные аналитики, подскажите пожалуйста, AdBlock тоже NPAPI использует?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Аноним (??) on 09-Окт-15, 10:03 
> Господа, анонимные аналитики, подскажите пожалуйста, AdBlock тоже NPAPI использует?

нет

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

67. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +3 +/
Сообщение от Ilya Indigo (ok) on 09-Окт-15, 17:35 
Плагин и дополнение - разные вещи.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

5. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +25 +/
Сообщение от Аноним (??) on 09-Окт-15, 10:02 
> NPAPI-плагинов как от источников проблем с производительностью, крахов и уязвимостей.

Хм, в этом случае первым делом нужно резать Flash, а не оставлять его.
Какой смысл искусственно запрещать установку редкоиспользуемых, но востребованных отдельными пользователями плагинов, когда NPAPI всё равно оставлен для Flash?
По сути это явная атака на Java, остальные плагины давно полутрупы.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

10. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Аноним (??) on 09-Окт-15, 10:05 
Согласен, или всё резать или ничего. Активации связанного с плагинами контента только по клику вполне хватает.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

11. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от eRIC (ok) on 09-Окт-15, 10:05 
+1 надо было Flash тоже рубить, чтобы полностью его похоронить...
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

37. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от Аноним (??) on 09-Окт-15, 11:50 
> +1 надо было Flash тоже рубить, чтобы полностью его похоронить...

Кого похоронить? Фаерфокс?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

15. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +4 +/
Сообщение от gkv311 (ok) on 09-Окт-15, 10:23 
Как это низко, избирательно блокировать плагины, оставляя рабочим Flash - самый глючный и тормозной NPAPI плагин! А те сайты, которые не могут нормально обойтись web-технологиями из-за их недостаточности развития теперь просто перестанут работать!
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

20. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Ан (??) on 09-Окт-15, 10:33 
То-то постоянно находятся анонимы у которых видео не заводится средствами html5. У FF на линуксах эта проблема как-то уж очень закостенела.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

39. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Аноним (??) on 09-Окт-15, 12:00 
> То-то постоянно находятся анонимы у которых видео не заводится средствами html5. У
> FF на линуксах эта проблема как-то уж очень закостенела.

В последних версиях чуть лучше, но половина сайтов html5 в принципе не поддерживает.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

56. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 09-Окт-15, 14:26 
УМВР ЧЯДНТ?
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

75. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 18:55 
Debian 8.2, Firefox 41.0.1, Chromium 42.0.2250.1, блоб Невидиа. Всё работает. По крайней мере крупные сайты работают. На YouTube во весь экран не делает и больше 720p не даёт смотреть.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

77. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Ан (??) on 09-Окт-15, 19:18 
Я понимаю что у некоторых по каким-либо причинам работает, но постоянно в новостях про новый FF встречаешь тех кто пытается завести воспроизведение и спотыкаются на том что вылазят какие-то глюки. Потому для некоторых решением является или скачка, или флеш.
Но это конечно со временем поправится.
Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

78. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от soarin (ok) on 09-Окт-15, 19:38 
Потому что firefox для этого использует внешний gstream, который установлен в системе.
А так как линуксов целый зоопарк, то весьма сильно могут результаты отлчаться.
Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

84. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от paulus (ok) on 09-Окт-15, 21:02 
firefox и без gstreamer нормально на youtube html5-видео гоняет...
Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

81. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +3 +/
Сообщение от непонятно on 09-Окт-15, 20:28 
about:config, поврубай всё, что находится по 'mediasource' и 'mp4' (кроме media.fragmented-mp4.use-blank-decoder).

И наступит счастье и радость!

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

21. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от qwwe (??) on 09-Окт-15, 10:35 
Перечитай новость, там сказано, что Flash используют слишком много людей. Думаю в Mozilla видней статистика.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

27. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Тот_Самый_Анонимус on 09-Окт-15, 10:56 
Перечитайте комментарий, на который отвечаете. Там всё ясно аргументировано.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

9. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 10:05 
и как теперь в этом поделии криптопро пользоваться?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

23. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Анонзо on 09-Окт-15, 10:40 
>>криптопро

Пусть тоже пошевелятся маленько. Чего и ВипНету хочу пожелать.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

34. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +7 +/
Сообщение от Аноним (??) on 09-Окт-15, 11:37 
>>>криптопро
> Пусть тоже пошевелятся маленько. Чего и ВипНету хочу пожелать.

Випнету хочется пожелать только смерти, причём скорой, чтобы скорее у всех их пользователей дела на лад пошли.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

45. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 12:55 
Это вы наверное Континента не видели.
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

53. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от anonymous (??) on 09-Окт-15, 13:50 
а что с ним не так? и про какую версию речь?
Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

80. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Anonplus on 09-Окт-15, 19:50 
> Випнету хочется пожелать только смерти, причём скорой, чтобы скорее у всех их
> пользователей дела на лад пошли.

Про випнет недавно проскакивала кулстори...

"У меня есть сомнения в качестве Випнета. Ну не может качественное ПО так нагло в конфигурации по умолчанию использовать в качестве виртуальных адреса из блока 11.0.0.0/8, который вообще-то принадлежит DoD USA. Фиг с ним, конечно, это неграмотно — самовольно использовать сети, для приватных целей не предназначенные; оставим это на совести того недоучки-разработчика, который принял такое решение. При отказе шифрования пакеты направятся прямо туда в открытом виде. А пакеты, как задумано, содержат именно те данные, которые мы бережно храним и лелеем по высшему уровню защиты. Это не шутка, я наблюдал пакеты с таким адресом назначения на пограничном маршрутизаторе. Каким образом это получило сертификаты ФСТЭК, ФСБ?"

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

87. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 23:25 
>[оверквотинг удален]
> "У меня есть сомнения в качестве Випнета. Ну не может качественное ПО
> так нагло в конфигурации по умолчанию использовать в качестве виртуальных адреса
> из блока 11.0.0.0/8, который вообще-то принадлежит DoD USA. Фиг с ним,
> конечно, это неграмотно — самовольно использовать сети, для приватных целей не
> предназначенные; оставим это на совести того недоучки-разработчика, который принял такое
> решение. При отказе шифрования пакеты направятся прямо туда в открытом виде.
> А пакеты, как задумано, содержат именно те данные, которые мы бережно
> храним и лелеем по высшему уровню защиты. Это не шутка, я
> наблюдал пакеты с таким адресом назначения на пограничном маршрутизаторе. Каким образом
> это получило сертификаты ФСТЭК, ФСБ?"

Да таким, что в реальном мире все такие же, как анонимы с опеннета - пальцы гнут каждый, а реальными спецами является полтора калеки, и те давно за бугром.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

98. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 10-Окт-15, 10:13 
> Да таким, что в реальном мире все такие же, как анонимы с
> опеннета - пальцы гнут каждый, а реальными спецами является полтора калеки,
> и те давно за бугром.

и к чему ты это ляпнул, забыв залогиниться?

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

24. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Максим (??) on 09-Окт-15, 10:49 
Криптопро уже вовсю пилит версию без NPAPI, правда нужна будет помощь со стороны разрабов использующих его
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

26. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 10:55 
Т.е. они делают плагин для браузера, вместо Java-апплета?
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

33. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 11:36 
пилит-пилит, никак не запилит, причём расширение для хромого, которое хранилищ не видит
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

18. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от th3m3 (ok) on 09-Окт-15, 10:29 
>>Unity Technologies предложила разработчикам игр перейти на WebGL

Очень смешно. У самой Unity этот WebGL не работает нормально нефига. Только пиарят, а на деле разработчики не имеют возможности использовать нормально WebGL в Unity. В этом плане рулит - Blend4Web.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

29. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от iPony on 09-Окт-15, 11:08 
Тогда safari останется единственным мажорным браузером поддерживающим NPAPI
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

35. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +4 +/
Сообщение от Аноним (??) on 09-Окт-15, 11:47 
И чем мне теперь в IPMI сервака смотреть? IE использовать? Наркоманы чертовы.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

47. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 12:56 
ipmitool sol activate
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

49. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от daemontux on 09-Окт-15, 13:04 
> И чем мне теперь в IPMI сервака смотреть? IE использовать? Наркоманы чертовы.

+1
Есть куча серваков  у которых ip kvm на жабе. Что теперь винду ставить?

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

58. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Stax (ok) on 09-Окт-15, 14:35 
Ну в более-менее новых часто Java WS, а не апплеты.
А где остались апплеты, открываем Konqueror'ом.
Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

70. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 18:20 
А зачем для этого ява-плагин? Достаточно Java Web Start или stand-alone приложения, типа IPMIView, как у супермикры.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

116. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от aim (ok) on 13-Окт-15, 02:08 
> И чем мне теперь в IPMI сервака смотреть? IE использовать? Наркоманы чертовы.

IPMI по JWS работает обычно.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

40. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Аноним (??) on 09-Окт-15, 12:08 
Даладна! А что взамен? PPAPI как не было, так и нет!

I-rinat, как это отразится на твоём враппере PPAPI-NPAPI-Firefox?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

62. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от irinat (ok) on 09-Окт-15, 15:44 
Сначала никак не отразится, ибо он анонсирует те же MIME-типы, что и Flash. А потом, когда совсем NPAPI выпилят (к этому всё идёт), перестанет работать.
Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

117. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от aim (ok) on 13-Окт-15, 02:09 
> Даладна! А что взамен? PPAPI как не было, так и нет!
> I-rinat, как это отразится на твоём враппере PPAPI-NPAPI-Firefox?

ничего не использовать - сказали же что не нужен механизм плагинов в 21 веке - есть веб-апи.

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

48. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +2 +/
Сообщение от Аноним (??) on 09-Окт-15, 12:58 
А еще IP-KVM/IPMI отвалятся
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

54. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 09-Окт-15, 14:00 
Теперь можно валить на хромиум не задумываясь. Фокс скатился в г*вно:
- Интерфейс испоганили
- Расширения терь многие сломают
- Тормозит как с*ка
- Стал часто падать на ровном месте

Осталось еще прикрутить blink и выпилить закладки для большей крипоты.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

85. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Анончик on 09-Окт-15, 21:40 
>>- Интерфейс испоганили

в хромом все равно хуже
>>- Тормозит как с*ка

хромой сильнее
>>- Стал часто падать на ровном месте

найтли у меня (за всех говорить не буду) работает стабильнее стабильного хрома

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

95. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от iPony on 10-Окт-15, 06:21 
А у соседа штаны более рваные (c)
Ответить | Правка | ^ к родителю #85 | Наверх | Cообщить модератору

111. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Анончик on 12-Окт-15, 11:22 
>>можно валить на хромиум

Кагбе поднимался вопрос перехода на хромиум, а не насколько испоганили фокс. Ваша ирония неуместна.

Ответить | Правка | ^ к родителю #95 | Наверх | Cообщить модератору

61. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +5 +/
Сообщение от anonymous (??) on 09-Окт-15, 15:38 
Вэбчик давно протух. Вместо тормозной жавы предлагают ещё более тормозное на js. Так победим.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

66. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Илья (??) on 09-Окт-15, 17:16 
а чем flash отличился?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

69. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Ilya Indigo (ok) on 09-Окт-15, 17:43 
Скорее всего они одумаются и оставят Java.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

72. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 18:35 
HTML5, WebSocket, HTML+KVM
Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

73. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от www2 (ok) on 09-Окт-15, 18:40 
Верной дорогой идут товарищи. Дальше жду блокировки флеша и яваскрипта. И картинок с анимацией.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

88. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 09-Окт-15, 23:26 
> Верной дорогой идут товарищи. Дальше жду блокировки флеша и яваскрипта. И картинок
> с анимацией.

Не дождешься.

Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

101. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Ан (??) on 10-Окт-15, 13:04 
Ну для картинок с анимацией и в прям порой нужен Click to Play.
Ответить | Правка | ^ к родителю #88 | Наверх | Cообщить модератору

74. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от DFX (ok) on 09-Окт-15, 18:41 
Последний гвоздь в гроб замученого Лиса.

✱ Thunderbird запустили и кодовую базу рассинхронизировали, из-за чего он тянет свои подгнивающие версии xul и gecko.
✱ Интерфейс затупили.
✱ Понапихали привязки к сторонним поделкам, засунули зачем-то всякую JS-срань, чатик и социалочки.
✱ Сделали жёсткую привязку к своим серверам, у которых он спрашивает разрешения, можно ли ему запускать любое дополнение (выпиливается перекомпиляцией... пока).
✱ XUL и NPAPI хотят вырезать, а это то, чем обеспечиваются вообще все уникальные функции, типа древовидной панели вкладок и встраивания libreoffice и okular для нормального просмотра документов прямо во вкладках.
✱ Неумело тужатся с мультипроцессностью. Отрисовку с OpenGL (OMTC) уже который год не могут осилить... больше ковыряются с direct2d, но при этом оно умудряется глючить ещё сильнее.

"Удаление NPAPI кардинально не отразится на рыночной доле производителей плагинов", зато отразится на "рыночной доле" FF. Нахрена он такой нужен ?
Если так хочется избавиться от говна на Flash и Java, то всего-то надо договориться с Гуглей блочить их по-умолчанию как устаревшее, жирное, кривое и небезопасное говно.

А что касается "банк-клиентов" и "подписей на java". Что, поддержку сертификатов из FF выпилили ? Помнится лет 5 назад, даже кажись под линуксами, работала авторизация по сертификату в webmoney. Неужто он не умеет ключами из них шифровать трафик ? Не верю, но даже если так, это не дольше и не сложнее исправить, чем вся эта чехарда. Другое дело, что Минкомсвязи дрочит приватизаторов бюрократии, и не удосуживается проведением ГОСТ-шифров в mainline, но это вообще не техническая проблема.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

97. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Тузя (ok) on 10-Окт-15, 09:30 
Простите, никогда не было webmoney. Что за авторизация по сертификату? Имеется в виду Mutual SSL/TLS?
Ответить | Правка | ^ к родителю #74 | Наверх | Cообщить модератору

99. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 10-Окт-15, 10:15 
> Простите, никогда не было webmoney. Что за авторизация по сертификату? Имеется в
> виду Mutual SSL/TLS?

это не ты на лоре своим мутуалом размахиваешь время от времени, включая лютого дурака на смешных вопросах?

Ответить | Правка | ^ к родителю #97 | Наверх | Cообщить модератору

108. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +1 +/
Сообщение от Тузя (ok) on 11-Окт-15, 07:55 
Я мало работал с сертификацией, с проверкой клиента по сертификату. Не разбираюсь в этом, потому и спрашиваю.
Меня нет на лоре.
Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

110. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от j3qq4 (??) on 12-Окт-15, 03:36 
Это не про сертификацию, это про *.PFX , *.cer и прочие *.SST  
Ответить | Правка | ^ к родителю #108 | Наверх | Cообщить модератору

118. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Тузя (ok) on 13-Окт-15, 15:46 
> Это не про сертификацию, это про *.PFX , *.cer и прочие *.SST

Это понятно, не понятно что именно выпилили?

Ответить | Правка | ^ к родителю #110 | Наверх | Cообщить модератору

119. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от DFX (ok) on 13-Окт-15, 19:21 
Я сам не вкурсе как именно это работает, но вот: https://wiki.webmoney.ru/projects/webmoney/wiki/Персональный_сертификат
До сих пор в моём профиле FF валяется такая штука с 2012 года, тогда им и авторизовывался, хотя WM-учётка у меня была, только чтоб поковыряться и понять, что это вообще такое.

Я не утверждал, что там что-то выпилили, я спрашивал. Мне так и не понятно, чего такого важного банкам не хватает в browser'ах ? В upstream открытых проектов добавляется поддержка гостовых алгоритмов, закрытые сосут лапу до просветления, делаются удостоверяющие сертификаты, затем сиди и тыкай по управляющим кнопкам. Что такого эзотерического в их плагинно-быдлокодерских поделках ?
И если это такое важное, общепринятое и уникальное дерьмо, которое в гляделки страничек никто упорно тащить не хочет, то может тогда уже пора запилить единый стандарт на реализацию универсальных банк-клиентов ?

Ответить | Правка | ^ к родителю #97 | Наверх | Cообщить модератору

90. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 10-Окт-15, 00:03 
internet explorer никогда не поддерживал NPAPI. у него есть (была) хрень под названием activex.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

96. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от iPony on 10-Окт-15, 06:25 
> internet explorer никогда не поддерживал NPAPI. у него есть (была) хрень под
> названием activex.

Поддерживал до версии 5.5, но опять же через прослойку.

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

107. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Аноним (??) on 10-Окт-15, 21:01 
ну в те времена считай и интернета не было (по сегодняшним меркам)
Ответить | Правка | ^ к родителю #96 | Наверх | Cообщить модератору

91. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  –1 +/
Сообщение от Аноним (??) on 10-Окт-15, 00:21 
С такими неугомонными "инновациями" palemoon становится всё актуальнее.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

100. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от shuL5Lix on 10-Окт-15, 12:52 
Райффайзен! Ау!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

112. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от ck80 (ok) on 12-Окт-15, 12:25 
В тему отпишусь. Три дня муохался с казахстанским сайтом, чтобы зайти по сертификату через жава-аплет.
2) сайт с неподписанным сертификатом. Все браузеры сразу кричат тревогу при входе.
3) жава-апплет на сайте без подписи. IE сразу блокирует, пока не понизишь требования безопасности. Гугл сразу лесом NPAPI не поддерживает. Мозизла открывает с предупреждениями.
4) При установленной в системе только 64битном плагине Java, апплет на сайте не грузится. Нужно в довесок ещё и 32битную жаву ставить.
5) И в итоге, после всех пройденых шагов, ИЕ виснет при выборе сертификата. Удалось зайти только через Мозилу.

А тут эта новость. Задолбали!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

121. "Firefox прекращает поддержку плагинов NPAPI, за исключением ..."  +/
Сообщение от Lain_13 (ok) on 16-Окт-15, 13:13 
Поставь себе портативную версию нужной версии фокса для этих целей и запретить ему обновления. Я себе вообще виртуальную машину поставил отдельную для подключений к клиентам, чтоб она не пересекалась с интернетом и прочим на реальной, а то разного рода VPNы часто всё на себя замыкают и потом даже если какая-нибудь документация понадобится — фиг что откроеш.
Ответить | Правка | ^ к родителю #112 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру