The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от opennews on 13-Апр-16, 12:15 
В настольных и серверных сборках Ubuntu 16.04 LTS, помимо традиционных deb-пакетов, появится (https://insights.ubuntu.com/2016/04/13/snaps-for-classic-ubuntu/) возможность использования самодостаточных пакетов snap (https://developer.ubuntu.com/en/snappy/build-apps/), не связанных зависимостями с остальными компонентами дистрибутива. Поддержка установки snap-пакетов даст возможность поставлять для Ubuntu новые выпуски программ, не заботясь об обеспечении привязки к поставляемым в дистрибутиве библиотекам, поставляя актуальные приложения даже спустя несколько лет после выпуска релиза дистрибутива.


Изоляция snap-приложений от остальной системы положительно повлияет на безопасность и позволит не опасаться на возможное негативное влияние на систему установки сторонних программ. Для разработчиков использование snap-пакетов для поставки своих программ удобно из-за возможности использования любых библиотек и версий привязанных компонентов, без оглядки на состав дистрибутива. Обновление snap-контейнера целиком также позволяет повысить предсказуемость поведения приложения в различных системных конфигурациях.

URL: https://insights.ubuntu.com/2016/04/13/snaps-for-classic-ubuntu/
Новость: http://www.opennet.ru/opennews/art.shtml?num=44237

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –10 +/
Сообщение от Модификатор on 13-Апр-16, 12:15 
Расскажите им кто-нибудь про статическую компиляцию.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +7 +/
Сообщение от A.Stahl (ok) on 13-Апр-16, 12:20 
Лицензии бывают разные. Далеко не со всем можно статически слинковаться.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

7. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +7 +/
Сообщение от Аноним (??) on 13-Апр-16, 12:29 
> Лицензии бывают разные. Далеко не со всем можно статически слинковаться.

Лицензии по идее ограничивают не сам факт линковки, а распространение _вместе_ с другими продуктами. ИМХО с юридической точки зрения snap-пакет это то же самое, что и статическая линковка.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +6 +/
Сообщение от A.Stahl (ok) on 13-Апр-16, 12:33 
>а распространение _вместе_ с другими продуктами

Вовсе нет. Рядом со своей супер-пупер-проприетарной программой ты вполне можешь хранить россыпь GPL *.so библиотек. А вот статически слинковаться с ними ты уже не сможешь.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

12. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Andrey Mitrofanov on 13-Апр-16, 12:47 
>>а распространение
>можешь хранить

/0

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

41. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 14:41 
Словами отвечают только му...и? Модно формулами?
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

54. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –4 +/
Сообщение от Аноним (??) on 13-Апр-16, 15:35 
> Словами отвечают только му...и? Модно формулами?

Это называется "поделил на ноль"
</КО>

Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

80. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 17:15 
>Рядом со своей супер-пупер-проприетарной программой ты вполне можешь хранить россыпь GPL *.so библиотек.

Не можешь. Правильная формулировка из текста лицензии начинается со слов:
_пользователь_ может ...

Распространение бинарников под GPL вместе с не-GPL есть факт нарушения лицензии. Закрытая программа должна НЕ зависить от функционала GPL-либ, иначе, ты своровал код (да, именно в такой жесткой, ляля, формулировке).

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

92. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –5 +/
Сообщение от Тот_Самый_Анонимус on 13-Апр-16, 17:51 
Гнилая, всё-таки, лицензия...
Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

121. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –2 +/
Сообщение от dlazerka (ok) on 14-Апр-16, 01:18 
Пример: я записываю на один DVD мою проприетарную программу и какой-нибудь дистриб линукса (который GPL), и распространяю этот DVD. Юзер может поставить себе линукс и запускать на нём мою программу, никаких проблем.
Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

115. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Легион on 13-Апр-16, 23:32 
http://www.gnu.org/licenses/gpl-faq#IfLibraryIsGPL
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

93. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 18:00 
>Лицензии по идее ограничивают

Лол, ты вообще читал хоть раз эти лицензии?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

135. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Кармер on 14-Апр-16, 09:27 
Сериализацию  отменили ?!!
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

4. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 12:26 
Далеко не весь софт в принципе требует компиляции.
Эта вещь будет полезна для привязки к конкретной версии jdk, например. Однако само решение хранить _все_ зависимости для каждого пакета отдельно - полный бред.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

14. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 12:50 
1. этап, каждое приложение будет идти со своим jdk
2. этап, oracle придумает как так хитро запустить "отдельные" экземпляры jvm что-бы начиная со второго они начинали использовать общие ресурсы
3. этап, придумают новый "контейнизатор" что-бы отделять инстансы jdk друг от друга
4. этап, каждое приложение будет идти со своим "контейнизатором"
5. этап ....
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

32. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 13:58 
Ставить отдельную jdk с каждой софтиной? No, thanks.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

65. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –3 +/
Сообщение от Khariton (ok) on 13-Апр-16, 16:33 
вам место жалко? даже если это вопреки улучшения работы?
Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

71. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +7 +/
Сообщение от Вареник on 13-Апр-16, 17:02 
Привязка к версии жавы - это признак треша, который некому фиксить, а не "улучшения работы".
Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

81. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от XoRe (ok) on 13-Апр-16, 17:26 
> вам место жалко?

Нам жалко время на выискивание и обновление ВСЕХ копий jdk/ssl/glibc/и т.д., в которой внезапно найдут очередную уязвимость и предложат срочно обновиться.

> даже если это вопреки улучшения работы?

улучшения чьей работы, извините?

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

67. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от _ (??) on 13-Апр-16, 16:44 
Каждой аппке - свой контейнер! А уж в контейнере - жабу!
А я пока посижу на берегу реки, скоро поплывут пачками .... :)
Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

116. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Легион on 13-Апр-16, 23:33 
> Ставить отдельную jdk с каждой софтиной? No, thanks.

Расскажи это Oracle

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

130. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Вареник on 14-Апр-16, 03:30 
Проприетарщина идет лесом.
Ответить | Правка | ^ к родителю #116 | Наверх | Cообщить модератору

118. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +2 +/
Сообщение от marks on 14-Апр-16, 00:03 
>Эта вещь будет полезна для привязки к конкретной версии jdk, например.

Половина софта будет поставляться с уязвимыми версиями библиотек, как это бывало с некоторыми dll в винде.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

42. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –9 +/
Сообщение от Аноним (??) on 13-Апр-16, 14:46 
Тебя хоть и заминусовали, но дело говоришь. К всеобщему сожалению, GNUдерасты против статической линковки.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

75. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Модификатор on 13-Апр-16, 17:07 
> Тебя хоть и заминусовали, но дело говоришь. К всеобщему сожалению, GNUдерасты против
> статической линковки.

Нет, то обычная школота самоутверждается.
На минусы плевать, а остальное - sapienti sat, как говорится.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

46. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Аноним (??) on 13-Апр-16, 14:56 
Расскажи авторам glibc про статическую линковку. Потому что glibc её не умеет.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

77. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Модификатор on 13-Апр-16, 17:08 
> Расскажи авторам glibc про статическую линковку. Потому что glibc её не умеет.

Ну так оно ССЗБ.

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

55. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 15:44 
Решает только 10% из поставленных задач.

Уже сто лет в обед пора было запилить сабж. Причем простой и прозрачный для пользователя и раумеется с изоляцией и возможностью автообновления отдельных пакетов. ХЗ как это сейчас выглядит, название ничего не говорит, но обнадеживает.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

78. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Модификатор on 13-Апр-16, 17:10 
> Решает только 10% из поставленных задач.

Каких задач?
Кому и кем поставленных?
Где они сформулированы?

> Уже сто лет в обед пора было запилить сабж. Причем простой и
> прозрачный для пользователя и раумеется с изоляцией и возможностью автообновления отдельных
> пакетов. ХЗ как это сейчас выглядит, название ничего не говорит, но
> обнадеживает.

Вся эта прекрасная картину рушится, как только от админства локалхоста замаячит переход к поддержке сколько-нибудь значимого количества продуктивных систем.

Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

99. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 19:36 
Достали уже. Все о своем говорят и считают себя исключительно правыми. Для "продуктивных систем" продукты есть (часто за деньги, но они же "продуктивные"), для писюков и ноутов обычных людей продуктов нет. Во всех дистрах ворох концептуальных проблем не говоря уж о просто багах.
Задачи можешь сам сформулировать на основании логики, если таковая имеется.
Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

107. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Модификатор on 13-Апр-16, 20:35 
> Достали уже. Все о своем говорят и считают себя исключительно правыми. Для
> "продуктивных систем" продукты есть (часто за деньги, но они же "продуктивные"),
> для писюков и ноутов обычных людей продуктов нет. Во всех дистрах
> ворох концептуальных проблем не говоря уж о просто багах.
> Задачи можешь сам сформулировать на основании логики, если таковая имеется.

То есть ты сначала пишешь

> Решает только 10% из поставленных задач.

и следом в ответ на просьбу уточнить эти "поставленные задачи" предлагаешь мне же их и сформулировать самому?

И при этом тебя же и "достали уже"

Прекрасный образец.

Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

141. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 17:44 
Задачи поставил рынок или пользователи. Показатель соответствия этим требованиям для линукса нынче составляет аж 1% (рыночная доля). Дальше думай какие проблемы зависят от дистрибутива и на которые может повлиять каноникл.
Ответить | Правка | ^ к родителю #107 | Наверх | Cообщить модератору

142. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 17:46 
И да, попробуй сформулировать сам. Чем сабжевая система может быть полезна более чем стат компиляция?
Ответить | Правка | ^ к родителю #107 | Наверх | Cообщить модератору

2. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –12 +/
Сообщение от Ksaelan email on 13-Апр-16, 12:18 
Звучит неплохо. Ввести бы такую систему в rolling-release дистры и можно не боятся сломать всю систему при обновлении. Хотя это ж убунту, так что не факт, что всё будет так безоблачно. Впрочем, будем посмотреть.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –4 +/
Сообщение от Аноним (??) on 13-Апр-16, 12:27 
> Звучит неплохо. Ввести бы такую систему в rolling-release

Rolling release подразумевает невозможность использовать разные версии одной либы одновременно. Если
> ввести такую систему

это уже будет не rolling release.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

28. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 13:47 
> Rolling release подразумевает невозможность использовать разные версии одной либы одновременно.

ой-ли?

$ eix -i --format '<installedversions:NAMEASLOT>'
app-text/docbook-xml-dtd:4.1.2
app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.4
app-text/docbook-xml-dtd:4.5
dev-cpp/eigen:2
dev-cpp/eigen:3
dev-db/phpmyadmin:4.4.6.1
dev-db/phpmyadmin:4.5.3.1
dev-db/phpmyadmin:4.5.4.1
dev-db/phpmyadmin:4.5.5.1
dev-java/ant-eclipse-ecj:3.7
dev-java/ant-eclipse-ecj:4.4
dev-java/asm:3
dev-java/asm:4
dev-java/eclipse-ecj:3.7
dev-java/eclipse-ecj:4.4
dev-java/junit:0
dev-java/junit:4
dev-java/maven-bin:2.2
dev-java/maven-bin:3.0
dev-java/oracle-jdk-bin:1.7
dev-java/oracle-jdk-bin:1.8
dev-java/tomcat-servlet-api:2.5
dev-java/tomcat-servlet-api:3.0
dev-java/xml-commons-external:1.3
dev-java/xml-commons-external:1.4
dev-lang/python:2.7
dev-lang/python:3.3
dev-lang/ruby:2.0
dev-lang/ruby:2.1
dev-python/beautifulsoup:python-2
dev-python/beautifulsoup:4
dev-qt/qtcore:4
dev-qt/qtcore:5
dev-qt/qtdbus:4
dev-qt/qtdbus:5
dev-qt/qtgui:4
dev-qt/qtgui:5
dev-ruby/arel:4.0
dev-ruby/arel:7.0
dev-ruby/builder:3
dev-ruby/builder:3.1
dev-ruby/rack:1.5
dev-ruby/rack:1.6
media-libs/gst-plugins-bad:0.10
media-libs/gst-plugins-bad:1.0
media-libs/gst-plugins-base:0.10
media-libs/gst-plugins-base:1.0
media-libs/gstreamer:0.10
media-libs/gstreamer:1.0
net-libs/webkit-gtk:3
net-libs/webkit-gtk:2
net-libs/webkit-gtk:4
sys-devel/autoconf:2.1
sys-devel/autoconf:2.5
sys-devel/automake:1.11
sys-devel/automake:1.14
sys-devel/automake:1.15
sys-libs/ncurses:0
sys-libs/ncurses:5
virtual/jpeg:0
virtual/jpeg:62
virtual/libusb:0
virtual/libusb:1
www-servers/tomcat:6
www-servers/tomcat:7
x11-libs/gtk+:2
x11-libs/gtk+:3
x11-libs/wxGTK:2.8
x11-libs/wxGTK:3.0

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

56. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –3 +/
Сообщение от Аноним (??) on 13-Апр-16, 15:46 
Гента? не совсем роллинг. В итоге дефолтной будет какая-то одна мажорная версия либы на которую указывет симлинк, как и в о других дистрах.
Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

62. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +2 +/
Сообщение от SysA on 13-Апр-16, 16:21 
> Гента? не совсем роллинг. В итоге дефолтной будет какая-то одна мажорная версия
> либы на которую указывет симлинк, как и в о других дистрах.

Не совсем так, ибо каждая аппликация может использовать для себя нужную версию не взирая на дефолтную.

Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

63. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +2 +/
Сообщение от SysA on 13-Апр-16, 16:23 
>> Гента? не совсем роллинг. В итоге дефолтной будет какая-то одна мажорная версия
>> либы на которую указывет симлинк, как и в о других дистрах.
> Не совсем так, ибо каждая аппликация может использовать для себя нужную версию
> не взирая на дефолтную.

Так что Генту очень даже роллинг!..

Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

103. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 19:42 
> Так что Генту очень даже роллинг!..

В любом случае, гента - не пример общепринятых решений.

Ответить | Правка | ^ к родителю #63 | Наверх | Cообщить модератору

108. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 21:06 
- А что это за груда деталей у вас в гараже?
- А это мой автомобиль. Я его собираю и разбираю, собираю и разбираю..
- А он хоть ездил когда?
- А зачем?.. Я его разбираю и собираю, разбираю и собираю..
Ответить | Правка | ^ к родителю #103 | Наверх | Cообщить модератору

139. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 14-Апр-16, 14:51 
Генту очень даже троллинг.
Ответить | Правка | ^ к родителю #63 | Наверх | Cообщить модератору

140. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Led (ok) on 14-Апр-16, 22:23 
> Генту очень даже троллинг.

С каких это пор школопрыщинг и гвидобейсинг прировняли к троллингу?

Ответить | Правка | ^ к родителю #139 | Наверх | Cообщить модератору

128. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +2 +/
Сообщение от Anonymouz on 14-Апр-16, 02:03 
Аппликации это то, что в детском саду делают, а не то, что ты имел в виду.
Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

60. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 16:15 
И далеко не все пакеты умеют в слоты. Поставить КДЕ4 и КДЕ5 вместе не получится
Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

82. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от XoRe (ok) on 13-Апр-16, 17:28 
> И далеко не все пакеты умеют в слоты. Поставить КДЕ4 и КДЕ5
> вместе не получится

Т.е. все, кроме KDE и Gnome?
Таких мастодонтов по пальцам пересчитать.

Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

66. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 16:36 
> Rolling release подразумевает невозможность использовать разные версии одной либы одновременно.

Эмм, а обоснование? Или мы должны на слово поверить?

Наоборот, rolling release как раз подразумевает использование разных версий библиотек одновременно. Для собственно облегчения постепенной миграции с одной версии на другую. Пример: Debian Unstable.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

83. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Клыкастый (ok) on 13-Апр-16, 17:29 
> Наоборот, rolling release как раз подразумевает использование разных версий библиотек одновременно.

да вы издеваетесь

Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

84. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от XoRe (ok) on 13-Апр-16, 17:30 
> Наоборот, rolling release как раз подразумевает использование разных версий библиотек
> одновременно. Для собственно облегчения постепенной миграции с одной версии на другую.
> Пример: Debian Unstable.

Эмм, а обоснование? Или мы должны на слово поверить?

"... система плавающих релизов позволяет пользователю всегда иметь последние версии устанавливаемых программ, избавляя его от необходимости периодической переустановки системы."

https://ru.wikipedia.org/wiki/Rolling_release

Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

96. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +3 +/
Сообщение от Аноним (??) on 13-Апр-16, 18:15 
> Эмм, а обоснование?

Так приведено же: "Для собственно облегчения постепенной миграции с одной версии на другую.
Пример: Debian Unstable."

Или вы считаете, что поддержка нескольких версий библиотек не облегчает постепенную миграцию? Или в Debian Unstable нет ни одной библиотеки в нескольких версиях? Или Debian Unstable - не rolling release?

Я всегда думал, что для _некоторых_ библиотек апгрейд происходит так:

1. В дистрибутиве находится библиотека версии 1, а также, скажем, 20 программ, которые её используют.
2. Появляется версия 2 библиотеки и попадает в дистрибутив. Таким образом, в дистрибутиве одновременно сосуществуют 2 версии библиотеки.
3. Те 20 программ постепенно, одна за другой, мигрируют на библиотеку версии 2.
4. Когда все перемигрировали - выясняется, что никто больше не использует версию 1 библиотеки, она больше не нужна и её удаляют. А иногда бывает, что и не все программы мигрируют. Тогда 2 версии живут совместно довольно долго, а может и 3-я версия к тому времени появляется.

Таким образом, возможность сосуществования нескольких версий библиотек облегчает постепенную миграцию. А это значит, программы могут апгрейдиться постепенно, по порядку и с той скоростью, с которой считают нужной, а не все резко должны перейти на новую версию библиотеки. Такой постепенный, плавный апгрейд программ - и есть одно из отличий роллинг-релиза от не-роллинг, который выпускается, скажем, раз в полгода, и в котором все пакеты меняются "одномоментно".


> система плавающих релизов позволяет пользователю всегда иметь последние версии устанавливаемых программ, избавляя его от необходимости периодической переустановки системы

Ну, так не вижу противоречия. Разверните мысль, а то я так тоже могу с умным видом цитат накидать, которые ничего не доказывают.

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

145. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –2 +/
Сообщение от XoRe (ok) on 15-Апр-16, 17:55 
rolling release нацелен на то, чтобы вы получили последнюю версию конкретной программы.
Вы сами должны заботиться о миграции на такой системе.
То, что вы описали, делается не на уровне пакетов в системе, а на уровне пакетов в репе, готовых к установке.
И какую версию ставить, выбираете вы сами.

Например, как в gentoo было с libpng 1.2->1.4.
В портежах есть и 1.2 и 1.4, причем 1.4 помечена, как экспериментальная.
Хотите - разрешите её установку и пересобирите весь софт с её использованием.
Если все ок, то остаетесь на 1.4.
Если где-то сломалось, вы смотрите, критично ли это или пофиг.
Если критично, возвращаете 1.2 и перекомпилируете софт с ней.

Ответить | Правка | ^ к родителю #96 | Наверх | Cообщить модератору

53. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 15:33 
> Звучит неплохо. Ввести бы такую систему в rolling-release дистры и можно не
> боятся сломать всю систему при обновлении.

Гм, в PCBSD после долгих раздумий все-таки отказались от самодостаточных пакетов-контейнеров (PBI)
https://www.opennet.ru/opennews/art.shtml?num=40073
хотя лет 10 как минимум им пользовались.

Кстати, тогда анонимы дружно высказались, что "самодостаточне контейнеры – ненужна!"
https://www.opennet.ru/openforum/vsluhforumID3/75484.html#1

Хотя – в убунте это уже традиция. Автоплей с винды тоже пытались скопировать, пока не наступили на те же грабли https://lwn.net/Articles/427135/

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

100. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –2 +/
Сообщение от Аноним (??) on 13-Апр-16, 19:38 
> Звучит неплохо. Ввести бы такую систему в rolling-release дистры и можно не
> боятся сломать всю систему при обновлении. Хотя это ж убунту, так
> что не факт, что всё будет так безоблачно. Впрочем, будем посмотреть.

С подобной системой реализованной через правильное место роллинги будут не нужны большинству юзеров и останутся популярны лишь у тестировщиков и энтузиастов.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 12:29 
Убунта, вот тебе совет.

1). Составляешь список либ, которые чаще всего используются программами. Ну там офисных возьми (скрибус, инкскейп, опеонфис, диа, d4x, linuxdc++), блендер, вайн, трансмишон, фаерфокс, гуглхром и так далее.

2). Ну вот у тебя получилось: либпнг: 1080, либасаунд: 980, либпульс: 980, гтк:220, питон 2.7: 181, libSDL2: 35.

3). Сделай TOP-50 наиболее часто используемых библиотек, а остальные - отсеки.

4). Прежде чем выси... пускать новую версию убунты, посмотри:

а). Если libasound2 превратился в libasound3, не стирай старый libasound! Пусть лежит в lib64, как лежал! Чё те, жалко что ли! Винты сейчас измеряютяс терабайтами!

б). Если наименование либы осталось тем же - просто обновляй, как раньше.

5). Отправь проприетарщиков компилять под LTS, обещая им что в не-LTS всё будет работать без пересборки. Тыкни их носом в TOP-50 и скажи им, чтобы остальные любы таскали с бинарём, подцепляя через LD_LIBRARY_PATH в sh-скрипте запуска приложения. Или прописать в зависимостях, если в репо осталась.

Всё! И не надо изобретать велосипеды" Ред хет вон обеспечил у себя обратную совместимость, чего же "самый лучшый дистр для десктопа" не может?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 12:39 
Примерно того же хотел от них Гейб. Я помню бета-тест Steam, как запустил его в Gentoo. В тот раз пакеты emul-32 заточили до идеальной своместимости с убунтой 12.04, аж до -r13 дошли! И вот запускаю я SpaceChem, и Steam молвит мне: сейчас я запущу apt-get install mono-core, введи пароль админа. Конечно же, команда не срабатывала, т.к. не-убунту была послана "до лучших времён". Зато в убунту была тесная интеграция с репозиторием дистрибутива. Даже драйверы видеокарты проверялись там же!

Но незадолго до релиза оказалось, что Valve послала не только не-Ubuntu, но и Ubuntu 12.10 и 13.04. Часто либ в ней обновилось (со сменой ABI), а пакеты со старыми исчезли из репозиториев. Часть игр весело перестал запускаться! Так появился Steam Runtime. Идею с тесной интеграцией с репозиторием похоронили по понятным причинам.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

21. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +3 +/
Сообщение от Аноним (??) on 13-Апр-16, 13:22 
> Steam молвит мне: сейчас я запущу apt-get install mono-core, введи пароль админа. Конечно же, команда не срабатывала

То есть на приглашение левого блоба ты-таки ввёл пароль админа? Зачёт.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

24. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +2 +/
Сообщение от Аноним (??) on 13-Апр-16, 13:31 
gnomesu показывает, какая команда будет выполнена.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

87. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +2 +/
Сообщение от XXasd on 13-Апр-16, 17:38 
> gnomesu показывает, какая команда будет выполнена.

а как узнать -- запущена именно gnomesu , или же просто показана формочка внешне похожаня на gnomesu ?

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

138. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Аноним (??) on 14-Апр-16, 14:10 
> а как узнать -- запущена именно gnomesu , или же просто показана
> формочка внешне похожаня на gnomesu ?

xprop

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

143. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 17:50 
>> Steam молвит мне: сейчас я запущу apt-get install mono-core, введи пароль админа. Конечно же, команда не срабатывала
> То есть на приглашение левого блоба ты-таки ввёл пароль админа? Зачёт.

Не запускать левые блобы - решение утопическое, а вот всегда их изолировать и контролировать что они делают - жизненная необходимость. Это если мы таки хотим вылезти за пределы 1%.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

18. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 12:56 
Т.е. если выпустят libopenal.so.2, то продолжать устанавливать в дистры libopenal.so.1, зная что ни одна програ ей пользоваться не будет, и она будет сиротливо лежать в lib, никому не нужная? Зато игроделы будут знать, что либа никуда не денется в случае смены версии.

А если в TOP-50 её нет, то класть с собой.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

43. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от vhgcutdcf26n on 13-Апр-16, 14:52 
>Пусть лежит в lib64, как лежал! Чё те, жалко что ли! Винты сейчас измеряютяс терабайтами!

Ради этого ставить систему на HDD?

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 12:41 
Если кто не знал, менеджер пакетов Nix можно использовать в неродных дистрибутивах, в том числе и в убунте.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

45. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от iumnf7f5c2n on 13-Апр-16, 14:54 
Чем он лучше/хуже pkgsrc?
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

111. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 21:33 
А чем лучше или хуже сабж zeroinstall?
Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

119. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от jhkugikudgui5giugiukdb on 14-Апр-16, 01:04 
>https://en.wikipedia.org/wiki/Zero_Install
>The first time software is accessed, it is downloaded from the Internet and cached; subsequently, software is accessed from the cache.

Отстой типа Go, именно из-за внутригугловой оптимизации типа "скрипт сам всё скачает, соберёт и установит" я ещё не в IPFS.

Ответить | Правка | ^ к родителю #111 | Наверх | Cообщить модератору

158. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Анон Петрович on 26-Авг-16, 00:17 
ты кретин, это единственный способ работы (а не гемморроя с автотулс, симэйк, залупэйк) - никто не виноват, что тест сюиты для своих поделок никто не пишет. Я не про ту хрень а про го. Есть гет -д для особо не ведающих про флаг хелп.
Ответить | Правка | ^ к родителю #119 | Наверх | Cообщить модератору

11. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 12:47 
Может вернётся былая слава к Убунту.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

85. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Клыкастый (ok) on 13-Апр-16, 17:31 
> Может вернётся былая слава к Убунту.

А что с ней случилось? Как был самым массовым дистром, так и остался.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

104. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 19:44 
И снова все с винды перейдут на убунту.
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +11 +/
Сообщение от Аноним (??) on 13-Апр-16, 12:49 
Привет /Aplications/
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним email(??) on 13-Апр-16, 12:51 
Ещё бы понять как его использовать.
Документация по нему на мой взгляд неудобоваримая. Готов предъявить критерии удобоваримости, если вы заинтересованы в сотрудничестве по данному направлению.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

88. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от XXasd on 13-Апр-16, 17:39 
> Ещё бы понять как его использовать.
> Документация по нему на мой взгляд неудобоваримая. Готов предъявить критерии удобоваримости,
> если вы заинтересованы в сотрудничестве по данному направлению.

нет, мы не заинтересованы.. так что можешь не называть критерии :-)

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

16. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –3 +/
Сообщение от один из on 13-Апр-16, 12:52 
Ура! Наконец можно будет не е@ться с зависимостями при установке какого-то редкого софта.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

25. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 13:41 
Где ты, клоун, для своего редкого софта возьмёшь дивный вантузный пакет без зависимостей?
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

105. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 19:49 
> Где ты, клоун, для своего редкого софта возьмёшь дивный вантузный пакет без
> зависимостей?

Почему сразу "вантузный"? Вот читаешь вас, местных лин-олигофренов и сразу хочется в винду перезагрузиться.


Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

144. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 17:54 
>> Где ты, клоун, для своего редкого софта возьмёшь дивный вантузный пакет без
>> зависимостей?
> Почему сразу "вантузный"? Вот читаешь вас, местных лин-олигофренов и сразу хочется в
> винду перезагрузиться.

Особенно бесит категория линуксоидов для которой сохранение своего статуса элиты (1%) важнее развития и распространения самого линукса. Такие орут, что у нас и так все хорошо и лишние пользователи - лишние проблемы =) Так то оно так в плане распространения вирусов и т п, но на рынке годной свободной системы все еще нет и это печально, а 1% всегда найдет куда свалить чтобы чувствовать себя замечательно.

Ответить | Правка | ^ к родителю #105 | Наверх | Cообщить модератору

120. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от lkbiukfgiugiyuguyfk on 14-Апр-16, 01:07 
Не пакет, а виртуалку. Всё движется в эту сторону.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

26. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –4 +/
Сообщение от Аноним (??) on 13-Апр-16, 13:47 
> Ура! Наконец можно будет не е@ться с зависимостями при установке какого-то редкого софта.

Поддерживаю. Только для вчера новость, прямо-таки значительный шаг. Чем больше они приблизят дистр к Windows, тем популярнее он будет и тем интереснее его монитизировать будет, и тем быстрее прогресс. А то топтание на месте всё время, что я за Linux наблюдаю.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

36. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 14:17 
>>топтание на месте

А у Win не топтание на месте? Тоже самое. Я почти уверен, что NT со своего создания вообще не изменилось, ну разве что пару правок внесли. А не изменилось, чтобы не ломать старый софт, лол. Так что у кого топтание на месте, ещё не известно.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

49. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним (??) on 13-Апр-16, 15:17 
И у этих тоже, но они хоть бабки норм зашибают. Значит, всё-таки их правда. Если будет дешёвая альтернатива Windows - чего плохого? Вон, MacOS уже есть, многие ей даже пользуются...
Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

51. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 15:30 
>>многие

2.5 Анонимуса? Ну да, действительно.

>>бабки норм зашибают. Значит, всё-таки их правда.

Только из-за того, что они монополисты на рынке ОС, правыми они не становятся. Ничего личного, просто бизнес.

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

52. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +2 +/
Сообщение от Я. Р. Ош on 13-Апр-16, 15:32 
макосятина на порядок лучше вантуза, это да. но хуже линуха
Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

70. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от _ (??) on 13-Апр-16, 17:01 
Нет скакаль, всё - овно! Правда каждое - овно по своему.
Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

146. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 17:56 
>>>топтание на месте
> А у Win не топтание на месте? Тоже самое. Я почти уверен,

Да, они топчутся на вершине пьедестала, да еще и жесты неприличные показывают. Но мы не такие!


Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

33. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +2 +/
Сообщение от Аноним (??) on 13-Апр-16, 14:02 
Это если тебе кто-то собрал этот редкий софт в snap пакет. Вероятность для редкого софта исчезающе мала.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

64. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от скарро on 13-Апр-16, 16:24 
ох есть версия что редкософтчики скорее будут собирать снапонли.. ибо так поддерживать проще..
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

68. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Khariton (ok) on 13-Апр-16, 16:49 
> ох есть версия что редкософтчики скорее будут собирать снапонли.. ибо так поддерживать
> проще..

кстати да.

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

72. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от Аноним (??) on 13-Апр-16, 17:03 
По мне, редкий софт во многом из-за нежелания/невозможности поддерживать и становится редким. А тут еще сделать снап...
Думаю, проприентарщики оценят сей инструмент, он для них, для родных.
Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

147. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 18:06 
> По мне, редкий софт во многом из-за нежелания/невозможности поддерживать и становится редким.
> А тут еще сделать снап...
> Думаю, проприентарщики оценят сей инструмент, он для них, для родных.

Да все бы оценили (зависит от реализации конечно). В убунте почти весь софт перманентно тухлый (как и в большинстве дистров). Нормальный юзер хочет свежие версии хотя бы некоторых программ. Перед ним выбор: самообновляемый изолированный и прозрачный в работе снап (в идеале от разработчика софта) или какой-то пользовательский реп непонятного качества и безопасности, из которого подтянется еще 100500 зависимойтей, которые еще попытаются заменить штатные либы либо навалятся в системе в рандомных местах, а послезавтра реп перестанут поддерживать и надо будет искать новый. Про самосборку не заикайтесь только.

Ответить | Правка | ^ к родителю #72 | Наверх | Cообщить модератору

122. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от mvmbjhujkg on 14-Апр-16, 01:34 
Можно сделать "make install", для единичных программ некритичное засирание системы. Естественно для полсистемы прохая идея.
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

155. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от JL2001 email(ok) on 16-Апр-16, 18:13 
> Можно сделать "make install", для единичных программ некритичное засирание системы.

даже для одного пакета это уже полностью засранная система

Ответить | Правка | ^ к родителю #122 | Наверх | Cообщить модератору

98. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 18:36 
0install существует уже много-много лет и есть во всех популярных дистрибутивах, в том числе и убунте.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

112. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 21:34 
Так а почему же выбор на него не пал?
Ответить | Правка | ^ к родителю #98 | Наверх | Cообщить модератору

117. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 23:57 
У него фатальный недостаток
Ответить | Правка | ^ к родителю #112 | Наверх | Cообщить модератору

148. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним (??) on 15-Апр-16, 18:08 
> 0install существует уже много-много лет и есть во всех популярных дистрибутивах, в
> том числе и убунте.

Сам дистр должен начать поставлять в нем пакеты, привлекать внимание к этому способу распространения в т ч и разработчиков. Пользователи должны увидеть профит и научиться с этим работать.
А то, что он где-то есть - ничего не значит.

Ответить | Правка | ^ к родителю #98 | Наверх | Cообщить модератору

17. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +5 +/
Сообщение от Sunderland93 (ok) on 13-Апр-16, 12:52 
Одни пилят xdg-app, другие Snap. Опять зоопарк.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от IMHO on 13-Апр-16, 13:25 
не линукс, а в мире животных
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

23. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 13:28 
И nix рядом надвисает. А потом ещё кдешники что-нибудь выкатят, потому что в последнее время они без остановки что-то выкатывают. И ещё какое-нибудь совсем хипстерское, но достаточно популярное решение набухнет. Ух, заживём.
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

73. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –2 +/
Сообщение от _ (??) on 13-Апр-16, 17:04 
>И nix рядом надвисает.

:-D
Охххх ... Спасибо, давно так не ржал! :)

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

94. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от KOT040188 on 13-Апр-16, 18:00 
Заживать придётся очень долго…
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

19. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от SLRU email on 13-Апр-16, 13:01 
Дожили!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 13:10 
Это же просто замечательно!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

27. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от dep email on 13-Апр-16, 13:47 
Поддерживаю.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

30. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +4 +/
Сообщение от DF (??) on 13-Апр-16, 13:52 
в LTS не хотеть никакой ереси
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

31. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от фыва2 on 13-Апр-16, 13:53 
как дети малые, ей богу...
нужно бизнесу- будет внедрено...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

34. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от CrossFire on 13-Апр-16, 14:09 
А можно будет ставить в обычную систему, или только в Snappy Ubuntu Core?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

37. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 14:22 
> А можно будет ставить в обычную систему, или только в Snappy Ubuntu
> Core?

Ты хочешь пакеты по >300Мб? Хочешь, чтобы место на диске кончалось быстрее, чем успеешь установить пару софтин? Скажу по секрету, когда я сидел на Windows, у меня директория Windows набухала до 20Гб всего за неделю. Я конечно понимаю, что сейчас уже время другое, и диске по *цать ТБ, но превращать GNU/Linux в очередную GNU/kNT, нет уж, увольте.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

58. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –3 +/
Сообщение от Аноним (??) on 13-Апр-16, 16:01 
>у меня директория Windows набухала до 20Гб всего за неделю

ты софт в C:\Widows ставил? Молодец, что тут сказать.

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

76. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 17:07 
>> ты софт в C:\Widows ставил? Молодец, что тут сказать.

Умник, венда туда не даёт ставить по понятным соображениям. Весь софт в C:\Programs Files был, конечно. А в Windows она кидает бэкапы системы, после почти каждой установленной программы (!) и частично всякое дерьмо, типа .NET. Вот и разбухает директория.
З.Ы. Сразу видно, что с вендой никогда дел не имел, счастливый человек.

Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

79. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 17:11 
>А в Windows она кидает бэкапы системы, после почти каждой установленной программы (!)

Это отключабельно.

Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

97. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 18:27 
> Это отключабельно.

Я отключал, естественно. Однако пути венды неисповедимы и она даже с отключенной опцией это делает.

Ответить | Правка | ^ к родителю #79 | Наверх | Cообщить модератору

113. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 21:42 
Бэкапы в папку Windows? Да и чего там столько набэкапилось?)
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

124. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от lkhlhkljhukgukg on 14-Апр-16, 01:36 
Ну его в прорубь, не путай свои бэкапы с системными.
Ответить | Правка | ^ к родителю #113 | Наверх | Cообщить модератору

134. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 14-Апр-16, 08:54 
>>папку

...
Папок не существует, так для сведения. А то, что всякие хомячки называют директории папками ничего не меняет.
Пардон, но просто раздражает немного.

Ответить | Правка | ^ к родителю #113 | Наверх | Cообщить модератору

149. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от Аноним (??) on 15-Апр-16, 18:11 
>>>папку
> ...
> Папок не существует, так для сведения. А то, что всякие хомячки называют
> директории папками ничего не меняет.
> Пардон, но просто раздражает немного.

Щас из шкафа достану папку с файлами и в нос ткну. А то, что какие-то гики называют папки заморскими гикотерминами ничего не меняет.

Ответить | Правка | ^ к родителю #134 | Наверх | Cообщить модератору

151. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Led (ok) on 15-Апр-16, 21:35 
> Щас из шкафа достану папку с файлами и в нос ткну. А
> то, что какие-то гики называют папки заморскими гикотерминами ничего не меняет.

Иди в венду.

Ответить | Правка | ^ к родителю #149 | Наверх | Cообщить модератору

152. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Анонимный Алкоголик on 16-Апр-16, 01:01 
>>>>папку
>> ...
>> Папок не существует, так для сведения. А то, что всякие хомячки называют
>> директории папками ничего не меняет.
>> Пардон, но просто раздражает немного.
> Щас из шкафа достану папку с файлами и в нос ткну. А
> то, что какие-то гики называют папки заморскими гикотерминами ничего не меняет.

По русски тогда указатель (файлов). Или каталог.
Собственно с заморского файл - это и есть папка (с документами). Файл содержит данные.
В отличии от файла и к изумлению хомяков каталог не является контейнером, содержащим внутри файлы. Он - каталог, содержащий ссылки на них.

Ответить | Правка | ^ к родителю #149 | Наверх | Cообщить модератору

154. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от SAF0001 email on 16-Апр-16, 14:43 
Это ты скорее не знаешь о чем пишеш. Почитай про папку WinSxS прежде чем писать про Винду дальше.
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

59. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –2 +/
Сообщение от Аноним (??) on 13-Апр-16, 16:01 
>у меня директория Windows набухала до 20Гб всего за неделю

ты софт в C:\Widows ставил? Молодец, что тут сказать.

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

126. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от lnlnklnuihuig on 14-Апр-16, 01:38 
Я в этом не копенгаген, но зачем ещё Windows?
Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

132. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от CrossFire on 14-Апр-16, 08:01 
Ну на маке же работает.
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

123. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Admino (ok) on 14-Апр-16, 01:35 
Да.
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

35. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +2 +/
Сообщение от Аноним (??) on 13-Апр-16, 14:12 
Тоесть lxqt они в LTS нини - говорят нестабильна. А какую-то поделку, что из альфы за несколько дней до релиза выпустили - в добрый путь.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

38. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от anonymous (??) on 13-Апр-16, 14:24 
Зато taglib там будет 1.9.1. А это гарантированные сегфолты амарока, клементина и кучи другого софта. Вот такая вот протекающая штабильность.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

125. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Admino (ok) on 14-Апр-16, 01:36 
> Тоесть lxqt они в LTS нини - говорят нестабильна. А какую-то поделку,
> что из альфы за несколько дней до релиза выпустили - в
> добрый путь.

Snappy разработан год назад. Год, Карл!

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

39. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Дуплик (ok) on 13-Апр-16, 14:28 
А где Unity 8 на Qt 5, который обещали нам в 14.10? Ахахахаха.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

57. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Pickle on 13-Апр-16, 15:52 
На смартах и планшетах.
Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

150. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –2 +/
Сообщение от Аноним (??) on 15-Апр-16, 18:13 
> На смартах и планшетах.

А где эти смарты и планщеты?

Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

40. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +7 +/
Сообщение от Kodir (ok) on 13-Апр-16, 14:36 
Да здравствуют грабли - теперь отложенные!! Пока потный админ пытается понять, почему либа - обновилась, а дыра всё ещё не залатана, апач спокойно работает, втихаря юзая решетолиб_1.2.3 из своего маленького загашничка.
Гении! Нет слов...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

44. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +4 +/
Сообщение от Аноним (??) on 13-Апр-16, 14:53 
Нормальный админ ЭТО на пушечный выстрел не подпустит к своим серверам.
Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

89. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –2 +/
Сообщение от _ (??) on 13-Апр-16, 17:42 
Твои нормальные админы уже подпустили бубунту ... поздно пить Боржоми ... :-\
Да и потом - одним бубуньусом\виндовсом больше\меньше - на мировую энтропию это влияния не окажет ...
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

91. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Аноним (??) on 13-Апр-16, 17:49 
А для десктопа пойдет.

Например, игоры можно будет для пингвина на дисках распространять.

Все что нужно, на диске.

Хотя, кому нужны диски в 2016 году?

Но суть понятна. Можно будет иметь программы все в одном. Ничего докачивать не надо, просто ставишь и все работает. Таким образом будет хоть какая то переносимость.

А то проги от прошлой версии дистрибутива, на следующей уже могут и не заработать.

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

47. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от f1ex (ok) on 13-Апр-16, 15:00 
Мдя, то ли я что-то не понял.

в 16.04 нет пакета snappy-tools, но есть snapcraft. Т.е. пакет собрать могу, а поставить нет

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

48. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от f1ex (ok) on 13-Апр-16, 15:04 
>This version of snapcraft only works on Ubuntu 16.04 (Xenial Xerus)
>Once your Ubuntu host system is up and running, you can then install the snappy-tools package, which will in turn install the optimal selection of Snappy development software to your system.
>$ sudo apt install snappy-tools

f3ex@f3ex-work:~$ sudo apt install snappy-tools
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
E: Не удалось найти пакет snappy-tools
f3ex@f3ex-work:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu Xenial Xerus (development branch)
Release:        16.04
Codename:       xenial

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

50. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +7 +/
Сообщение от Я. Р. Ош on 13-Апр-16, 15:28 
>Изоляция snap-приложений от остальной системы положительно повлияет на безопасность

Феерично звучит. Если например появляется обновление libpng с устранением уязвимости, обновляешь её и все ок, все приложения что слинкованы с ней в безопасности, то теперь будет куча контейнеров с дырявыми версиями и пока еще автор пакета почешется.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

69. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –2 +/
Сообщение от Khariton (ok) on 13-Апр-16, 16:52 
>>Изоляция snap-приложений от остальной системы положительно повлияет на безопасность
> Феерично звучит. Если например появляется обновление libpng с устранением уязвимости,
> обновляешь её и все ок, все приложения что слинкованы с ней
> в безопасности, то теперь будет куча контейнеров с дырявыми версиями и
> пока еще автор пакета почешется.

Вот единственный разумный контраргумент.

Ну при большом желании можно линк на обновленную либу замутить, пока автор не поправил...(((

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

90. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от _ (??) on 13-Апр-16, 17:48 
> Ну при большом желании можно линк на обновленную либу замутить, пока автор не поправил...(((

Путь самурая полон боли ... (С) Микадо

Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

127. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от nkbjjivjkvyivyuv on 14-Апр-16, 01:41 
Самурай - это не синоним мазохиста. То есть он готов терпеть боль, но это не самоцель.
Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

61. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от скарро on 13-Апр-16, 16:20 
так я нипонял убунту стор выпиливают в пользу ГСЦ или нет? или это тока для убунтугномэдишн?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

74. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от phrippy email on 13-Апр-16, 17:06 
Это всё сговор интернет-провайдеров (нужно качать много раз почти одно и то же) ,  производителей жестких дисков (нужно больше места)  и разработчиков антивирусных программ (потому что эта концепция - потенциальная дыра в безопасности ОС).
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

129. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от nbbkhrkilh on 14-Апр-16, 02:06 
И им мешает Роском[Роскомнадзор]. Зачем нужен интернет-провайдер в Северной Корее?
Ответить | Правка | ^ к родителю #74 | Наверх | Cообщить модератору

86. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Анонимс on 13-Апр-16, 17:34 
Гном с Кедами это врядли, разве что тестовые версии, поставить потестить.
Большую пользу это принесет проприетарщикам, которые ноют про много-образие дистрибутивов. Так что если этот снаппи взлетит то это будет эпик вин. Проприетарь не будет гадить в системе и возможно некие криворучки начнут выпускать нормальные пакеты, неговоря уже о тех кто вообще начнет что-то выпускать, если собрать этот снаппи будет просто.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

95. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 18:06 
>Большую пользу это принесет проприетарщикам, которые ноют про много-образие дистрибутивов.  Так что если этот снаппи взлетит то это будет эпик вин.

Но ведь вся снап система пока на убунту и инфраструктура каноникла завязана и не то чтобы их сильно другие интересовали. В то время как те же xdg-app уже в федоре есть, роллинг версии опенсусе и экспериментале дебиана маринуется. Это что-то вроде вейланда и мира в итоге выйдет.

Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

102. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 13-Апр-16, 19:42 
Через Ubuntu Store ещё должно свезти что-нибудь поставить :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

131. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +/
Сообщение от Аноним (??) on 14-Апр-16, 04:29 
Сначала Linux под Виндой, теперь статическая линковка под Убунту. Хорошо так опыт перенимают в Canonical и Microsoft
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

133. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –2 +/
Сообщение от foror (ok) on 14-Апр-16, 08:44 
А почему бы не сделать гибридную систему, когда по хеш-кодам в систему вытягиваются только отсутствующие либы с сервера, а на диске пользователя часть либ "выносится за скобки"? И обновления безопасности не будут качать +100500 мегабайтов бинарей.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

136. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от Аноним (??) on 14-Апр-16, 10:32 
вы только что изобрели реестр windows
Ответить | Правка | ^ к родителю #133 | Наверх | Cообщить модератору

137. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от Priestone email(ok) on 14-Апр-16, 10:38 
Ну здравствуй, виндовс на ubuntu!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

153. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  +1 +/
Сообщение от Аноним (??) on 16-Апр-16, 10:07 
Они должны были это сделать ещё в 2004 году. Как бы они упростили многих жизнь.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

156. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от JL2001 email(ok) on 16-Апр-16, 18:14 
тот неловкий момент когда хочешь чтоб Потеринг запилил installd и вынудил всех использовать его
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

157. "В Ubuntu 16.04 обеспечена поддержка установки самодостаточны..."  –1 +/
Сообщение от DFX (ok) on 17-Апр-16, 17:51 
Welcome to The Dll Hell !
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

159. "В Ubuntu 16.04 будет обеспечена поддержка установки самодост..."  +/
Сообщение от Анон Петрович on 26-Авг-16, 00:23 
Не увидел не одного повода для радости. Кто мешает собрать .deb без зависимостей. Утилита alien существует. LSB стандарту следуют многие популярные дистрибутивы.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру