The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Доступен язык программирования Dart 1.18"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Доступен язык программирования Dart 1.18"  +/
Сообщение от opennews (??) on 28-Июл-16, 23:34 
Компания Google представила (http://news.dartlang.org/2016/07/dart-118-laying-foundations...)  выпуск языка программирования Dart 1.18 (http://www.dartlang.org/), который  позиционируется как язык структурированного программирования для Web, обладает похожим на Java синтаксисом, не требует явного определения типов и может использоваться для создания серверных и клиентских приложений. Для запуска внутри браузера код на языке Dart компилируется в представление JavaScript, для выполнения серверных приложений развивается специальная виртуальная машина Dart VM. Код связанных с языком компонентов распространяется под лицензией BSD.

Для упрощения разработки на языке Dart поставляется SDK (http://www.dartlang.org/docs/sdk/), включающий в себя компилятор в JavaScript - dart2js (http://www.dartlang.org/docs/dart2js/), виртуальную машину Dart VM (http://www.dartlang.org/docs/standalone-dart-vm/), пакетный менеджер pub (http://pub.dartlang.org/),  статический анализатор кода dart_analyzer (https://www.dartlang.org/docs/dart-up-and-running/contents/c...), набор библиотек,  интегрированная среда разработки Dart Editor (http://www.dartlang.org/docs/editor/) и плагины с поддержкой Dart для IntelliJ IDEA, WebStorm (https://www.dartlang.org/tools/webstorm/), Eclipse (https://www.dartlang.org/tools/eclipse-plugin/), Emacs (https://github.com/nex3/dart-mode), Sublime Text 2 (https://github.com/dart-lang/dart-sublime-bundle#readme) и Vim (https://github.com/dart-lang/dart-vim-plugin). Для выполнения и отладки приложений на языке Dart, без компиляции в JavaScript, предоставляется Dartium (https://www.dartlang.org/tools/dartium/) - специальная сборка браузера Chromium с интегрированной виртуальной машиной Dart VM. Дополнительные пакеты с библиотеками и утилитами распространяются через репозиторий pub (https://pub.dartlang.org/packages), который насчитывает 1565 пакетов, в том числе фреймворки для разработки web-приложений  AngularDart (https://github.com/angular/angular.dart) и polymer.dart (https://www.dartlang.org/polymer-dart/).


В новой версии проведена работа по улучшению поддержки средств разработки и runtime для создания мобильных приложений с использованием фреймворка  Flutter (https://flutter.io/). Увеличена стабильность и производительность анализатора кода. Проведена работа по доведению до финального вида таких возможностей языка, как иницилизация формальных аргументов (https://github.com/dart-lang/sdk/issues/26655) и допущение (https://github.com/dart-lang/sdk/issues/26644) указания запятых после последнего аргумента или параметра.


URL: http://news.dartlang.org/2016/07/dart-118-laying-foundations...
Новость: http://www.opennet.ru/opennews/art.shtml?num=44870

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Доступен язык программирования Dart 1.18"  +/
Сообщение от Саня (??) on 28-Июл-16, 23:34 
Почему они свой Angular 2 в первую очередь на TypeScript пишут?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Доступен язык программирования Dart 1.18"  +/
Сообщение от Илья (??) on 29-Июл-16, 04:23 
https://vsavkin.com/writing-angular-2-in-typescript-1fa77c78...
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "Доступен язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 28-Июл-16, 23:36 
И на кой он нужен?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Доступен язык программирования Dart 1.18"  +2 +/
Сообщение от dgdsgfsadfgsdfgsdfg on 28-Июл-16, 23:44 
Некоторые не принимают JS таким, какой он есть.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Доступен язык программирования Dart 1.18"  –8 +/
Сообщение от dimcha (??) on 28-Июл-16, 23:55 
Точно, поэтому люди используют cofeescript
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

9. "Доступен язык программирования Dart 1.18"  +3 +/
Сообщение от Аноним (??) on 29-Июл-16, 01:58 
Кофе не имеет своего движка внутри браузера.
В Dart есть аппаратный DartVM лишенный заразных вещей JS.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

10. "Доступен язык программирования Dart 1.18"  +2 +/
Сообщение от Аноним (??) on 29-Июл-16, 03:03 
> Кофе не имеет своего движка внутри браузера.
> В Dart есть аппаратный DartVM лишенный заразных вещей JS.

А толку от этого?

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

13. "Доступен язык программирования Dart 1.18"  +/
Сообщение от анон on 29-Июл-16, 07:41 
так в этом и плюс. кстати, кофи также лишен заразных вещей js.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

14. "Доступен язык программирования Dart 1.18"  +/
Сообщение от dimcha (??) on 29-Июл-16, 08:25 
> Кофе не имеет своего движка внутри браузера.
> В Dart есть аппаратный DartVM лишенный заразных вещей JS.

Уточните плз, где эта vm на данный момент реализована, в каких браузерах? Может я чего пропустил?

Q. Is Dart supported by my browser?
Although no production browsers can execute Dart code directly, all modern browsers can execute Dart code that’s been compiled to JavaScript. For convenience while you’re developing Dart code, you can use a version of Chromium (nicknamed Dartium) has the Dart VM integrated into it.
https://webdev.dartlang.org/faq

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

17. "Доступен язык программирования Dart 1.18"  +1 +/
Сообщение от Аноним (??) on 29-Июл-16, 12:01 
- dart2js
- серверной части Dartium
- в клиентской части Dartium
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

25. "Доступен язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 29-Июл-16, 17:18 
>> Кофе не имеет своего движка внутри браузера.
>> В Dart есть аппаратный DartVM лишенный заразных вещей JS.

Dart тоже не имеет своего движка внутри браузера.
Dartium - это не браузер.
Это для отладки ПО написанного на Dart.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

12. "Доступен язык программирования Dart 1.18"  +2 +/
Сообщение от Илья (??) on 29-Июл-16, 04:28 
> И на кой он нужен?

Чтобы вы ботинки на апельсины не пытались делить. Хотя, в конечном итоге, в рантайме вам никто ничего не гарантирует

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

15. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от artem.stecenko (ok) on 29-Июл-16, 08:43 
Не Dart Editor, а DartPad https://dartpad.dartlang.org
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 29-Июл-16, 11:06 
жаль что они пошли по пути прмежуточного звена, а не как полной альтернативы для js со встраиванием vm в chrome, на данном поприще как по мне у gopherjs есть больше шансов.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

19. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 29-Июл-16, 12:39 
Раньше так и было, но потом завернули.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Увидел свет язык программирования Dart 1.18"  +1 +/
Сообщение от Аноним (??) on 29-Июл-16, 12:12 
Разве Google не отказался от Dart? Вроде уже некоторое время coomunity project, не?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

21. "Увидел свет язык программирования Dart 1.18"  +2 +/
Сообщение от Mail on 29-Июл-16, 13:42 
Никто не подхватил капашку - пришлось самим тянуть дальше.
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

26. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 29-Июл-16, 17:20 
>> Никто не подхватил капашку - пришлось самим тянуть дальше.

Точно сказал.
Точнее некуда.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

20. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от омномномнимус on 29-Июл-16, 12:45 
Новости о релизах выходят, а что-то о применении дарта не слышно. Как так?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Увидел свет язык программирования Dart 1.18"  +1 +/
Сообщение от _ (??) on 29-Июл-16, 16:35 
А что - оно одно такое? Чему удивляЦЦо то?
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

27. "Увидел свет язык программирования Dart 1.18"  +1 +/
Сообщение от Аноним (??) on 29-Июл-16, 17:22 
>> Новости о релизах выходят, а что-то о применении дарта не слышно. Как так?

Так ведь уже ответили выше - "Никто не подхватил капашку".

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

24. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 29-Июл-16, 17:16 
Плагин с поддержкой Dart для Eclipse.
Это неправда. Не развивает его Google.
Давно уже забросили.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

28. "Увидел свет язык программирования Dart 1.18"  +/
Сообщение от Аноним (??) on 29-Июл-16, 21:32 
Проведена работа по доведению до финального вида таких возможностей языка, как инициализация формальных аргументов и допущение указания запятых после последнего аргумента или параметра.

Похоже колоссальную работу проделали - "допущение указания запятых после последнего аргумента или параметра".

Такие важные возможности языка доведены до финального вида.
Время задуматься: "А не пора ли попробовать? Хотя бы ради возможностей языка доведенных до финального вида".

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру