The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Уязвимость в платформе для создания интернет-магазинов WooCo..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Уязвимость в платформе для создания интернет-магазинов WooCo..."  +/
Сообщение от opennews (??), 08-Ноя-18, 14:16 
В WooCommerce (https://wordpress.org/plugins/woocommerce/), плагине к системе управления контентом WordPress, позволяющем создавать площадки для продажи товаров, выявлена (https://blog.ripstech.com/2018/wordpress-design-flaw-leads-t.../) уязвимость, позволяющая выполнить код на сервере и получить полный контроль за сайтом.  WooCommerce насчитывает более 4 млн установок и по статистике разработчиков используется для обеспечения работы около 30% всех интернет-магазинов в сети. Проблема устранена в выпуске WooCommerce 3.4.6 (https://woocommerce.com/).


Для эксплуатации уязвимости необходимо наличие прав менеджера торговой площадки. Отправив определённым образом оформленный запрос можно удалить произвольные файлы на сервере, насколько это позволяют полномочия, под которыми выполняется WordPress. Например, в ходе атаки можно удалить файл wp-config.php и инициировать процесс установки нового экземпляра WordPress. В ходе атаки злонамеренный сотрудник может завести новый аккаунт администратора WordPress, при помощи которого можно запустить произвольный PHP-код на сервере.


Для атаки также можно воспользоваться недоработкой в организации обработки привилегий в WordPress. На уровне плагина пользователи с правами менеджера торговой площадки имеют право только изменять учётные записи клиентов, но не имеют полномочий для изменения других аккаунтов, в том числе аккаунта администратора. При этом роль менеджера торговой площадки с правом edit_users определяется на уровне платформы WordPress и в случае отключения плагина WooCommerce, так как ограничение доступа реализовано на его уровне, менеджеры торговой площадки получают возможность редактирования профилей всех пользователей WordPress. Воспользовавшись вышеописанной уязвимостью можно удалить файл woocommerce.php и отключить таким образом плагин WooCommerce, что позволит получить права администратора и выполнить PHP-код на сервере.

URL: https://blog.ripstech.com/2018/wordpress-design-flaw-leads-t.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=49578

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Уязвимость в платформе для создания интернет-магазинов WooCo..."  +4 +/
Сообщение от Аноним (1), 08-Ноя-18, 14:16 
> Для атаки также можно воспользоваться недоработкой в организации обработки привилегий в WordPress. На уровне плагина пользователи с правами менеджера торговой площадки имеют право только изменять учётные записи клиентов, но не имеют полномочий для изменения аккаунтов администратора. При этом роль менеджера торговой площадки с правом edit_users определяется на уровне платформы WordPress и в случае отключения плагина WooCommerce, так как ограничение доступа реализовано на его уровне, менеджеры торговой площадки получают возможность редактирования профилей всех пользователей WordPress.

Это не «недоработка», а последствие использования т.н. костыля.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Уязвимость в платформе для создания интернет-магазинов WooCo..."  +1 +/
Сообщение от Вот оно че (?), 08-Ноя-18, 23:20 
А нельзя придумать для интерпретатора какой-нибудь релиз/дев режимы? Чтобы можно было запретить ненужные и потенциально опасные функции.

Например, функции записи на диск и т.д. Так сказать кастрировать интерпретатор.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Уязвимость в платформе для создания интернет-магазинов WooCo..."  +1 +/
Сообщение от DeKa (?), 08-Ноя-18, 23:49 
disable_functions string
Эта директива позволяет отключить некоторые функции по причинам безопасности. Она принимает список имен функций, разделенный запятыми. disable_functions не подвержена влиянию безопасного режима.

Только внутренние функции могут быть отключены с помощью этой директивы. Пользовательские функции ей не подвержены.

Эта директива должна быть установлена в php.ini. Например, ее нельзя использовать в httpd.conf.

disable_classes string
Эта директива позволяет отключить некоторые классы по причинам безопасности. Она принимает список имен классов, разделенных запятыми. disable_classes не подвержена влиянию безопасного режима. Эта директива должна быть установлена в php.ini. Например, ее нельзя использовать в httpd.conf.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Уязвимость в платформе для создания интернет-магазинов WooCo..."  +/
Сообщение от MVK (??), 09-Ноя-18, 10:07 
Раньше был SAFE_MODE, а начиная с PHP 5.4.0 - геморой
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "Уязвимость в платформе для создания интернет-магазинов WooCo..."  +/
Сообщение от redwolf (ok), 09-Ноя-18, 11:15 
Есть ещё Suhosin -- набор патчей на эту же тему.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Уязвимость в платформе для создания интернет-магазинов WooCo..."  +/
Сообщение от Аноним (8), 09-Ноя-18, 10:20 
>В ходе атаки злонамеренный сотрудник может завести новый аккаунт администратора WordPress, при помощи которого можно запустить произвольный PHP-код на сервере.

И потом присесть за НСД...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor