The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от opennews (??), 02-Май-19, 09:43 
В значительном выпуске системы 3D-моделирования Blender 2.80, который ожидается (https://code.blender.org/2019/04/2-80-release-plan/) в июле, разработчики расчитывали обеспечить работу с GPU, выпущенными за последние 10 лет и имеющими рабочие драйверы OpenGL 3.3. Но в ходе подготовки нового выпуска выяснилось (https://code.blender.org/2019/04/supported-gpus-in-blender-2-80/), что во мнгих OpenGL-драйверах для старых GPU имеются критические ошибки, которые не позволили обеспечить качественную поддержку всего запланированного оборудования. Отмечается, что в Linux ситуация не так критична как в Windows, так как старые драйверы в Linux продолжают обновляться, а пропритеарные драйверы в Windows остаются без сопровождения.  


В частности, для Windows не удаётся добиться корректной поддержки графических чипов AMD, выпущенных за последние 10 лет, так как для старых GPU AMD всплывают проблемы при использовании движка рендеринга Eevee из-за ошибок в драйвере Terascale, который не обновлялся уже три года. Поэтому в Windows удалось официально предоставить поддержку только GPU AMD на базе архитектуры GCN 1 (HD 7000) и более новых.


Отдельные проблемы также возникают при использовании старых GPU Intel, поэтому в  Blender 2.80 удалось гарантировать беспроблемную работу GPU только начиная с семейства Haswell, так как Windows-драйверы Intel для старых чипов  также не обновлялись уже около 3 лет и ошибки остаются неисправленными. В Linux с драйверами для старых GPU Intel проблем не возникает, так как они продолжают обновляться. Проблем нет также с GPU NVIDIA  благодаря продолжению поддержки ветки драйверов NVIDIA для устаревших устройств для всех заявленных платформ.

URL: https://www.phoronix.com/scan.php?page=news_item&px=Blender-...
Новость: https://www.opennet.ru/opennews/art.shtml?num=50613

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +11 +/
Сообщение от Аноним (1), 02-Май-19, 09:43 
осталось только еще и новые драйвера лучше поддерживать и вендокапец =D
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

62. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +8 +/
Сообщение от Канделябры (?), 03-Май-19, 00:55 
> и вендокапец

Да. Очередной. Плановый.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. Скрыто модератором  –22 +/
Сообщение от 123 (??), 02-Май-19, 10:05 
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. Скрыто модератором  +2 +/
Сообщение от Аноним (20), 02-Май-19, 12:53 
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

28. Скрыто модератором  +3 +/
Сообщение от Аноним (28), 02-Май-19, 14:18 
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

31. Скрыто модератором  –2 +/
Сообщение от аллюминь (?), 02-Май-19, 15:58 
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

36. Скрыто модератором  –10 +/
Сообщение от йож (?), 02-Май-19, 17:24 
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

37. Скрыто модератором  +1 +/
Сообщение от Пользователь (?), 02-Май-19, 17:47 
Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

39. Скрыто модератором  +8 +/
Сообщение от Аноним (-), 02-Май-19, 18:02 
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

47. Скрыто модератором  +2 +/
Сообщение от Аноним (47), 02-Май-19, 19:14 
Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

3. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –2 +/
Сообщение от Аноним (3), 02-Май-19, 10:08 
Ну так это OpenGL-драйверы. Майкрософт с ним борется на своей платформе. Например в Windows XP доступна библиотека OpenGL 2, а в Windows 7 уже OpenGL 1. Системную реализацию OpenGL использует например Intel. А NVIDIA с AMD используют свои реализации
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –6 +/
Сообщение от Аноним (9), 02-Май-19, 11:11 
> Системную реализацию OpenGL использует например Intel. А NVIDIA с AMD используют свои реализации

Ты не поверишь, под линуксом точно так же: Intel юзает mesa, а у невидии и AMD свои велосипеды.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

21. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +4 +/
Сообщение от Аноним (20), 02-Май-19, 12:57 
Во-первых, меза - это нк реализация огл, а универсальная основа. Собственная реализация, так или иначе, есть у всех вендоров.
А во вторых amdgpu основан на gallium и mesa. На сей день отличилась только нвидия, которая продолжает использовать свой переизобретенный графический стек в драйвере (включая нк то что безмесовый огл, но и даже drm)
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

29. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –2 +/
Сообщение от Аноним (3), 02-Май-19, 14:35 
> А во вторых amdgpu основан на gallium и mesa. На сей день отличилась только нвидия

С тех пор, как появился Vulkan, про Gallium все благополучно забыли.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

30. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +5 +/
Сообщение от leap42 (ok), 02-Май-19, 14:50 
лолшто? в mesa все драйвера на базе gallium, кроме i965 (современные встройки intel), только он один - classic. более того, intel в 2020 году выпустит дискретную графику и с этого момента вся новая графика intel (включая встройки) будет работать через gallium.
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

32. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от аллюминь (?), 02-Май-19, 16:00 
Драйвера пукана отдельные
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

42. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (20), 02-Май-19, 18:43 
Ну конечно, ведь вулкан моментально заменил огл прямо в момент своего появления
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

15. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +2 +/
Сообщение от Иваныч (??), 02-Май-19, 11:45 
Вот сколько помню то всегда можно на всех платформах использовать только OpenGL 1.1 не опасаясь. Далее только wglGetProcAddress/glXGetProcAddress во все поля без каких либо проблем.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

4. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –25 +/
Сообщение от Аноним (-), 02-Май-19, 10:21 
У меня прям сразу рдились слоганы:
- Лучшее устаревшее для отстающих!
- Некрофилию - некрофилам!

>Поэтому в Windows удалось официально предоставить поддержку только GPU AMD на базе архитектуры GCN 1 (HD 7000) и более новых.

Эээ, то есть я не играл в Муровинд, Готику1-2-3, КБ и кучу других 3Д игор, не юзал 3Дмакс на RadeonX1600pro c дровами от амд без каких либо глюков?

> в Blender 2.80 удалось гарантировать беспроблемную работу GPU только начиная с семейства Haswell

Блендер на HD4400=8600GT в 2019, но... зачем? Рендеринг уровня 2012 года, но... зачем? Сейчас как бэ стоит юзать не ниже RX560(+-) или GF1050(+-).

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +4 +/
Сообщение от IRASoldier (?), 02-Май-19, 11:02 
>Муровинд

- это DirectX 9, а не OpenGL.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

76. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (76), 03-Май-19, 19:17 
ага щас, 8.1
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

80. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от IRASoldier (?), 03-Май-19, 20:09 
> ага щас, 8.1

А, точно, сейчас посмотрел, что лежит в инсталляционном сидюке. Ну и 2002 год, да.


Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

12. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от Аноним (12), 02-Май-19, 11:22 
а ведь тебе явно больше 10-и лет
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

16. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +4 +/
Сообщение от Zenitur (ok), 02-Май-19, 11:52 
Ты бы ещё спросил, зачем финальный рендеринг делают на процах. Они же медленнее GPU!
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

23. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Аноним (20), 02-Май-19, 13:01 
Да никто не мешает финально рендерить на гпу, только не при помощи ogl
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

66. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +4 +/
Сообщение от й (?), 03-Май-19, 03:42 
> юзал 3Дмакс на RadeonX1600pro

я пользовал 3dsmax на компьютере с 20Мб оперативной памяти.
в качестве видеоадаптера там, кажется, был какой-то sis.

как тебе такое, илон маск?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

69. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Annoynymous (ok), 03-Май-19, 14:47 
> но... зачем?

Не всем мамка денег даёт.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

78. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +2 +/
Сообщение от Аноним (76), 03-Май-19, 19:22 
Играл. Драйвера для Radeon X1600 и windows 7 были выпущены 10-15 лет назад и будут работать пока windows 7 не сдохла (и даже после этого)
А у нас в GNU/Linux Stable API nonsense и ничего не работает :-(
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от Аноним (6), 02-Май-19, 11:00 
Отсутствие подобного бардака очень воодушевляет:
http://winitpro.ru/index.php/2017/05/17/microsoft-ogranichil.../
Психически здоровые люди радуются.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –8 +/
Сообщение от IRASoldier (?), 02-Май-19, 11:10 
Ой-вэй... Неужто на каком-нибудь асуснетбуке птичкой вспорхнёт, скажем, свежая Kubuntu и явит величие вечной поддержки фекалий мамонта? Отчего-то мне думается, что психически здоровые люди станут на некрожелезо ставить что-то навроде MX Linux или какого-нибудь подобного спецдистриба.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

22. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от vitalif (ok), 02-Май-19, 12:58 
Таки взлетает, у меня до сих пор валяется оуе пуси старое какое то с упоротым gpu, который интел но не интел

Другое дело конечно нах оно надо... удовольствие так себе

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

24. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +3 +/
Сообщение от Аноним (20), 02-Май-19, 13:03 
Интел но не интел - это, надо понимать, powervr? Открытые драйвера для них по сей день работают через пень, так что если и заводится, то с попдывшими цветами и без ускорения
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

38. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +2 +/
Сообщение от Пользователь (?), 02-Май-19, 17:52 
Для таких как ты изобрели Windows 10, Linux - для нормальных людей
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

48. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от IRASoldier (?), 02-Май-19, 19:41 
> Для таких как ты изобрели Windows 10, Linux - для нормальных людей

"Чукча комментов не читает, чукча сам комментирует!" (tm) (#дисклаймер - мы не имели в виду унизить достоинство представителей народа чукч)


Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

49. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –2 +/
Сообщение от IRASoldier (?), 02-Май-19, 19:49 
> Windows 10

UPD

Кстати, вполне нормальная десктопная ОСь. (#trollface)

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

72. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от Legionz (?), 03-Май-19, 17:30 
> Кстати, вполне нормальная десктопная ОСь. (#trollface)

фу-фу-фу!

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

63. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Канделябры (?), 03-Май-19, 01:01 
> Linux - для нормальных людей

Нуу.. ОК.. ?

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

52. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от JL2001 (ok), 02-Май-19, 20:51 
> Ой-вэй... Неужто на каком-нибудь асуснетбуке птичкой вспорхнёт, скажем, свежая Kubuntu

на ноуте 2006 свежая убунта, amd tl-56 4gb, r200 какая-то

резиновые и пластиковые элементы корпуса уже рассыпаются :( тртья замена вентилятора

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

54. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от IRASoldier (?), 02-Май-19, 20:56 
Встать-то встала, а как насчёт шустроты, вот в чём вопрос. У ThinkPad'ов тех же лет выпуска с рассыпучестью проблем поменьше, но вот вкрячивать туда имеет смысл именно что MX-подобные дистры, а не майнстрим.
Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

57. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от JL2001 (ok), 02-Май-19, 22:41 
> Встать-то встала, а как насчёт шустроты

фаерфокс, фильмы 720р, тде кмейл, рсс-читалка
но так-то больше сервером работает и удалённый запуск приложений (почтовик и рсс), а так же как гостевой ноут

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

10. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –4 +/
Сообщение от Аноним (9), 02-Май-19, 11:18 
Психически здоровые люди понимают, что M$ просто не хочет поддерживать 7 так же долго, как XP. В Linux такой проблемы не встаёт в принципе, новые драйвера в старые версии не бекпортируются. Новой железке — новое ядро. (Не, есть извращенцы типа RedHat, но это их проблемы, а я про мейнлайн.)
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

53. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +3 +/
Сообщение от IRASoldier (?), 02-Май-19, 20:52 
> Не, есть извращенцы типа RedHat

Ну, в корпоративном секторе замена железа может влететь в ну очень нехилую копеечку, так что RedHat как раз тут не извращенцы, а рыночно удовлетворяют спрос на ось, которая будет фурычить на этом железе. Бизнес же ж.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

73. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (9), 03-Май-19, 17:30 
Ты хотя бы понял, о чём я? Шляпа бекпортирует новые дрова в своё допотопное ядро. Не для того, чтобы работать на старом железе, а для того, чтобы работать и на новом тоже. На старом-то и свежие версии ядра неплохо себя чувствуют.
Ответить | Правка | ^ к родителю #53 | Наверх | Cообщить модератору

77. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от IRASoldier (?), 03-Май-19, 19:18 
> Ты хотя бы понял, о чём я? (...) а для того, чтобы работать и на новом тоже

Проглядел, бывает. Но я всё равно не понял, что тут прямо уж извращенского.

Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

13. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от segesg (?), 02-Май-19, 11:22 
Этапять!))
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

11. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Аноним (-), 02-Май-19, 11:22 
Эх, если б еще на моем ноуте с R2 графикой дровишки не зависали...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

19. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Skullnetemail (?), 02-Май-19, 12:17 
Да и современные GPU AMD и Intel лучше работают.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

25. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –4 +/
Сообщение от Аноним (25), 02-Май-19, 13:17 
Da kakie AMD i Intel,ya nedavno Void Linux i686 na celeron 1400,512 mb ram  i Matrox G450 puskal,videokarta norm rabotala pod Xorg,pravda 3d nety ibo iz Mesa davno vykinuli kod dlya matrox-ov.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

50. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +5 +/
Сообщение от Аноним (50), 02-Май-19, 20:11 
Это прекрасно. Но все же осиль setxkbmap.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

26. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от Аноним (26), 02-Май-19, 13:32 
пусть раскрывают всю инфу о железе, раз не могут проприетарные дрова выкатить
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

27. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (20), 02-Май-19, 13:51 
Было бы что раскрывать, там уже все отреверсили
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

64. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от Канделябры (?), 03-Май-19, 01:05 
И клоунские носы пусть оденут.. И ботинки разноцветные ещё!
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

34. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Аноним (34), 02-Май-19, 16:54 
какой Linux пойдёт под этот мобильный проц Intel Core Duo T2050
подскажите
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

44. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от 0ffh (??), 02-Май-19, 18:47 
этот процик лучше выкинуть - он 32 ух битный
а ему на замену за бутылку пива поставить 5600-7200 - эти 64 битные - можно будет юзать все современное по
с оговоркой на легкую тормознутость
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

46. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от 0ffh (??), 02-Май-19, 18:52 
главное тока не нахомутать с сокетом
у тебя сокет М
не купи сокет Р
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

65. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Канделябры (?), 03-Май-19, 01:07 
Я могу выпить его новый процессор залпом за 10 сек!
Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

51. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +3 +/
Сообщение от Аноним (9), 02-Май-19, 20:18 
> какой Linux пойдёт под этот мобильный проц Intel Core Duo T2050

Любой из ныне поддерживаемых: 3.16, 4.4, 4.9, 4.14, 4.19, 5.0.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

35. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +16 +/
Сообщение от Анонимemail (35), 02-Май-19, 16:56 
Опеннет странный предмет:
Недовльны, если поддержка есть,
Недовольны, если ее нет.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

95. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (95), 06-Май-19, 09:22 
Вывод если ты всем доволен не пиши на опеннет.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

43. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от gfederix (ok), 02-Май-19, 18:44 
Увы лучше чем в винде, не говорит о том, что эти драйверы хорошего качества.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

45. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +2 +/
Сообщение от 0ffh (??), 02-Май-19, 18:50 
можно добавить
у меня есть старый ноут самсунг р40
видео ати 1200
64 битных дров на винду 7 уже нет
а fgrlx все еще работает в 64 битном линухе
хотя от поддержки ати - амд отказалась после ее покупки
так что можно сказать - что для старого железа линух лучше чем винда


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

68. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (3), 03-Май-19, 12:47 
Драйвер Catalyst 9.3, значит? Чтобы он работал, надо соблюсти два условия. Это ядро Linux не новее 2.6.27 (версия которого была выбрана не случайно: это ядро с долговременной поддержкой, обновления для которого выпускались 5, что ли, лет) и X-Server не новее 1.6 (и опять же не случайно. Именно эта версия использовалась в SLES 11, а SUSE всегда славилась своим идеально вылизанным X11, за что вендоры GPU её любили)

Ты можешь установить на этот ноут Debian Lenny (там как раз ядро Linux 2.6.27), а также Ubuntu 9.04. Всё: новее ты ничего не установишь. CentOS 6.10 хоть и имеет ядро 2.6.32, а значит, в теории можно пропатчить модуль ядра fglrx (а если точнее, то "обвязку" вокруг бинарного блоба). И это уже делали: я находил пакет fglrx для Fedora 12, внутри которого были патчи, добавляющие поддержку ядра 2.6.32. Но теперь я не могу найти этот RPM-файл: ссылка на Dporbox уже 404.

А вот графический стек обновляли в CentOS 6.1, 6.2 и т.д. Сейчас там X-Server 1.19. Может тогда версию 6.0? Облом, там X-Server 1.7.7, а надо 1.6.

Как вариант, можно попробовать Ubuntu 10.04.4. Под неё много софта, а значит, можно заморочиться с драйвером Catalyst 9.3. Для этого надо пропатчить fglrx (что, как мы выяснили, мы не умеем делать), а также установить более старый X-Server 1.6 (вместо 1.7) из Ubuntu 9.10. Ты можешь поискать на Опеннете статью, как заставить работать драйвер 13.1-lecacy в Ubuntu 13.04, а драйвер 15.12 - в Ubuntu 16.04. И действовать аналогично им.

Ну, или SLES (SLED) 11. Первый релиз на ядре 2.6.27, релиз SP1 на 2.6.32. Или openSUSE 11.1, на котором базируется SLES 11. Но я сразу скажу, что это геморно. Новый софт под ним запустить можно, но очень сложно. Поэтому лучше Debian Lenny, как я и говорил в начале.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

83. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (3), 04-Май-19, 06:36 
А почему в CentOS 6 нельзя установить X-Server 1.6 из Fedora 11? Для CentOS-то софта больше. И Firefox последний сразу в комплекте
Ответить | Правка | ^ к родителю #68 | Наверх | Cообщить модератору

56. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –2 +/
Сообщение от Аноним (56), 02-Май-19, 22:26 
Но зачем сопровождать драйвера для устаревших GPU?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

58. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от axredneck (?), 02-Май-19, 23:45 
Допустим, я - пользователь винды (на самом деле нет, но допустим). Допустим, собрался я купить новый дорогой GPU. Смотрю я, значит, в интернетах, у кого с драйверами дела лучше. И покупаю Nvidia, потому что их GPU под виндой дольше не "устареет".
Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

59. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от axredneck (?), 02-Май-19, 23:51 
edit: речь идет о GPU верхнего ценового сегмента, который покупаешь надолго.
Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

70. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (70), 03-Май-19, 15:06 
GPU верхнего ценового сегмента как раз не покупаются надолго.
Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

60. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (56), 03-Май-19, 00:49 
для чего нужна дорогая GPU? чтоб тянула современные игрухи! ну вот как только она перестанет их тянуть, то нах она нужна и её поддержка?
Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

61. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Канделябры (?), 03-Май-19, 00:54 
А вот меня проблемы взБлендера вообще не волнуют.

> Сопровождение драйверов для устаревших GPU AMD и Intel в Linux оказалось лучше, чем в Windows

Чего, среди ослов закусивших удила, один я заметил явную подмену понятий?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

71. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Ordu (ok), 03-Май-19, 16:48 
> Чего, среди ослов закусивших удила, один я заметил явную подмену понятий?

Совершенно ненужная самокритика. Но да, видимо ты один. Что за подмена понятий?

Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

74. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (9), 03-Май-19, 17:37 
> А вот меня проблемы взБлендера вообще не волнуют.

А вот нас очень волнует, что же тебя не волнует. Спасибо, что держишь в курсе!

Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

67. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +1 +/
Сообщение от anonymous (??), 03-Май-19, 09:59 
> Проблем нет также с GPU NVIDIA благодаря продолжению поддержки ветки драйверов NVIDIA для устаревших устройств для всех заявленных платформ.

Что за ветка? Можно ссылку? А то у меня ядро обновить не получается, ибо новые дрова не поддерживают старое оборудование, а старые дрова не работают с новым ядром.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

75. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (76), 03-Май-19, 19:14 
Очень странно. С играми на старых, не поддерживаемых драйверах в windows никаких проблем нет, а blender не работает. Хотя может быть потому что игры на direct3d, а blender на opengl.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

79. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Ordu (ok), 03-Май-19, 19:25 
Потому что игры тестируются, и как и блендер сейчас вносят в код своих движков воркэраунды? Вон блендер начали тестировать и выяснили, что без воркэраундов никуда.

А может и потому что opengl.

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

85. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (85), 04-Май-19, 07:22 
Потому что опенсорсу все должны, а он никому ничего не должен. Это ж не царское дело, воркараунды делать.
Ответить | Правка | ^ к родителю #79 | Наверх | Cообщить модератору

86. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Ordu (ok), 04-Май-19, 09:06 
К чему ты это сказал? Править баги в драйверах на соответствие стандартам -- это дело того, кто драйвера писал. Особенно если драйвера эти идут пропиетарным блобом. И если ты знаешь какого-нибудь пропиераста, кто думает иначе, то расскажи мне о нём, вместе посмеёмся над идиотом.
Ответить | Правка | ^ к родителю #85 | Наверх | Cообщить модератору

81. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (81), 03-Май-19, 20:57 
>Проблем нет также с GPU NVIDIA благодаря продолжению поддержки ветки драйверов NVIDIA для устаревших устройств для всех заявленных платформ.

Увы, но это до поры до времени. GeForce 9500 GT скоро вообще дропнется: ядра все новее, а последний драйвер 340х, который последний раз "подрихтовали" под новые ядра где-то в мае прошлого года. Дебиан еще молодцы, у них есть nvidia-legacy. Как в других дистрах с этим не знаю. А между прочим, у меня есть еще даже GeForce 8600 GT :) Да, я могу купить новую видюху, но зачем... Как-то не хочется отправлять на свалку работающие карточки, но, чувствую, придется.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

82. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (82), 04-Май-19, 03:04 
>>Отмечается, что в Linux ситуация не так критична как в Windows, так как старые драйверы в Linux продолжают обновляться, а пропритеарные драйверы в Windows остаются без сопровождения.

В Windows проблема с дровами всегда была проблемой номер 1. Помню, при установке Windows, чтобы поставить все драйвера, приходилось возиться с ними битый час, а если каких-то драйверов не хватало на дисках, надо было скачивать нужный драйвер из Интернета. Плюс ко всему, старый драйвер для Mustek негде было найти. Еле скачал тогда.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

84. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (85), 04-Май-19, 07:20 
То ли дело линукс! Ставил подруге убунту, проблема с вайфаем решилась очень просто — заменой модуля. И хорошо, что ещё ноутбук позволил.
Ответить | Правка | ^ к родителю #82 | Наверх | Cообщить модератору

87. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от zg_nico (ok), 04-Май-19, 12:06 
Это что ж за экзотика такая стояла? Broadcom? Realtek? На модулях Intel проблемы крайне редко возникают. С Broadcom как правило достаточно дать машине интернет и
sudo ubuntu-drivers autoinstall
На realtek - там да, могут быть заморочки: сперва dkms в систему засунуть, после из репозиториев энтузиастов драйвера накатывать...
Замена самого модуля в большинстве случаев не нужна, - достаточно освоить как и где именно для него надыбать драйвер.
Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

90. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (81), 04-Май-19, 23:27 
>Ставил подруге убунту...

Ну и? Самое главное не сказал же!

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

96. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Аноним (95), 06-Май-19, 09:24 
А если бы ставил виндоуз то подруга поблагодарила тебя гораздо раньше.
Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

88. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Аноним (-), 04-Май-19, 15:35 
Ну да навреняка поддержка вида: if эта часть /пока что ещё/ не написана then рендерить софтово.
Никакого даже близкого сравнения проведено не было...
Ура ура венде капец - в линуксе есть поддержка драйверами даже при отсутствии видеочипа как такового!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

89. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от Анонимemail (89), 04-Май-19, 22:45 
Уж не знаю, что там на винде, но, товарищи коллеги, может, кто знает, есть ли возможность завести проприетарный opencl на Radeon HD 7660, на чём-нибудь более свежем, чем ubuntu 14.04?

С месой нужный софт работать отказывается.

Не то чтобы это была такая уж критическая задача, но странно делать процом то, что видяха должна уметь лучше.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

91. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от KonstantinB (ok), 05-Май-19, 06:56 
В 16.04 можно даунгрейднуть ядро до 3.19. Может, так заведется.
Ответить | Правка | ^ к родителю #89 | Наверх | Cообщить модератору

92. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +2 +/
Сообщение от Аноним (92), 05-Май-19, 09:33 
AMD болт кладут на поддержку старых видюх, очевидно, что по этой причине поддержка в линукс лучше (за счет сообщества), так как 0.00001 больше, чем 0. А интел да, молодцы
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

93. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Аноним (93), 05-Май-19, 12:02 
Зато для TeraScale3 под линуксом вообще нет поддержки критически важных OpenCL API. Результат - сложить 2 массива можно, а ни одно серьёзное приложение, будь то GIMP или hashcat, не работает.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

94. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от anonymous (??), 05-Май-19, 12:35 
Это значит лишь то, что AMD не очень хочет в HPC.
Ответить | Правка | ^ к родителю #93 | Наверх | Cообщить модератору

97. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  –1 +/
Сообщение от Аноним (97), 06-Май-19, 12:56 
Умиляют новости в стиле "мы лучше винды хоть в чем-то, хотя это все равно никому не надо"
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

98. "Сопровождение драйверов для устаревших GPU AMD и Intel в Lin..."  +/
Сообщение от anonymous (??), 06-Май-19, 22:38 
Скорее тут про обратное: в Linux наибольшее количество боли с драйверами (в сравнении с Windows) концентрировалось покруг именно GPU (ибо такие гиганты как AMD и NVidia вечно чихали на Linux во всём, что не касается HPC, и никаких вменяемых спец не предоставляют, чтобы можно было самому драйвер написать). Похожая проблема с некоторыми сетевыми устройствами (особенно WiFi), хотя тут обычно всё лечится тупо установкой firmware-файла (который в большинстве дистрибутивов есть из коробки). А тут, видимо, новость про то, что даже в GPU дела не так-то и плохи.
Ответить | Правка | ^ к родителю #97 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру