The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Доступны web-браузеры qutebrowser 2.5 и Min 1.24"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от opennews (?), 03-Апр-22, 08:43 
Опубликован релиз web-браузера qutebrowser 2.5, предоставляющего минимальный графический интерфейс, не отвлекающий от просмотра содержимого, и систему навигации в стиле текстового редактора Vim, построенную целиком на клавиатурных комбинациях. Код написан на языке Python с использованием PyQt5 и QtWebEngine. Исходные тексты распространяются под лицензией GPLv3. Применение Python не сказывается на производительности, так как отрисовка и разбор контента осуществляется силами движка Blink и библиотеки Qt...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=56957

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +3 +/
Сообщение от Kumo (?), 03-Апр-22, 08:43 
Самое то для любителей оконных менеджеров.
Ответить | Правка | Наверх | Cообщить модератору

2. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Анонимemail (2), 03-Апр-22, 08:59 
во, тоже первое на ум пришло, что идеально для мозаичных
Ответить | Правка | Наверх | Cообщить модератору

12. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +3 +/
Сообщение от Аноним (12), 03-Апр-22, 10:26 
> для любителей оконных менеджеров

Надо чтобы оконный менеджер был в окне, который в оконном менеджере, который в окне, который ...

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

26. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +4 +/
Сообщение от Аноним (26), 03-Апр-22, 12:47 
Самое НЕ ТО для любителей оконных менеджеров. Как пользователь i3 заявлю, что любая программа, сама предоставляющая "табы", не может считаться "имеющей минималистичный интерфейс", т. к. табирование окон -- это прерогатива WM, а не приложухи. Сравним с хромом: там тоже табы. А раз и тут табы, и там табы, то конкретно по "минималистичности UI" qutebrowser не подкупает, так что остается сравнивать по другим критериям, по которым qutebrowser уже проигрывает: поддержка веб-стандартов, девтулзы и все такое.

Дайте мне наконец браузер, который во-первых на блинке (лучше него нет), и который НЕ реализует концепт табов, и в котором всё по хоткеям. И который настройки хранит в текст/плейн файлах, а не как хром в какой-то бинарной черной дыре ~/.config/chromium.

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

36. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +3 +/
Сообщение от Аноним (36), 03-Апр-22, 19:53 
> qutebrowser уже проигрывает: поддержка веб-стандартов, девтулзы и все такое

Что с ними не так?
> НЕ реализует концепт табов

:set tabs.show never
> и в котором всё по хоткеям

Да, из коробки, плюс есть команда :bind, позволяющая в т.ч. биндить последовательности действий.
> И который настройки хранит в текст/плейн файлах

Да.

Ответить | Правка | Наверх | Cообщить модератору

47. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Сергей Борисович Кореневскийemail (?), 12-Май-22, 13:04 
Минималистичный браузер это способ упаковать г-но в хорошую упаковку.
Как на подобии, когда устраиваешься в компанию на работу из 10человек. А в вакансии пишут: "Наша компания самая активноразвивающаяся на рынке. Перпективы гарантировпны. Компания на рынке с 2000 года".
Какая же активноразвивающаяся но на рынке  с 2000 года.
.
С другой стороны можем рассмотреть Lite Yandex браузер для андроид.
То что он г-но это понятно, но этот браузер использует движок VebWiew самого Андроида. И таким образом он легкий как дистрибутив, и не занимает лишнего места.
Прочитал описание новости, так и не понял о каких окнах в менеджере идет речь. Могу предположить это окошко внутри браузера. И что тут такого.
"Это пригодится для любителей оконных бракзеров", звучит как "Мосфильм снял фильм го-но про войну, для любителей войны подойдет" если фильм г-но, то оно и есть го-но, его студент снял на свой андроид, причём тут война.
.
Если браузер г-но причём тут окна.
Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

33. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (33), 03-Апр-22, 13:58 
Так все программы оконные менеджеры: картинок, кин(ов), описаний исторических хроник, настроек поведенческих инстинктов менеджеров, kdeconnect..
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

3. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  –2 +/
Сообщение от _kusb (ok), 03-Апр-22, 09:25 
Серьёзно - почему браузерный движок плох для отрисовки интерфейса браузера? Просто изолировать вещи чтобы из веб-страницы не получалось обращаться к интерфейсу.
Ответить | Правка | Наверх | Cообщить модератору

41. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +2 +/
Сообщение от _kusb (ok), 03-Апр-22, 22:09 
> Серьёзно - почему браузерный движок плох для отрисовки интерфейса браузера? Просто изолировать
> вещи чтобы из веб-страницы не получалось обращаться к интерфейсу.

Очень характерно что нет ответов, но три минуса. Потому что нечего ответить, наверное. Это печально, сочувствую.

Ответить | Правка | Наверх | Cообщить модератору

46. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Анонимemail (46), 27-Апр-22, 14:57 
Плох тем, что тогда интерфейс браузера - это ещё одна тормозящяя и лагучая вещь, на которую нужно тратить ресурсы компьютера.
Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

4. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +3 +/
Сообщение от Аноним (4), 03-Апр-22, 10:02 
Qutebrowser - основной мой браузер. Начать хотя бы с того, что его конфиг - config.py - исходный код на python. То есть задание переменных, например, User-Agent можно сделать динамичным. Некоторое время делал эту переменную через fake_useragent, но этот модуль забросили.

Также браузер позволяет писать свои userscript'ы, которые являются простыми исполняемыми файлами (напоминает программирование CGI-скриптов, так же есть переменные среды $QUTE_URL и др.).

Даже python не мешает этому браузеру быть намного легче Firefox'а или Chrome, однако браузер не имеет аппаратного ускорения, поэтому воспроизводить видео лучше через внешний плеер -> How do I play Youtube videos with mpv? https://qutebrowser.org/FAQ.html

Ответить | Правка | Наверх | Cообщить модератору

18. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +3 +/
Сообщение от КО (?), 03-Апр-22, 11:05 
Браузер, который не браузит, но зато написан на офигенном языке и вообще вы не понимаете, это другое
Ответить | Правка | Наверх | Cообщить модератору

31. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +1 +/
Сообщение от Бывалый смузихлёб (?), 03-Апр-22, 13:53 
притом что использует кутёвый модуль, сделанный на базе хромиума
Ответить | Правка | Наверх | Cообщить модератору

28. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Bob (??), 03-Апр-22, 13:31 
"python не мешает этому браузеру быть намного легче Firefox'а или Chrome"
---
Ну, Lynx тоже не мешает быть намного легче чего угодно, но это не делает с оного полноценного современного вэб браузера...
Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

5. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от rvs2016 (ok), 03-Апр-22, 10:07 
> Для просмотра видео в YouTube
> можно настроить вызов внешнего видеопроигрывателя

Но как?!

Ответить | Правка | Наверх | Cообщить модератору

7. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +1 +/
Сообщение от Попандопала (?), 03-Апр-22, 10:18 
Вон ссылка вверху,от доброго анонима. Пункт 10.
Ответить | Правка | Наверх | Cообщить модератору

6. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +1 +/
Сообщение от Попандопала (?), 03-Апр-22, 10:12 
Слабоватые хоткеи, надо в вимовском стиле сделать. Эквилибристы тогда оценят.D
Ответить | Правка | Наверх | Cообщить модератору

8. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (12), 03-Апр-22, 10:21 
> в вимовском стиле

с режимами порчи и пищания.

> эквилибристы

это имаксеры, для которых даже педалей недостаточно.

Ответить | Правка | Наверх | Cообщить модератору

9. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  –1 +/
Сообщение от rvs2016 (ok), 03-Апр-22, 10:22 
> В то же время выпущена новая версия браузера Min 1.24

Как его шукать в pkg search?
А то шукаю pkg search min, а их там...

% pkg search min | wc -l
341

Лениво столько экранов всё читать...

Ответить | Правка | Наверх | Cообщить модератору

13. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (13), 03-Апр-22, 10:26 
просто загугли "min"
Ответить | Правка | Наверх | Cообщить модератору

15. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (12), 03-Апр-22, 10:38 
> % pkg search

Это фря(?). Ищи в 'www/*', например, www/firefox

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

19. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (19), 03-Апр-22, 11:12 
Во бжде электрона почти нет. Точнее есть, но не так чтобы рабочий. Возможно заработает в линуксаторе.
Ответить | Правка | Наверх | Cообщить модератору

38. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от man man (?), 03-Апр-22, 20:27 
$ ll /usr/ports/www/ni^D
nibbleblog/ nift/      
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

39. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от man man (?), 03-Апр-22, 20:34 
/mi, не /ni. my bad. впрочем, результат не сильно отличается:

> ll /usr/ports/www/min^D

mini_httpd/   miniflux/     minio-client/ minio/        miniserve/    

Ответить | Правка | Наверх | Cообщить модератору

34. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (34), 03-Апр-22, 17:02 
% pkg search -x "^min*" | wc -l

сколько показывает?

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

37. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от man man (?), 03-Апр-22, 20:26 
$ pkg search -x '^min*' | wc -l
     122
Ответить | Правка | Наверх | Cообщить модератору

42. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +1 +/
Сообщение от rvs2016 (ok), 04-Апр-22, 03:09 
> $ pkg search -x '^min*' | wc -l
>      122

Во. А у меня 55.

% freebsd-version
13.0-RELEASE-p5

% grep url /etc/pkg/FreeBSD.conf
url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly",

А у тебя 122 в какой среде?

Но 55 читать уже не сильно лениво.
Прочитал.
Там всё-равно браузера нет. Список результатов поиска тут:
https://pastebin.com/wK6RYErm

Ответить | Правка | Наверх | Cообщить модератору

10. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +3 +/
Сообщение от ИмяХ (?), 03-Апр-22, 10:24 
>>минимальный графический интерфейс, не отвлекающий от просмотра содержимого, и систему навигации в стиле текстового редактора Vim, построенную целиком на клавиатурных комбинациях

Будешь, не отвлекаясь, смотреть на клавиатуру

Ответить | Правка | Наверх | Cообщить модератору

14. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (13), 03-Апр-22, 10:27 
> Буду, не отвлекаясь, смотреть на клавиатуру

пофиксил

Ответить | Правка | Наверх | Cообщить модератору

27. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (27), 03-Апр-22, 13:07 
Это для тех кто умеет в слепую печать, если Вы к ним не относитесь, то да, для Вас это минус, а не плюс
Ответить | Правка | К родителю #10 | Наверх | Cообщить модератору

20. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +2 +/
Сообщение от Аноним (19), 03-Апр-22, 11:13 
Min - это ещё одна телеметризилла. Спрыгнул с него после добавления телеметрии.
Ответить | Правка | Наверх | Cообщить модератору

21. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  –1 +/
Сообщение от rvs2016 (ok), 03-Апр-22, 11:13 
> Qutebrowser - основной мой браузер

У меня-то основным браузером всегда был Firefox.
Но после того, как из-за нехватки ресурсов системы он стал не только тормозить, но и закрывать без предупреждения и даже без уведомления вкладки, которые считает ресурсопожирателями, то Файрфоксом в качестве основного браузера пользоваться стало совсем невозможно и пришлось основным у себя сделать qutebrowser.

Когда Файрфокс просто тормозил - это пол беды. Ну посидишь, подождёшь, пока он расшевелится и работаешь в нём кое-как дальше, хоть и медленно. Ну это как в 90-х годах неспешно запускались программы, потом в 2000-х неспешно загружались сайты, а потом пришёл Файрфокс. :-)
Но когда Файрфокс научился портить данные (а уничтожение вкладки приводит к потере ценной информации), то пользоваться таким браузером стало вообще невозможно.

Ответить | Правка | Наверх | Cообщить модератору

22. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  –1 +/
Сообщение от EuPhobos (ok), 03-Апр-22, 11:25 
Наверняка это где то отключается в about:config..
С каждым обновлением теперь приходится лазить туда и делать так, что бы просто работало по человечески, а не то, что привнесло рукожопое новшество с очередным обновлением.
Ответить | Правка | Наверх | Cообщить модератору

23. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (23), 03-Апр-22, 11:30 
Что значит "закрывать без предупреждения вкладки"? Мне приходится auto tab discard держать, чтобы он выгружал мне лишние вкладки, и он весьма ресурсоёмкий. Но они не закрываются. Я видел только сообщения о зависших аддонах (на деле они просто очень долго отрабатывают), но как можно повесить страницу? Вкладки с "ценными" данными (такими, как введённый текст) даже auto tab discard способен не выгружать. При этом, на случай падения или других ситуаций (вроде случайно нажатого хоткея, закрывшего страницу) я использую form history control (раньше был lazarus) -- на мой взгляд, это проблема все браузеров, они теряют важные данные на которые ты потратил время. И это настоящая потеря. Однако, такие аддоны сохраняют набранный текст практически во всех случаях

Чушь о производительности я комментировать не буду, ориентировочно с тех пор, как перешли на вебрендер, она возросла достаточно для того, чтобы уделывать хром, но и раньше мои проблемы были только на билдах с гтк2 (действительно запуск сессии мог занимать минуты при достаточном числе вкладок, но это баг). Всерьёз говорить о таком нельзя.

Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

32. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +2 +/
Сообщение от Бывалый смузихлёб (?), 03-Апр-22, 13:54 
ладно, фаерфокс
У сафари( мобильного ), даже когда памяти хватает но много вкладок, он умудряется их порядок каждый раз перемешивать
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

24. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +2 +/
Сообщение от Аноним (24), 03-Апр-22, 12:10 
>Перемещение по странице осуществляется при помощи клавиш "hjkl"

Клавиши со стрелками это же так не илитно.

Ответить | Правка | Наверх | Cообщить модератору

25. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +1 +/
Сообщение от Аноним (25), 03-Апр-22, 12:39 
есть еще nyxt довольно неплохой
https://nyxt.atlas.engineer
Ответить | Правка | Наверх | Cообщить модератору

30. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от Аноним (30), 03-Апр-22, 13:45 
О, как хорошо, что узнал о нем. Буду использовать как маркер. Если встречу человека, который признается, что пользуется ЭТИМ, сразу буду понимать, что передо мной интересная личность
Ответить | Правка | Наверх | Cообщить модератору

35. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  –1 +/
Сообщение от Аноним (35), 03-Апр-22, 19:08 
Без блокировщиков рекламы нет смысла, к сожалению. Давно уже без ublock origin и umatrix в интернеты не хожу
Ответить | Правка | Наверх | Cообщить модератору

40. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +1 +/
Сообщение от Блокировщик (?), 03-Апр-22, 21:36 
Есть у него блокировщик рекламы (порт блокировщика Brave).
Устанавливаешь блокировщик и кидаешь ему фильтры с adblock или ublock.
Ответить | Правка | Наверх | Cообщить модератору

43. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от qwertyuseremail (?), 04-Апр-22, 06:31 
Ютуп из коропки не может, зато ...встроенный просмотрщик PDF (pdf.js)... есть. Чтож делать то? Без просмоторщика пдф ну никак в наше время.  

...а в версии 3.0 будет прекращена поддержка многих устаревших платформ... какие они оптимистичные :)

Ответить | Правка | Наверх | Cообщить модератору

44. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  +/
Сообщение от yurikoles (ok), 04-Апр-22, 07:19 
>":w" для записи страницы

Т.е. через браузер можно делать deface страниц? Нужно проверить на whitehouse.gov

Ответить | Правка | Наверх | Cообщить модератору

45. "Доступны web-браузеры qutebrowser 2.5 и Min 1.24"  –1 +/
Сообщение от Аноним (45), 09-Апр-22, 14:43 
> QtWebEngine

Фу какая гадость. Оно ж не работает в нормальных OS.

А сборка с QtWebKit поддерживается?

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру