The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Настройка l2tp клиента"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Настройка l2tp клиента"  
Сообщение от andr email(??) on 04-Авг-07, 18:18 
Прошу помощи в настройке l2tp клиента на c851w
Написал конфиг, соединение устанавливается, но интерфейсу virtual-ppp1 не присваивается ip адрес. В чем может быть проблема?

yourname#sh run
Building configuration...

Current configuration : 3740 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default none
aaa authorization network default local
!
!
aaa session-id common
!
!
ip cef
no ip domain lookup
ip domain name yourdomain.com
l2tp-class CORBINA
!
!
!
crypto pki trustpoint TP-self-signed-4250846057
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4250846057
revocation-check none
rsakeypair TP-self-signed-4250846057
!
!
crypto pki certificate chain TP-self-signed-4250846057
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34323530 38343630 3537301E 170D3032 30333031 30323238
  34355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32353038
  34363035 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100EA28 E64836ED ABCB6C28 FA803373 F9AAB9AC 1852F656 A0AF5DAA 3832B368
  EB7DB944 C1DB8286 42AD12D6 A28F3E7D 83217504 921DF380 A9547DD4 F54FCCB3
  B34CBB6B 7C34132D 3FFD9B69 94613174 A26B62D6 DEDCD17B 5A566489 6E6A89C1
  4D505D74 331B2141 766F8C29 1ABBC272 F4E48750 D498407C 61230064 F852E33C
  D3A30203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 140B357D 7BBEC2FD F36DDF3B 12E669AC 45C5F4A8
  93301D06 03551D0E 04160414 0B357D7B BEC2FDF3 6DDF3B12 E669AC45 C5F4A893
  300D0609 2A864886 F70D0101 04050003 818100DD AED1A345 59AB86D9 0CCCE9F3
  2762AA96 9F14BCDE DEDB5DA9 80B9148D ADCBB07B 4FC22838 1F0CD2AF 260A476E
  6E4A500F 7B2F7E6C 8A132D32 BD8751F5 EF22E9FA F7F7F252 F3C15813 31698A00
  271A5725 F4EEEE93 4A15E1E8 1327C5A9 EE46A96C 2EAF0D20 534DCD23 1BEBD65D
  C33DC1B7 52A68915 F39161A2 0E27719E DB5C94
  quit
!
!
username andr privilege 15 secret 5 $1$V5Vh$CX/AktusNrvn4EgyvxQDT1
!
pseudowire-class CLASS1
encapsulation l2tpv2
ip local interface FastEthernet4
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
54.0
station-role root
!
interface Virtual-PPP1
ip address negotiated
ip nat outside
ip virtual-reassembly
no cdp enable
ppp authentication chap callout
ppp chap hostname login
ppp chap password 7 pass
pseudowire 85.21.0.19 10 pw-class CLASS1
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 192.168.88.1 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 10.0.0.0 255.0.0.0 10.84.0.17
ip route 10.0.0.0 255.255.0.0 10.84.0.17
ip route 85.21.0.19 255.255.255.255 10.84.0.17
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet4 overload
ip nat inside source list 101 interface Virtual-PPP1 overload
!
access-list 100 permit ip any any
access-list 101 permit ip any any
no cdp run
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Настройка l2tp клиента"  
Сообщение от oleg_matroskin (??) on 04-Авг-07, 19:16 
>[оверквотинг удален]
>!
>line con 0
> no modem enable
>line aux 0
>line vty 0 4
> privilege level 15
> transport input telnet ssh
>!
>scheduler max-task-time 5000
>end

я так думаю что надо vpdn включить и сделать соответствующие настройки для него!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Настройка l2tp клиента"  
Сообщение от andr email(??) on 06-Авг-07, 14:06 
>[оверквотинг удален]
>>line aux 0
>>line vty 0 4
>> privilege level 15
>> transport input telnet ssh
>>!
>>scheduler max-task-time 5000
>>end
>
>я так думаю что надо vpdn включить и сделать соответствующие настройки для
>него!

а разве vpdn не на серверной части настраивается?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Настройка l2tp клиента"  
Сообщение от Eduard_k (ok) on 05-Авг-07, 00:25 
>[оверквотинг удален]
>!
>line con 0
> no modem enable
>line aux 0
>line vty 0 4
> privilege level 15
> transport input telnet ssh
>!
>scheduler max-task-time 5000
>end

deb ppp authentication

почему кстати
ppp authentication chap callout
имхо должно быть ppp authentication chap calin

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Настройка l2tp клиента"  
Сообщение от andr email(??) on 06-Авг-07, 13:59 
>[оверквотинг удален]
>> no modem enable
>>line aux 0
>>line vty 0 4
>> privilege level 15
>> transport input telnet ssh
>>!
>>scheduler max-task-time 5000
>>end
>
>deb ppp authentication

выводит только сообщение что включен дебаг и больше ничего

>
>почему кстати
>ppp authentication chap callout
>имхо должно быть ppp authentication chap calin

если ставлю callin, то интерфейс virtual-ppp1 не поднимается
при значениии callout интерфейс поднимается, создается туннель, но не присваивается ip

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Настройка l2tp клиента"  
Сообщение от Eduard_k (ok) on 06-Авг-07, 15:54 
>[оверквотинг удален]
>>>line vty 0 4
>>> privilege level 15
>>> transport input telnet ssh
>>>!
>>>scheduler max-task-time 5000
>>>end
>>
>>deb ppp authentication
>
>выводит только сообщение что включен дебаг и больше ничего

term mon
clear vpdn tunnel l2tp all
>>
>>почему кстати
>>ppp authentication chap callout
>>имхо должно быть ppp authentication chap calin
>
>если ставлю callin, то интерфейс virtual-ppp1 не поднимается
>при значениии callout интерфейс поднимается, создается туннель, но не присваивается ip

virtual-ppp1 поднимается и находится в апе или перезагружается?
вот кстати тут мой конфиг рабочий для корбины, может поможет
http://www.opennet.ru/openforum/vsluhforumID6/12882.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру