The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"проблемы с ppp"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"проблемы с ppp"  
Сообщение от andr email(??) on 16-Сен-07, 17:57 
Всем привет!
Есть следующая проблема. Настроил циску 851w для работы с корбиной. Только вот ppp соединение создается и сразу же разрывается. Подскажите в чем грабли.

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(11)T, RELEASE SOFTWARE (fc2)


Current configuration : 3913 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication ppp default local
aaa authorization network default none
!
!
aaa session-id common
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.88.1
!
ip dhcp pool home-network
   import all
   network 192.168.88.0 255.255.255.248
   default-router 192.168.88.1
   lease 0 2
!
!
ip cef
no ip domain lookup
ip domain name yourdomain.com
ip multicast-routing
l2tp-class corbina
!
!
!
crypto pki trustpoint TP-self-signed-4250846057
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4250846057
revocation-check none
rsakeypair TP-self-signed-4250846057
!
!
crypto pki certificate chain TP-self-signed-4250846057
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34323530 38343630 3537301E 170D3032 30333032 30343338
  31385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32353038
  34363035 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100EA28 E64836ED ABCB6C28 FA803373 F9AAB9AC 1852F656 A0AF5DAA 3832B368
  EB7DB944 C1DB8286 42AD12D6 A28F3E7D 83217504 921DF380 A9547DD4 F54FCCB3
  B34CBB6B 7C34132D 3FFD9B69 94613174 A26B62D6 DEDCD17B 5A566489 6E6A89C1
  4D505D74 331B2141 766F8C29 1ABBC272 F4E48750 D498407C 61230064 F852E33C
  D3A30203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 140B357D 7BBEC2FD F36DDF3B 12E669AC 45C5F4A8
  93301D06 03551D0E 04160414 0B357D7B BEC2FDF3 6DDF3B12 E669AC45 C5F4A893
  300D0609 2A864886 F70D0101 04050003 818100CA 1E312519 BCB2AC6E F7CD2DB4
  0C3212C4 8D1FE19B D36D9E05 21BB88B8 D5D315FD 72240036 FADC57A7 C2854E40
  5D40B9EE A7CA261A 2AF9F53A F4AECB4A 80E94FE1 6052B74C D3EC1F6A EE805418
  45E57D35 FE94BC6C 31290EEA 37FF9CED A68E1BAE A60DF2B2 75B9A0F6 FFDEB83B
  8FB55282 163E9BDD 8419116A 7BB6BC06 634C3D
  quit
!
!
username andr privilege 15 secret 5 $1$C/0v$6dI/q/892mXlwfNECKhwT/
!
pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet4
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Virtual-PPP1
ip address negotiated
ip nat outside
ip virtual-reassembly
no cdp enable
ppp authentication chap callin
ppp chap hostname ******
ppp chap password 0 ******
pseudowire 85.21.151.142 10 pw-class class1
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 192.168.88.1 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 10.0.0.0 255.0.0.0 10.84.0.17
ip route 85.21.0.19 255.255.255.255 10.84.0.17
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet4 overload
ip nat inside source list 101 interface Virtual-PPP1 overload
!
access-list 100 permit ip any any
access-list 101 permit ip any any
no cdp run
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
end

по deb ppp auth и deb ppp neg
пишет следующее:

*Mar  2 02:36:30.363: Vp1 LCP: State is Listen
*Mar  2 02:36:31.395: Vp1 LCP: I CONFREQ [Listen] id 1 len 19
*Mar  2 02:36:31.395: Vp1 LCP:    MRU 1464 (0x010405B8)
*Mar  2 02:36:31.395: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  2 02:36:31.395: Vp1 LCP:    MagicNumber 0x7D4F8B53 (0x05067D4F8B53)
*Mar  2 02:36:31.395: Vp1 LCP: Dropping packet, state is Listen
*Mar  2 02:36:32.363: Vp1 LCP: Timeout: State Listen
*Mar  2 02:36:32.363: Vp1 PPP: Authorization required
*Mar  2 02:36:32.363: Vp1 PPP: No remote authentication for call-out
*Mar  2 02:36:32.363: Vp1 LCP: O CONFREQ [Listen] id 141 len 10
*Mar  2 02:36:32.363: Vp1 LCP:    MagicNumber 0x16C20FB0 (0x050616C20FB0)
*Mar  2 02:36:32.363: Vp1 LCP: I CONFACK [REQsent] id 141 len 10
*Mar  2 02:36:32.363: Vp1 LCP:    MagicNumber 0x16C20FB0 (0x050616C20FB0)
*Mar  2 02:36:33.415: Vp1 LCP: I CONFREQ [ACKrcvd] id 2 len 19
*Mar  2 02:36:33.415: Vp1 LCP:    MRU 1464 (0x010405B8)
*Mar  2 02:36:33.415: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  2 02:36:33.415: Vp1 LCP:    MagicNumber 0x7D4F8B53 (0x05067D4F8B53)
*Mar  2 02:36:33.415: Vp1 LCP: O CONFNAK [ACKrcvd] id 2 len 8
*Mar  2 02:36:33.415: Vp1 LCP:    MRU 1500 (0x010405DC)
*Mar  2 02:36:33.415: Vp1 LCP: I CONFREQ [ACKrcvd] id 3 len 19
*Mar  2 02:36:33.415: Vp1 LCP:    MRU 1500 (0x010405DC)
*Mar  2 02:36:33.415: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  2 02:36:33.415: Vp1 LCP:    MagicNumber 0x7D4F8B53 (0x05067D4F8B53)
*Mar  2 02:36:33.415: Vp1 LCP: O CONFACK [ACKrcvd] id 3 len 19
*Mar  2 02:36:33.419: Vp1 LCP:    MRU 1500 (0x010405DC)
*Mar  2 02:36:33.419: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  2 02:36:33.419: Vp1 LCP:    MagicNumber 0x7D4F8B53 (0x05067D4F8B53)
*Mar  2 02:36:33.419: Vp1 LCP: State is Open
*Mar  2 02:36:33.419: Vp1 PPP: No authorization without authentication
*Mar  2 02:36:33.419: Vp1 PPP: Phase is AUTHENTICATING, by the peer
*Mar  2 02:36:33.443: Vp1 CHAP: I CHALLENGE id 1 len 27 from "bras19"
*Mar  2 02:36:33.447: Vp1 CHAP: Using hostname from interface CHAP
*Mar  2 02:36:33.447: Vp1 CHAP: Using password from interface CHAP
*Mar  2 02:36:33.447: Vp1 CHAP: O RESPONSE id 1 len 29 from "andr1983"
*Mar  2 02:36:33.487: Vp1 CHAP: I SUCCESS id 1 len 4
*Mar  2 02:36:33.487: Vp1 PPP: Phase is FORWARDING, Attempting Forward
*Mar  2 02:36:33.487: Vp1 PPP: Queue IPCP code[1] id[1]
*Mar  2 02:36:33.487: Vp1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar  2 02:36:33.491: Vp1 PPP: Phase is UP
*Mar  2 02:36:33.491: Vp1 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar  2 02:36:33.491: Vp1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar  2 02:36:33.491: Vp1 PPP: Process pending ncp packets
*Mar  2 02:36:33.491: Vp1 IPCP: Redirect packet to Vp1
*Mar  2 02:36:33.491: Vp1 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  2 02:36:33.491: Vp1 IPCP:    Address 85.21.0.19 (0x030655150013)
*Mar  2 02:36:33.491: Vp1 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  2 02:36:33.491: Vp1 IPCP:    Address 85.21.0.19 (0x030655150013)
*Mar  2 02:36:33.519: Vp1 IPCP: I CONFNAK [ACKsent] id 1 len 10
*Mar  2 02:36:33.519: Vp1 IPCP:    Address 78.107.253.1 (0x03064E6BFD01)
*Mar  2 02:36:33.519: Vp1 IPCP: O CONFREQ [ACKsent] id 2 len 10
*Mar  2 02:36:33.519: Vp1 IPCP:    Address 78.107.253.1 (0x03064E6BFD01)
*Mar  2 02:36:33.527: Vp1 IPCP: I CONFACK [ACKsent] id 2 len 10
*Mar  2 02:36:33.527: Vp1 IPCP:    Address 78.107.253.1 (0x03064E6BFD01)
*Mar  2 02:36:33.527: Vp1 IPCP: State is Open
*Mar  2 02:36:33.527: Vp1 IPCP: Install negotiated IP interface address 78.107.253.1
*Mar  2 02:36:33.531: Vp1 IPCP: Install route to 85.21.0.19
*Mar  2 02:36:33.535: Vp1 PPP: Sending Acct Event[Down] id[F0]
*Mar  2 02:36:33.535: Vp1 IPCP: State is Closed
*Mar  2 02:36:33.535: Vp1 PPP: Phase is TERMINATING
*Mar  2 02:36:33.535: Vp1 LCP: O TERMREQ [Open] id 142 len 4
*Mar  2 02:36:33.539: Vp1 PPP: Outbound ip packet dropped
*Mar  2 02:36:33.551: Vp1 IPCP: Remove route to 85.21.0.19
*Mar  2 02:36:35.531: Vp1 LCP: Timeout: State TERMsent
*Mar  2 02:36:35.531: Vp1 LCP: O TERMREQ [TERMsent] id 143 len 4
*Mar  2 02:36:35.531: Vp1 LCP: I TERMACK [TERMsent] id 143 len 4
*Mar  2 02:36:35.531: Vp1 LCP: State is Closed
*Mar  2 02:36:35.531: Vp1 PPP: Phase is DOWN
*Mar  2 02:36:35.535: Vp1 PPP: Phase is ESTABLISHING, Passive Open
*Mar  2 02:36:35.535: Vp1 LCP: State is Listen

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "проблемы с ppp"  
Сообщение от StarWoofy email(??) on 18-Сен-07, 00:06 
по поводу похожей проблемы, мне порекомендовали ios 12.4.9T3
Пока в поиске...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "проблемы с ppp"  
Сообщение от andr email(??) on 21-Сен-07, 12:54 
>по поводу похожей проблемы, мне порекомендовали ios 12.4.9T3
>Пока в поиске...

спасибо за совет
сегодня вечером буду пробовать
если нужен 12.4.Т9 выложил на рапиду
http://rapidshare.com/files/57177899/c850-advsecurityk9-mz.124-9.T3.bin.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "проблемы с ppp"  
Сообщение от Eduard_k (ok) on 21-Сен-07, 13:03 
>>по поводу похожей проблемы, мне порекомендовали ios 12.4.9T3
>>Пока в поиске...
>
>спасибо за совет
>сегодня вечером буду пробовать
>если нужен 12.4.Т9 выложил на рапиду
>http://rapidshare.com/files/57177899/c850-advsecurityk9-mz.124-9.T3.bin.html

попробуйте  ip route 85.21.151.142 255.255.255.255 10.84.0.17
хотя в доках и написано, что ip local interface FastEthernet4 достаточно, но у меня не заработало, до тех пор, пока не указал в явном виде маршрут на l2tp сервер.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "проблемы с ppp"  
Сообщение от andr email(??) on 21-Сен-07, 18:20 
>[оверквотинг удален]
>>
>>спасибо за совет
>>сегодня вечером буду пробовать
>>если нужен 12.4.Т9 выложил на рапиду
>>http://rapidshare.com/files/57177899/c850-advsecurityk9-mz.124-9.T3.bin.html
>
>попробуйте  ip route 85.21.151.142 255.255.255.255 10.84.0.17
>хотя в доках и написано, что ip local interface FastEthernet4 достаточно, но
>у меня не заработало, до тех пор, пока не указал в
>явном виде маршрут на l2tp сервер.

маршрут прописывал - не помогает
у меня в конфиге прописан ip route на 85.21.0.19 (тоже их l2tp сервере),
просто перед тем как постить конфиг в pseudowire указал другой l2tp сервер,
а про роут забыл.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "проблемы с ppp"  
Сообщение от StarWoofy email(ok) on 21-Сен-07, 15:49 
На форуме sysadmins.ru в теме workman выложен конфиг который работает (я им воспользовался).
http://forum.sysadmins.ru/32/176772/?start=0&postdays=0&postorder=asc&highlight=

Там и образец для настройки wifi тоже есть.

ps. пока на Fe4 не был явно задан адрес (без всякого dhcp)
у меня с PC ничего не работало.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "проблемы с ppp"  
Сообщение от andr email(??) on 21-Сен-07, 18:22 
>На форуме sysadmins.ru в теме workman выложен конфиг который работает (я им
>воспользовался).
>http://forum.sysadmins.ru/32/176772/?start=0&postdays=0&postorder=asc&highlight=
>
>Там и образец для настройки wifi тоже есть.

как раз по этому конфигу я и делал.

>
>ps. пока на Fe4 не был явно задан адрес (без всякого dhcp)
>
>у меня с PC ничего не работало.

спасибо, сегодня вечером попробую


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру