The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"загрузка проца 2821 при Full BGP. Help!!!"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid email(ok) on 13-Дек-07, 16:28 
Доброе время суток!
Была тут на форуме тема о том, что 2821 с гигом памяти тянет 1-2 Full BGP.

Я мож чё-нить не даганяю, но у меня 1 Full BGP забивает проц под горлышко.
Подскажите мож что в конфиге поправить?
Я уже и префиксы до /24 порезал, всё равно загрузка периодически под завязку,
когда 2821 перечитывает таблицу.

---------------------------------------------------------------------------
ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
Cisco 2821 (revision 53.51) with 1036288K/12288K bytes of memory.
Processor board ID FCZ11327019
2 Gigabit Ethernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
239K bytes of non-volatile configuration memory.
125184K bytes of ATA CompactFlash (Read/Write)

                Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
Processor   45034840   977057728    81682440   895375288   783363492   781401320

CPU utilization for five seconds: 99%/0%; one minute: 73%; five minutes: 78%

interface GigabitEthernet0/0
ip address 212.1.1.2 255.255.255.252
ip accounting output-packets
duplex auto
speed auto
random-detect
!
interface GigabitEthernet0/1
ip address 193.2.2.2 255.255.255.224
ip accounting output-packets
duplex auto
speed auto
random-detect
!
router bgp 77777
no synchronization
bgp default local-preference 2000
bgp log-neighbor-changes
bgp dampening
bgp scan-time 60
network 193.2.2.0 mask 255.255.254.0  # мои PI адреса
redistribute connected
neighbor 195.3.3.3 remote-as 66666  # AS вышестоящего прова
neighbor 195.3.3.3 description ### P-t-P BGP
neighbor 195.3.3.3 ebgp-multihop 9
neighbor 195.3.3.3 update-source GigabitEthernet0/0
neighbor 195.3.3.3 version 4
neighbor 212.1.1.1 remote-as 66666
neighbor 212.1.1.1 description ### PtP на вышестоящего прова
neighbor 212.1.1.1 version 4
neighbor 212.1.1.1 timers 30 90
neighbor 212.1.1.1 remove-private-as
neighbor 212.1.1.1 prefix-list Net in
neighbor 212.1.1.1 prefix-list AS77777 out
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 212.1.1.1
ip route 193.2.2.0 255.255.254.0 Null0
!
!
ip prefix-list AS77777 seq 10 permit 193.2.2.0/23
!
ip prefix-list Net seq 10 permit 0.0.0.0/0 ge 24

----------------------------------------------------------------

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от seducer (??) on 13-Дек-07, 16:59 
Покажите:
sh ver
sh proc mem (первые 3 строчки)
sh proc cpu sor - во время полной загрузки
sh proc cpu sor | i BGP Scanner

Был у меня 3725 с 2 fullview,20 мб траффика,загрузка 60-80%,там много чего крутилось,но загружал роутер больше всех "BGP Scanner" который отрабатывает каждые 60 сек. Побороть его резкой префиксов тоже не удалось,но проблема решилась с переходом на G2. Может вы упёрлись в мощность роутера.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 13-Дек-07, 22:30 
#sho ver
Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(12), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Fri 17-Nov-06 12:02 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Astra-BGP uptime is 3 days, 14 hours, 39 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-adventerprisek9-mz.124-12.bin"

Cisco 2821 (revision 53.51) with 1036288K/12288K bytes of memory.
Processor board ID FCZ11327019
2 Gigabit Ethernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
239K bytes of non-volatile configuration memory.
125184K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

#sho proc mem
Processor Pool Total:  977057728 Used:  171392716 Free:  805665012
      I/O Pool Total:   12582912 Used:    5294656 Free:    7288256

PID TTY  Allocated      Freed    Holding    Getbufs    Retbufs Process
   0   0   33677700    7934080   17445872        656       5396 *Init*

#sho proc cpu sor
CPU utilization for five seconds: 99%/0%; one minute: 84%; five minutes: 79%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  98    11871388     69910     169814 43.33% 44.45% 40.69%   0 IP RIB Update
162     8909516    257068      34658 43.17% 30.79% 28.36%   0 BGP Router
214     1955464     16027     122010 11.11%  7.26%  6.74%   0 BGP Scanner
   5      387960     37088      10460  1.13%  0.75%  0.61%   0 Check heaps
119         580    609441          0  0.08%  0.02%  0.00%   0 DHCPD Receive

#sho proc cpu sor | i BGP Scanner
214     1961976     16063     122142  0.00%  6.23%  6.55%   0 BGP Scanner
#sho proc cpu sor | i BGP Scanner
214     1962176     16064     122147 19.14%  7.35%  6.78%   0 BGP Scanner
#sho proc cpu sor | i BGP Scanner
214     1962376     16065     122152  4.11%  6.84%  6.69%   0 BGP Scanner
#sho proc cpu sor | i BGP Scanner
214     1962548     16066     122155  3.53%  6.58%  6.64%   0 BGP Scanner

>Может вы упёрлись в мощность роутера.

Врядли. Канал 10Мбит, роутер сейчас вообще пустой. Канал в тестовом режиме, трафик - только анонсы BGP и всё.

Причём такая загрузка в момент, когда 2821 перечитывает таблицу. В общем крыша уже едет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Аноним on 14-Дек-07, 01:55 
>[оверквотинг удален]
>    122155  3.53%  6.58%  6.64%
>  0 BGP Scanner
>
>>Может вы упёрлись в мощность роутера.
>
>Врядли. Канал 10Мбит, роутер сейчас вообще пустой. Канал в тестовом режиме, трафик
>- только анонсы BGP и всё.
>
>Причём такая загрузка в момент, когда 2821 перечитывает таблицу. В общем крыша
>уже едет.

это справедливо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 07:12 
>>[оверквотинг удален]
>>    122155  3.53%  6.58%  6.64%
>>  0 BGP Scanner
>>
>>>Может вы упёрлись в мощность роутера.
>>
>>Врядли. Канал 10Мбит, роутер сейчас вообще пустой. Канал в тестовом режиме, трафик
>>- только анонсы BGP и всё.
>
>это справедливо.

Справедливо что?
Я спрашиваю у спецов как исправить, если возможно.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от seducer (??) on 14-Дек-07, 08:39 
>Причём такая загрузка в момент, когда 2821 перечитывает таблицу. В общем крыша
>уже едет.

Когда роутер принимает таблицу BGP такая загрузка это нормально,процесс можно посмотреть sh ip bgp sum,после получения всех префиксов на данный момент 236xxx загрузка должна нормализоваться.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 09:19 
>Когда роутер принимает таблицу BGP такая загрузка это нормально,процесс можно посмотреть sh
>ip bgp sum,после получения всех префиксов на данный момент 236xxx загрузка
>должна нормализоваться.
>
>http://www.cisco.com/en/US/tech/tk365/technologies_tech_note...

Когда первый раз получает - согласен, но в процессе работы 2821 получает короткие апдейты и там загрузка небольшая.  Сам роутер примерно раз в 30 секунд перепрочитывает свою таблицу и при этом загрузка под 100%. Таблицу перепрочитает и опять на 30 секунд загрузка 3-8%

#sho proc cpu sor
CPU utilization for five seconds: 99%/0%; one minute: 62%; five minutes: 65%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
162    19302828    364093      53016 44.79% 37.21% 36.35%   0 BGP Router
  98    26067548    147459     176781 34.91% 15.23% 19.82%   0 IP RIB Update
214     4324360     29154     148328 20.76%  8.32%  7.67%   0 BGP Scanner


#sho proc cpu sor
CPU utilization for five seconds: 6%/0%; one minute: 64%; five minutes: 66%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
162    19330576    364567      53024  5.65% 39.46% 37.67%   0 BGP Router
164       15884     61977        256  0.40%  0.36%  0.24%   0 BGP I/O
  77       80400    466396        172  0.16%  0.18%  0.14%   0 IP Input
   2        1024     70266         14  0.08%  0.02%  0.00%   0 Load Meter

И такая загрузка прыгает раз в 30 секунд.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от seducer (??) on 14-Дек-07, 09:31 
Покажите на всякий случай "sh run"
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от seducer (??) on 14-Дек-07, 10:06 
Да еще покажите:
show ip bgp neighbors | include max data
и
sh int интерфейса через кот приходит BGP,есть ли у вас там дропы

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 12:07 
>Да еще покажите:
>show ip bgp neighbors | include max data

>sh int интерфейса через кот приходит BGP,есть ли у вас там дропы

#sho run  (Было сверху, дублирую ещё раз, потому как что-то менял, пробывал
по разному. Не помогает пока.)

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname хххххххх
!
boot-start-marker
boot-end-marker
!
enable secret хххххххххххххх
enable password ххххххххххх
!
no aaa new-model
!
no ip cef
!
ip domain name ххххххх
ip name-server ххххххх
!
username хххххххххх

interface GigabitEthernet0/0
ip address 212.1.1.2 255.255.255.252
ip accounting output-packets
duplex auto
speed auto
random-detect
!
interface GigabitEthernet0/1
ip address 193.2.2.2 255.255.255.224
ip accounting output-packets
duplex auto
speed auto
random-detect
!
router bgp 77777
no synchronization
bgp default local-preference 2000
no bgp log-neighbor-changes
neighbor 195.3.3.3 remote-as 66666  # AS вышестоящего прова
neighbor 195.3.3.3 description ### P-t-P BGP
neighbor 195.3.3.3 ebgp-multihop 9
neighbor 195.3.3.3 update-source GigabitEthernet0/0
neighbor 195.3.3.3 version 4
neighbor 212.1.1.1 remote-as 66666
neighbor 212.1.1.1 description ### PtP на вышестоящего прова
neighbor 212.1.1.1 version 4
neighbor 212.1.1.1 timers 30 90
bgp dampening
bgp scan-time 60
!
address-family ipv4
redistribute connected
redistribute static
neighbor 195.3.3.3 activate
neighbor 212.1.1.1 activate
neighbor 212.1.1.1 remove-private-as
neighbor 212.1.1.1 prefix-list Net in
neighbor 212.1.1.1 prefix-list AS77777 out
no auto-summary
!
network 193.2.2.0 mask 255.255.254.0  # мои PI адреса
ip route 0.0.0.0 0.0.0.0 212.1.1.1
ip route 193.2.2.0 255.255.254.0 Null0
!
ip prefix-list AS77777 seq 10 permit 193.2.2.0/23
!
ip prefix-list Net seq 10 permit 0.0.0.0/0 ge 24
!
-----------------------------------------------------------------------

#sho interface GigabitEthernet0/0
GigabitEthernet0/0 is up, line protocol is up
  Hardware is MV96340 Ethernet, address is x.x.x (bia x.x.x)
  Internet address is 212.1.1.0/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is T
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: random early detection(RED)
  5 minute input rate 10000 bits/sec, 12 packets/sec
  5 minute output rate 143000 bits/sec, 10 packets/sec
     50139681 packets input, 169999992 bytes, 0 no buffer
     Received 18275 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     53658178 packets output, 2656783798 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

------------------------------------------------------------------------------

#show ip bgp neighbors | include max data
Datagrams (max data segment is 536 bytes):
Datagrams (max data segment is 1460 bytes):

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от seducer (??) on 14-Дек-07, 12:23 
Сразу на вскидку,а что у вас ip cef отключин?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Аноним on 14-Дек-07, 12:33 
>Сразу на вскидку,а что у вас ip cef отключин?

потомучто он дибил.
на 28хх с bgp FV делать нечего.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 12:59 
>>Сразу на вскидку,а что у вас ip cef отключин?
>
>потомучто он дибил.
>на 28хх с bgp FV делать нечего.

ананий, базар фильтруй, умник.

http://www.opennet.ru/openforum/vsluhforumID6/13407.html

в архиве поройся, тема взята не с потолка.
у людей работает, во всяком случае пишут что работает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от seducer (??) on 14-Дек-07, 13:00 
Нечего криминального в конфиге не увидел,но ip cef всетки включите
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 12:55 
>Сразу на вскидку,а что у вас ip cef отключин?

С включенным тоже самое.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Аноним on 14-Дек-07, 13:11 
>>Сразу на вскидку,а что у вас ip cef отключин?
>
>С включенным тоже самое.

cef - это экспресс коммутация и к процессу BGP не имеет отношения.

смотрите  процесс IP RIB update берет много ресурсов - а так недолжно быть "по-идеи" у меня на 7200/g1 оно пролетает за мгновения
покажите в момент загрузки
sh mem
sh buf

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 13:20 
>[оверквотинг удален]
>
>cef - это экспресс коммутация и к процессу BGP не имеет отношения.
>
>
>смотрите  процесс IP RIB update берет много ресурсов - а так
>недолжно быть "по-идеи" у меня на 7200/g1 оно пролетает за мгновения
>
>покажите в момент загрузки
>sh mem
>sh buf

Больше всего потребляют 2 процесса IP RIB UPDATES  и  BGP ROUTER
Они всё и отъедают.

#sho mem
                Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
Processor   45034840   977057728    84313672   892744056   783002504   790453560
      I/O   3F400000    12582912     5325656     7257256     7224784     7227612


P#sho buf
Buffer elements:
     1117 in free list (1119 max allowed)
     2862406 hits, 0 misses, 619 created

Public buffer pools:
Small buffers, 104 bytes (total 62, permanent 50, peak 217 @ 05:34:43):
     59 in free list (20 min, 150 max allowed)
     1242455 hits, 118 misses, 176 trims, 188 created
     0 failures (0 no memory)
Middle buffers, 600 bytes (total 57, permanent 25, peak 61 @ 00:31:47):
     50 in free list (10 min, 150 max allowed)
     135728 hits, 87 misses, 123 trims, 155 created
     4 failures (0 no memory)
Big buffers, 1536 bytes (total 50, permanent 50):
     50 in free list (5 min, 150 max allowed)
     503573 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 10, permanent 10):
     10 in free list (0 min, 100 max allowed)
     0 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)
Large buffers, 5024 bytes (total 0, permanent 0):
     0 in free list (0 min, 10 max allowed)
     0 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)
Huge buffers, 18024 bytes (total 0, permanent 0):
     0 in free list (0 min, 4 max allowed)
     0 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)

Interface buffer pools:
Syslog ED Pool buffers, 600 bytes (total 150, permanent 150):
     118 in free list (150 min, 150 max allowed)
     92 hits, 0 misses
CD2430 I/O buffers, 1536 bytes (total 0, permanent 0):
     0 in free list (0 min, 0 max allowed)
     0 hits, 0 fallbacks
IPC buffers, 4096 bytes (total 2, permanent 2):
     2 in free list (1 min, 8 max allowed)
     0 hits, 0 fallbacks, 0 trims, 0 created
     0 failures (0 no memory)

Header pools:
Header buffers, 0 bytes (total 768, permanent 768):
     256 in free list (128 min, 1024 max allowed)
     512 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)
     512 max cache size, 512 in cache
     1335 hits in cache, 0 misses in cache

Particle Clones:
     1024 clones, 0 hits, 0 misses

Public particle pools:
F/S buffers, 256 bytes (total 768, permanent 768):
     256 in free list (128 min, 1024 max allowed)
     512 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)
     512 max cache size, 512 in cache
     0 hits in cache, 0 misses in cache
Normal buffers, 1548 bytes (total 768, permanent 768):
     768 in free list (128 min, 1024 max allowed)
     0 hits, 0 misses, 0 trims, 0 created
     0 failures (0 no memory)

Private particle pools:
IDS SM buffers, 240 bytes (total 128, permanent 128):
     0 in free list (0 min, 128 max allowed)
     128 hits, 0 fallbacks
     128 max cache size, 128 in cache
     0 hits in cache, 0 misses in cache
GigabitEthernet0/0 buffers, 1536 bytes (total 192, permanent 192):
     0 in free list (0 min, 192 max allowed)
     192 hits, 0 fallbacks
     192 max cache size, 128 in cache
     50216363 hits in cache, 0 misses in cache
GigabitEthernet0/1 buffers, 1536 bytes (total 192, permanent 192):
     0 in free list (0 min, 192 max allowed)
     192 hits, 0 fallbacks
     192 max cache size, 128 in cache
     98292437 hits in cache, 0 misses in cache
NETGX_CACHE_BUFFERS buffers, 1700 bytes (total 256, permanent 256):
     0 in free list (0 min, 256 max allowed)
     256 hits, 0 fallbacks
     256 max cache size, 256 in cache
     0 hits in cache, 0 misses in cache

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Аноним on 14-Дек-07, 14:54 
>[оверквотинг удален]
>     98292437 hits in cache, 0 misses in
>cache
>NETGX_CACHE_BUFFERS buffers, 1700 bytes (total 256, permanent 256):
>     0 in free list (0 min, 256
>max allowed)
>     256 hits, 0 fallbacks
>     256 max cache size, 256 in cache
>
>     0 hits in cache, 0 misses in
>cache

на скидку могу предположить следующее: данные процессы действительно ресурсоемкие, но кратковременные - вероятно получается следующий механизм, что на данные ресурс должен выделенна память, но изза получения быстрой памяти процессор увеличивает задержку т.е увеличивается время на получение ресурса.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 15:30 
>[оверквотинг удален]
>>     256 hits, 0 fallbacks
>>     256 max cache size, 256 in cache
>>
>>     0 hits in cache, 0 misses in
>>cache
>
>на скидку могу предположить следующее: данные процессы действительно ресурсоемкие, но кратковременные -
>вероятно получается следующий механизм, что на данные ресурс должен выделенна память,
>но изза получения быстрой памяти процессор увеличивает задержку т.е увеличивается время
>на получение ресурса.

на выходные попробую завернуть через этот маршрутизатор несколько юзеров,
посмотрим, будет трафик тормозиться в момент перепрочтения таблицы или нет.

BGP activity 951880/951877 prefixes, 951897/951894 paths, scan interval 60 secs

Похоже всё-таки процесорной мощи 2821 при перепрочтении сей беды нехватает, вот он и растягивает это во времени и соответственно забирает весь ресурс на себя ((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Аноним on 14-Дек-07, 15:52 
>[оверквотинг удален]
>>на получение ресурса.
>
>на выходные попробую завернуть через этот маршрутизатор несколько юзеров,
>посмотрим, будет трафик тормозиться в момент перепрочтения таблицы или нет.
>
>BGP activity 951880/951877 prefixes, 951897/951894 paths, scan interval 60 secs
>
>Похоже всё-таки процесорной мощи 2821 при перепрочтении сей беды нехватает, вот он
>и растягивает это во времени и соответственно забирает весь ресурс на
>себя ((

а попробуйте софт по-проще установить.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 15:54 
>[оверквотинг удален]
>>на выходные попробую завернуть через этот маршрутизатор несколько юзеров,
>>посмотрим, будет трафик тормозиться в момент перепрочтения таблицы или нет.
>>
>>BGP activity 951880/951877 prefixes, 951897/951894 paths, scan interval 60 secs
>>
>>Похоже всё-таки процесорной мощи 2821 при перепрочтении сей беды нехватает, вот он
>>и растягивает это во времени и соответственно забирает весь ресурс на
>>себя ((
>
>а попробуйте софт по-проще установить.

какой? посоветуйте.
пользую такой, который шёл в комплекте при покупке.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от arahnid (ok) on 14-Дек-07, 18:31 
>[оверквотинг удален]
>>на выходные попробую завернуть через этот маршрутизатор несколько юзеров,
>>посмотрим, будет трафик тормозиться в момент перепрочтения таблицы или нет.
>>
>>BGP activity 951880/951877 prefixes, 951897/951894 paths, scan interval 60 secs
>>
>>Похоже всё-таки процесорной мощи 2821 при перепрочтении сей беды нехватает, вот он
>>и растягивает это во времени и соответственно забирает весь ресурс на
>>себя ((
>
>а попробуйте софт по-проще установить.

ХМ, самое интересное, что походу проблема решилась, причём достаточно просто:

router bgp 77777
no synchronization
bgp default local-preference 2000
no bgp log-neighbor-changes
neighbor 195.3.3.3 remote-as 66666  # AS вышестоящего прова
neighbor 195.3.3.3 description ### P-t-P BGP
neighbor 195.3.3.3 ebgp-multihop 9
neighbor 195.3.3.3 update-source GigabitEthernet0/0
neighbor 195.3.3.3 version 4
neighbor 212.1.1.1 remote-as 66666
neighbor 212.1.1.1 description ### PtP на вышестоящего прова
neighbor 212.1.1.1 version 4
neighbor 212.1.1.1 timers 30 90
bgp dampening
bgp scan-time 60
!
address-family ipv4
redistribute connected
redistribute static
neighbor 195.3.3.3 activate
neighbor 195.3.3.3 prefix-list Net in      <-------  сюда переставил
neighbor 212.1.1.1 activate
neighbor 212.1.1.1 remove-private-as
##neighbor 212.1.1.1 prefix-list Net in    <------- отсюда убрал
neighbor 212.1.1.1 prefix-list AS77777 out
no auto-summary
!
network 193.2.2.0 mask 255.255.254.0  # мои PI адреса
ip route 0.0.0.0 0.0.0.0 212.1.1.1
ip route 193.2.2.0 255.255.254.0 Null0
!
ip prefix-list AS77777 seq 10 permit 193.2.2.0/23
!
ip prefix-list Net seq 10 permit 0.0.0.0/0 ge 23


В результате обрезал префиксы и нагрузка стала не более 25-30%.
Так что в принципе 2821 может потянуть фулл-BGP в кастрированном виде.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Аноним on 14-Дек-07, 18:50 
>[оверквотинг удален]
>ip route 0.0.0.0 0.0.0.0 212.1.1.1
>ip route 193.2.2.0 255.255.254.0 Null0
>!
>ip prefix-list AS77777 seq 10 permit 193.2.2.0/23
>!
>ip prefix-list Net seq 10 permit 0.0.0.0/0 ge 23
>
>
>В результате обрезал префиксы и нагрузка стала не более 25-30%.
>Так что в принципе 2821 может потянуть фулл-BGP в кастрированном виде.

в кастированном виде у меня на 3750 работает --

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от noname (??) on 16-Дек-07, 12:38 
Может я туплю, но при таком префикс листе:
ip prefix-list Net seq 10 permit 0.0.0.0/0 ge 23
тебе придут перефиксы с prefix-legth от /23 до /32, на кой это нужно.
Может лучше так:
ip prefix-list Net seq 10 permit 0.0.0.0/0 le 23
???
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от fantom email(ok) on 17-Дек-07, 10:52 
>Покажите:
>sh ver
>sh proc mem (первые 3 строчки)
>sh proc cpu sor - во время полной загрузки
>sh proc cpu sor | i BGP Scanner
>
>Был у меня 3725 с 2 fullview,20 мб траффика,загрузка 60-80%,там много чего
>крутилось,но загружал роутер больше всех "BGP Scanner" который отрабатывает каждые 60
>сек. Побороть его резкой префиксов тоже не удалось,но проблема решилась с
>переходом на G2. Может вы упёрлись в мощность роутера.

Прописать статические роуты ко всем некст-хопам, которые участвуют в БГП таблице и будет вам счастье :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Den (??) on 05-Янв-08, 01:26 
>[оверквотинг удален]
>>sh proc cpu sor - во время полной загрузки
>>sh proc cpu sor | i BGP Scanner
>>
>>Был у меня 3725 с 2 fullview,20 мб траффика,загрузка 60-80%,там много чего
>>крутилось,но загружал роутер больше всех "BGP Scanner" который отрабатывает каждые 60
>>сек. Побороть его резкой префиксов тоже не удалось,но проблема решилась с
>>переходом на G2. Может вы упёрлись в мощность роутера.
>
>Прописать статические роуты ко всем некст-хопам, которые участвуют в БГП таблице и
>будет вам счастье :)

опередили с ответом, самое оно. Если нету статик роутов к некст-хопам, то рутер пересчитывает таблицу (в какой интерфейс кидать пакет для каждого приехавшего роута). Так как статиков нету, вот он бедняга и загибается от ненужной работы.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "загрузка проца 2821 при Full BGP. Help!!!"  
Сообщение от Barbos email on 17-Дек-07, 08:09 
>[оверквотинг удален]
>!
>ip route 0.0.0.0 0.0.0.0 212.1.1.1
>ip route 193.2.2.0 255.255.254.0 Null0
>!
>!
>ip prefix-list AS77777 seq 10 permit 193.2.2.0/23
>!
>ip prefix-list Net seq 10 permit 0.0.0.0/0 ge 24
>
>----------------------------------------------------------------

У меня также стоит кошка 2821 с гигом памяти, при этом от трех провов тащил полностью три таблицы. Была такая же нагрузка, пока на адреса соседей по BGP статические маршруты не прописал, т.е.
ip route 195.3.3.3 255.255.255.255 212.1.1.1 <------ Можно указать и другой дистанейшн.
Ну а на второго у вас и так маршрут есть.
Проблема в том что как только приходит апдейт кошка начинает перестраивать всю таблицу и пересчитывать в какой интерфейс ей пихать трафик, т.к. она определенно не знает где нахотится сосед по BGP.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру