The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ошибка с rate-limit."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Ошибка с rate-limit."  
Сообщение от asidko email(??) on 07-Июн-08, 07:10 
Привет всем.

Есть циска 7206 есть канал 100mb. Нужно огрпничить ширину канала для клиентов. Кпримеру до 2,5 mb для каждого.
Все клиенты в разных vlan-ах.
--------
interface GigabitEthernet0/3.214192
description -=-= IITC - 192.168.214.192/27 - VLAN192  -=-=
encapsulation dot1Q 192
ip address 192.168.214.193 255.255.255.224
--------

Делаю вот так:
Создал ACL
----------
access-list 103 permit ip 192.168.214.192 0.0.0.31 any log
access-list 103 deny   ip any any
access-list 103 remark ---------IITC shaper OUT up to 2.5Mbps--------
----------
Потом добавляю в interface GigabitEthernet0/3.214192
строку которая шейпит:
----------
rate-limit output access-group 103 2616000 2621400 2621400 conform-action drop exceed-action drop
----------
Но в итоге трафик по этому интерфейсу падает до 0, авижу:
----------
gate#sh access-lists
Extended IP access list 103
    10 permit ip 192.168.214.192 0.0.0.31 any log
    20 deny ip any any (21291 matches)
----------
Отчего все пакеты дропаются?

Ладно думаю, что клиенты могли  у себя тунелей настроить и пр. Уберу ACL сделаю шейпинг без него:
----------
gate(config-subif)#rate-limit input 2616000 2621400 2621400 conform-action drop exceed-action drop
gate(config-subif)#rate-limit output 2616000 2621400 2621400 conform-action drop exceed-action drop
----------

Тоже самое вижу, что трафик по субинтерфейсу останавливается.

Подскажите, в чем ошибка?
Спасибо!

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ошибка с rate-limit."  
Сообщение от Ranger99 (??) on 07-Июн-08, 08:14 
>Подскажите, в чем ошибка?

в "...conform-action DROP..."
стоит поменять на conform-action transmit


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Ошибка с rate-limit."  
Сообщение от asidko email(??) on 07-Июн-08, 18:13 
>>Подскажите, в чем ошибка?
>
>в "...conform-action DROP..."
>стоит поменять на conform-action transmit

Согласен был неправ, спасибо! (Спать надо больше :)

Но почему всетаки deny счетчики на ACL увеличиваются?

Access-list вот такой:
----------
access-list 103 permit ip 192.168.214.192 0.0.0.31 any log
access-list 103 deny   ip any any
access-list 103 remark ---------IITC shaper OUT up to 2.5Mbps--------
----------
И вижу:
----------
gate#sh access-lists
Extended IP access list 103
    10 permit ip 192.168.214.192 0.0.0.31 any log
    20 deny ip any any (21291 matches)
----------
Значит ацесс лист их дропает до того как они попадают на shape .

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Ошибка с rate-limit."  
Сообщение от KiM email on 07-Июн-08, 20:48 
>[оверквотинг удален]
>----------
>И вижу:
>----------
>gate#sh access-lists
>Extended IP access list 103
>    10 permit ip 192.168.214.192 0.0.0.31 any log
>    20 deny ip any any (21291 matches)
>----------
>Значит ацесс лист их дропает до того как они попадают на shape
>.

нет просто всё что не попало в 10 строку попало в 20 вот и всё.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Ошибка с rate-limit."  
Сообщение от asidko email(??) on 07-Июн-08, 23:04 
>[оверквотинг удален]
>>gate#sh access-lists
>>Extended IP access list 103
>>    10 permit ip 192.168.214.192 0.0.0.31 any log
>>    20 deny ip any any (21291 matches)
>>----------
>>Значит ацесс лист их дропает до того как они попадают на shape
>>.
>
>нет просто всё что не попало в 10 строку попало в 20
>вот и всё.

Это я понял.

Я имею ввиду, что 10-я строка отбирает пакеты для шейпа, а все остальные (20) мы запрешаем. В этой подсети "живет" оборудование клиента с адрессами 192.168.214.192/27 но правило для отбора этих пакетов не работает. Все остальные пакеты дропаются.

Значит ли это, что клиенты используют тунелли к примеру с (10.х или 172.16.х сетями) а они обрезаются 20 правилом?

Или лучще в конкретном случае не использовать ACL для rate-limit?

Спасибо!

Андрей.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Ошибка с rate-limit."  
Сообщение от KiM email on 09-Июн-08, 16:03 
>[оверквотинг удален]
>остальные пакеты дропаются.
>
>Значит ли это, что клиенты используют тунелли к примеру с (10.х или
>172.16.х сетями) а они обрезаются 20 правилом?
>
>Или лучще в конкретном случае не использовать ACL для rate-limit?
>
>Спасибо!
>
>Андрей.

я видимо не от мира сего тк не понял ничего из написаного выше:) но ситуёвина такая на один интерфей можеш вешать кучу rate-limit у каждого свой acl если надо что сеть 192.168.214.192/27 шепилась по первоме правилу вписывай, надо чтоб по своему создавай новый райт и ацл, не надо чтоб шейпилась оставляё как есть.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Ошибка с rate-limit."  
Сообщение от sh_ email(??) on 09-Июн-08, 17:20 
Уберите log из access-list
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру