The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Добавление в VRF маршрутов из RIP/GLOBAL"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от OVDP email(ok) on 22-Июл-08, 08:14 
Уважаемые!

на киске создается табл маршрут посредством RIP. так же есть VRFы.
Можно ли как нить указать VRFам использовать глобальную таблицу маршрутизациии (а лучще часть ёё, а именно о маршрутах на 172.16.0.0)

часть конфига:

ip vrf EDGE100
rd 200:100

interface FastEthernet0/0.100
description TEST
ip vrf forwarding EDGE100
ip address 10.0.0.1 255.255.255.0
ip virtual-reassembly

interface FastEthernet0/1.10
description CORE10
ip vrf receive EDGE100
ip address 192.168.12.30 255.255.255.0
no ip redirects
ip rip advertise 90
ip rip receive version 2
ip virtual-reassembly
ip policy route-map CORE10

router rip
version 2
passive-interface FastEthernet0/0
network 172.16.0.0
network 192.168.12.0
no auto-summary

ip access-list stand PBR100
permit ip 172.16.0.0 0.15.255.255 any

route-map CORE10 permit 100
match ip address PBR100
set vrf EDGE100

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от anonymous (??) on 22-Июл-08, 11:56 
может так:
ip route vrf VPN_X 172.16.0.0 0.0.0.0 a.b.c.d global
>Уважаемые!
>
>на киске создается табл маршрут посредством RIP. так же есть VRFы.
>Можно ли как нить указать VRFам использовать глобальную таблицу маршрутизациии (а лучще
>часть ёё, а именно о маршрутах на 172.16.0.0)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от OVDP email(ok) on 22-Июл-08, 12:21 
>может так:
>ip route vrf VPN_X 172.16.0.0 0.0.0.0 a.b.c.d global
>>Уважаемые!
>>
>>на киске создается табл маршрут посредством RIP. так же есть VRFы.
>>Можно ли как нить указать VRFам использовать глобальную таблицу маршрутизациии (а лучще
>>часть ёё, а именно о маршрутах на 172.16.0.0)

к сажаленью так не катит, потому что в данном случае указывается IP внешнего устройства... то есть статика грубо гря... а мне нужно использовать маршрутьы динамические...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от migosm on 22-Июл-08, 12:42 
>[оверквотинг удален]
>>ip route vrf VPN_X 172.16.0.0 0.0.0.0 a.b.c.d global
>>>Уважаемые!
>>>
>>>на киске создается табл маршрут посредством RIP. так же есть VRFы.
>>>Можно ли как нить указать VRFам использовать глобальную таблицу маршрутизациии (а лучще
>>>часть ёё, а именно о маршрутах на 172.16.0.0)
>
>к сажаленью так не катит, потому что в данном случае указывается IP
>внешнего устройства... то есть статика грубо гря... а мне нужно использовать
>маршрутьы динамические...

С BGP

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/gu...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от OVDP email(??) on 22-Июл-08, 13:00 
>[оверквотинг удален]
>>>>Можно ли как нить указать VRFам использовать глобальную таблицу маршрутизациии (а лучще
>>>>часть ёё, а именно о маршрутах на 172.16.0.0)
>>
>>к сажаленью так не катит, потому что в данном случае указывается IP
>>внешнего устройства... то есть статика грубо гря... а мне нужно использовать
>>маршрутьы динамические...
>
>С BGP
>
>http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/gu...

BGP нет... есть RIP и только по нему можно получать в моём случае анонсы...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от migosm on 22-Июл-08, 12:33 
>[оверквотинг удален]
> network 172.16.0.0
> network 192.168.12.0
> no auto-summary
>
>ip access-list stand PBR100
> permit ip 172.16.0.0 0.15.255.255 any
>
>route-map CORE10 permit 100
> match ip address PBR100
> set vrf EDGE100

http://www.cisco.com/en/US/tech/tk436/tk832/technologies_con...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от OVDP email(??) on 22-Июл-08, 12:42 
>[оверквотинг удален]
>> no auto-summary
>>
>>ip access-list stand PBR100
>> permit ip 172.16.0.0 0.15.255.255 any
>>
>>route-map CORE10 permit 100
>> match ip address PBR100
>> set vrf EDGE100
>
>http://www.cisco.com/en/US/tech/tk436/tk832/technologies_con...

ок! попробую

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Добавление в VRF маршрутов из RIP/GLOBAL"  
Сообщение от OVDP email(ok) on 22-Июл-08, 13:02 
>[оверквотинг удален]
>>>ip access-list stand PBR100
>>> permit ip 172.16.0.0 0.15.255.255 any
>>>
>>>route-map CORE10 permit 100
>>> match ip address PBR100
>>> set vrf EDGE100
>>
>>http://www.cisco.com/en/US/tech/tk436/tk832/technologies_con...
>
>ок! попробую

при попытке довавить маршрут:
Router(config)#ip route vrf EDGE100 172.16.0.0 255.240.0.0 FastEthernet0/1.10
% For VPN routes, must specify a next hop IP address if not a point-to-point interface

таким образом возвращаемся к статике :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру