The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"cisco 7204vxr. установка rate-limit через радиус."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от ili4 (??) on 04-Сен-08, 11:04 
Добрый день.

Cisco 7204VXR + NPE400 в качестве сервера pptp для раздачи интернета.
Авторизация происходит через RADIUS (freeradius). Необходимо используя радиус ограничивать ширину канала на каждого пользователя.

радиус возвращает циске параметр
Cisco-AVpair = "lcp:interface-config#1=rate-limit output 128000 8000 8000 conform-action transmit exceed-action drop"

в логах циски (debug radius) видно:
*Sep  4 06:31:24.135: RADIUS:   Cisco AVpair       [1]   102 "lcp:interface-config#1=rate-limit output 128000 8000 8000 conform-action transmit exceed-action drop"

но параметры на интерфейсе не устанавливаются, sh interfaces rate-limit ничего не показывает.

в разных мануалах (в т.ч. с цискосайта) сказано, что чтобы менять параметры интерфейса радиусом, надо в конфиге прописать строчку "virtual-profile aaa", но у меня вообще нет такой команды в конфиге. IOS 12.4(18)


собственно конфиг:
Current configuration : 1849 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable password *****
!
aaa new-model
!
!
aaa group server radius VEDI
server ***** auth-port 10112 acct-port 10113
!
aaa authentication login vedi group VPN
aaa authentication login vpn group VEDI
aaa authentication ppp vpn group VEDI
aaa authorization exec vpn group VEDI
aaa accounting update periodic 1
aaa accounting network vpn start-stop group VEDI
aaa accounting connection vpn start-stop group VEDI
!
aaa session-id common
!
!
no ip cef
ip name-server 80.76.176.19
!
!
virtual-profile if-needed
virtual-profile virtual-template 1
vpdn enable
!
vpdn-template
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
local name orn
!
!
!
!
!
username root password 0 *****
!
!
!
!
!
interface Loopback0
ip address 172.16.254.252 255.255.255.0
!
interface FastEthernet3/0
ip address 80.76.186.201 255.255.255.252
duplex full
!
interface FastEthernet4/0
ip address 80.76.176.40 255.255.255.240
duplex full
!
interface Virtual-Template1
mtu 1400
ip unnumbered Loopback0
no ip proxy-arp
ip flow ingress
ip flow egress
ip virtual-reassembly
no logging event link-status
peer default ip address pool vpnpool
no keepalive
ppp authentication ms-chap-v2 vpn
ppp accounting vpn
ppp multilink
!
ip local pool vpnpool 80.76.186.193 80.76.186.200
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 80.76.176.33
!
no ip http server
!
!
!
!
!
radius-server host ***** auth-port 10112 acct-port 10113 key *****
!
control-plane
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0
session-timeout 3600
password *****
line vty 1 4
!
!
end

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от edgars (??) on 04-Сен-08, 14:06 
Hello,

takaja zhe situacija no toljko na 2801. V majom sluchaje gljuk ios, nado delatj update.


>[оверквотинг удален]
> stopbits 1
>line aux 0
> stopbits 1
>line vty 0
> session-timeout 3600
> password *****
>line vty 1 4
>!
>!
>end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от ili4 (??) on 04-Сен-08, 14:33 
>Hello,
>
>takaja zhe situacija no toljko na 2801. V majom sluchaje gljuk ios,
>nado delatj update.
>
>

ИОС вроде свежий (12.4), если просто перезалить ту же версию - поможет?

кстати, при загрузке циска в консоль выдает:
%SYS-4-CONFIG_NEWER: Configuration from version 12.4 may not be correctly understood

полный sh ver:

Router#sh ver
Cisco IOS Software, 7200 Software (C7200-JS-M), Version 12.4(18), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Sat 01-Dec-07 03:07 by prod_rel_team

ROM: System Bootstrap, Version 12.2(4r)B2, RELEASE SOFTWARE (fc2)
BOOTLDR: 7200 Software (C7200-BOOT-M), Version 12.0(16)S, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Router uptime is 3 hours, 57 minutes
System returned to ROM by reload at 06:06:48 UTC Thu Sep 4 2008
System image file is "sup-slot0:/c7200-js-mz.124-18.bin"
Last reload reason: Reload Command


Cisco 7204VXR (NPE400) processor (revision A) with 229376K/32768K bytes of memory.
Processor board ID 14532465
R7000 CPU at 350MHz, Implementation 39, Rev 3.3, 256KB L2 Cache
4 slot VXR midplane, Version 2.0

Last reset from power-on

PCI bus mb0_mb1 (Slots 0, 1, 3 and 5) has a capacity of 600 bandwidth points.
Current configuration on bus mb0_mb1 has a total of 200 bandwidth points.
This configuration is within the PCI bus capacity and is supported.

PCI bus mb2 (Slots 2, 4, 6) has a capacity of 600 bandwidth points.
Current configuration on bus mb2 has a total of 200 bandwidth points
This configuration is within the PCI bus capacity and is supported.

Please refer to the following document "Cisco 7200 Series Port Adaptor
Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
for c7200 bandwidth points oversubscription and usage guidelines.


2 FastEthernet interfaces
125K bytes of NVRAM.

125952K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

может поставить более старый ИОС?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от edgars (??) on 04-Сен-08, 14:37 
Samuju svezhiju versiju poprobuj zalei.
u menja trabl na v12.4(11) po hodu. Pro 18 build nemogu nichevo skazatj.
a konfig s kakoi versii bralsja?

>[оверквотинг удален]
>125K bytes of NVRAM.
>
>125952K bytes of ATA PCMCIA card at slot 0 (Sector size 512
>bytes).
>4096K bytes of Flash internal SIMM (Sector size 256K).
>Configuration register is 0x2102
>
>
>
>может поставить более старый ИОС?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от ili4 (??) on 04-Сен-08, 14:48 
>Samuju svezhiju versiju poprobuj zalei.
>u menja trabl na v12.4(11) po hodu. Pro 18 build nemogu nichevo
>skazatj.

так ты свою проблему перезаливом ИОСа решил?

>a konfig s kakoi versii bralsja?

не знаю, мы ее такую купили.

p.s.
может сразу подскажешь, где скачать под эту циску свежий ИОС, и как его туда залить?
а то уже голова от всего этого пухнет, всю неделю бьюсь с ней.. (((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от edgars (??) on 04-Сен-08, 18:02 
Na testovoi mashine zarabotalo s posvezheje ios'om. Na production jescho ne proboval.
gde skachatj pod 7204 ne znaju :(

>[оверквотинг удален]
>
>>a konfig s kakoi versii bralsja?
>
>не знаю, мы ее такую купили.
>
>p.s.
>может сразу подскажешь, где скачать под эту циску свежий ИОС, и как
>его туда залить?
>а то уже голова от всего этого пухнет, всю неделю бьюсь с
>ней.. (((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от ili4 (??) on 05-Сен-08, 11:44 
>[оверквотинг удален]
>>
>>>a konfig s kakoi versii bralsja?
>>
>>не знаю, мы ее такую купили.
>>
>>p.s.
>>может сразу подскажешь, где скачать под эту циску свежий ИОС, и как
>>его туда залить?
>>а то уже голова от всего этого пухнет, всю неделю бьюсь с
>>ней.. (((

залил c7200-jk9s-mz.124-21.bin - не помогло (((

p.s.
никто не знает, как через радиус ограничить сессию по трафику (не ширину канала, а кол-во байт за сессию)?
в линуксе на pppd использовался атрибут Session-Octets-Limit, но циска его явно не понимает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от vorch on 05-Сен-08, 11:48 
Если проблема с IOS - то только с конкретной вашей версией. У меня все нормально работает на c7200-jk9s-mz.123-11.T10, а он гораздо постарше будет
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от ili4 (??) on 05-Сен-08, 11:55 
>Если проблема с IOS - то только с конкретной вашей версией. У
>меня все нормально работает на c7200-jk9s-mz.123-11.T10, а он гораздо постарше будет
>

да я вот думаю, может поставить ИОС по-старше?...
можете вашим поделиться?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "cisco 7204vxr. установка rate-limit через радиус."  
Сообщение от ili4 (??) on 26-Сен-08, 12:34 
проблема решена.

надо было в interface Virtual-Template1 добавить
ppp authorization vpn

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру