The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с транляцией по NAT (Cisco 1811)"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с транляцией по NAT (Cisco 1811)"  
Сообщение от s1asher (ok) on 06-Май-09, 15:51 
Не могу разобратся с трансляцией порта локального компьютера на тот же порт дополнительного IP адреса. Со второго роутера (не циска) форвард порта идет корректно, все работает.
По show ip nat translations я вижу, что заданная трансляция отображается, но при это соединения нету.
Пинг с циски на локальный адрес проходит, телнетом внутри сети с этим адресом по порту соединится я могу, а извне телнет работать не хочет.

Где копать?


interface FastEthernet0
mac-address 0080.483f.ec1a
ip address x.x.x.18 255.255.255.128 secondary
ip address x.x.x.17 255.255.255.128
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!


interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
ip address 192.168.0.3 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Async1
no ip address
encapsulation slip
!
ip route 0.0.0.0 0.0.0.0 x.x.x.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 10 interface FastEthernet0 overload
ip nat inside source static tcp 192.168.0.5 500 x.x.x.18 500 extendable
!
access-list 10 permit 192.168.0.0 0.0.0.255
no cdp run
!


Вот активныая трансляция в циске:

Pro Inside global      Inside local       Outside local      Outside global
tcp x.x.x.18:500 192.168.0.5:500    *.*.*.155:20547 *.*.*.155:20547

Было бы классно если бы кто-то что-то сказал, а то второй день сижу страдаю.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с транляцией по NAT (Cisco 1811)"  
Сообщение от SergTel (ok) on 06-Май-09, 16:18 
>[оверквотинг удален]
>
>Вот активныая трансляция в циске:
>
>
Pro Inside global      Inside local   
>    Outside local      
>Outside global
>tcp x.x.x.18:500 192.168.0.5:500    *.*.*.155:20547 *.*.*.155:20547

>
>Было бы классно если бы кто-то что-то сказал, а то второй день
>сижу страдаю.

Судя по трансляции циска пробросила коннект

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с транляцией по NAT (Cisco 1811)"  
Сообщение от SergTel (ok) on 06-Май-09, 16:20 
>[оверквотинг удален]
>>
>>
Pro Inside global      Inside local   
>>    Outside local      
>>Outside global
>>tcp x.x.x.18:500 192.168.0.5:500    *.*.*.155:20547 *.*.*.155:20547

>>
>>Было бы классно если бы кто-то что-то сказал, а то второй день
>>сижу страдаю.
>
>Судя по трансляции циска пробросила коннект

а вот ответ идет не с 18 адреса
ip nat pool tttt x.x.x.18 x.x.x.18 netmask 255.255.255.128
ip nat inside source list 10 interface FastEthernet0 overload
ip nat inside source list 11 pool tttt overload
ip nat inside source static tcp 192.168.0.5 500 x.x.x.18 500 extendable
!
access-list 10 deny host 192.168.0.5
access-list 10 permit 192.168.0.0 0.0.0.255
access-list 11 permit host 192.168.0.5

и ip secondary можно удалить с интерфейса

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с транляцией по NAT (Cisco 1811)"  
Сообщение от s1asher (ok) on 06-Май-09, 16:52 
Я думаю проблема не в этом. Сделал по вашему совету - не получилось. По быстрому переделал конфиг, с одним ИП адресом тоже не НАТится, хотя инет изнутри работает.

interface FastEthernet0
mac-address 0080.483f.ec1a
ip address x.x.x.17 255.255.255.128
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!

interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
ip address 192.168.0.3 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Async1
no ip address
encapsulation slip
!
ip route 0.0.0.0 0.0.0.0 x.x.x.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 10 interface FastEthernet0 overload
ip nat inside source static tcp 192.168.0.5 500 x.x.x.17 500 extendable
!
access-list 10 permit 192.168.0.0 0.0.0.255


Здесь то, что имеет по транляциям:


Cisco1811#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22446 *.255.5.155:22446
tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22693 *.255.5.155:22693
tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22731 *.255.5.155:22731
tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22773 *.255.5.155:22773
tcp x.x.x.17:500 192.168.0.5:500    ---                ---


Соственно вот... в чем может быть грабля?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с транляцией по NAT (Cisco 1811)"  
Сообщение от SergTel (ok) on 06-Май-09, 17:12 
>[оверквотинг удален]
>tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22446 *.255.5.155:22446
>tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22693 *.255.5.155:22693
>tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22731 *.255.5.155:22731
>tcp x.x.x.17:500 192.168.0.5:500    *.255.5.155:22773 *.255.5.155:22773
>tcp x.x.x.17:500 192.168.0.5:500    ---      
>          ---
>
>
>
>Соственно вот... в чем может быть грабля?

ip nat pool tttt x.x.x.18 x.x.x.18 netmask 255.255.255.128
ip nat inside source list 10 interface FastEthernet0 overload
ip nat inside source list 11 pool tttt overload
ip nat inside source static tcp 192.168.0.5 500 x.x.x.18 500 extendable
!
access-list 10 deny host 192.168.0.5
access-list 10 permit 192.168.0.0 0.0.0.255
access-list 11 permit host 192.168.0.5

а так что не получилось?

софт точно один tcp 500 порт использует?

что по коннектам сервер говорит?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с транляцией по NAT (Cisco 1811)"  
Сообщение от s1asher (ok) on 07-Май-09, 09:28 
все разобрался, спасибо за наводку. Проблема была в сервере, он на запросы циски отвечал на другой роутер. Вот блин))


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру