The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"2800 IPSec + NAT + 2 ISP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"2800 IPSec + NAT + 2 ISP"  +/
Сообщение от woodcut email(ok) on 11-Июл-09, 13:25 
Туннель работает, но клиенты из локалки в него не попадают. Сам роутер же в туннель спокойно ходит.
Полагаю, что из-за NAT.

Конфиг:

!
interface GigabitEthernet0/0
ip address 22.22.22.22 255.255.255.240
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map TUNNEL-MAP
!
interface GigabitEthernet0/1
ip address 33.33.33.33 255.255.255.240
ip access-group 101 in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!

!
interface Vlan2          
ip address 10.80.1.1 255.255.255.0                                      
ip nat inside                                                          
ip virtual-reassembly                                                  
ip policy route-map ISP1-NAT
!
interface Vlan3
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip policy route-map ISP2-NAT
!

ip route 0.0.0.0 0.0.0.0 22.22.22.1
ip route 0.0.0.0 0.0.0.0 33.33.33.1

ip nat inside source route-map ISP1-NAT interface GigabitEthernet0/0 overload
ip nat inside source route-map ISP2-NAT interface GigabitEthernet0/1 overload

access-list 10 permit 192.168.1.0 0.0.0.255
access-list 121 permit ip 10.80.1.0 0.0.0.255 172.16.197.0 0.0.0.255
access-list 122 deny   ip 10.80.1.0 0.0.0.255 172.16.197.0 0.0.0.255
access-list 122 permit ip 10.80.1.0 0.0.0.255 any

route-map ISP2-NAT permit 10
match ip address 10
match interface GigabitEthernet0/1
set ip default next-hop 33.33.33.1
!
route-map ISP1-NAT permit 20
match ip address 122
match interface GigabitEthernet0/0
set ip default next-hop 22.22.22.1
!

В туннель идёт сеть 10.80.1.0/24

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "2800 IPSec + NAT + 2 ISP"  +/
Сообщение от AleX (??) on 12-Июл-09, 02:02 
sh ip route
в студию :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "2800 IPSec + NAT + 2 ISP"  +/
Сообщение от woodcut email(ok) on 12-Июл-09, 11:22 
>sh ip route
>в студию :)

C       22.22.22.0 is directly connected, GigabitEthernet0/0
     172.16.0.0/26 is subnetted, 1 subnets
S       172.16.197.64 [1/0] via 192.168.1.11
     10.0.0.0/24 is subnetted, 1 subnets
C       10.80.1.0 is directly connected, Vlan2
     33.33.33.0/28 is subnetted, 1 subnets
C       33.33.33.0 is directly connected, GigabitEthernet0/1
C    192.168.1.0/24 is directly connected, Vlan3
S    192.168.100.0/24 [1/0] via 192.168.1.100
S*   0.0.0.0/0 [1/0] via 33.33.33.1
               [1/0] via 22.22.22.1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру