The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"NAT, Loopback на cisco 3725"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 09:10 
есть сеть из 16 ip адресов, выданная провайдером. 3 сервера за натом. Надо их высунуть наружу по 3 разным глобальным ip адресам.

сеть - 92.46.x.0 255.255.255.240
шлюз - 92.46.x.1
сервер1 - 92.46.x.7 (опубликовать по порту 1433), локальный ip - 192.168.0.60
сервер2 - 92.46.x.8 (опубликовать по порту 1433), локальный ip - 192.168.0.133
сервер3 - 92.46.x.13 (опубликовать по порту 8080), локальный ip - 192.168.0.103

interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside

interface FastEthernet2/0
ip address 92.46.x.13 255.255.255.240
ip nat outside

ip route 0.0.0.0 0.0.0.0 92.46.x.1
ip nat inside source list 1 interface FastEthernet2/0 overload
access-list 1 permit 192.168.0.0 0.0.0.255

Подскажите каким образом грамотно развесить глобальные адреса по лупбэкам? Я что-то туплю...

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "NAT, Loopback на cisco 3725"  +/
Сообщение от евгений (??) on 08-Окт-09, 10:07 
>[оверквотинг удален]
>interface FastEthernet2/0
> ip address 92.46.x.13 255.255.255.240
> ip nat outside
>
>ip route 0.0.0.0 0.0.0.0 92.46.x.1
>ip nat inside source list 1 interface FastEthernet2/0 overload
>access-list 1 permit 192.168.0.0 0.0.0.255
>
>Подскажите каким образом грамотно развесить глобальные адреса по лупбэкам? Я что-то туплю...
>

лупбэки? зачем?
static nat

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 10:10 
>[оверквотинг удален]
>>
>>ip route 0.0.0.0 0.0.0.0 92.46.x.1
>>ip nat inside source list 1 interface FastEthernet2/0 overload
>>access-list 1 permit 192.168.0.0 0.0.0.255
>>
>>Подскажите каким образом грамотно развесить глобальные адреса по лупбэкам? Я что-то туплю...
>>
>
>лупбэки? зачем?
>static nat

Сейчас у меня так и сделано.
ip nat inside source static tcp 192.168.0.60 1433 92.46.x.7 1433 extendable
ip nat inside source static tcp 192.168.0.133 1433 92.46.x.8 1433 extendable

а сами глобальные ip адреса висят на fa 2/0 как secondary.
Недоступны они периодически. Местные гуру говорят, что так не делается!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "NAT, Loopback на cisco 3725"  +/
Сообщение от евгений (??) on 08-Окт-09, 12:55 
>[оверквотинг удален]
>>
>>лупбэки? зачем?
>>static nat
>
>Сейчас у меня так и сделано.
>ip nat inside source static tcp 192.168.0.60 1433 92.46.x.7 1433 extendable
>ip nat inside source static tcp 192.168.0.133 1433 92.46.x.8 1433 extendable
>
>а сами глобальные ip адреса висят на fa 2/0 как secondary.
>Недоступны они периодически. Местные гуру говорят, что так не делается!

что значит недоступны? опишите ситуацию подробнее.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 12:58 
>что значит недоступны? опишите ситуацию подробнее.

Тут описано: http://www.opennet.ru/openforum/vsluhforumID6/19743.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "NAT, Loopback на cisco 3725"  +/
Сообщение от GolDi (??) on 08-Окт-09, 13:17 
>[оверквотинг удален]
>>
>>лупбэки? зачем?
>>static nat
>
>Сейчас у меня так и сделано.
>ip nat inside source static tcp 192.168.0.60 1433 92.46.x.7 1433 extendable
>ip nat inside source static tcp 192.168.0.133 1433 92.46.x.8 1433 extendable
>
>а сами глобальные ip адреса висят на fa 2/0 как secondary.
>Недоступны они периодически. Местные гуру говорят, что так не делается!

Вам же говорили, не надо secondary делать.А если бы вам сетку /24 выделили, вы тоже
как secondary их прописывали?
Просто NAT  правильно сделайте.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 13:21 
>Просто NAT  правильно сделайте.

Вы такой умный! Вам череп не жмёт? А я о чём здесь сейчас спрашиваю то?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "NAT, Loopback на cisco 3725"  +/
Сообщение от GolDi (??) on 08-Окт-09, 13:27 
>>Просто NAT  правильно сделайте.
>
>Вы такой умный! Вам череп не жмёт? А я о чём здесь
>сейчас спрашиваю то?

Попробуй IOS поменять

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 13:29 
>>>Просто NAT  правильно сделайте.
>>
>>Вы такой умный! Вам череп не жмёт? А я о чём здесь
>>сейчас спрашиваю то?
>
>Попробуй IOS поменять

У меня стоит advipservicesk9-mz.124-3
Что мне это даст?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "NAT, Loopback на cisco 3725"  +/
Сообщение от GolDi (??) on 08-Окт-09, 13:31 
>>>>Просто NAT  правильно сделайте.
>>>
>>>Вы такой умный! Вам череп не жмёт? А я о чём здесь
>>>сейчас спрашиваю то?
>>
>>Попробуй IOS поменять
>
>У меня стоит advipservicesk9-mz.124-3
>Что мне это даст?

Просто займётесь чем-нибудь :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 13:35 
>Просто займётесь чем-нибудь :)

Я вообще то ожидал дельного совета, а не глупых шуточек :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "NAT, Loopback на cisco 3725"  +/
Сообщение от klin (ok) on 08-Окт-09, 13:56 
>>Просто займётесь чем-нибудь :)
>
>Я вообще то ожидал дельного совета, а не глупых шуточек :(

Свич который VLAN-ы умеет есть?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 08-Окт-09, 13:59 
>Свич который VLAN-ы умеет есть?

Есть. D-Link гигабитный 48 портовый

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "NAT, Loopback на cisco 3725"  +/
Сообщение от GolDi (??) on 08-Окт-09, 19:18 
>>Свич который VLAN-ы умеет есть?
>
>Есть. D-Link гигабитный 48 портовый

В топку..

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "NAT, Loopback на cisco 3725"  +/
Сообщение от Ixxtiander (ok) on 09-Окт-09, 07:48 
Так что делать то? Кучу вторичных адресов на 1 интерфейс вешать - неправильно!? На лупбэки их развесить не получится! Что вариантов нет больше?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "и никаких лупбеков"  +/
Сообщение от ДорогойДрук on 10-Окт-09, 16:23 
Никаких лупбеков тут не надо
Благодарности шлите моей секретарше :)

вот вся конфига:

interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside

interface FastEthernet2/0
ip address 92.46.x.2 255.255.255.240
ip nat outside

ip route 0.0.0.0 0.0.0.0 92.46.x.1
ip nat inside source list 1 interface FastEthernet2/0 overload
ip nat inside source static tcp 192.168.0.103 8080 92.46.x.13 8080 extendable
ip nat inside source static tcp 192.168.0.60 1433 92.46.x.7 1433 extendable
ip nat inside source static tcp 192.168.0.133 1433 92.46.x.8 1433 extendable

access-list 1 permit 192.168.0.0 0.0.0.255

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру