The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 1811w проблема с bridging при IRB"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Cisco 1811w проблема с bridging при IRB"  +/
Сообщение от KdF (??) on 08-Июн-10, 09:25 
Всем привет, я в тупике, нужна помощь. Есть циска 1811w, тривиальный сетап - канал в интернет, нат, wi-fi и локалка в vlan10.

Клиенты по wi-fi и по сети подключаются, получают адреса, ходят в интернет, видят другие сети через тоннель. Но при этом НЕ ВИДЯТ ДРУГ ДРУГА, то есть бриджинг не работает.

Стояла 12.3 какая-то, обновлена до flash:c181x-advipservicesk9-mz.124-9.T.bin в отчаянных попытках завести бриджинг.
Пока еще не было возможности проверить после апгрейда, но думаю ситуация не изменится.

В чем в принципе может быть проблема? Реально не могу воткнуть, всю голову сломал. на 871 все прекрасно работает в аналогичной конфигурации. Может это с ip inspect связано? Как его выключить или хотя бы заставить работать этот бриджинг? Или это я уже просто туплю?

Вот основные моменты конфига.


no aaa new-model
!
resource policy
!
ip cef
no ip dhcp use class
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.29.1
ip dhcp excluded-address 192.168.29.128 192.168.29.255
!
ip dhcp pool office
   import all
   network 192.168.29.0 255.255.255.0
   default-router 192.168.29.1
   netbios-name-server 192.168.40.1
   dns-server 8.8.8.8
   option 150 ip 192.168.40.7
   domain-name XXX
!
!
ip inspect name default streamworks
no spanning-tree vlan 10
!
bridge irb
!        
!
interface Tunnel0
ip address 192.168.28.1 255.255.255.252
tunnel source FastEthernet0
tunnel destination XXX.XXX.XXX.XXX
tunnel key XXX
!
interface FastEthernet0
description provider uplink
ip address XXX.XXX.XXX.XXX 255.255.255.224
ip access-group 1 in
ip access-group 1 out
ip nat outside
ip virtual-reassembly
speed auto
full-duplex
!
interface FastEthernet1
no ip address
ip access-group 1 in
ip access-group 1 out
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
interface FastEthernet2
switchport access vlan 10
!
interface FastEthernet3
switchport access vlan 10
!
interface FastEthernet4
switchport access vlan 10
!
interface FastEthernet5
switchport access vlan 10
!
interface FastEthernet6
switchport access vlan 10
!
interface FastEthernet7
switchport access vlan 10
!
interface FastEthernet8
switchport access vlan 10
!
interface FastEthernet9
switchport access vlan 10
!
interface Dot11Radio0
no ip address
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
!
encryption vlan 10 mode ciphers tkip
!
encryption mode ciphers tkip
!
ssid XXX
    vlan 10
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 XXXXXXX
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.10
encapsulation dot1Q 10 native
no ip route-cache
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
shutdown
speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
no ip address
ip access-group 120 in
ip access-group 120 out
ip inspect default in
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
!
interface Async1
no ip address
encapsulation slip
!
interface BVI1
ip address 192.168.29.1 255.255.255.0
ip access-group 120 in
ip access-group 120 out
ip nat inside
ip inspect default in
ip virtual-reassembly
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map vpdnusers
network 192.168.0.0 0.0.255.255 area 0
!
ip forward-protocol spanning-tree
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!
!
ip http server
no ip http secure-server
ip nat inside source list 100 interface FastEthernet0 overload
!
access-list 1 permit any
access-list 100 deny   ip 192.168.29.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 100 permit ip 192.168.29.0 0.0.0.255 any
access-list 120 permit ip any any
access-list 150 permit icmp any any
!
!!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1811w проблема с bridging при IRB"  +/
Сообщение от CrAzOiD (ok) on 08-Июн-10, 11:30 
>[оверквотинг удален]
>access-list 120 permit ip any any
>access-list 150 permit icmp any any
>!
>!!
>control-plane
>!
>bridge 1 protocol ieee
>bridge 1 route ip
>!
>end

ИМХО, курите в сторону WiFi AP isolation:
"This option isolates all wireless clients and wireless
devices on your network from each other."

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Cisco 1811w проблема с bridging при IRB"  +/
Сообщение от sh_ email(ok) on 08-Июн-10, 18:06 
А давайте уберем ip inspect с vlan10 и bvi1.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Cisco 1811w проблема с bridging при IRB"  +/
Сообщение от KdF (??) on 09-Июн-10, 18:50 
>А давайте уберем ip inspect с vlan10 и bvi1.

ip inspect туда был от отчаяния поставлен, просто была ситуация когда-то давно, когда в виде костыля это помогло на другой железке.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Cisco 1811w проблема с bridging при IRB"  +/
Сообщение от KdF (??) on 10-Июн-10, 23:27 
После обновления IOS до 12.4-9, пересохранения конфига, no ip inspect в основном конфиге и на итерфейсах все завелось каким-то чудесным образом.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру