The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  правила/FAQ  поиск  регистрация  вход/выход  слежка  RSS
"Улучшить сходимость сети"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Оборудование Lucent, Nortell и др.)
Изначальное сообщение [ Отслеживать ]
Курсы по Juniper Junos в Москве и Петербурге
"Улучшить сходимость сети"  +/
Сообщение от Ilmet (ok) on 11-Апр-17, 14:08 
Добрый день!
Есть стенд (кольцо):
- (ge0/23) Cisco ME3600 (ge0/24) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/23) Cisco ME3600 (ge0/24) -

Задача: Сходимость сети <50мс. В настоящий момент около 5с. (Замеряю Ping Plotter)

Конфиг Cisco:


ip vrf OPS
rd 10.8.194.70:103
route-target export 65000:103
route-target import 65000:103
!
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng fast-reroute backup-prot-preempt optimize-bw
mpls traffic-eng auto-tunnel backup
mpls traffic-eng auto-tunnel backup timers removal unused 7200 7200
mpls traffic-eng auto-tunnel backup tunnel-num min 2000 max 2999
mpls traffic-eng auto-tunnel backup srlg exclude preferred
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config mpls ip
mpls traffic-eng auto-tunnel primary tunnel-num min 1000 max 1999
!
vlan 103
name OPS
!
!
interface Loopback0
ip address 10.8.194.70 255.255.255.255
!
!
interface GigabitEthernet0/1
description OPS
switchport access vlan 103
!
interface GigabitEthernet0/23
no switchport
mtu 1600
ip address 172.16.1.17 255.255.255.252
no ip redirects
ip ospf dead-interval 4
ip ospf hello-interval 1
mpls ip
mpls traffic-eng tunnels
mpls traffic-eng srlg 5
bfd interval 50 min_rx 50 multiplier 3
!
interface GigabitEthernet0/24
no switchport
mtu 1600
ip address 172.16.1.9 255.255.255.252
no ip redirects
ip ospf dead-interval 4
ip ospf hello-interval 1
mpls ip
mpls traffic-eng tunnels
mpls traffic-eng srlg 5
bfd interval 50 min_rx 50 multiplier 3
!
interface Vlan1
no ip address
shutdown
!
!
interface Vlan103
ip vrf forwarding OPS
ip address 192.168.202.33 255.255.255.248
!
router ospf 1
router-id 10.8.194.70
network 10.8.194.70 0.0.0.0 area 0
network 172.16.1.8 0.0.0.3 area 0
network 172.16.1.16 0.0.0.3 area 0
bfd all-interfaces
!
router bgp 65000
bgp router-id 10.8.194.70
bgp log-neighbor-changes
neighbor 10.8.194.75 remote-as 65000
!
address-family vpnv4
  neighbor 10.8.194.75 activate
  neighbor 10.8.194.75 send-community both
exit-address-family
!
address-family ipv4 vrf OPS
  redistribute connected
exit-address-family
!

Конфиг Huawei:


board add 0/8 24GE

#
lldp enable
#
dhcp enable
#
ip vpn-instance OPS
ipv4-family
  route-distinguisher 10.8.194.73:103
  vpn-target 65000:103 export-extcommunity
  vpn-target 65000:103 import-extcommunity
#
vlan 103
name OPS
#
bfd
#
mpls lsr-id 10.8.194.73                  
mpls
mpls te
mpls te auto-frr
mpls te srlg path-calculation preferred
mpls rsvp-te
mpls te cspf
#
mpls ldp
auto-frr lsp-trigger all
#
interface Vlanif103
ip binding vpn-instance OPS
ip address 192.168.202.41 255.255.255.248
#
interface MEth0/0/0
ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet0/0/0
mtu 1600
ip address 172.16.1.10 255.255.255.252
ospf timer hello 1
ospf bfd enable
ospf bfd min-tx-interval 50 min-rx-interval 50
mpls                                    
mpls te
mpls te srlg 5
mpls rsvp-te
mpls ldp
#
interface GigabitEthernet0/0/1
mtu 1600
ip address 172.16.1.5 255.255.255.252
ospf timer hello 1
ospf bfd enable
ospf bfd min-tx-interval 50 min-rx-interval 50
mpls
mpls te
mpls te srlg 5
mpls rsvp-te
mpls ldp
#
interface GigabitEthernet0/0/4
description VirtualPort
ip address dhcp-alloc                    
#
interface GigabitEthernet8/0/1
description OPS
port link-type access
port default vlan 103
#
interface LoopBack0
ip address 10.8.194.73 255.255.255.255
#
bgp 65000
router-id 10.8.194.73
peer 10.8.194.75 as-number 65000
#
ipv4-family unicast
  undo synchronization                    
  undo peer 10.8.194.75 enable
#
ipv4-family vpnv4
  policy vpn-target
  peer 10.8.194.75 enable
#
ipv4-family vpn-instance OPS
  import-route direct
#
ospf 1 router-id 10.8.194.73
bfd all-interfaces enable
bfd all-interfaces min-tx-interval 50 min-rx-interval 50
opaque-capability enable
frr
area 0.0.0.0
  network 10.8.194.73 0.0.0.0
  network 172.16.1.4 0.0.0.3
  network 172.16.1.8 0.0.0.3              
  mpls-te enable
#

10.8.194.75 - Route Reflecror

Для улучшения сходимости уменьшил Hello Interval и Dead Interval, включил BFD.

На оборудовании заказчика так же настроено:


mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng fast-reroute backup-prot-preempt optimize-bw
mpls traffic-eng auto-tunnel backup
mpls traffic-eng auto-tunnel backup timers removal unused 7200 7200
mpls traffic-eng auto-tunnel backup tunnel-num min 2000 max 2999
mpls traffic-eng auto-tunnel backup srlg exclude preferred
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config mpls ip
mpls traffic-eng auto-tunnel primary tunnel-num min 1000 max 1999

Возможно, кто-то сможет подсказать как реализовать это на Huawei?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Улучшить сходимость сети"  +/
Сообщение от gfh1gfh1 (ok) on 12-Апр-17, 08:31 
http://blog.ine.com/2010/06/02/ospf-fast-convergenc/
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Улучшить сходимость сети"  +/
Сообщение от eek (ok) on 12-Апр-17, 10:31 
> Добрый день!
> Есть стенд (кольцо):
> - (ge0/23) Cisco ME3600 (ge0/24) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/0/0)
> Huawei AR3260 (ge0/0/1) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/23) Cisco
> ME3600 (ge0/24) -
> Задача: Сходимость сети <50мс. В настоящий момент около 5с. (Замеряю Ping Plotter)

Поддержку тему.

Что на этот вопрос ответили в сапорте хуавея?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Улучшить сходимость сети"  +/
Сообщение от Ilmet (ok) on 12-Апр-17, 16:30 
>> Добрый день!
>> Есть стенд (кольцо):
>> - (ge0/23) Cisco ME3600 (ge0/24) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/0/0)
>> Huawei AR3260 (ge0/0/1) - (ge0/0/0) Huawei AR3260 (ge0/0/1) - (ge0/23) Cisco
>> ME3600 (ge0/24) -
>> Задача: Сходимость сети <50мс. В настоящий момент около 5с. (Замеряю Ping Plotter)
> Поддержку тему.
> Что на этот вопрос ответили в сапорте хуавея?

Благодарю за поддержку. В саппорте хуавея ответили, что мы его не купили. Точнее, техподдержку хуавея заказчик активирует после ПНР.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Улучшить сходимость сети"  +/
Сообщение от Ilya S on 13-Сен-17, 23:06 
> Есть стенд (кольцо):
> mpls ldp
>  auto-frr lsp-trigger all

В кольце LFA не будет работать, даже per prefix.
Нужен Remote-LFA или TI-LFA, но это уже другая история.


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor