The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 1803. Проблемы с NAT."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 04-Окт-10, 21:43 
Здравствуйте. Помогите пожалуйста решить проблему. В локальной сети провайдера имеется VPN сервер для выхода в интернет, а так же в сети прова имеются различные ресурсы (ftp-сервера, игровые сервера и т.д.). Для доступа ко всему этому с домашних компов решил использовать Cisco 1803. Циску настроил, PPP сессия устанавливается без проблем. Проблема заключается в следующем: пинги с циски до локальных ресурсов и до ресурсов интернет проходят нормально, а вот компы домашней сети, подключенные к этой циске, ничего кроме ее самой пингануть не могут, но при этом работает скайп и торрент. Подозреваю что дело в NAT. Будте добры, помогите решить данную проблему.
P.S. Ниже привожу конфиг своей железки.

yourname#sh run
Building configuration...

Current configuration : 6051 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 3
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2
!
!
ip domain name yourdomain.com
ip multicast-routing
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pptp
  rotary-group 0
initiate-to ip 10.0.0.21
initiate-to ip 10.0.0.23
initiate-to ip 10.0.0.24
initiate-to ip 10.0.0.25
initiate-to ip 10.0.0.26
initiate-to ip 10.0.0.27
initiate-to ip 10.0.0.28
initiate-to ip 10.0.0.29
initiate-to ip 10.0.0.30
initiate-to ip 10.0.0.31
initiate-to ip 10.0.0.32
initiate-to ip 10.0.0.33
initiate-to ip 10.0.0.34
authen-before-forward
!
!
!
crypto pki trustpoint TP-self-signed-2588796006
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2588796006
revocation-check none
rsakeypair TP-self-signed-2588796006
!
!
crypto pki certificate chain TP-self-signed-2588796006
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32353838 37393630 3036301E 170D3037 30393137 31363235
  33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35383837
  39363030 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B959 2A2E6CD7 6D81C285 D97004E5 D4348738 A5684D69 3423FED8 C22020B3
  95516876 E7F40A89 BE29C198 4AA21E0B E0EDDD66 27EA0033 7ECFC1ED 1C369803
  802AF3DA 53688FF0 BF8EDE6F 717F7048 8D863299 4182C232 E4C406F9 F61593A1
  2FA4164B FD39B3C1 B3EC9818 A0E37307 CDB820C6 5456C6DA BDB643B1 27068F0B
  3E610203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 14457D20 6635F352 3718E960 990B584B E51CB839
  E4301D06 03551D0E 04160414 457D2066 35F35237 18E96099 0B584BE5 1CB839E4
  300D0609 2A864886 F70D0101 04050003 81810099 E2AC00BE E7B2DD84 DC26D258
  327D6DBC A5E28EBC 7282D64B C6AD3283 92EE1ABB 0F9D3AF3 84B9D472 898EB71D
  88522DFB E67D39B5 E5E751D9 7349465D 075F845C 42E99CC1 844D9346 F1E3F5BB
  992BC6A9 E1FFF422 33ED66A5 5F93896D 4D1956C0 3681C55D A4AB6CD4 EE3C0E6F
  F4D136E0 140DADD4 821FC48A F2A36586 92BD8C
  quit
username cisco privilege 15 secret 5 $1$5EHM$5BNOLSkxNzUD5GyclLika/
username xxxxx privilege 15 password 0 xxxxx
!
!
controller DSL 0
line-term cpe
!
!
!
!
!
interface FastEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$
ip address 10.10.10.1 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
mtu 1450
ip address negotiated
no ip proxy-arp
ip pim dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no peer neighbor-route
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname xxxxx
ppp chap password 0 xxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.21 255.255.255.255 10.50.26.1
ip route 10.0.0.23 255.255.255.255 10.50.26.1
ip route 10.0.0.24 255.255.255.255 10.50.26.1
ip route 10.0.0.25 255.255.255.255 10.50.26.1
ip route 10.0.0.26 255.255.255.255 10.50.26.1
ip route 10.0.0.27 255.255.255.255 10.50.26.1
ip route 10.0.0.28 255.255.255.255 10.50.26.1
ip route 10.0.0.29 255.255.255.255 10.50.26.1
ip route 10.0.0.30 255.255.255.255 10.50.26.1
ip route 10.0.0.31 255.255.255.255 10.50.26.1
ip route 10.0.0.32 255.255.255.255 10.50.26.1
ip route 10.0.0.33 255.255.255.255 10.50.26.1
ip route 10.0.0.34 255.255.255.255 10.50.26.1
ip route 10.0.0.0 255.0.0.0 dhcp
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 23 interface Dialer0 overload
!
access-list 23 permit 10.10.10.0 0.0.0.7
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
control-plane
!
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
no scheduler allocate
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от sh_ email(ok) on 04-Окт-10, 23:10 
Сдается мне, что у вас просто dns не прописан на компиках. Либо прописан, но не тот. ;)
Только сбивает ваша фраза:
>а вот компы домашней сети, подключенные к этой циске, ничего кроме ее самой пингануть не могут, но при этом работает скайп и торрент.

Вы верите в чудеса?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 05-Окт-10, 09:58 
> Сдается мне, что у вас просто dns не прописан на компиках. Либо
> прописан, но не тот. ;)
> Только сбивает ваша фраза:
>>а вот компы домашней сети, подключенные к этой циске, ничего кроме ее самой пингануть не могут, но при этом работает скайп и торрент.
> Вы верите в чудеса?

Скажите пожалуйста, а можно ли сделать так, чтобы циска автоматически раздавала dns компам. И если не трудно, опишите как это реализовать.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от lumenous (ok) on 05-Окт-10, 10:08 
>> Сдается мне, что у вас просто dns не прописан на компиках. Либо
>> прописан, но не тот. ;)
>> Только сбивает ваша фраза:
>>>а вот компы домашней сети, подключенные к этой циске, ничего кроме ее самой пингануть не могут, но при этом работает скайп и торрент.
>> Вы верите в чудеса?
> Скажите пожалуйста, а можно ли сделать так, чтобы циска автоматически раздавала dns
> компам. И если не трудно, опишите как это реализовать.

У вас же локальные компы по DHCP получают IP?
Вот в DHCP пуле и пропишите
dns-server %IP сервера%

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 05-Окт-10, 10:15 
> У вас же локальные компы по DHCP получают IP?
> Вот в DHCP пуле и пропишите
> dns-server %IP сервера%

А пуле прописать IP dns-сервера провайдера? Извиняюсь за подобные вопросы. Никогда с таким сталкиваться не приходилось =(


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от lumenous (ok) on 05-Окт-10, 10:17 
>> У вас же локальные компы по DHCP получают IP?
>> Вот в DHCP пуле и пропишите
>> dns-server %IP сервера%
> А пуле прописать IP dns-сервера провайдера? Извиняюсь за подобные вопросы. Никогда с
> таким сталкиваться не приходилось =(

Ну, видимо да, DNS сервера провайдера.
А вообще поищите на cisco.com что можно указывать в настройках DHCP пула. Там все подробно расписано.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 05-Окт-10, 10:22 
> Ну, видимо да, DNS сервера провайдера.
> А вообще поищите на cisco.com что можно указывать в настройках DHCP пула.
> Там все подробно расписано.

Спасибо за совет. Пойду на cisco.com, почитаю. Вечером попробую применить Ваши советы на железке. Результат отпишу.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 05-Окт-10, 23:48 
>> Ну, видимо да, DNS сервера провайдера.
>> А вообще поищите на cisco.com что можно указывать в настройках DHCP пула.
>> Там все подробно расписано.
> Спасибо за совет. Пойду на cisco.com, почитаю. Вечером попробую применить Ваши советы
> на железке. Результат отпишу.

Попробовал прописать dns сервера прова, а так же сервера Google Public DNS. Все осталось по прежнему =( Компы из домашней сетки никак не хотят идти ни в инет, ни в локалку прова. Но с компов проходят пинги до 74.125.232.49 и до других адресов (при этом ftp сервера прова не пингуются). Подскажите пожалуйста, что еще можно попробовать сделать или же хоть в какую сторону копать. 3 дня бьюсь, а эффекта пока так и нет =(


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от blank (ok) on 06-Окт-10, 10:26 
> ftp сервера прова не пингуются)

у вас не описан нат для сети провайдера,
> Попробовал прописать dns сервера прова, а так же сервера Google Public DNS.
> Все осталось по прежнему =( Компы из домашней сетки никак не

на компах nslookup раотает?
покажите трайсер с любого компа до куда нибудь в иннет и sh ip nat trans в этот момент.


эмммм.. у вас локалка прова с адресами 10.х.х.х?
а нафигаж вы и своей локальной сети адреса из того же диапазона выдаете.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 06-Окт-10, 12:42 
> эмммм.. у вас локалка прова с адресами 10.х.х.х?
> а нафигаж вы и своей локальной сети адреса из того же диапазона
> выдаете.

Адреса в своей локалке поменял:
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool sdm-pool
   import all
   network 192.168.0.0 255.255.255.248
   default-router 192.168.0.1
   lease 0 2
!
!
ip domain name yourdomain.com
ip name-server 10.0.0.120
ip name-server 10.0.0.185
ip multicast-routing

> на компах nslookup раотает?
> покажите трайсер с любого компа до куда нибудь в иннет и sh
> ip nat trans в этот момент.

Вот nslookup и tracert с компа:

C:\Program Files\Far>nslookup
Default Server:  UnKnown
Address:  10.0.0.120

C:\Program Files\Far>tracert 77.88.21.11

Трассировка маршрута к 77.88.21.11 с максимальным числом прыжков 30

  1    <1 мс    <1 мс    <1 мс  192.168.0.1
  2     1 ms     1 ms     1 ms  10.0.0.28
  3     *        *        *     Превышен интервал ожидания для запроса.
  4     2 ms     2 ms     2 ms  193.232.246.93
  5     2 ms     2 ms     2 ms  77.88.16.125
  6     3 ms     2 ms     2 ms  213.180.213.44
  7     2 ms     2 ms     2 ms  77.88.21.11

Трассировка завершена.


А вот show ip nat translations во время трассировки:

yourname#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 84.51.99.155:768  192.168.0.2:768    77.88.21.11:768    77.88.21.11:768
tcp 84.51.99.155:4266  192.168.0.2:4266   79.132.4.6:10798   79.132.4.6:10798
tcp 84.51.99.155:4269  192.168.0.2:4269   74.201.34.2:443    74.201.34.2:443
tcp 84.51.99.155:4273  192.168.0.2:4273   134.2.194.45:80    134.2.194.45:80
tcp 84.51.99.155:4274  192.168.0.2:4274   205.188.8.98:5190  205.188.8.98:5190
tcp 84.51.99.155:4276  192.168.0.2:4276   207.46.124.65:1863 207.46.124.65:1863
tcp 84.51.99.155:4279  192.168.0.2:4279   205.188.8.106:5190 205.188.8.106:5190
udp 84.51.99.155:30276 192.168.0.2:30276  46.73.55.180:35917 46.73.55.180:35917
udp 84.51.99.155:30276 192.168.0.2:30276  68.3.26.111:10724  68.3.26.111:10724
udp 84.51.99.155:30276 192.168.0.2:30276  68.44.21.14:54667  68.44.21.14:54667
udp 84.51.99.155:30276 192.168.0.2:30276  68.119.61.34:443   68.119.61.34:443
udp 84.51.99.155:30276 192.168.0.2:30276  89.189.178.18:47225 89.189.178.18:47225
udp 84.51.99.155:30276 192.168.0.2:30276  94.71.90.75:4414   94.71.90.75:4414
udp 84.51.99.155:30276 192.168.0.2:30276  94.180.225.161:13358 94.180.225.161:13358
udp 84.51.99.155:30276 192.168.0.2:30276  95.29.130.213:17613 95.29.130.213:17613
udp 84.51.99.155:30276 192.168.0.2:30276  114.47.208.244:20982 114.47.208.244:20982
udp 84.51.99.155:30276 192.168.0.2:30276  174.116.125.134:38906 174.116.125.134:38906
Pro Inside global      Inside local       Outside local      Outside global
udp 84.51.99.155:30276 192.168.0.2:30276  187.44.146.9:443   187.44.146.9:443
udp 84.51.99.155:30276 192.168.0.2:30276  187.90.104.101:36241 187.90.104.101:36241
udp 84.51.99.155:30276 192.168.0.2:30276  187.116.189.36:23998 187.116.189.36:23998
udp 84.51.99.155:30276 192.168.0.2:30276  211.19.251.105:57933 211.19.251.105:57933
udp 84.51.99.155:50818 192.168.0.2:50818  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:50818 192.168.0.2:50818  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:55463 192.168.0.2:55463  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:55463 192.168.0.2:55463  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:56785 192.168.0.2:56785  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:56785 192.168.0.2:56785  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:56962 192.168.0.2:56962  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:56962 192.168.0.2:56962  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:61176 192.168.0.2:61176  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:61176 192.168.0.2:61176  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:63669 192.168.0.2:63669  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:63669 192.168.0.2:63669  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:63670 192.168.0.2:63670  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:63670 192.168.0.2:63670  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:63671 192.168.0.2:63671  10.0.0.120:53      10.0.0.120:53
Pro Inside global      Inside local       Outside local      Outside global
udp 84.51.99.155:63671 192.168.0.2:63671  10.0.0.185:53      10.0.0.185:53
udp 84.51.99.155:65457 192.168.0.2:65457  10.0.0.120:53      10.0.0.120:53
udp 84.51.99.155:65457 192.168.0.2:65457  10.0.0.185:53      10.0.0.185:53
yourname#

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от blank (ok) on 06-Окт-10, 14:51 
> Вот nslookup и tracert с компа:
> C:\Program Files\Far>nslookup
> Default Server:  UnKnown
> Address:  10.0.0.120

сделайте:
nslookup
ya.ru
если имя резолвится с ДНС все нормально.
> C:\Program Files\Far>tracert 77.88.21.11
> Трассировка маршрута к 77.88.21.11 с максимальным числом прыжков 30
> Трассировка завершена.
> А вот show ip nat translations во время трассировки:
> yourname#sh ip nat translations
> Pro Inside global      Inside local  
>     Outside local    
> Outside global
> icmp 84.51.99.155:768  192.168.0.2:768    77.88.21.11:768    77.88.21.11:768

трайсер прошел уже хорошо, ваш комп 192.168.0.2 прошел через нат 84.51.99.155
что конкретно не работает?

access-list 23 permit 10.10.10.0 0.0.0.7 поменять не забыли?
и покажите конфиг полностью, с изменениями.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 06-Окт-10, 16:21 
> сделайте:
> nslookup
> ya.ru
> если имя резолвится с ДНС все нормально.

Вот что он мне говорит при nslookup:

C:\Documents and Settings\Администратор>nslookup
DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address 10.0.0.120: Timed out
DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address 10.0.0.185: Timed out
*** Default servers are not available
Default Server:  UnKnown
Address:  10.0.0.120

> ya.ru

Server:  UnKnown
Address:  10.0.0.120

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
> google.com

Server:  UnKnown
Address:  10.0.0.120

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
>

Вот конфиг со всеми сдеанными изменениями:

yourname#sh run
Building configuration...

Current configuration : 6159 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool sdm-pool
   import all
   network 192.168.0.0 255.255.255.248
   default-router 192.168.0.1
   dns-server 10.0.0.120 10.0.0.185
   lease 0 2
!
!
ip domain name yourdomain.com
ip name-server 10.0.0.120
ip name-server 10.0.0.185
ip multicast-routing
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pptp
  rotary-group 0
initiate-to ip 10.0.0.21
initiate-to ip 10.0.0.23
initiate-to ip 10.0.0.24
initiate-to ip 10.0.0.25
initiate-to ip 10.0.0.26
initiate-to ip 10.0.0.27
initiate-to ip 10.0.0.28
initiate-to ip 10.0.0.29
initiate-to ip 10.0.0.30
initiate-to ip 10.0.0.31
initiate-to ip 10.0.0.32
initiate-to ip 10.0.0.33
initiate-to ip 10.0.0.34
authen-before-forward
!
!
!        
crypto pki trustpoint TP-self-signed-2588796006
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2588796006
revocation-check none
rsakeypair TP-self-signed-2588796006
!
!
crypto pki certificate chain TP-self-signed-2588796006
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32353838 37393630 3036301E 170D3037 30393137 31363235
  33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35383837
  39363030 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B959 2A2E6CD7 6D81C285 D97004E5 D4348738 A5684D69 3423FED8 C22020B3
  95516876 E7F40A89 BE29C198 4AA21E0B E0EDDD66 27EA0033 7ECFC1ED 1C369803
  802AF3DA 53688FF0 BF8EDE6F 717F7048 8D863299 4182C232 E4C406F9 F61593A1
  2FA4164B FD39B3C1 B3EC9818 A0E37307 CDB820C6 5456C6DA BDB643B1 27068F0B
  3E610203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 14457D20 6635F352 3718E960 990B584B E51CB839
  E4301D06 03551D0E 04160414 457D2066 35F35237 18E96099 0B584BE5 1CB839E4
  300D0609 2A864886 F70D0101 04050003 81810099 E2AC00BE E7B2DD84 DC26D258
  327D6DBC A5E28EBC 7282D64B C6AD3283 92EE1ABB 0F9D3AF3 84B9D472 898EB71D
  88522DFB E67D39B5 E5E751D9 7349465D 075F845C 42E99CC1 844D9346 F1E3F5BB
  992BC6A9 E1FFF422 33ED66A5 5F93896D 4D1956C0 3681C55D A4AB6CD4 EE3C0E6F
  F4D136E0 140DADD4 821FC48A F2A36586 92BD8C
  quit
username cisco privilege 15 secret 5 $1$5EHM$5BNOLSkxNzUD5GyclLika/
username XXXXX privilege 15 password 0 XXXXX
!
!
controller DSL 0
line-term cpe
!
!
!
!
!
interface FastEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!        
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$
ip address 192.168.0.1 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
mtu 1450
ip address negotiated
no ip proxy-arp
ip pim dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no peer neighbor-route
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname XXXXX
ppp chap password 0 XXXXX
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.21 255.255.255.255 10.50.26.1
ip route 10.0.0.23 255.255.255.255 10.50.26.1
ip route 10.0.0.24 255.255.255.255 10.50.26.1
ip route 10.0.0.25 255.255.255.255 10.50.26.1
ip route 10.0.0.26 255.255.255.255 10.50.26.1
ip route 10.0.0.27 255.255.255.255 10.50.26.1
ip route 10.0.0.28 255.255.255.255 10.50.26.1
ip route 10.0.0.29 255.255.255.255 10.50.26.1
ip route 10.0.0.30 255.255.255.255 10.50.26.1
ip route 10.0.0.31 255.255.255.255 10.50.26.1
ip route 10.0.0.32 255.255.255.255 10.50.26.1
ip route 10.0.0.33 255.255.255.255 10.50.26.1
ip route 10.0.0.34 255.255.255.255 10.50.26.1
ip route 10.0.0.0 255.0.0.0 dhcp
!
ip dns server
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 23 interface Dialer0 overload
!
access-list 23 permit 192.168.0.0 0.0.0.7
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
control-plane
!
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
no scheduler allocate
end

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от lumenous (ok) on 06-Окт-10, 10:26 
>[оверквотинг удален]
>>> Там все подробно расписано.
>> Спасибо за совет. Пойду на cisco.com, почитаю. Вечером попробую применить Ваши советы
>> на железке. Результат отпишу.
> Попробовал прописать dns сервера прова, а так же сервера Google Public DNS.
> Все осталось по прежнему =( Компы из домашней сетки никак не
> хотят идти ни в инет, ни в локалку прова. Но с
> компов проходят пинги до 74.125.232.49 и до других адресов (при этом
> ftp сервера прова не пингуются). Подскажите пожалуйста, что еще можно попробовать
> сделать или же хоть в какую сторону копать. 3 дня бьюсь,
> а эффекта пока так и нет =(

Надо делать пинги трейсы, смотреть появляются ли трансляции нат на циске, включать дебаг. Вариантов траблшутинга море. =)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от blank (ok) on 06-Окт-10, 15:04 
и добавьте
ip dhcp pool sdm-pool
   import all
   network 192.168.0.0 255.255.255.248
   default-router 192.168.0.1
   dns-server 10.0.0.120 10.0.0.185
   lease 0 2
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Cisco 1803. Проблемы с NAT."  +/
Сообщение от Zloy_chesnok (ok) on 06-Окт-10, 17:36 
Уффф....
Все, решил проблему.
Решилась она следующим образом:
1.Создал 2 access-list
access-list 100 permit ip 192.168.0.0 0.0.0.7 10.0.0.0 0.255.255.255
access-list 101 permit ip 192.168.0.0 0.0.0.7 any

2.Применил их следующим образом
ip nat inside source list 100 interface FastEthernet0 overload
ip nat inside source list 101 interface Dialer0 overload

После данных манипуляций, инет пошел на компы, а так же заработали локальные ресурсы прова. Огромнейшее спасибо ВСЕМ тем, кто помогал мне в решении данной проблемы. Нижу привожу свой листинг. Тему можно закрывать. До свидания. И еще раз благодарю за участие.

yourname#sh run
Building configuration...

Current configuration : 6342 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool sdm-pool
   import all
   network 192.168.0.0 255.255.255.248
   default-router 192.168.0.1
   dns-server 10.0.0.120 10.0.0.185
   lease 0 2
!
!
ip domain name yourdomain.com
ip name-server 10.0.0.120
ip name-server 10.0.0.185
ip multicast-routing
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pptp
  rotary-group 0
initiate-to ip 10.0.0.21
initiate-to ip 10.0.0.23
initiate-to ip 10.0.0.24
initiate-to ip 10.0.0.25
initiate-to ip 10.0.0.26
initiate-to ip 10.0.0.27
initiate-to ip 10.0.0.28
initiate-to ip 10.0.0.29
initiate-to ip 10.0.0.30
initiate-to ip 10.0.0.31
initiate-to ip 10.0.0.32
initiate-to ip 10.0.0.33
initiate-to ip 10.0.0.34
authen-before-forward
!
!
!        
crypto pki trustpoint TP-self-signed-2588796006
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2588796006
revocation-check none
rsakeypair TP-self-signed-2588796006
!
!
crypto pki certificate chain TP-self-signed-2588796006
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32353838 37393630 3036301E 170D3037 30393137 31363235
  33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35383837
  39363030 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B959 2A2E6CD7 6D81C285 D97004E5 D4348738 A5684D69 3423FED8 C22020B3
  95516876 E7F40A89 BE29C198 4AA21E0B E0EDDD66 27EA0033 7ECFC1ED 1C369803
  802AF3DA 53688FF0 BF8EDE6F 717F7048 8D863299 4182C232 E4C406F9 F61593A1
  2FA4164B FD39B3C1 B3EC9818 A0E37307 CDB820C6 5456C6DA BDB643B1 27068F0B
  3E610203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 14457D20 6635F352 3718E960 990B584B E51CB839
  E4301D06 03551D0E 04160414 457D2066 35F35237 18E96099 0B584BE5 1CB839E4
  300D0609 2A864886 F70D0101 04050003 81810099 E2AC00BE E7B2DD84 DC26D258
  327D6DBC A5E28EBC 7282D64B C6AD3283 92EE1ABB 0F9D3AF3 84B9D472 898EB71D
  88522DFB E67D39B5 E5E751D9 7349465D 075F845C 42E99CC1 844D9346 F1E3F5BB
  992BC6A9 E1FFF422 33ED66A5 5F93896D 4D1956C0 3681C55D A4AB6CD4 EE3C0E6F
  F4D136E0 140DADD4 821FC48A F2A36586 92BD8C
  quit
username cisco privilege 15 secret 5 $1$5EHM$5BNOLSkxNzUD5GyclLika/
username XXXXX privilege 15 password 0 XXXXX
!
!
controller DSL 0
line-term cpe
!
!
!
!
!
interface FastEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!        
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$
ip address 192.168.0.1 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
mtu 1450
ip address negotiated
no ip proxy-arp
ip pim dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no peer neighbor-route
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname XXXXX
ppp chap password 0 XXXXX
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.21 255.255.255.255 10.50.26.1
ip route 10.0.0.23 255.255.255.255 10.50.26.1
ip route 10.0.0.24 255.255.255.255 10.50.26.1
ip route 10.0.0.25 255.255.255.255 10.50.26.1
ip route 10.0.0.26 255.255.255.255 10.50.26.1
ip route 10.0.0.27 255.255.255.255 10.50.26.1
ip route 10.0.0.28 255.255.255.255 10.50.26.1
ip route 10.0.0.29 255.255.255.255 10.50.26.1
ip route 10.0.0.30 255.255.255.255 10.50.26.1
ip route 10.0.0.31 255.255.255.255 10.50.26.1
ip route 10.0.0.32 255.255.255.255 10.50.26.1
ip route 10.0.0.33 255.255.255.255 10.50.26.1
ip route 10.0.0.34 255.255.255.255 10.50.26.1
ip route 10.0.0.0 255.0.0.0 dhcp
!
ip dns server
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet0 overload
ip nat inside source list 101 interface Dialer0 overload
!
access-list 23 permit 192.168.0.0 0.0.0.7
access-list 100 permit ip 192.168.0.0 0.0.0.7 10.0.0.0 0.255.255.255
access-list 101 permit ip 192.168.0.0 0.0.0.7 any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege level of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use.

For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
no scheduler allocate
end

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру