The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"HSRP + BGP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"HSRP + BGP"  +/
Сообщение от xporter (ok) on 02-Ноя-10, 14:14 
На схеме имеется два рутера R1 и R2, которые относятся к провайдеру , через которые он выходит в мир, также иметься рутер LX(local exchange), который обеспечивает связь между  другими организациями подключенных к этому провайдеру. Рутеры A1 и A2 мои рутеры(7206), на которых поднят BGP  и HSRP , которые  должны обеспечивать отказоустойчивость.
1.    При добавления префикса ip prefix-list XXX seq 5 permit 192.168.0.0/24 на бекап рутер A2 , трассировка на мой адрес из вне идет через  рутер A2, тоесть трафик идет через A2 , а не через A1 как должно быть. Провайдер сказал нужно увеличить путь до него путем препенда.
Set as-path prepend 1111 1111 1111 , результатов не дало. В чем может быть проблема что настроено, не так ?

2.    Надо поднять BGP между моими рутерами A1  и A2, для того чтобы в случае падения аплинка от R1 к A1, весь трафик перенаправился к A2  и оттуда ушел к провайдеру. Как это сделать точно я не знаю, физически аплинк между ними будет. Если можно распишите по подробнее зарание спасибо

http://files.mail.ru/C0GGMA?t=1  - схема
2 желтые линии , физически один аплинк разделенный виланами, с фиолетовыми , та же ситуация.


Настройка рутера A1:

interface GigabitEthernet0/1.82
encapsulation dot1Q 82
ip address 192.168.1.62 255.255.255.252
!
interface GigabitEthernet0/1.83
encapsulation dot1Q 83
ip address 192.168.2.66 255.255.255.252

router bgp 11111
bgp always-compare-med
bgp log-neighbor-changes
bgp deterministic-med
neighbor 192.168.1.61 remote-as 29049
neighbor 192.168.1.61 description DELTA-Internet-BGP  
neighbor 192.168.1.61 ebgp-multihop 2
neighbor 192.168.2.65 remote-as 29049
neighbor 192.168.2.65 description DELTA-Local-BGP  
neighbor 192.168.2.65 ebgp-multihop 2
neighbor 192.168.2.65 remote-as 29049
!
address-family ipv4
  redistribute connected route-map DELTA-OUT
  redistribute static
  neighbor 192.168.1.61 activate
  neighbor 192.168.1.61 soft-reconfiguration inbound
  neighbor 192.168.1.61 route-map DELTA-OUT out
  neighbor 192.168.2.65 activate
  neighbor 192.168.2.65 soft-reconfiguration inbound
  neighbor 192.168.2.65 route-map DELTA-OUT out
  
  no auto-summary
  synchronization
  network 192.168.0.0 mask 255.255.255.0
exit-address-family
!
no ip http server
no ip http secure-server
!
ip route 192.168.0.0 255.255.255.0 Null0

!
!
ip access-list extended second-net
!
!
ip prefix-list XXX seq 5 permit 192.168.0.0/24
logging alarm informational
route-map DELTA-OUT permit 5
match ip address prefix-list XXX

настройки рутера A2

interface GigabitEthernet0/1.82
encapsulation dot1Q 82
ip address 192.168.3.178 255.255.255.252
!
interface GigabitEthernet0/1.83
description Delta Local Exchange
encapsulation dot1Q 83
ip address 192.168.2.134 255.255.255.252
ip flow ingress

!
router bgp 11111
bgp always-compare-med
bgp log-neighbor-changes
bgp deterministic-med
neighbor 192.168.3.177 remote-as 29049
neighbor 192.168.3.177 description DELTA-Internet-BGP  
neighbor 192.168.3.177 ebgp-multihop 3
neighbor 192.168.2.133 remote-as 29049
neighbor 192.168.2.133 description DELTA-Local-BGP
neighbor 192.168.2.133 ebgp-multihop 3
!
address-family ipv4
  redistribute connected route-map DELTA-OUT
  redistribute static
  neighbor 192.168.3.177 activate
  neighbor 192.168.3.177 soft-reconfiguration inbound
  neighbor 192.168.3.177 route-map DELTA-OUT out
  neighbor 192.168.2.133 activate
  neighbor 192.168.2.133 soft-reconfiguration inbound
  neighbor 192.168.2.133 route-map DELTA-OUT out
  
  no auto-summary
  synchronization
  network 192.168.0.0 mask 255.255.255.0
exit-address-family
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.255.0 Null0
no ip http server
no ip http secure-server
!
!
!
!
ip prefix-list XXX seq 4 permit 192.168.0.0/24
logging alarm informational
!
!
!
!
route-map DELTA-OUT permit 5
match ip address prefix-list XXX
set as-path prepend 11111 11111 11111

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • HSRP + BGP, ivb, 15:00 , 02-Ноя-10, (1)  
    • HSRP + BGP, xporter, 16:17 , 02-Ноя-10, (2)  
      • HSRP + BGP, GByte, 20:31 , 02-Ноя-10, (3)  
        • HSRP + BGP, xporter, 15:56 , 03-Ноя-10, (4)  
          • HSRP + BGP, GByte, 21:28 , 03-Ноя-10, (5)  
          • HSRP + BGP, арч, 12:08 , 04-Ноя-10, (6)  

Сообщения по теме [Сортировка по времени | RSS]


1. "HSRP + BGP"  +/
Сообщение от ivb (??) on 02-Ноя-10, 15:00 
Вы можете через предпочитаемый роутер отдать более мелкие IP префиксы,
тогда входящий трафик пойдет через него точно.
Допустим 192.168.0.0/24 как два по  /25.
Если нет такой возможности, проверьте as-path внимательно, как отдаются препенды.

ПО резервированию, из схемы - HSRP шлюз для внутрисети.
При падении роутера, доступ до шлюза всегда будет.
Сделайте линк по BGP между роутерами, для защиты от падения провайдеров R1 и R2.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "HSRP + BGP"  +/
Сообщение от xporter (ok) on 02-Ноя-10, 16:17 
> Вы можете через предпочитаемый роутер отдать более мелкие IP префиксы,
> тогда входящий трафик пойдет через него точно.
> Допустим 192.168.0.0/24 как два по  /25.
> Если нет такой возможности, проверьте as-path внимательно, как отдаются препенды.
> ПО резервированию, из схемы - HSRP шлюз для внутрисети.
> При падении роутера, доступ до шлюза всегда будет.
> Сделайте линк по BGP между роутерами, для защиты от падения провайдеров R1
> и R2.

С первым более менее понятно, ночью попробую, а вот со вторым я не совсем уверен как сделать более правильнее. Если сделаю на отдельном вилане, с любыми адресами, например из класса C  и буду использовать тот же номер AS , что и с провайдером, будет работать, проблем не будет ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "HSRP + BGP"  +/
Сообщение от GByte (??) on 02-Ноя-10, 20:31 
> Если сделаю на отдельном
> вилане, с любыми адресами, например из класса C  и буду
> использовать тот же номер AS , что и с провайдером, будет
> работать, проблем не будет ?

Внутри своей AS вы должны использовать один номер, это будет iBGP.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "HSRP + BGP"  +/
Сообщение от xporter (ok) on 03-Ноя-10, 15:56 
>> Если сделаю на отдельном
>> вилане, с любыми адресами, например из класса C  и буду
>> использовать тот же номер AS , что и с провайдером, будет
>> работать, проблем не будет ?
> Внутри своей AS вы должны использовать один номер, это будет iBGP.

neighbor  remote-as ???  - какой значение должно быть здесь ?
  
neighbor  ebgp-multihop ??? и здесь ?

Извините за ламерские вопросы, просто за каждое падение мне бывает огромный втык, я хочу быть уверенным, что все сразу заработает или хотя бы не будет катастрофы.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "HSRP + BGP"  +/
Сообщение от GByte (??) on 03-Ноя-10, 21:28 

> neighbor  remote-as ???  - какой значение должно быть здесь ?

Здесь номер твоей AS.

> neighbor  ebgp-multihop ??? и здесь ?

нет, это только если у тебя сосед из другой AS находится на расстоянии более одного хопа от тебя.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "HSRP + BGP"  +/
Сообщение от арч on 04-Ноя-10, 12:08 
> neighbor  remote-as ???  - какой значение должно быть здесь ?
> neighbor  ebgp-multihop ??? и здесь ?

Купите книжку или хотя бы почитайте Sam Halabi.
Даже если у вас получится каким-то чудом поднять всё, не понимая ни одной строчки в конфиге, всё равно удача продлится ровно до первого падения.

> Извините за ламерские вопросы, просто за каждое падение мне бывает огромный втык,
> я хочу быть уверенным, что все сразу заработает или хотя бы
> не будет катастрофы.

Ничего личного, но вам нужен для этого специалист, bgp довольно сложная тема.
А бесперебойность вообще стоит дорого и ещё многократно тяжелее в обслуживании.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру