The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco Eigrp / BGP balanced"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 06-Дек-10, 17:36 
Добрый день.
Продолжаю мучить динамические протоколы маршрутизации.)
Прошу помочь в реализации, грамотности топологии и рациональности схемы.

Дано:
- 2 роутера R1 и R2 связаны друг с другом 3 линками.

Задача:
- прокидывать по xconnect L2 клиентов с балансировкой по каналам
- управление ходит по BGP

------------------------------------
Собрал такое:
http://s003.radikal.ru/i201/1012/3e/339ce3d81772.jpg

Для быстрой сходимости выбрал протокол EIGRP. Роутеры R1 и R2 сделал в одной EIGRP AS.
BGP AS у них разные (это в будущем при масштабируемости, чтоб не создавать роутер-рефлекторы и для предотвращения зацикливания маршрутов)
Поверх EIGRP запустил BGP.
Loopback'и для XCONNECT обозначил по BGP

Вот что получилось:

R1:
----
R1#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B    200.200.200.0/24 [20/0] via 20.20.20.20, 00:13:14
     100.0.0.0/24 is subnetted, 1 subnets
C       100.100.100.0 is directly connected, FastEthernet0/1.100
     192.168.30.0/30 is subnetted, 1 subnets
C       192.168.30.0 is directly connected, FastEthernet0/1.30
     20.0.0.0/32 is subnetted, 1 subnets
D       20.20.20.20 [90/156160] via 192.168.30.2, 00:15:32, FastEthernet0/1.30
                    [90/156160] via 192.168.20.2, 00:15:32, FastEthernet0/1.20
                    [90/156160] via 192.168.10.2, 00:15:32, FastEthernet0/1.10
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, FastEthernet0/1.10
     22.0.0.0/32 is subnetted, 1 subnets
B       22.22.22.22 [20/0] via 20.20.20.20, 00:15:22
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, FastEthernet0/1.20
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback10
     11.0.0.0/32 is subnetted, 1 subnets
C       11.11.11.11 is directly connected, Loopback11
R1#

-----------------------

R2:
---

R2#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.200.200.0/24 is directly connected, FastEthernet0/1.200
     100.0.0.0/24 is subnetted, 1 subnets
B       100.100.100.0 [20/0] via 10.10.10.10, 00:15:02
     192.168.30.0/30 is subnetted, 1 subnets
C       192.168.30.0 is directly connected, FastEthernet0/1.30
     20.0.0.0/32 is subnetted, 1 subnets
C       20.20.20.20 is directly connected, Loopback20
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, FastEthernet0/1.10
     22.0.0.0/32 is subnetted, 1 subnets
C       22.22.22.22 is directly connected, Loopback22
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, FastEthernet0/1.20
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/156160] via 192.168.30.1, 00:16:50, FastEthernet0/1.30
                    [90/156160] via 192.168.20.1, 00:16:50, FastEthernet0/1.20
                    [90/156160] via 192.168.10.1, 00:16:50, FastEthernet0/1.10
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 10.10.10.10, 00:16:09
R2#

--------------------------
XCONNECT поднялись:


R2#sh l2tun ses

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 2

LocID      RemID      TunID      Username, Intf/      State  Last Chg Uniq ID  
                                 Vcid, Circuit                                  
64591      40567      33368      111, Fa0/0.111:111   est    00:37:08 3      
64592      40568      33368      112, Fa0/0.112:112   est    00:37:08 4      

%No active PPTP tunnels
R2#

Компы сервера пингуют, все ок.
Но вот прямой канал все таки делят пополам( (т.е. ходят по какому-то одному линку)

С ip load-sharing per pecket не хочу связываться. Оно работает, я собирал, но из-за большого объема трафика не могу позволить себе такое по процессору.

Каналы у меня равнозначные.
Важен вопрос сходимости для XCONNECT'ов, чтоб простоя у юзеров не было.

Указал:
router eigrp 100
variance 3

Как грамотно балансируется именно трафик. Сети при BGP можно раскидать, а у меня по 1 Loopback'у на цыску для Xconnect'ов.
Может что забыл?

-------------------------------------------------------------------
Конфиги:

R1
---

hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
l2tp-class Eigrp_signal
hello 10
cookie size 8
!        
!
pseudowire-class wire_Eigrp
encapsulation l2tpv3
protocol l2tpv3 Eigrp_signal
ip local interface Loopback11
ip tos reflect
!
!
!
interface Loopback10
ip address 10.10.10.10 255.255.255.255
!
interface Loopback11
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
description Users
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!        
interface FastEthernet0/0.1
description dead VLAN 1
encapsulation dot1Q 1 native
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
interface FastEthernet0/0.111
description PD_User_1
encapsulation dot1Q 111
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no cdp enable
xconnect 22.22.22.22 111 encapsulation l2tpv3 pw-class wire_Eigrp
!
interface FastEthernet0/0.112
description PD_User_2
encapsulation dot1Q 112
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no cdp enable
xconnect 22.22.22.22 112 encapsulation l2tpv3 pw-class wire_Eigrp
!
interface FastEthernet0/1
description Tag_port_1
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1.1
description dead VLAN 1
encapsulation dot1Q 1 native
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
interface FastEthernet0/1.10
description CH-1
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.20
description CH-2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.30
description CH-3
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.100
description UPO_R1
encapsulation dot1Q 100
ip address 100.100.100.100 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no cdp enable
!
router eigrp 100
variance 3
network 10.10.10.10 0.0.0.0
network 192.168.10.0 0.0.0.3
network 192.168.20.0 0.0.0.3
network 192.168.30.0 0.0.0.3
no auto-summary
!
router bgp 100
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 100.100.100.0 mask 255.255.255.0
neighbor 20.20.20.20 remote-as 200
neighbor 20.20.20.20 ebgp-multihop 2
neighbor 20.20.20.20 update-source Loopback10
maximum-paths 3
no auto-summary
!        
!

R2:
----

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
l2tp-class Eigrp_signal
hello 10
cookie size 8
!        
!
pseudowire-class wire_Eigrp
encapsulation l2tpv3
protocol l2tpv3 Eigrp_signal
ip local interface Loopback22
ip tos reflect
!
!
!
interface Loopback20
ip address 20.20.20.20 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
description Users
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!        
interface FastEthernet0/0.1
description dead VLAN 1
encapsulation dot1Q 1 native
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
interface FastEthernet0/0.111
description PD_User_1
encapsulation dot1Q 111
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no cdp enable
xconnect 11.11.11.11 111 encapsulation l2tpv3 pw-class wire_Eigrp
!
interface FastEthernet0/0.112
description PD_User_2
encapsulation dot1Q 112
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no cdp enable
xconnect 11.11.11.11 112 encapsulation l2tpv3 pw-class wire_Eigrp
!
interface FastEthernet0/1
description Tag_port_1
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1.1
description dead VLAN 1
encapsulation dot1Q 1 native
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
interface FastEthernet0/1.10
description CH-1
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.20
description CH-2
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.30
description CH-3
encapsulation dot1Q 30
ip address 192.168.30.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no cdp enable
!
interface FastEthernet0/1.200
description UPO_R2
encapsulation dot1Q 200
ip address 200.200.200.200 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no cdp enable
!
router eigrp 100
variance 3
network 20.20.20.20 0.0.0.0
network 192.168.10.0 0.0.0.3
network 192.168.20.0 0.0.0.3
network 192.168.30.0 0.0.0.3
no auto-summary
!
router bgp 200
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
network 200.200.200.0 mask 255.255.255.255
neighbor 10.10.10.10 remote-as 100
neighbor 10.10.10.10 ebgp-multihop 2
neighbor 10.10.10.10 update-source Loopback20
maximum-paths 3
no auto-summary
!
!

На сети 200.200.200.0 /24 и 100.100.100.0 /24 не обращайте внимания. Это управление. Для него не требуется балансировка.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Aleks305 (ok) on 06-Дек-10, 20:50 
>[оверквотинг удален]
>  network 200.200.200.0 mask 255.255.255.255
>  neighbor 10.10.10.10 remote-as 100
>  neighbor 10.10.10.10 ebgp-multihop 2
>  neighbor 10.10.10.10 update-source Loopback20
>  maximum-paths 3
>  no auto-summary
> !
> !
> На сети 200.200.200.0 /24 и 100.100.100.0 /24 не обращайте внимания. Это управление.
> Для него не требуется балансировка.

если балансировка нагрузки для eigrp, то необходимо указать
maximum-paths 3
traffic-share balanced

В этом случае трафик будет балансироваться по трем каналам пропорционально метрике

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 07-Дек-10, 08:44 
> если балансировка нагрузки для eigrp, то необходимо указать
> maximum-paths 3
> traffic-share balanced
> В этом случае трафик будет балансироваться по трем каналам пропорционально метрике

maximum-paths вроде отвечает кол-во промежуточных "хопов" до места назначения своего соседа.
Т.е. было бы у меня:

   -    
R1 - Rx - R2         (R1 имеет 3 линка до Rx)
   -

То вроде без этой команды сетки в таблице маршрутизации прилетят с одной стороны.
Если поставить на R1 maximum-paths 3 - то будет 3 равноценных маршрута до R2.
Но у меня промежуточных пока нет. Самую простую схему собрал.

Вроде оно так работает.
Но и так я пробовал тоже(

> router eigrp 100
> maximum-paths 3
> traffic-share balanced

(на интерфейсах ip load-sharing не прописывал.)
Не получилось все равно, 3 одинаковых маршрута есть, но прямой трафик по Xcpnnect'ам юзеров все равно делится м/у ними. Обратный можно не балансировать (но было бы тоже интересно)

L2 туннели вообще балансируется? Может это не реально?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Aleks305 email(ok) on 07-Дек-10, 09:40 
maximum-paths прописывают количество маршрутов находящихся в таблице маршрутизации, по которым можно отправлять трафик к определенной подсети. Если между R1 и Rx три линка, то по ним трафик и будет балансироваться, если между Rx и R2 один линк, то весь трафик будет складываться в этот один линк...вот и все.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 07-Дек-10, 10:40 
> maximum-paths прописывают количество маршрутов находящихся в таблице маршрутизации,
> по которым можно отправлять трафик к определенной подсети. Если между R1
> и Rx три линка, то по ним трафик и будет балансироваться,
> если между Rx и R2 один линк, то весь трафик будет
> складываться в этот один линк...вот и все.

Aleks305, в том и дело что если бы я анонсировал сети для L3 клиентов по EIGRP, то при этом конфиге maximum-paths 3 оно бы работало и все балансировалось (мне кажется)
Но у меня L2 тунели, по которым бегает трафик юзеров.
Xconnect'ы связаны на loopback, которые в свою очередь маршрутизируются по BGP поверх EIGRP.
Если эти loopback просто принимать по EIGRP то тоже эффекта ноль. Траффик l2tun не балансируется.
Если я добавлю на сабинтерфейсы ip load-sharing per packet, то пакетики разлетятся по 3 каналам. И в принципе все ок. Но из-за тяжести трафика L2tun и небольшой мощности цыски я не могу себе такое позволить. Да и некрасиво это, с точки зрения рутинга. Хотелось чтобы на уровне протокола динамической маршрутизации это работало.

Мне необходимо балансировать не L3 сети, а именно L2 тунели, которые ходят поверх протокола динамической маршрутизации

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Cisco Eigrp / BGP balanced"  +/
Сообщение от chocholl email(??) on 07-Дек-10, 10:47 
зона ответственности протокола маршрутизации заканчивается когда маршрут(ы) помещен(ы) в RIB.
дальше дело в том какой механизм свитчинга вы выбираете.
как раз per destination или per packet.
пока не включен per packet, в rib может быть сколько угодно маршрутов.
но, так как трафик реально ходит между двумя лупбеками, балансировка cef выберет в вашем случае только один путь.


>[оверквотинг удален]
> Xconnect'ы связаны на loopback, которые в свою очередь маршрутизируются по BGP поверх
> EIGRP.
> Если эти loopback просто принимать по EIGRP то тоже эффекта ноль. Траффик
> l2tun не балансируется.
> Если я добавлю на сабинтерфейсы ip load-sharing per packet, то пакетики разлетятся
> по 3 каналам. И в принципе все ок. Но из-за тяжести
> трафика L2tun и небольшой мощности цыски я не могу себе такое
> позволить. Да и некрасиво это, с точки зрения рутинга. Хотелось чтобы
> на уровне протокола динамической маршрутизации это работало.
> Мне необходимо балансировать не L3 сети, а именно L2 тунели.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 07-Дек-10, 11:02 
> зона ответственности протокола маршрутизации заканчивается когда маршрут(ы) помещен(ы)
> в RIB.
> дальше дело в том какой механизм свитчинга вы выбираете.
> как раз per destination или per packet.
> пока не включен per packet, в rib может быть сколько угодно маршрутов.
> но, так как трафик реально ходит между двумя лупбеками, балансировка cef выберет
> в вашем случае только один путь.

При per destination (что по умолчанию):


R2#
R2#clear ip e 100 ne    
R2#
R2#
*Dec  7 07:53:59.391: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.10.1 (FastEthernet0/1.10) is down: manually cleared
*Dec  7 07:53:59.391: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.20.1 (FastEthernet0/1.20) is down: manually cleared
*Dec  7 07:53:59.391: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.30.1 (FastEthernet0/1.30) is down: manually cleared
*Dec  7 07:54:01.759: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.20.1 (FastEthernet0/1.20) is up: new adjacency
*Dec  7 07:54:03.295: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.30.1 (FastEthernet0/1.30) is up: new adjacency
*Dec  7 07:54:03.787: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.10.1 (FastEthernet0/1.10) is up: new adjacency
R2#
R2#ping 10.10.10.10 rep 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 1/2/4 ms
R2#
*Dec  7 07:55:29.355: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.355: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.359: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.359: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.359: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.359: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.359: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.359: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.359: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.359: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.363: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.363: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.363: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.363: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.363: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.363: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.363: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.363: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.367: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.367: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.367: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.367: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.367: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.367: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.367: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.367: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.371: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.371: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.371: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.371: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.371: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.371: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.371: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.371: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.375: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB
*Dec  7 07:55:29.375: IP: s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), len 100, rcvd 3
*Dec  7 07:55:29.375: IP: tableid=0, s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), routed via FIB
*Dec  7 07:55:29.375: IP: s=192.168.20.2 (local), d=10.10.10.10 (FastEthernet0/1.20), len 100, sending
*Dec  7 07:55:29.375: IP: tableid=0, s=10.10.10.10 (FastEthernet0/1.20), d=192.168.20.2 (FastEthernet0/1.20), routed via RIB


-------------
Вижу пакетики побежали через один соурс. Включив бы per packet, оно бы разлетелось по разным. Каким образом тогда лучше балансировать L2 трафик? Только указывая per packet? (

R2#sh ip cef
Prefix              Next Hop             Interface
10.10.10.10/32      192.168.30.1         FastEthernet0/1.30
                    192.168.20.1         FastEthernet0/1.20
                    192.168.10.1         FastEthernet0/1.10

На интерфейсак fast-switching выключен :  no ip route-cache, т.е. по идее роутер должен производить балансировку для каждого пакета.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 07-Дек-10, 11:14 
Я уже такое делал, но по IS-IS.
Добился того, что трафик по Xconnect бежал по 2 линкам. Но с использованием load-sharing per packet.
А хотелось бы без этого, если это вообще возможно)

Вот видео моего стенда (тот же l2 трафик бежит по 1 каналу, а потом по 2ум балансируясь с большей скоростью):
http://www.youtube.com/watch?v=9FReMjkVt0M

Сходимость у ISIS так себе конечно.

Теперь же мне необходимо не объединять полосу, а автоматом делить нагрузку на каналах.
Т.е. работает юзер, качает что-то по одному каналу. Влез еще один, роутер видит: "ага, этот канал забит 80%, а вон тот всего 1%, иди туда." И т.д.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Cisco Eigrp / BGP balanced"  +/
Сообщение от chocholl email(??) on 07-Дек-10, 13:17 
почитайте про OER
у него есть такая функциональность, хотя заморочек много.

если транзитная сеть своя, используйте сквозной l2 + эзерченел.

>[оверквотинг удален]
> А хотелось бы без этого, если это вообще возможно)
> Вот видео моего стенда (тот же l2 трафик бежит по 1 каналу,
> а потом по 2ум балансируясь с большей скоростью):
> http://www.youtube.com/watch?v=9FReMjkVt0M
> Сходимость у ISIS так себе конечно.
> Теперь же мне необходимо не объединять полосу, а автоматом делить нагрузку на
> каналах.
> Т.е. работает юзер, качает что-то по одному каналу. Влез еще один, роутер
> видит: "ага, этот канал забит 80%, а вон тот всего 1%,
> иди туда." И т.д.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 07-Дек-10, 13:46 
> почитайте про OER
> у него есть такая функциональность, хотя заморочек много.

спасибо. Про OER не знал. Попробую.
Думал просто, что l2 можно как то проще балансировать.

Вообще полная топология это кольцо, но с перекресщивающимися линками внутри. Каналы узкие, вот и надо, пробрасывать l2 трафик автоматом и как можно рациональнее загружая каналы.

> если транзитная сеть своя, используйте сквозной l2 + эзерченел.

это вроде удел коммутаторов.
У меня линки приходят на роутер(не обязательно ethernet, а E1, frame-relay и т.д) Надо именно на цыске такое придумать.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Cisco Eigrp / BGP balanced"  +/
Сообщение от Semop email(ok) on 07-Дек-10, 18:13 
Не знаю правильно ли такое решение, но в принципе заработало )

Решил обмануть l2tp.
Сделал пока на 2х каналах, тестовых хостов не хватило.

Создал на R1 и R2 по 2 loopback (кол-во каналов = кол-ву loopback), их с каждой стороны проанонсировал по EIGRP.

На роутере получил:

D       10.10.10.10 [90/156160] via 192.168.20.1, 00:31:59, FastEthernet0/1.20
                    [90/156160] via 192.168.10.1, 00:31:59, FastEthernet0/1.10
     11.0.0.0/32 is subnetted, 1 subnets
D       11.11.11.11 [90/156160] via 192.168.20.1, 00:31:59, FastEthernet0/1.20
                    [90/156160] via 192.168.10.1, 00:31:59, FastEthernet0/1.10

А L2tp раскидал так:

interface FastEthernet0/0.111
description PD_User_1
encapsulation dot1Q 111
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no cdp enable
xconnect 10.10.10.10 111 encapsulation l2tpv3 pw-class wire_Eigrp-1
!
interface FastEthernet0/0.112
description PD_User_2
encapsulation dot1Q 112
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no cdp enable
xconnect 11.11.11.11 112 encapsulation l2tpv3 pw-class wire_Eigrp-2

Т.е. на 2 разных лупбэка, но находящиеся на одном роутере.(все равно ж по EIGRP эти лупбэки прилетят) Получается балансировка не самого траффика L2TP, а балансировка трафика на лупбэках.

Глядя на FTP кач с хостов по L2TP вижу прерывание - 5сек. при падении канала. Потом трафик делится и все ок. Восстанавливается также ~5сек и загружены оба канала по максимуму.

Чем такое грозит пока не знаю, сработал per-destination (по-умолчанию) без нагрузки на процессор, что для меня немаловажно.

Отписавшимся спасибо.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру