The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"OSPF и резервировние через GRE"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
SWITCH+ROUTE+TSHOOT – курсы Cisco CCNP для администраторов больших сетей
"OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 17-Дек-17, 10:10 
Господа помогите найти ошибку в настроек OSPF
схема почти классическая , три маршрутизатора соединены wifi бриджами , настроен и работает OSPF , сейчас хочу добавить резерв канала через инет (GRE тоннели)

r1 (центральный)
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1492
ip address 192.10.0.21 255.255.255.252
ip mtu 1400
ip tcp adjust-mss 1360
ip ospf cost 1000
ip ospf 1 area 0
tunnel source 10.136.104.126
tunnel destination 10.136.87.254
!
!
interface Tunnel2014
ip address 192.10.0.25 255.255.255.252
ip mtu 1400
ip tcp adjust-mss 1360
ip ospf cost 1000
ip ospf 1 area 0
tunnel source 10.136.104.126
tunnel destination 10.136.109.252
!

router ospf 1
log-adjacency-changes
redistribute connected
redistribute static subnets
network 192.10.0.20 0.0.0.3 area 0
network 192.10.0.24 0.0.0.3 area 0
network 192.11.11.0 0.0.0.127 area 0
!

r2
interface Loopback0
ip address 1.1.1.2 255.255.255.255
!
interface Tunnel1492
ip address 192.10.0.22 255.255.255.252
ip mtu 1400
ip tcp adjust-mss 1360
ip ospf cost 1000
ip ospf 1 area 0
tunnel source 10.136.87.254
tunnel destination 10.136.104.126
!
router ospf 1
log-adjacency-changes
redistribute connected
network 192.10.0.20 0.0.0.3 area 0
network 192.11.11.0 0.0.0.127 area 0


r3
interface Loopback0
ip address 1.1.1.3 255.255.255.255
!
interface Tunnel2014
ip address 192.10.0.26 255.255.255.252
ip mtu 1400
ip tcp adjust-mss 1360
ip ospf cost 1000
ip ospf 1 area 0
tunnel source 10.136.109.252
tunnel destination 10.136.104.126

router ospf 1
log-adjacency-changes
redistribute connected
redistribute static subnets
network 192.10.0.24 0.0.0.3 area 0
network 192.11.11.0 0.0.0.127 area 0


Так вот, не почему почему на r2 и r3 ospf не видит соседей через GRE

r1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.2           1   FULL/BDR        00:00:35    192.11.11.20    Vlan101
1.1.1.3           1   FULL/DR         00:00:31    192.11.11.30    Vlan101
1.1.1.3           0   INIT/  -        00:00:32    192.10.0.26     Tunnel2014
1.1.1.2           0   INIT/  -        00:00:37    192.10.0.22     Tunnel1492

r2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DROTHER    00:00:36    192.11.11.10    Vlan101
1.1.1.3           1   FULL/DR         00:00:31    192.11.11.30    Vlan101

r3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DROTHER    00:00:36    192.11.11.10    Vlan101
1.1.1.2           1   FULL/BDR        00:00:37    192.11.11.20    Vlan101

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "OSPF и резервировние через GRE"  +/
Сообщение от fantom (??) on 17-Дек-17, 16:40 
>[оверквотинг удален]
> r3#show ip ospf neighbor
> Neighbor ID     Pri   State  
>         Dead Time  
>  Address         Interface
> 1.1.1.1           1
>   FULL/DROTHER    00:00:36    192.11.11.10
>    Vlan101
> 1.1.1.2           1
>   FULL/BDR        00:00:37
>    192.11.11.20    Vlan101

https://www.opennet.ru/openforum/vsluhforumID1/97073.html
У вас та же ошибка.
redistr connected

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 17-Дек-17, 17:18 
>[оверквотинг удален]
>>  Address         Interface
>> 1.1.1.1           1
>>   FULL/DROTHER    00:00:36    192.11.11.10
>>    Vlan101
>> 1.1.1.2           1
>>   FULL/BDR        00:00:37
>>    192.11.11.20    Vlan101
> https://www.opennet.ru/openforum/vsluhforumID1/97073.html
> У вас та же ошибка.
> redistr connected

я удалил анонс сетей GRE из OSPF картинка совсем не поменялась  
хотя вот в этой статье сети в GRE добавляются в анонс https://www.cisco.com/c/en/us/support/docs/security-vpn/ipse...

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "OSPF и резервировние через GRE"  +/
Сообщение от fantom (??) on 17-Дек-17, 23:35 
>[оверквотинг удален]
>>>   FULL/DROTHER    00:00:36    192.11.11.10
>>>    Vlan101
>>> 1.1.1.2           1
>>>   FULL/BDR        00:00:37
>>>    192.11.11.20    Vlan101
>> https://www.opennet.ru/openforum/vsluhforumID1/97073.html
>> У вас та же ошибка.
>> redistr connected
> я удалил анонс сетей GRE из OSPF картинка совсем не поменялась
> хотя вот в этой статье сети в GRE добавляются в анонс https://www.cisco.com/c/en/us/support/docs/security-vpn/ipse...

Убрать надо было
redistr connected


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "OSPF и резервировние через GRE"  +/
Сообщение от fantom (??) on 17-Дек-17, 23:38 
>[оверквотинг удален]
>>>> 1.1.1.2           1
>>>>   FULL/BDR        00:00:37
>>>>    192.11.11.20    Vlan101
>>> https://www.opennet.ru/openforum/vsluhforumID1/97073.html
>>> У вас та же ошибка.
>>> redistr connected
>> я удалил анонс сетей GRE из OSPF картинка совсем не поменялась
>> хотя вот в этой статье сети в GRE добавляются в анонс https://www.cisco.com/c/en/us/support/docs/security-vpn/ipse...
> Убрать надо было
> redistr connected

И проверить что туннели впринципе поднялись....

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "OSPF и резервировние через GRE"  +/
Сообщение от Del on 18-Дек-17, 07:30 
Не вижу статистической маршрутизации до конечных точек туннелей. Вероятно прилетает дефолт по ОСПФ и начинается треш, угар и садомия.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 18-Дек-17, 20:44 
> Не вижу статистической маршрутизации до конечных точек туннелей. Вероятно прилетает дефолт
> по ОСПФ и начинается треш, угар и садомия.

зачем ? там же по одному маршрутеру с обеих сторон тоннеля , они и так попадают в таблицу, и трассируются из внутренних подсетей что характерно

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "OSPF и резервировние через GRE"  +/
Сообщение от Del on 19-Дек-17, 11:19 
>> Не вижу статистической маршрутизации до конечных точек туннелей. Вероятно прилетает дефолт
>> по ОСПФ и начинается треш, угар и садомия.
> зачем ? там же по одному маршрутеру с обеих сторон тоннеля ,
> они и так попадают в таблицу, и трассируются из внутренних подсетей
> что характерно

tunnel source 10.136.104.126
tunnel destination 10.136.87.254

до этих адресов роутеры как ходят, не увидел их в конфиге

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

11. "OSPF и резервировние через GRE"  +/
Сообщение от fantom (??) on 19-Дек-17, 16:41 
>>> Не вижу статистической маршрутизации до конечных точек туннелей. Вероятно прилетает дефолт
>>> по ОСПФ и начинается треш, угар и садомия.
>> зачем ? там же по одному маршрутеру с обеих сторон тоннеля ,
>> они и так попадают в таблицу, и трассируются из внутренних подсетей
>> что характерно
> tunnel source 10.136.104.126
> tunnel destination 10.136.87.254
> до этих адресов роутеры как ходят, не увидел их в конфиге

1. Кипаливы на туннели добавте.
Может они у вас вообще "мертвые", вот только этого невидно.
2. в некоторых IOS есть проблема с построением 2-х GRE с одного SRC.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 19-Дек-17, 22:41 
>>> Не вижу статистической маршрутизации до конечных точек туннелей. Вероятно прилетает дефолт
>>> по ОСПФ и начинается треш, угар и садомия.
>> зачем ? там же по одному маршрутеру с обеих сторон тоннеля ,
>> они и так попадают в таблицу, и трассируются из внутренних подсетей
>> что характерно
> tunnel source 10.136.104.126
> tunnel destination 10.136.87.254
> до этих адресов роутеры как ходят, не увидел их в конфиге

по дефалтовым маршрутам
10.136.104.1
10.136.87.129

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "OSPF и резервировние через GRE"  +/
Сообщение от Del on 20-Дек-17, 05:28 
>[оверквотинг удален]
>>>> по ОСПФ и начинается треш, угар и садомия.
>>> зачем ? там же по одному маршрутеру с обеих сторон тоннеля ,
>>> они и так попадают в таблицу, и трассируются из внутренних подсетей
>>> что характерно
>> tunnel source 10.136.104.126
>> tunnel destination 10.136.87.254
>> до этих адресов роутеры как ходят, не увидел их в конфиге
> по дефалтовым маршрутам
> 10.136.104.1
> 10.136.87.129

они статикой нарисованы?

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

9. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 18-Дек-17, 21:15 
>[оверквотинг удален]
>>>> 1.1.1.2           1
>>>>   FULL/BDR        00:00:37
>>>>    192.11.11.20    Vlan101
>>> https://www.opennet.ru/openforum/vsluhforumID1/97073.html
>>> У вас та же ошибка.
>>> redistr connected
>> я удалил анонс сетей GRE из OSPF картинка совсем не поменялась
>> хотя вот в этой статье сети в GRE добавляются в анонс https://www.cisco.com/c/en/us/support/docs/security-vpn/ipse...
> Убрать надо было
> redistr connected

убрал , естественно из маршрутов ушли все vlan , добавил анон сетей руками
но на публикацию тоннеля это не повеяло , как не было соседа по тоннель интерфейсу так инет  

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "OSPF и резервировние через GRE"  +/
Сообщение от Del on 18-Дек-17, 06:31 
Что дебаг то говорит?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 18-Дек-17, 20:48 
> Что дебаг то говорит?

вроде хелло видит с обеих интерфейсов (и физики и тоннеля)
а вот  в соседях только с физики

r1
*Dec 18 19:05:22.368: OSPF: End of hello processing
*Dec 18 19:05:24.636: OSPF: Send hello to 224.0.0.5 area 0 on Vlan101 from 192.11.11.10
*Dec 18 19:05:25.008: OSPF: Rcv hello from 1.1.1.2 area 0 from Vlan101 192.11.11.20
*Dec 18 19:05:25.008: OSPF: End of hello processing
*Dec 18 19:05:25.532: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel1492 from 192.10.0.21
*Dec 18 19:05:26.072: OSPF: Rcv hello from 1.1.1.2 area 0 from Tunnel1492 192.10.0.22
*Dec 18 19:05:26.072: OSPF: Send immediate hello to nbr 1.1.1.2, src address 192.10.0.22, on Tunnel1492
*Dec 18 19:05:26.076: OSPF: Send hello to 192.10.0.22 area 0 on Tunnel1492 from 192.10.0.21
*Dec 18 19:05:26.076: OSPF: End of hello processing
*Dec 18 19:05:28.300: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.25
*Dec 18 19:05:28.832: OSPF: Rcv hello from 1.1.1.3 area 0 from Tunnel2014 192.10.0.26
*Dec 18 19:05:28.832: OSPF: Send immediate hello to nbr 1.1.1.3, src address 192.10.0.26, on Tunnel2014
*Dec 18 19:05:28.832: OSPF: Send hello to 192.10.0.26 area 0 on Tunnel2014 from 192.10.0.25
*Dec 18 19:05:28.832: OSPF: End of hello processing
*Dec 18 19:05:32.280: OSPF: Rcv hello from 1.1.1.3 area 0 from Vlan101 192.11.11.30
*Dec 18 19:05:32.280: OSPF: End of hello processing
*Dec 18 19:05:34.068: OSPF: Rcv hello from 1.1.1.2 area 0 from Vlan101 192.11.11.20
*Dec 18 19:05:34.068: OSPF: End of hello processing
*Dec 18 19:05:34.516: OSPF: Send hello to 224.0.0.5 area 0 on Vlan101 from 192.11.11.10
*Dec 18 19:05:34.616: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel1492 from 192.10.0.21
*Dec 18 19:05:35.556: OSPF: Rcv hello from 1.1.1.2 area 0 from Tunnel1492 192.10.0.22
*Dec 18 19:05:35.556: OSPF: Send immediate hello to nbr 1.1.1.2, src address 192.10.0.22, on Tunnel1492
*Dec 18 19:05:35.556: OSPF: Send hello to 192.10.0.22 area 0 on Tunnel1492 from 192.10.0.21
*Dec 18 19:05:35.560: OSPF: End of hello processing
*Dec 18 19:05:37.656: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.25
*Dec 18 19:05:38.604: OSPF: Rcv hello from 1.1.1.3 area 0 from Tunnel2014 192.10.0.26
*Dec 18 19:05:38.604: OSPF: Send immediate hello to nbr 1.1.1.3, src address 192.10.0.26, on Tunnel2014
*Dec 18 19:05:38.604: OSPF: Send hello to 192.10.0.26 area 0 on Tunnel2014 from 192.10.0.25
*Dec 18 19:05:38.604: OSPF: End of hello processing

r2
000062: Dec 18 17:48:01.935: OSPF: End of hello processing
000063: Dec 18 17:48:06.151: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.26
000064: Dec 18 17:48:09.051: OSPF: Send hello to 224.0.0.5 area 0 on Vlan101 from 192.11.11.30
000065: Dec 18 17:48:10.487: OSPF: Rcv hello from 1.1.1.1 area 0 from Vlan101 192.11.11.10
000066: Dec 18 17:48:10.487: OSPF: End of hello processing
000067: Dec 18 17:48:11.203: OSPF: Rcv hello from 1.1.1.2 area 0 from Vlan101 192.11.11.20
000068: Dec 18 17:48:11.203: OSPF: End of hello processing
000069: Dec 18 17:48:15.883: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.26
000070: Dec 18 17:48:18.591: OSPF: Send hello to 224.0.0.5 area 0 on Vlan101 from 192.11.11.30
000071: Dec 18 17:48:20.379: OSPF: Rcv hello from 1.1.1.1 area 0 from Vlan101 192.11.11.10
000072: Dec 18 17:48:20.379: OSPF: End of hello processing
000073: Dec 18 17:48:20.591: OSPF: Rcv hello from 1.1.1.2 area 0 from Vlan101 192.11.11.20
000074: Dec 18 17:48:20.591: OSPF: End of hello processing
000075: Dec 18 17:48:25.431: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.26
000076: Dec 18 17:48:27.715: OSPF: Send hello to 224.0.0.5 area 0 on Vlan101 from 192.11.11.30
000077: Dec 18 17:48:30.263: OSPF: Rcv hello from 1.1.1.1 area 0 from Vlan101 192.11.11.10
000078: Dec 18 17:48:30.263: OSPF: End of hello processing
000079: Dec 18 17:48:30.567: OSPF: Rcv hello from 1.1.1.2 area 0 from Vlan101 192.11.11.20
000080: Dec 18 17:48:30.567: OSPF: End of hello processing
000081: Dec 18 17:48:35.199: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.26
000082: Dec 18 17:48:37.431: OSPF: Send hello to 224.0.0.5 area 0 on Vlan101 from 192.11.11.30
000083: Dec 18 17:48:39.851: OSPF: Rcv hello from 1.1.1.1 area 0 from Vlan101 192.11.11.10
000084: Dec 18 17:48:39.851: OSPF: End of hello processing
000085: Dec 18 17:48:40.247: OSPF: Rcv hello from 1.1.1.2 area 0 from Vlan101 192.11.11.20
000086: Dec 18 17:48:40.247: OSPF: End of hello processing

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

14. "OSPF и резервировние через GRE"  +/
Сообщение от Del on 20-Дек-17, 05:45 
Чисто как догадка, попробуйте на туннельных интерфейсах mtu ignore написать.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 20-Дек-17, 21:17 
> Чисто как догадка, попробуйте на туннельных интерфейсах mtu ignore написать.

только что построил gre тоннель между третьем маршрутером и втором с теме же параметрами, он прекрасно появился в "соседях" ...

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "OSPF и резервировние через GRE"  +/
Сообщение от _alecx_ (ok) on 21-Дек-17, 11:16 
1. 10.136.104.1 - не похоже на Интерент. Вы за NAT? Каким? ICMP ходит через Туннели?
2. Можно глянуть полный конфиг R1 и R2. В лабе ваша схема поднялась с "полпинка", а ж интересно.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 21-Дек-17, 23:33 
> 1. 10.136.104.1 - не похоже на Интерент. Вы за NAT? Каким? ICMP
> ходит через Туннели?
> 2. Можно глянуть полный конфиг R1 и R2. В лабе ваша схема
> поднялась с "полпинка", а ж интересно.

Это роутеры связи школ (зданий) , школам мин.образования , не дает белый ип ни под каким предлогам, но при этом серые ипы, между собой доступны и никак не фильтруются и связь осуществляется через них
вот полные конфиги  
ftp://ftp.radio-portal.ru/Incoming/conf_2014_sch2014-2911.txt
ftp://ftp.radio-portal.ru/Incoming/conf_1492_sch1492-2911.txt
ftp://ftp.radio-portal.ru/Incoming/conf_1978_sch1978-2911.txt

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "OSPF и резервировние через GRE"  +/
Сообщение от fantom (??) on 22-Дек-17, 08:42 
>[оверквотинг удален]
>> ходит через Туннели?
>> 2. Можно глянуть полный конфиг R1 и R2. В лабе ваша схема
>> поднялась с "полпинка", а ж интересно.
> Это роутеры связи школ (зданий) , школам мин.образования , не дает белый
> ип ни под каким предлогам, но при этом серые ипы, между
> собой доступны и никак не фильтруются и связь осуществляется через них
> вот полные конфиги
> ftp://ftp.radio-portal.ru/Incoming/conf_2014_sch2014-2911.txt
> ftp://ftp.radio-portal.ru/Incoming/conf_1492_sch1492-2911.txt
> ftp://ftp.radio-portal.ru/Incoming/conf_1978_sch1978-2911.txt

1.keepalive на туннели добавить.
Иначе у вас туннель не падает при реальном пропадании связи.

2.
На Р1
*Dec 18 19:05:25.532: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel1492 from 192.10.0.21
*Dec 18 19:05:26.072: OSPF: Rcv hello from 1.1.1.2 area 0 from Tunnel1492 192.10.0.22
т.е. отправляет/получает

на Р2
000063: Dec 18 17:48:06.151: OSPF: Send hello to 224.0.0.5 area 0 on Tunnel2014 from 192.10.0.26

и никаких Rcv hello from туннель.
А значит скорее всего туннель таки "упал", но рутеры этого не обнаруживают.

3. бродкаст на GRE??? а накой? DR/BDR выбирать? так их там по-любому только 2...

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "OSPF и резервировние через GRE"  +/
Сообщение от _alecx_ (ok) on 22-Дек-17, 11:47 
>[оверквотинг удален]
>> ходит через Туннели?
>> 2. Можно глянуть полный конфиг R1 и R2. В лабе ваша схема
>> поднялась с "полпинка", а ж интересно.
> Это роутеры связи школ (зданий) , школам мин.образования , не дает белый
> ип ни под каким предлогам, но при этом серые ипы, между
> собой доступны и никак не фильтруются и связь осуществляется через них
> вот полные конфиги
> ftp://ftp.radio-portal.ru/Incoming/conf_2014_sch2014-2911.txt
> ftp://ftp.radio-portal.ru/Incoming/conf_1492_sch1492-2911.txt
> ftp://ftp.radio-portal.ru/Incoming/conf_1978_sch1978-2911.txt

Попробую собрать лабу на Ваших конфигах.
Вы не ответили: icmp через туннели ходит? туннели живые?
Офф.топ. а зачем у вас везде no ip route-cache и no ip route-cache cef?

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

20. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 22-Дек-17, 12:40 
>[оверквотинг удален]
>> ип ни под каким предлогам, но при этом серые ипы, между
>> собой доступны и никак не фильтруются и связь осуществляется через них
>> вот полные конфиги
>> ftp://ftp.radio-portal.ru/Incoming/conf_2014_sch2014-2911.txt
>> ftp://ftp.radio-portal.ru/Incoming/conf_1492_sch1492-2911.txt
>> ftp://ftp.radio-portal.ru/Incoming/conf_1978_sch1978-2911.txt
> Попробую собрать лабу на Ваших конфигах.
> Вы не ответили: icmp через туннели ходит? туннели живые?
> Офф.топ. а зачем у вас везде no ip route-cache и no ip
> route-cache cef?

icmp ходит
no ip route-cache
route-cache cef
с такими настройками пришел из образования - я и трогать не стал

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "OSPF и резервировние через GRE"  +/
Сообщение от _alecx_ (ok) on 22-Дек-17, 13:02 
В лабе завелось, с мелкими правками даже перестало flap`апь:
на всех Tun поставил:
ip ospf network point-to-point

на Vlan:
ip ospf network broadcast

на всех интерфейсах, участвующих в OSPF:
ip ospf mtu-ignore

в router ospf 1 везде указал router-id ip_Loopback

попробуй так, но вряд-ли поможет. Вроде все верно, надо трублшутить на месте руками.

p.s. ip route cache - включает аппаратную обработку заголовков пакетов, а ip route-cache cef - использовать cef таблицу для принятия решения при форвардинге пакетов. Иначе каждый пакет будет лететь в CPU маршртизатора, что сильно снижает его производительность.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

22. "OSPF и резервировние через GRE"  +/
Сообщение от Doc email(ok) on 28-Дек-17, 16:03 
нашел странность в работе тоннелей
по какой то причине другая сторона тоне ля пеленгуется из сети за роутером , не не ассигнуется с само роутера , причем если тоннель "передернуть", то на одном конце есть принятые и отправленные пакеты (по всей видимости ospf шлет), а на другой есть только отправленные, а принятых нет (и именно на стороне где нет приятных пакетов, и нет соседа в ospf, что логично)  
но тем неимения если прописать статический маршрут через тоннель то все сети доступны (и трафик идет именно через тоннель, и счетчики пакетов с обеих сторон тикают). но по прежнему другой конец тоннеля с самого роутера недоступен.
Что за фокусы не пойму никак.

Как и у Вас в лаборатории все завилось на ура без вязких доработок, причем попробовал как и в студенческом пактетресере, так и на двух старых 1700 роутерах, все отлично работает, что за глюк тут никак не могу понять и воспроизвести


Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor