The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"877-K9"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"877-K9"  +/
Сообщение от IvanTT (ok) on 23-Май-18, 00:18 
Доброе время суток. Ребята помогите пожалуйста новичку в оборудовании Cisco.
Никогда не работал с Cisco, но вот всё же приобрел сие чудо.
У нас в посёлке интернет к сожалению только через adsl (Ростелеком), имеется небольшая локальная сеть, два канала adsl (два номера телефона), соответственно два adsl - сплиттера, далее два модема и далее на роутеры, каждая сеть работает отдельно друг от друга, так и нужно, суть не в этом.
На данный момент, модемы фирмы Zyxel P-660RT3-EE, настроены в режиме router, то есть я настроил подключение в самих модемах, что бы не "париться" с созданием подключений.
Приобрёл на замену Zyxel две Cisco 877-K9, так как это уже старое оборудование, можно купить на авито не дорого.
И вот, к сожалению, уже столкнулся с проблемой, пришлось заказывать переходники com - usb, для (я так понимаю) подключения консольного кабеля от Cisco.
Попросту говоря, нужно эти Cisco настроить так же как и Zyxel, и вот с чего начать, как настроить, к сожалению я не знаю, прошу помощи в этом :)
Конечно, по поискам в интернете, я нашёл кое какую инфу, но подробной инструкции "для чайников" что то мне не попадалось. Web - интерфейс, я так понял, нужно сначала настроить через вот эту консоль, что бы можно было далее настроить, как привык), но в основном пишут, что с cisco через web интерфейс никто не работает.
И ещё один момент, так же надо бы на порты LAN настроить ограничение скорости траффика.
Приобретались они для, скажем так, более стабильной работы сети с моей стороны.
Заранее очень благодарен :).
Ответить | Правка | Cообщить модератору

Оглавление

  • 877-K9, ShyLion, 07:34 , 23-Май-18, (1)  
    • 877-K9, IvanTT, 09:10 , 23-Май-18, (3)  
  • 877-K9, ShyLion, 07:38 , 23-Май-18, (2)  
    • 877-K9, IvanTT, 09:49 , 23-Май-18, (4)  
      • 877-K9, ShyLion, 11:00 , 23-Май-18, (5)  
        • 877-K9, ShyLion, 11:02 , 23-Май-18, (7)  
        • 877-K9, IvanTT, 19:21 , 23-Май-18, (8)  
          • 877-K9, Pofigist, 08:07 , 24-Май-18, (9)  
            • 877-K9, ShyLion, 10:20 , 24-Май-18, (11)  
              • 877-K9, Pofigist, 12:35 , 24-Май-18, (19)  
            • 877-K9, ShyLion, 10:27 , 24-Май-18, (12)  
              • 877-K9, Pofigist, 12:28 , 24-Май-18, (16)  
              • 877-K9, Pofigist, 12:31 , 24-Май-18, (17)  
            • 877-K9, IvanTT, 11:23 , 25-Май-18, (20)  
          • 877-K9, ShyLion, 10:34 , 24-Май-18, (14)  
            • 877-K9, IvanTT, 11:26 , 25-Май-18, (21)  
              • 877-K9, ShyLion, 13:24 , 25-Май-18, (22)  
            • 877-K9, IvanTT, 21:38 , 30-Май-18, (23)  
              • 877-K9, ShyLion, 12:40 , 31-Май-18, (25)  
        • 877-K9, IvanTT, 02:55 , 03-Июн-18, (32)  
    • 877-K9, Pofigist, 08:16 , 24-Май-18, (10)  
      • 877-K9, ShyLion, 10:28 , 24-Май-18, (13)  
        • 877-K9, ShyLion, 10:43 , 24-Май-18, (15)  
          • 877-K9, Pofigist, 12:33 , 24-Май-18, (18)  
  • 877-K9, NAI, 11:00 , 23-Май-18, (6)  
  • 877-K9, IvanTT, 12:13 , 31-Май-18, (24)  
    • 877-K9, IvanTT, 21:03 , 31-Май-18, (26)  
      • 877-K9, IvanTT, 03:19 , 01-Июн-18, (27)  
        • 877-K9, Иван, 05:29 , 01-Июн-18, (28)  
        • 877-K9, ShyLion, 08:41 , 01-Июн-18, (29)  
          • 877-K9, IvanTT, 09:54 , 01-Июн-18, (30)  
            • 877-K9, IvanTT, 21:32 , 01-Июн-18, (31)  
              • 877-K9, ShyLion, 09:39 , 04-Июн-18, (33)  
                • 877-K9, IvanTT, 12:32 , 04-Июн-18, (34)  
                  • 877-K9, ShyLion, 12:48 , 04-Июн-18, (35)  
                    • 877-K9, IvanTT, 14:28 , 04-Июн-18, (36)  
                      • 877-K9, IvanTT, 22:03 , 04-Июн-18, (37)  
                        • 877-K9, IvanTT, 05:09 , 05-Июн-18, (38)  
                        • 877-K9, ShyLion, 07:59 , 05-Июн-18, (39)  
                        • 877-K9, IvanTT, 14:10 , 05-Июн-18, (40)  
                        • 877-K9, IvanTT, 14:13 , 05-Июн-18, (41)  
                        • 877-K9, IvanTT, 21:06 , 05-Июн-18, (42)  
                        • 877-K9, Иван, 06:39 , 06-Июн-18, (43)  
                        • 877-K9, ShyLion, 08:18 , 06-Июн-18, (44)  
                        • 877-K9, IvanTT, 10:50 , 10-Июн-18, (45)  
                        • 877-K9, IvanTT, 10:51 , 10-Июн-18, (46)  
                        • 877-K9, ShyLion, 13:54 , 10-Июн-18, (47)  
                        • 877-K9, IvanTT, 14:03 , 10-Июн-18, (48)  
                        • 877-K9, ShyLion, 18:43 , 10-Июн-18, (49)  
                        • 877-K9, IvanTT, 03:40 , 11-Июн-18, (50)  

Сообщения по теме [Сортировка по времени | RSS]


1. "877-K9"  +/
Сообщение от ShyLion (ok) on 23-Май-18, 07:34 
Инет на кису хотите езернетом присунуть или в АДСЛ порт?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "877-K9"  +/
Сообщение от IvanTT (ok) on 23-Май-18, 09:10 
> Инет на кису хотите езернетом присунуть или в АДСЛ порт?

в ADSL порт

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "877-K9"  +/
Сообщение от ShyLion (ok) on 23-Май-18, 07:38 
На сетевом уровне как подключение к инету подано - статика, пппое, что-то другое?
Какая адресация в локалке? нужен ли сервис DHCP? и т.д. и т.п.

Короче прежде чем дать вменяемый пример конфига нужны подробности.

Насчет веб-морды - есть конечно любители, но после того как освоишься в CLI, про веб морду и не вспомнишь. Весь конфиг единым файлом в котором все структурировано и наглядно.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "877-K9"  +/
Сообщение от IvanTT (ok) on 23-Май-18, 09:49 
> На сетевом уровне как подключение к инету подано - статика, пппое, что-то
> другое?
> Какая адресация в локалке? нужен ли сервис DHCP? и т.д. и т.п.
> Короче прежде чем дать вменяемый пример конфига нужны подробности.
> Насчет веб-морды - есть конечно любители, но после того как освоишься в
> CLI, про веб морду и не вспомнишь. Весь конфиг единым файлом
> в котором все структурировано и наглядно.

Подключение к интернет по PPPoE, что касается DHCP - нужен. Ограничение скорости надо на одной сети, на второй компов мало там не надо, я и не настраивал. На первой у меня настроено ограничение в роутере D-LINK, там к каждому компу присваивал IP адрес, что бы создавать правила для них в роутере.
То есть схема простая :) - провайдер -> Zyxel -> Dlink (с настроенным ограничением) -> User`s это одна сеть, вторая тоже самое только без настройки правил, там DHCP нужен. Что касается первой сети, там у меня постоянный ip внешний адрес (так нужно по работе), писали заявление провайдеру для этого.
Вчера, точнее сегодня ночью, занимался "попытками" что нить сделать :), пока переходники com-usb не приехали, нашел инфу, что в Cisco 851(871) уже есть некие заводские настройки, предположил что и в моих 877 они тоже есть. Скачал putty, попробовал подключиться по ssh к роутеру (через lan порт), вбил ip адрес (из инфы что нашел), подключился, но он мне пишет login as:, и что бы я не писал в ответ, выдает предложение, или скорее какое то описание что надо сменить пароль и логин, и ниже спрашивает пароль, я так понял по умолчанию cisco\cisco, вот набираю пароль, не пускает, после нескольких попыток, соединение отключается. Похоже всё равно придется дождаться этих переходников.  

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "877-K9"  +/
Сообщение от ShyLion (ok) on 23-Май-18, 11:00 
Вот рыба конфига. Читать внимательно, VPI/VCI, логины/пароли поставить свои.


service nagle
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no service config
no ip bootp server
!
hostname tvoya_877
!
logging buffered 51200 warnings
enable secret 0 свой enable пароль, задать приличный и забыть, не пригодится
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization console
aaa authorization exec default local
!
aaa session-id common
!
!
! Поменять на свое название зоны и смещение от UTC. Название не имеет принципиального значения
clock timezone MSK 3
!
ip cef
ip arp proxy disable
no ip source-route
!
no ip forward-protocol nd
no ip forward-protocol udp tftp
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
!
!
no ip domain lookup
ip domain name local
!
! админская учетка. использовать нормальное имя а не admin, root, cisco и т.п. если не хочешь сюрпризов
! использовать нормальный пароль по той-же причине
username vasia priv 15 secret 0 пароль
!
no username cisco
!
crypto key gen rsa usage mod 2048
! подождать генерации ключа!!!

!
ip ssh version 2
!
!
!
ip dhcp pool LAN
! подставить свое
network 10.x.x.0 /24
default-router 10.x.x.1
dns-server 8.8.8.8 8.8.4.4
domain-name local
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
! задать свои VPI/VCI
interface ATM0.1 point-to-point
pvc 0/33
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
description Inet, PPPoE
ip address negotiated
ip mtu 1470
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ppp_user password 0 ppp_pass
! еcли у провайдера CHAP
! ppp authentication chap callin
! ppp chap hostname ppp_user
! ppp chap password ppp_pass
ppp ipcp route default
!
!
interface FastEthernet0
description port, LAN
!
interface FastEthernet1
description port, LAN
!
interface FastEthernet2
description port, LAN
!
interface FastEthernet3
description port, LAN
!
interface Vlan1
description LAN
! подставить свое
ip address 10.x.x.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1400
!
ip flow-top-talkers
top 50
sort-by bytes
cache-timeout 1000
!
!
no ip http server
no ip http secure-server
!
ip access-list extended nat
deny ip any 10.0.0.0 0.255.255.255
deny ip any 192.168.0.0 0.0.255.255
deny ip any 172.16.0.0 0.15.255.255
deny ip any 169.254.0.0 0.0.255.255
! подставить свое
permit ip 10.x.x.0 0.0.0.255 any
!
ip access-list extended vty
! подставить свое
permit ip 10.x.x.0 0.0.0.255 any
!
ip nat inside source list nat interface Dialer1 overload
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class vty in
exec-timeout 600 0
logging synchronous
transport input ssh
transport output all
!
ntp server 193.124.11.11
ntp server 194.149.67.130
ntp server 193.125.143.173
ntp server 193.125.143.172
ntp server 84.204.87.243
ntp server 80.249.135.2
ntp server 80.68.242.188
ntp server 194.87.0.20
ntp server 89.111.168.177
ntp server 194.33.191.69
ntp server 194.87.0.28
ntp server 81.200.8.213

DNS службу держать на этом роутере сильно не рекомендую, поэтому не показываю как настроить.
Начни с базовых настроек через консоль, потом ЛАН часть подними, подцепись по ssh. Потом мучай ADSL и PPPoE.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "877-K9"  +/
Сообщение от ShyLion (ok) on 23-Май-18, 11:02 
Ограничением скорости займешья потом, когда база заработает.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "877-K9"  +/
Сообщение от IvanTT (ok) on 23-Май-18, 19:21 
> Начни с базовых настроек через консоль, потом ЛАН часть подними, подцепись по
> ssh. Потом мучай ADSL и PPPoE.

Спасибо. По ssh видимо подключения как такового нет, пишет login as:, что бы я не писал, после предлагает ввести пароль, при вводе дефолтных cisco\cisco пишет доступ закрыт, может я чего недопонимаю), но похоже только после как залогаюсь там, я уже смогу что то посмотреть\изменить\настроить. Видимо без этого переходника на консольный кабель не обойтись, а они приедут в нашу "тутуновку" аж в понедельник :(
Ну вот только не пойму, в этом putty, нужно будет выбрать "serial", я так понял, и проверить настройки com порта, это я по видео с ютуба понял, но боюсь не выдаст ли он мне тоже самое login as, и что потом тогда делать, сбрасывать его полностью кнопкой reset?)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "877-K9"  +/
Сообщение от Pofigist on 24-Май-18, 08:07 
>[оверквотинг удален]
> бы я не писал, после предлагает ввести пароль, при вводе дефолтных
> cisco\cisco пишет доступ закрыт, может я чего недопонимаю), но похоже только
> после как залогаюсь там, я уже смогу что то посмотреть\изменить\настроить. Видимо
> без этого переходника на консольный кабель не обойтись, а они приедут
> в нашу "тутуновку" аж в понедельник :(
> Ну вот только не пойму, в этом putty, нужно будет выбрать "serial",
> я так понял, и проверить настройки com порта, это я по
> видео с ютуба понял, но боюсь не выдаст ли он мне
> тоже самое login as, и что потом тогда делать, сбрасывать его
> полностью кнопкой reset?)

ssh надо сначала настроить.
Если дефолтные пароли не подходят - гуглить по словам cisco password reset, вот например для другого роутера, но он по идее подойдет - https://www.cisco.com/c/en/us/support/docs/routers/2800-seri...
Консольный кабель при работе с любым серьезным сетевым оборудованием не роскошь, а жизненая необходимость. Для кошек стандартные параметры 9600 8-N-1
Пример неплохого конфига под твои задачи - http://blog.irsi.net.ru/2010/10/blog-post.html настройки правда там для стрим/мгтс/мтс, так что в строчке pvc 1/50 у тебя могут быть другие цифры, это VPI/VCI, немного инфы по этим параметрам для ростелекома - http://samnastroyu.ru/rostelecom/znacheniya-dlya-vpi-vci.php и не факт что она верная.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

11. "877-K9"  +/
Сообщение от ShyLion (ok) on 24-Май-18, 10:20 
> у тебя могут быть другие цифры, это VPI/VCI, немного инфы по
> этим параметрам для ростелекома - http://samnastroyu.ru/rostelecom/znacheniya-dlya-vpi-vci.php
> и не факт что она верная.

Зачем гадать, когда АДСЛ модем под рукой? Зашел да посмотрел :)

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

19. "877-K9"  +/
Сообщение от Pofigist on 24-Май-18, 12:35 
>> у тебя могут быть другие цифры, это VPI/VCI, немного инфы по
>> этим параметрам для ростелекома - http://samnastroyu.ru/rostelecom/znacheniya-dlya-vpi-vci.php
>> и не факт что она верная.
> Зачем гадать, когда АДСЛ модем под рукой? Зашел да посмотрел :)

Угу, для начала надо будет раздобыть на него пароль :)

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

12. "877-K9"  +/
Сообщение от ShyLion (ok) on 24-Май-18, 10:27 
> Пример неплохого конфига под твои задачи - http://blog.irsi.net.ru/2010/10/blog-post.html

"Неплохой конфиг" начинается с


! нужно строго наоборот, чтобы пароль не ушел налево при продаже железки например
no service password-encryption
!
! нахрена новичку включать неведомую херню, которая сегодня работает а завтра нет?
service internal
!
! enable secret !!!!
enable password
!
! лишние дыры в безопасности
ip source-route
!
! в момент загрузки роутра ни о каких pool.ntp.org он знать не будет и инета у него еще не будет
ntp server pool.ntp.org
!
! супер-безопасность!
ip ssh version 1
!

и до кучи дырявый телнет включен
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

16. "877-K9"  +/
Сообщение от Pofigist on 24-Май-18, 12:28 
Если ты не заметил там есть VPN-терминатор (рртр). Можно сколько угодно ругать pptp (и за дело), но "бытовые" проблемы с доступом в локальную сеть из любой точки мира он рещшает. От этого 90% странных и потенциально небезопасных строк в конфиге. Правильней конечно настроить l2tp+ipsec с доступом по сертификату и хранением пользователей не локально, а через radius... Но для дома это большинству не надо, да и не осилят имхо.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

17. "877-K9"  +/
Сообщение от Pofigist on 24-Май-18, 12:31 
> ! в момент загрузки роутра ни о каких pool.ntp.org он знать не
> будет и инета у него еще не будет
> ntp server pool.ntp.org
>

Это - работает. Оно при настроенных днс (а они там - настроены) на этапе конкурирования преобразуется в IP.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

20. "877-K9"  +/
Сообщение от IvanTT (ok) on 25-Май-18, 11:23 

> у тебя могут быть другие цифры, это VPI/VCI, немного инфы по
> этим параметрам для ростелекома - http://samnastroyu.ru/rostelecom/znacheniya-dlya-vpi-vci.php
> и не факт что она верная.

Спасибо, VPI\VCI я знаю свои, настраивал модемы Zyxel :)

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

14. "877-K9"  +/
Сообщение от ShyLion (ok) on 24-Май-18, 10:34 
> тоже самое login as, и что потом тогда делать, сбрасывать его
> полностью кнопкой reset?)

Вкратце:
при загрузке жамкнешь ctrl-break
роутер вывалится в ROMMON - это загрузчик
командой изменения конф-регистра выключишь загрузку конфига
продолжишь загрузку
роутер загрузится в девственно чистый конфиг по умолчанию
сохранишь конфиг
вернешь регистр как был
перезагрузишься для верности
роутер как новый

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

21. "877-K9"  +/
Сообщение от IvanTT (ok) on 25-Май-18, 11:26 
>[оверквотинг удален]
> Вкратце:
> при загрузке жамкнешь ctrl-break
> роутер вывалится в ROMMON - это загрузчик
> командой изменения конф-регистра выключишь загрузку конфига
> продолжишь загрузку
> роутер загрузится в девственно чистый конфиг по умолчанию
> сохранишь конфиг
> вернешь регистр как был
> перезагрузишься для верности
> роутер как новый

без консольного кабеля можно такое провернуть?, по ssh как бы подключается, но пишет login as, далее требует пароль.., ну я писал выше., или после такого сброса вообще всё сброситься, и там уже точно только через кабель?

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

22. "877-K9"  +/
Сообщение от ShyLion (ok) on 25-Май-18, 13:24 
> без консольного кабеля можно такое провернуть?, по ssh как бы подключается, но

нет конечно. так бы все и сбрасывали чужие роутеры.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

23. "877-K9"  +/
Сообщение от IvanTT (ok) on 30-Май-18, 21:38 

> Вкратце:
> при загрузке жамкнешь ctrl-break
> роутер вывалится в ROMMON - это загрузчик
> командой изменения конф-регистра выключишь загрузку конфига
> продолжишь загрузку
> роутер загрузится в девственно чистый конфиг по умолчанию
> сохранишь конфиг
> вернешь регистр как был
> перезагрузишься для верности
> роутер как новый

Подскажите пожалуйста, какую команду вписать, просто не знаю списка команд этого rommon`a)
Переходники наконец то приехали, вот сижу пытаюсь подключиться. Такой вопрос возник, одна из Cisco после включения издаёт странный щелчок похожий на звук реле, но при входе в этот режим rommon, щелкать перестаёт, что это за фигня?)
А пароли походу надо сбрасывать на обоих аппаратах, по подробней можете описать процесс сброса конфига?, заранее спасибо :)

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

25. "877-K9"  +/
Сообщение от ShyLion (ok) on 31-Май-18, 12:40 
Из гайда:

Type confreg 0x2142 at the rommon 1> prompt in order to boot from Flash.

This step bypasses the startup configuration where the passwords are stored.

Type reset at the rommon 2> prompt.

The router reboots, but ignores the saved configuration.

Type no after each setup question, or press Ctrl-C in order to skip the initial setup procedure.

Type enable at the Router> prompt.

You are in enable mode and should see the Router# prompt.

дальше пишешь erase /all startup-config

перегружаешься
плучаешь девственно чистый роутер (почти)
при конфиге не забудь ввести confreg 0x2102, чтобы потом конфиг считывался.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

32. "877-K9"  +/
Сообщение от IvanTT (ok) on 03-Июн-18, 02:55 
>[оверквотинг удален]
> ntp server 194.87.0.20
> ntp server 89.111.168.177
> ntp server 194.33.191.69
> ntp server 194.87.0.28
> ntp server 81.200.8.213
>
> DNS службу держать на этом роутере сильно не рекомендую, поэтому не показываю
> как настроить.
> Начни с базовых настроек через консоль, потом ЛАН часть подними, подцепись по
> ssh. Потом мучай ADSL и PPPoE.

В общем не получается у меня с этим конфигом, и тут кстати какой то глюк вот в этом блоке > interface Dialer1 , видимо не указали encapsulation ppp, потому что без указания энкапсуляции он не даёт установить тип авторизации чап или пап. Так же поробовал вот этот конфиг :


version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!

###Пропишем имя хоста для нашего маршрутизатора:

hostname router
!
boot-start-marker
boot-end-marker
!
### Установим пароль на режим enable:

enable password mypassword
!
no aaa new-model
!
resource policy
!
no ip source-route
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
### Поднимаем DHCP
ip dhcp pool local_net
import all
network 192.168.1.0 255.255.255.0
dns-server 88.147.129.15 88.147.128.17
default-router 192.168.1.1
!
!
ip tcp synwait-time 10
no ip bootp server
ip domain name domain.local
ip name-server 88.147.129.15
ip name-server 88.147.128.17
ip ssh time-out 60
ip ssh authentication-retries 2
!
### Активируем режим irb
bridge irb
!
### Заводим WAN-интерфейс
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
### Так как у нас 1 канал PVC, то и саб-интерфейс будем заводить один
interface ATM0.1 point-to-point
description $WAN$
no snmp trap link-status
!
### Прописываем парамеры канала vpi — 0 и vci — 33
pvc 0/33
pppoe-client dial-pool-number 1
!
!
bridge-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
### Поднимаем интерфейс, смотрящий во внутреннюю сеть
interface Vlan1
description $INSIDE$
ip address 192.168.1.1 255.255.255.0
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!

###Так как необходимо поднять PPPoE-клиент,то поднимается интерфейс Dialer.
interface Dialer0
description $OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip inspect DEFAULT100 out
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
### Указываем типы авторизации
ppp authentication chap pap
### Прописываем логин и пароль на доступ в Интернет для каждого типа
ppp chap hostname my_login
ppp chap password 7 my_password
ppp pap sent-username my_login password 7 my_password
!
### Указываем дефолтовый маршрут
ip route 0.0.0.0 0.0.0.0 Dialer0
!
### Отключаем встроенный HTTP сервер
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
### Разрешаем всё для нашего аксесс-листа. Если же необходимо ограничить доступ к/от другим сетям, то необходимо будет под каждую из них прописывать правила.
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!


и он тоже не работает, я хз, может я чего не так делаю, но вроде разобрался как конфиги переписывать в роутер, а толку 0(. Что может быть не так в этих конфигах или во мне?), просто команды все принимаются, вон даже ошибку нашел с энкапсуляцией в первом конфиге)). Уже голова начинает болеть, сутками сижу с этой циской. Помогите плз отредактировать конфиг. Насчёт веб интерфейса, забросил я эту тему, потому что столько хлама пришлось поставить на комп, и плюс столько времени потратил на поиски этого хлама, который ещё и не работает.
В общем от этой циски надо, что бы подключение к ADSL Ростелеком (Пензенская область), было в самой циске, что бы она подключалась сама через соответсвенно порт адсл, я так понял это интерфейс ATM0, и раздавала этот adsl интернет в свой встроенный роутер на все 4 порта ethernet, без всяких ip адресов пускай этим dhcp занимается. И в компах, обязательно этот шлюз прописывать?, который присвоен на интерфейс vlan1, можно как нить настроить, что бы не писать никаких шлюзов, что бы комп получал автоматический ip, причем на любом из 4х портов. Просто бывает по работе нужно будет подключать разные компы к этому роутеру, это нужно пока на одной сети как и писал выше. Со второй потом разберусь, первую бы настроить что бы работала. Заранее благодарен за хороший конфиг :)


Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

10. "877-K9"  +/
Сообщение от Pofigist on 24-Май-18, 08:16 

> Насчет веб-морды - есть конечно любители, но после того как освоишься в
> CLI, про веб морду и не вспомнишь. Весь конфиг единым файлом
> в котором все структурировано и наглядно.

Угу... Но ровно до того момента как не потребуется настроить тот же ZBFW - в нем ОЧЕНЬ захочется аналога asdm...

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

13. "877-K9"  +/
Сообщение от ShyLion (ok) on 24-Май-18, 10:28 
>> Насчет веб-морды - есть конечно любители, но после того как освоишься в
>> CLI, про веб морду и не вспомнишь. Весь конфиг единым файлом
>> в котором все структурировано и наглядно.
> Угу... Но ровно до того момента как не потребуется настроить тот же
> ZBFW - в нем ОЧЕНЬ захочется аналога asdm...

Для задач домашнего роутера или мелкого офиса там ничего супер-сложного. Смотри тред рядом.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

15. "877-K9"  +/
Сообщение от ShyLion (ok) on 24-Май-18, 10:43 
>>> Насчет веб-морды - есть конечно любители, но после того как освоишься в
>>> CLI, про веб морду и не вспомнишь. Весь конфиг единым файлом
>>> в котором все структурировано и наглядно.
>> Угу... Но ровно до того момента как не потребуется настроить тот же
>> ZBFW - в нем ОЧЕНЬ захочется аналога asdm...
> Для задач домашнего роутера или мелкого офиса там ничего супер-сложного. Смотри тред
> рядом.

Хотя для новичка да, сложновато.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

18. "877-K9"  +/
Сообщение от Pofigist on 24-Май-18, 12:33 
>>>> Насчет веб-морды - есть конечно любители, но после того как освоишься в
>>>> CLI, про веб морду и не вспомнишь. Весь конфиг единым файлом
>>>> в котором все структурировано и наглядно.
>>> Угу... Но ровно до того момента как не потребуется настроить тот же
>>> ZBFW - в нем ОЧЕНЬ захочется аналога asdm...
>> Для задач домашнего роутера или мелкого офиса там ничего супер-сложного. Смотри тред
>> рядом.
> Хотя для новичка да, сложновато.

Да там и опытному... легко запутаться. :) Конфиги конечно в разы более читаемы чем ipfw/iptables, но их много и посему - не слишком нагядно.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

6. "877-K9"  +/
Сообщение от NAI on 23-Май-18, 11:00 
> Доброе время суток. Ребята помогите пожалуйста новичку в оборудовании Cisco.
> Никогда не работал с Cisco, но вот всё же приобрел сие чудо.
> вот с чего начать, как настроить, к сожалению я не знаю,

Начать стоит со статей "Сети для самых маленьких" ( http://linkmeup.ru/blog/12.html ), там нет ничего про ADSL, но есть много про настройку цисок (подключение, отключение и пр.) и понимания сетей.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

24. "877-K9"  +/
Сообщение от IvanTT (ok) on 31-Май-18, 12:13 
Ребят, похоже что то не то с прошивкой или с самим роутером, есть ли возможность вернуть\сбросить роутер до заводских настроек\прошивки. Писали об этом вкратце), но по поискам нашел более подробное описание режима rommon, сменил значение, загрузился, и командой dir flash увидел в первой строке которая -rw-, я так понял должна быть дата и т.п. прошивки, так вот там прочерки стоят, это нормально?, тоже самое командой dir nv ram, в первой строке тоже прочерки. Это я так понял сама прошивка c870-advipservicesk9-mz.124-4.T1.bin и как сделать что бы всё было как "новое"?) Извиняюсь конечно, но пока я только осваиваю cisco, в моём случае роутер б\у, просто хотелось бы сбросить его полностью и начать свою конфигурацию.
И вот эти "щелчки", после сброса кнопкой reset (при включении), прекратились, так же прекратилось мигание индикатора CD. По поискам в сети, есть инфа что роутер "загибается", или кривая прошивка.


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

26. "877-K9"  +/
Сообщение от IvanTT (ok) on 31-Май-18, 21:03 
Подскажите плз уважаемые цисковеды, ковыряюсь целый день)). Конечно инфы много в сети, но вот интересует такой вопрос, можно ли просто включить\настроить web интерфейс, и настроить роутер cisco под себя так как нужно именно в этом веб интерфейсе, как я делал это на Zyxel`е или D-link, или вот обязательно терминал - это основа настроек?
Одна из цисок походу полудохлая (щелкает там чёто, подвисает при вводе команд иногда) :(, ну б\у есть б\у. Но вторая новенькая, конфиг похоже чистый, хоть одну настроить правильно), а потом ковырять дохлую, может прошить заново, не знаю, но пока цель - настроить хоть одну, что бы работала, и желательно, очень желательно, черев веб интерфейс. Спасибо.

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

27. "877-K9"  +/
Сообщение от IvanTT (ok) on 01-Июн-18, 03:19 
В общем добрался я до веб интрефейса (ну почти), всё описывать не буду, в итоге в netscape 9.0 когда я набираю ip адрес роутера, что бы попасть в веб интерфейс, открывается окно с надписью что SDM Express грузится, пожалуйста погодите, и в общем на этом походу всё, грузится грузится..., и ничего не происходит. блин. ну вот немного осталось до веб интерфейса)


Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

28. "877-K9"  +/
Сообщение от Иван (??) on 01-Июн-18, 05:29 
> В общем добрался я до веб интрефейса (ну почти), всё описывать не
> буду, в итоге в netscape 9.0 когда я набираю ip адрес
> роутера, что бы попасть в веб интерфейс, открывается окно с надписью
> что SDM Express грузится, пожалуйста погодите, и в общем на этом
> походу всё, грузится грузится..., и ничего не происходит. блин. ну вот
> немного осталось до веб интерфейса)

сомневаюсь что тут кто-то юзает вебинтерфейс...

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

29. "877-K9"  +/
Сообщение от ShyLion (ok) on 01-Июн-18, 08:41 
> В общем добрался я до веб интрефейса (ну почти), всё описывать не
> буду, в итоге в netscape 9.0 когда я набираю ip адрес
> роутера, что бы попасть в веб интерфейс, открывается окно с надписью
> что SDM Express грузится, пожалуйста погодите, и в общем на этом
> походу всё, грузится грузится..., и ничего не происходит. блин. ну вот
> немного осталось до веб интерфейса)

Я же тебе выше дал почти котовый конфиг.

Веб морда там заточена под определенный браузер, не помню какой, и вставляет в конфиг кучу ненужного г-на, поэтому ей мало кто пользуется.

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

30. "877-K9"  +/
Сообщение от IvanTT (ok) on 01-Июн-18, 09:54 

> Я же тебе выше дал почти котовый конфиг.
> Веб морда там заточена под определенный браузер, не помню какой, и вставляет
> в конфиг кучу ненужного г-на, поэтому ей мало кто пользуется.

Спасибо. Сегодня попытаюсь понять, как его правильно переписать в cisco, так как пока ещё не совсем понимаю, вот что то в подобном плане: это "кусок", скажем так, конфига с описанием что и куда писать:)
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
____________________________________________________________
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
____________________________________________________________

Задаем имя роутера и доменное имя и добавляем пользователя:
____________________________________________________________
Router(config)#hostname R1
R1(config)#ip domain-name mydomain
R1(config)#username user privilege 15 password mypass
____________________________________________________________

Теперь необходимо обеспечить элементарную безопасность роутера включив шифрование паролей, установив пароли на терминальное подключение и привилегированный режим а также включив ssh, который понадобиться в дальнейшем для управления маршрутизатором через сеть.
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

То есть, есть описание, что бы не ошибиться. Кстати пробовал я этот конфиг вписать, но не подключается к интернет, попытался совместить его с Вашим, что дали выше, в общем итог - пока к сожалению не могу освоить терминальные команды cisco, может быть есть возможность как то создать файл, скопировать конфиг в него, и потом уже переписать его в циску каким то образом?, и ещё его там надо наверно отредактировать\активировать.

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

31. "877-K9"  +/
Сообщение от IvanTT (ok) on 01-Июн-18, 21:32 
>> Я же тебе выше дал почти котовый конфиг.

Кажется начинаю немного "въезжать", установил Cisco configuration pro, настроил роутер, подключился, в проге роутер успешно определился, и вот там немного поудобней с ним управляться чем через этот страшный putty.
Ну по крайне мере, кажется понимаю теперь как скопировать готовый конфиг в роутер, точнее импортировать. Но вот теперь вопросик по самой конфигурации, что Вы мне дали выше, там Вы отключаете http и https сервера, которые нужны для работы с этой программой, вот может быть как то кусками скопировать конфиг можно?, или надо полностью его переделывать?, хотел просто попробовать его скопировать, подставить всё своё как Вы писали, а тут такая проблемка).
И ещё такой вопрос, в сети много конфигов под adsl, но вот например в одном из конфигов есть такая запись "bridge irb", которая говорит (я так думаю) о режиме работы роутера в brige, но мне не надо в бридж, мне надо роутер, что бы он сам подключался к провайдеру).
Ну и ещё вопросик :), вот через эту прогу, смотрю есть файл менеджер, там можно посмотреть что в роутере на flash имеется, и там есть файл прошивки c870-advipsecurity и т.п., вот можно его как то через эту прогу скопировать на ПК, а затем во вторую "полудохлую" циску, попробовать "запихать"?, ну и соответственно, в дальнейшем, если со второй циской всё норм будет, то залить туда конфиг с рабочей циски (если настрою когда ни будь)), только пароли и логины сменить, и всё ок будет)

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

33. "877-K9"  +/
Сообщение от ShyLion (ok) on 04-Июн-18, 09:39 
>>> Я же тебе выше дал почти котовый конфиг.
> Кажется начинаю немного "въезжать", установил Cisco configuration pro, настроил роутер,
> подключился, в проге роутер успешно определился, и вот там немного поудобней

Блин, чувак, тут тебе не школа :)
Возьми, прочитай хотябы материалы к курсу ICND, а лучше посети его лично. Чуствую узнаешь много нового и полезного.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

34. "877-K9"  +/
Сообщение от IvanTT (ok) on 04-Июн-18, 12:32 
>>>> Я же тебе выше дал почти котовый конфиг.
>> Кажется начинаю немного "въезжать", установил Cisco configuration pro, настроил роутер,
>> подключился, в проге роутер успешно определился, и вот там немного поудобней
> Блин, чувак, тут тебе не школа :)
> Возьми, прочитай хотябы материалы к курсу ICND, а лучше посети его лично.
> Чуствую узнаешь много нового и полезного.

да добрался да вебинтерфейса, всё настроил как положено, нашел даже инструкцию на турецком языке как настраивать))). Но дело не в этом, к провайдеру роутер подключается, но интернета всё равно нет, о подключении говорит индикатор CD, так же загорается индикатор PPP и так же иногда помаргивают индикаторы TXD и RXD, я так понял, что интернет не раздаётся на интерфейс vlan1, то есть за несколько дней\ночей поисков, могу предположить что что с интерфейсам ATM, может надо ещё один создать 0.1 или 0.2?, в общем запарился я с этой циской, всё конечно понимаю, но конфиг не работает Ваш :(, и так же не работает мой конфиг, который я сам настроил в веб интерфейсе, там всё тоже самое практически получилось что и Вы писали. Я хз, вот в чём может быть трабл?
Ну вот ласт конфиг "проконфиганный" в веб интерфейсе, я хз, ну вот чё там не так ?:(, гляньте плз, подскажите, чего там исправить надо?)
!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service sequence-numbers
!
hostname XXXXX
!
boot-start-marker
boot-end-marker
!
no logging buffered
logging console critical
enable secret 5 XXXXXXX
!
no aaa new-model
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-2678466572
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2678466572
revocation-check none
rsakeypair TP-self-signed-2678466572
!
!
crypto pki certificate chain TP-self-signed-2678466572
certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32363738 34363635 3732301E 170D3138 30363034 30363132
  XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX
Эта фигня на самом деле большая) это от https сервера кракозябры какие то))
  8E280CAB DEC3BABE CC624B04 F423FEBA 9A96
      quit
dot11 syslog
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
ip dhcp pool LAN
   import all
   dns-server 213.177.96.1 213.177.97.1
   default-router 192.168.1.1
!
!
no ip bootp server
ip domain name XXXXXXX
!
!
!
username XXXXX privilege 15 secret 5 XXXXXXXXX
!
!
archive
log config
  hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $FW_OUTSIDE$$ES_WAN$
ip nat outside
ip virtual-reassembly
pvc 0/33
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
description $FW_OUTSIDE$
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname XXXXXXXXX
ppp chap password XXXXXXXXX
ppp pap sent-username XXXXXXXXX password XXXXXXXXXXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 1 interface ATM0.1 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Заранее очень благодарен :)

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

35. "877-K9"  +/
Сообщение от ShyLion (ok) on 04-Июн-18, 12:48 
У тебя нат настроен почему-то на ATM а не на Dialer

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

36. "877-K9"  +/
Сообщение от IvanTT (ok) on 04-Июн-18, 14:28 
> У тебя нат настроен почему-то на ATM а не на Dialer

Там в веб интерфейсе, галочка есть и написано Dialer(ATM 0.1), может как то через путти это можно переписать ?
interface ATM0.1 point-to-point
description $FW_OUTSIDE$$ES_WAN$
ip nat outside
ip virtual-reassembly
pvc 0/33
  pppoe-client dial-pool-number 1
но только без ip nat?, правильно капаю ?), просто сравнил с Ваши листингом, вроде всё норм кроме этого куска )

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

37. "877-K9"  +/
Сообщение от IvanTT (ok) on 04-Июн-18, 22:03 
!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname ХХХХХХХХ
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret ХХХХХХХХХХХХХХХХ
!
no aaa new-model
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-2678466572
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2678466572
revocation-check none
rsakeypair TP-self-signed-2678466572
!
!
crypto pki certificate chain TP-self-signed-2678466572
certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32363738 34363635 3732301E 170D3138 30363034 30373234
  35355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 36373834
  ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ
  0D06092A 864886F7 0D010104 05000381 810071E6 E152A98E EC45F5C2 68E7B734
  653B969A 56BF185F 5424ECD2 F8320826 D821708B 534F53AC 4925B0DC 7496635E
  85A04C5C C9A1EB4C 26F27AFC 7505C71C 7A9DCE7F 5AE3F2BD F1EB2DCA CECDEFAC
  5609B8AE ABC878F0 5231246D 8B2B9D16 27CEF79F 53C4084A AAD26504 18E126E1
  B2599304 6A19DA25 A5CB9EE5 A0320F03 7D98
      quit
dot11 syslog
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
!
no ip bootp server
ip domain name Cisco199.home
ip name-server 213.177.96.1
ip name-server 213.177.97.1
!
!
!
username ХХХХХХХХХХХХ privilege 15 secret ХХХХХХХХХХХХХХХХХХХХХ
!
!
archive
log config
  hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $FW_OUTSIDE$$ES_WAN$
ip nat outside
ip virtual-reassembly
pvc 0/33
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ХХХХХХХХХХХ password ХХХХХХХХХХХХ
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end


Переделал нат на дилер0 вместо атм, всёравно интернета нет :(, подключение проходит в циске, а на компе ничё нет. Может ещё чего не так?)

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

38. "877-K9"  +/
Сообщение от IvanTT (ok) on 05-Июн-18, 05:09 
Да и нат убрал с атм0.1 переделал на дилер0.
Конфиг выкладывать смысла наверно нет) А так эта sdm очень даже удобная штуковина), там есть express версия и полная версия, вот в експресс версии там вобще всё просто, как в zyxel`е примерно, даже мастер настройки есть, только вот толку от этих настроек, почему на компе нет интернета, я уж и шлюз указывал в на сетевой карте.., проьлема в том что циска подключается, видно по индикаторам, но на портах vlan`а интернета нет(. Всёже гляньте пожалуйста конфиг, если можно, что там ещё можно переделать кроме ната?), и если можно, напишите в виде листинга, ато ведь опять придётся капать сеть). Заранее спасибо.
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

39. "877-K9"  +/
Сообщение от ShyLion (ok) on 05-Июн-18, 07:59 
show ip route
show ip int dial0
ping 8.8.8.8
Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

40. "877-K9"  +/
Сообщение от IvanTT (ok) on 05-Июн-18, 14:10 
> show ip route
> show ip int dial0
> ping 8.8.8.8

результаты команд, я так понял не пингуется гугловский днс


Cisco199#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Vlan1


Cisco199#show ip int dial0
Dialer0 is up, line protocol is up
  Internet address will be negotiated using DHCP
  Broadcast address is 255.255.255.255
  MTU is 1452 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is disabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are never sent
  ICMP unreachables are never sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Flow switching is enabled
  IP CEF switching is enabled
  IP CEF Flow Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, Flow cache, CEF, Full Flow
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is enabled, interface in domain outside
  BGP Policy Mapping is disabled


Cisco199#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

41. "877-K9"  +/
Сообщение от IvanTT (ok) on 05-Июн-18, 14:13 
и вот конфиг, который сейчас, переделал нат, вернул роутинг, убрал нат с атм0 и сделал его на дилер. И не работает(

!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Cisco199
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret XXXXXXX
!
no aaa new-model
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-2678466572
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2678466572
revocation-check none
rsakeypair TP-self-signed-2678466572
!
!
crypto pki certificate chain TP-self-signed-2678466572
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ
  300D0609 2A864886 F70D0101 04050003 8181001D 4EF6E44E 2D81C043 8DB1FCB8
  835DD198 DDD7ECE2 EACA185D 5A529364 19522ACB 7D0F1AF1 C3F13299 E4D6C04D
  0DFF71D6 124A0145 CAE1F888 7CF7F22C E3499C12 DE35360C E1CCAC6B 7F5BC987
  F42F8DFF 3BFC6578 E3E2026A 5104CD3A 5F228A03 5213C11B D421954E 5B4A4752
  E11A8D51 1CF238CF 816EE17E BDED4400 057845
      quit
dot11 syslog
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
!
no ip bootp server
ip domain name Cisco199.home
ip name-server 80.95.37.230
ip name-server 80.95.37.232
!
!
!
username XXXXXXXX privilege 15 secret XXXXXXXXXXXXXXXXXXX
!
!
archive
log config
  hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
pvc 0/33
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname XXXXXXXXX
ppp chap password XXXXXXXX
ppp pap sent-username XXXXXXXXX password XXXXXXXXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for  one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

42. "877-K9"  +/
Сообщение от IvanTT (ok) on 05-Июн-18, 21:06 
УУУУРРРААААА!!!!)))) ЗАРАБОТАЛО!!!!))))))))

Вот конфиг

!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Cisco199
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret ХХХХХХХХХХХХХХХХХ
!
no aaa new-model
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-2678466572
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2678466572
revocation-check none
rsakeypair TP-self-signed-2678466572
!
!
crypto pki certificate chain TP-self-signed-2678466572
certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ
  D290DD2C 53B2F695 07A02AD8 F2619C5E 311C10EE B321F6AC 83532C44 47426BAB
  FDED0FDC B8E5E94E D304894B D6515126 464B0819 126467C2 9C34F1FC 630C35D0
  C711B99A 880AD668 C79197DA C25513B0 93A4
      quit
dot11 syslog
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
!
no ip bootp server
ip domain name Cisco199.home
ip name-server 80.95.37.230
ip name-server 80.95.37.232
!
!
!
username ХХХХХХХ privilege 15 secret ХХХХХХХХХХХХХХХХХХХ
!
!
archive
log config
  hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
pvc 0/33
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ХХХХХХХХХХХ
ppp chap password ХХХХХХХХХХХ
ppp pap sent-username ХХХХХХХХХ password ХХХХХХХХХХХХ
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for  one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Но работает, при условии если прописать эти днс сервера ip name-server 80.95.37.230
ip name-server 80.95.37.232 в компе, можно их как то вписать в роутер, что бы не прописывать их в компе?, подскажите пожалуйста), просто например в зухеле стоит автополучение днсов, и один из них был указан этот 80.95.37.230, видимо он меняется при переподключении, второй днс сам нашёл, может лучше провайдеру позвонить, узнать какие лучше днсы прописать?
если правильно понимаю то нужно их вписать вот в этот кусок
ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

Подскажите плз:) Пока пусть поработает, может ресурсы какие открываться не будут, посмотрю пока, но если всё гуд, то напишу гайдик, как "нуб" настраивал циску, может кому пригодится)))
И ещё такой туповатый вопросик)), насчёт отключения циски, если просто выключать как например зухель, ничего там с конфигом не случится?, или надо как то специфически выключать?)


Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

43. "877-K9"  +/
Сообщение от Иван (??) on 06-Июн-18, 06:39 
> УУУУРРРААААА!!!!)))) ЗАРАБОТАЛО!!!!))))))))

.
.
.
> Подскажите плз:) Пока пусть поработает, может ресурсы какие открываться не будут, посмотрю
> пока, но если всё гуд, то напишу гайдик, как "нуб" настраивал
> циску, может кому пригодится)))
> И ещё такой туповатый вопросик)), насчёт отключения циски, если просто выключать как
> например зухель, ничего там с конфигом не случится?, или надо как
> то специфически выключать?)

Конфиг сохраняешь командами write или copy running-config startup-config
Ну а выключать "тумблером" )


Касательно DNS

ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 80.95.37.230 80.95.37.232

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

44. "877-K9"  +/
Сообщение от ShyLion (ok) on 06-Июн-18, 08:18 
> ip dhcp pool sdm-pool1
>    import all


ip dhcp pool sdm-pool1
no import all

нефиг тащить что попало из глобала

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

45. "877-K9"  +/
Сообщение от IvanTT (ok) on 10-Июн-18, 10:50 
Добрый день, как я и обещал, вот мини-гайд, точнее описание, как не опытному, не разбирающемуся в Cisco человеку, настроить Cisco 877-K9
под ADSL интернет Ростелеком.
Для начала, скажу Вам, так как я не разбираюсь в Cisco, мне нужно было попасть в веб-интерфейс данного аппарата.
Для этого нужно скачать такие программы:
1. Cisco Configuration Professional версии 2.8
2. Скачать и установить Java для win10 (у меня просто win10X64).
3. Так же скачать java jre-1_5_0_06 это для winXP.
4. Скачать cisco-sdm-v25.
5. Скачать и установить VirtualBox, у меня стоит версия 5.2.8
6. Скачать Putty.
Так же, нужно что бы в компьютере был com-порт, если такового нет, то можно использовать переходник USB-COM, но о том как его настроить, тоже можно найти в сети,
так как у меня есть com-порт на материнке asus sabertooth 990fx r2.0, мне это не потребовалось :).

Итак, вот есть все необходимые программы, приступаю :).
Устнавливаем и создаем виртуальную машину, о том как её установить, я описывать не буду, в сети очень много гайдов как это сделать. Устанавливаем winXP на
эту самую виртуальную машину (у меня установлено XP SP3 X86), далее настраиваем общую папку, что бы можно было обмениваться файлами между компьютером и
виртуальной машиной. Закидываем в эту общую папку программы из списка выше, это java jre-1_5_0_06 это для winXP, и cisco-sdm-v25, затем установим эти программы
на виртуальной машине. Так же в свойтвах IE6 (это в XP виртуальной машины), во вкладке "Конфиденциальность", передвинуть ползунок параметров на минимум (принимать
все "cookie"), и снять галочку "Блокировать всплывающие окна", жмём применить.
Далее, устанавливаем java в win10, затем установим Cisco Configuration Professional, и так же установим Putty.
На этом установка программа завершена, теперь приступим к самому роутеру.
Подключаем роутер к компьютеру через консольный кабель к com-порту, запускаем Putty, ставим голачку (там их 4 RAW, Telnet, Rlogin, SSH и Serial) на Serial,
ничего больше настраивать не нужно, (но если используете переходник usb-com то тогда нужно произвести настройки, про это можно посмотреть в youtube),  так как там всё настроено по умолчанию, жмём кнопку open откроется терминал. Включаем роутер, в открывшемся окне, увидим
загрузку роутера, после загрузки, появится приглашение в виде Router>. Если требует пароль, можно его сбросить, для этого, выключаем роутер,
затем включаем снова, в момент загрузки жмём CTRL+Break, жмём как на компе del, если хотим зайти в биос. Появится приглашение rommon>, тут пишем confreg 0X2142
далее роутер напишет что надо перезагрузится, в следующей строке rommon пишем reset и жмём enter, загружаемся в чистую конфигурацию роутера, на вопрос мастера
настройки отвечаем no (он спросит об этом в момент загрузки), далее появится приглашение Router>, нам нужно зайти в привелигированный режим, для этого пишем enable
жмём enter, появится приглашение Router#, далее нам надо сохранить эту текущую конфигурацию роутера, для этого пишем write mem (можно просто wr), жмём enter,
далее нам надо перезагрузить роутер, и вернуть конфигурационный регистр, для этого пишем reload, жмём enter, и снова, в момент загрузки жмём CTRL+Break, так же
появится приглашение rommon>, там пишем confreg 0X2102, так же он затребует перезагрузку, пишем reset, жмём enter, перезагружаемся в нашу чистую конфигурацию.
Иногда бывает, что при вводе confreg 0X2142 или 0X2102, появляется надпись мол unknown command, ничего страшного, пишем команду ещё раз, странно, но у меня так было.
Итак, сбросили пароль, если он был, в любом случае, теперь нужно проверить конфигурационный регистр, на месте он или нет), для этого пишем в приглашении Router>enable,
далее в приглашении Router#sh ver, и смотрим в самом конце должна быть надпись 0X2102, что означает - всё гуд.
Приступим к конфигурированию роутера для того что бы зайти в веб-интерфейс, для этого пишем команды:
Router> enable
Router# conf t
Router(config)# ip http server
Router(config)# ip http secure-server
Router(config)# ip http authentication local
Router(config)# username ХХХХХХХ privilege 15 password 0 ХХХХХХХ
Router(config)# line vty 0 4
Router(config?line)# privilege level 15
Router(config?line)# login local
Router(config?line)# transport input telnet
Router(config?line)# transport input telnet ssh
Router(config?line)# exit
Router(config)# interface Vlan1
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# exit
Router(config)# logging buffered 51200 warning
Router(config)# exit
Router#wr
Вместо ХХХХХХ вписываем Ваши логин и пароль (придумайте сами), которые нам потребуются при входе в веб-интерфес роутера.
После этого, в свойствах сетевого адаптера на компьютере, пропишем адрес нашего роутера 192.168.1.1 и маска 255.255.255.0.
Идем дальше, нам потребуется загрузить файлы веб интерфейса на flash память роутера, для этого
запускаем программу Cisco Configuration Professional, при первом запуске появится окно с добавлением нового роутера, итак, добавляем, в строке
IP address пишем адрес роутера 192.168.1.1, в строке Username пишем логин что придумали вместо ХХХХХ, ну и соответственно, в строке Password пишем наш ХХХХХ пароль.
Жмём OK, роутер подключится и появится в программе (будет ip нашего роутера), далее в окне программы выбираем наш роутер (192.168.1.1),
и нажимаем кнопку Discover, ждём когда программа подключится к роутеру, об этом станет известно когда слева в строке
"Select Community Member" появится ip адрес нашего роутера, и так же станут доступны Utilities (это снизу слева), вот в этих Utilities выбираем Flash File Manager.
Справой стороны в программе, появится этот файл менеджер, и мы увидим все файлы, хранящиеся на flash памяти роутера, нажимаем кнопку Upload, и идём в каталог
cisco-sdm-v25, и копируем из этого каталога следующие файлы на роутер
es.tar
common.tar
128MB.sdf
home.tar
sdmconfig-8xx.cfg
home.shtml
Примечание* Если такие файлы уже есть в роутере, то надо их удалить, но ТОЛЬКО эти файлы, смотрите по названию файлов выше, то есть их надо заменить на файлы
из списка выше, так как возможно в роутере они другой версии.
Так, скопировали, можно закрывать Cisco Configuration Professional, и преходить к виртуальной машине.
На виртуальной машине, открываем браузер IE, пишем адрес нашего роутера 192.168.1.1, появится окно с вводом логина и пароля (это наши ХХХХХ), пишем их, жмём ok,
разрешаем всё что спросит, жмём ok, спросит ещё раз логин и пароль, так же пишем, появятся всякие окна (они могут быть за окном браузера, смотрите внимательно, просто
из за этого, что не нажали ok в каком то окне, интерфейс не откроется), жмём везде ok, и вуаля вот он наш веб-интерфейс, по умолчанию откроется Cisco SDM Express, это
скажем так, обычный вид интерфейса, что бы перейти в расширенный вид, нужно слева внизу в этом Cisco SDM Express, нажать на Cisco SDM, снова будут всякие окна, в которых
жмём ok (смотрите внимательно, они могут быть за окном браузера), откроется расширенный веб-интерфейс. Далее, можно приступать к настройке, если конечно разберётесь там:)
В общем, это всё для того что бы попасть в веб-интерфейс роутера :)), покрайне мере я делал так).


Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

46. "877-K9"  +/
Сообщение от IvanTT (ok) on 10-Июн-18, 10:51 
Если Вам не нужен веб-интерфейс, то вот готовая рабочая конфигурация, но она настроена через веб-интерфейс, с некоторыми правками, которые мне тут подсказали на этом форуме,
за что огромное спасибо ещё раз. Эти правки я делал через putty.

!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Cisco199
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret ХХХХХХХХХХХХХХХХХ
!
no aaa new-model
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-2678466572
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2678466572
revocation-check none
rsakeypair TP-self-signed-2678466572
!
!
crypto pki certificate chain TP-self-signed-2678466572
certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ ХХХХХХХХ
  D290DD2C 53B2F695 07A02AD8 F2619C5E 311C10EE B321F6AC 83532C44 47426BAB
  FDED0FDC B8E5E94E D304894B D6515126 464B0819 126467C2 9C34F1FC 630C35D0
  C711B99A 880AD668 C79197DA C25513B0 93A4
      quit
dot11 syslog
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.1.0 255.255.255.0
   dns-server 80.95.37.230 80.95.37.232
   default-router 192.168.1.1
!
!
no ip bootp server
ip domain name Cisco199.home
ip name-server 80.95.37.230
ip name-server 80.95.37.232
!
!
!
username ХХХХХХХ privilege 15 secret ХХХХХХХХХХХХХХХХХХХ
!
!
archive
log config
  hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
pvc 0/33
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ХХХХХХХХХХХ
ppp chap password ХХХХХХХХХХХ
ppp pap sent-username ХХХХХХХХХ password ХХХХХХХХХХХХ
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for  one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Опять же XXXXX это Ваши логин и пароль, и dns сервера, смотрите сами, указывайте те которые будут лучше, можно хоть гугловские указать 8.8.8.8 и 8.8.4.4,
просто я узнавал их у провайдера.
Если всё сделать правильно, то всё будет работать.
Мои скажем так, впечатления о работе Cisco 877-K9, сайты открываются быстро, видео грузит хорошо, но к сожалению пинг в онлайн играх выше чем например
в Zyxel P660-й серии, не знаю почему, но выше, напрмер в World of Warcraft, через Zyxel пинг у меня 65-70 через Cisco 80-100, по этому, любителям оналйн игр
наверно эта Cisco не подойдёт, может я ошибаюсь, но к сожалению это так :(.
Да, и не забудьте потом в свойствах сетевой карты компьютера, установить на получение ip адресов автоматически.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

47. "877-K9"  +/
Сообщение от ShyLion (ok) on 10-Июн-18, 13:54 
Cisco роутеры _не для дома_. Это энтерпрайз сегмент, 800 серия используется в малонаселенных узлах единой корпоротивной сети и служит для подключения филиала в общую сеть. Тунели там всякие, протоколы маршрутизации и все остальное.
Они не предназначены для настройки неопытными админами.
Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

48. "877-K9"  +/
Сообщение от IvanTT (ok) on 10-Июн-18, 14:03 
> Cisco роутеры _не для дома_. Это энтерпрайз сегмент, 800 серия используется в
> малонаселенных узлах единой корпоротивной сети и служит для подключения филиала в
> общую сеть. Тунели там всякие, протоколы маршрутизации и все остальное.
> Они не предназначены для настройки неопытными админами.

Да понятно, но ведь таких людей как я наверно не мало, да и в деревнях adsl лучший вариант наверно, но есть конечно альтернатива в виде мобильной связи, но это крайне не стабильная вещь, в городе ещё может быть. Так же пробовал асинхронный спутник, там вобще молчу, не знаю как это объяснить..))
На самом деле, я очень долго искал конфиг, и вот ну ни один из конфигов не работал, а я их перепробовал штук 5 точно, а вот этот, пускай он дырявый, но он работает) Конечно, это не выход, но может кому пригодится, хотя бы как некий дырявый шаблон)))

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

49. "877-K9"  +/
Сообщение от ShyLion (ok) on 10-Июн-18, 18:43 
> точно, а вот этот, пускай он дырявый, но он работает) Конечно,
> это не выход, но может кому пригодится, хотя бы как некий
> дырявый шаблон)))

В таких вещах нужно разбираться последовательно от простого к сложному. А подбирать конфиги - антинаучно :)

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

50. "877-K9"  +/
Сообщение от IvanTT (ok) on 11-Июн-18, 03:40 
> Мои скажем так, впечатления о работе Cisco 877-K9, сайты открываются быстро, видео
> грузит хорошо, но к сожалению пинг в онлайн играх выше чем
> например
> в Zyxel P660-й серии, не знаю почему, но выше, напрмер в World
> of Warcraft, через Zyxel пинг у меня 65-70 через Cisco 80-100,
> по этому, любителям оналйн игр
> наверно эта Cisco не подойдёт, может я ошибаюсь, но к сожалению это
> так :(.

Играть можно и ещё как, перенастроил роутер через веб интерфейс, ничего не трогал, и включил фаерволл, настраивал с помощью мастера настройки в веб интерфейсе после того как там же перезагрузил роутер до заводских настроек после этого пинг например в том же wow стал 70-75. Теперь надо подумать о безопасности, что можно добавить в этот новый конфиг?), подскажите пожалуйста, только поконкретней, ато ведь опять буду целый день искать в сети :), заранее благодарен, вот конфиг с фаерволлом:

!This is the running config of the router: 192.168.1.1
!----------------------------------------------------------------------------
!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Cisco038
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200
logging console critical
enable secret XXXXXXXXXXXXXXXXXXXXXXXXXX
!
no aaa new-model
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-246611640
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-246611640
revocation-check none
rsakeypair TP-self-signed-246611640
!
!
crypto pki certificate chain TP-self-signed-246611640
certificate self-signed 01
3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX XXXXXXXX
032307F7 3122A5D6 F9A3CF4F 7F9815F5 89425441 CBE5127D 7BBED11B 20684386
08DBD390 E1A6CA1C B086BFAE 1B93495C 97710F98 6942909C 2CF885DD 35BE994B
938A90D9 906DD9A6 2EDB2B0A 8BD3C287
quit
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool1
import all
network 192.168.1.0 255.255.255.0
dns-server 80.95.37.230 80.95.37.232
default-router 192.168.1.1
!
!
no ip bootp server
ip domain name Cisco038.home
ip name-server 80.95.37.230
ip name-server 80.95.37.232
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username XXXXXXXXXXX privilege 15 secret XXXXXXXXXXXXXXXXX
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
class-map type inspect match-any sdm-cls-insp-traffic
match protocol cuseeme
match protocol dns
match protocol ftp
match protocol h323
match protocol https
match protocol icmp
match protocol imap
match protocol pop3
match protocol netshow
match protocol shell
match protocol realmedia
match protocol rtsp
match protocol smtp extended
match protocol sql-net
match protocol streamworks
match protocol tftp
match protocol vdolive
match protocol tcp
match protocol udp
class-map type inspect match-all sdm-insp-traffic
match class-map sdm-cls-insp-traffic
class-map type inspect match-any sdm-cls-icmp-access
match protocol icmp
match protocol tcp
match protocol udp
class-map type inspect match-all sdm-invalid-src
match access-group 100
class-map type inspect match-all sdm-icmp-access
match class-map sdm-cls-icmp-access
class-map type inspect match-all sdm-protocol-http
match protocol http
!
!
policy-map type inspect sdm-permit-icmpreply
class type inspect sdm-icmp-access
inspect
class class-default
pass
policy-map type inspect sdm-inspect
class type inspect sdm-invalid-src
drop log
class type inspect sdm-insp-traffic
inspect
class type inspect sdm-protocol-http
inspect
class class-default
policy-map type inspect sdm-permit
class class-default
!
zone security out-zone
zone security in-zone
zone-pair security sdm-zp-self-out source self destination out-zone
service-policy type inspect sdm-permit-icmpreply
zone-pair security sdm-zp-out-self source out-zone destination self
service-policy type inspect sdm-permit
zone-pair security sdm-zp-in-out source in-zone destination out-zone
service-policy type inspect sdm-inspect
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
pvc 0/33
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
zone-member security in-zone
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname XXXXXXXXX
ppp chap password XXXXXXXXX
ppp pap sent-username XXXXXXXXXX password XXXXXXXXXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 remark SDM_ACL Category=128
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor