The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Нужен совет по настройке двух провайдеров на Cisco 2901/K9"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Нужен совет по настройке двух провайдеров на Cisco 2901/K9"  +/
Сообщение от alsyro (ok) on 08-Июн-18, 16:58 
Доброго вам здоровьеца, соколики, подсобите коли не сложно советом, куда смотреть.
Есть 2 провайдера (Я назвал их Махнетом и Спуди. Махнет - основной 1.1.1.37/28, спуди 2.2.2.2/24 - резервный) и одна циска с 2мя портами. Ge0/1, который смотрит в Lan и другой Ge0/0 - в Wan на 2 провайдера, один идёт нетегом (спуди), другой тегом (Махнет). Очень хотелось настроить резервирование, но не знаю, получилось или нет (скорее нет, чем да.), т.к. явилась проблема, откуда не ждали. Каждый провайдер работает, если прописать только его. Инет есть на внутренней локалке, но вот если пускать через кофиг резервирования, спуди отказывается проводить пропинговку по ip sla и пишет таймауты везде, где только можно. На конфиге, который я ниже скину, работает один провайдер. Махнет и инет от него есть. Если вырубить, Спуди машет ушами и отказывается робить. Пробовал переводить всё в поток, эффект тот же. Всё что знал - испробовал, но то ли знал мало, то ли не так пробовал. В общем в тупике я, соколики. Помогите, люди добрые, направьте на путь истины.
За ересь в конфиге прошу отнестись снисходительно. Сами мы не местные...
За помощь в наставлении - очищение всех грехов вплоть до 7го колена вашим внукам и внучкам. И внучатым племянницам, что уж тут.


Мahnet - ip 1.1.1.37/28 gw: 1.1.1.33
Spoody - ip 2.2.2.150/24 gw 2.2.2.254

--Конфиг

version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2901
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging userinfo
logging buffered 51200 warnings
no logging console
!
aaa new-model
!
!
aaa authentication password-prompt "---password: "
aaa authentication username-prompt "---login as: "
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone Moscow 3
!
no ipv6 cef
no ip source-route
ip cef
!
!
!
ip dhcp pool CR
   network 172.18.100.0 255.255.255.0
   dns-server 77.88.8.8
   default-router 172.18.100.1
!
!
no ip bootp server
ip domain name R2901.domain
ip name-server 8.8.8.8
ip name-server 77.88.8.8
login block-for 60 attempts 3 within 30
login delay 1
login on-failure log
login on-success log
!
multilink bundle-name authenticated
!
!
!
crypto pki server MAIN-R2901
shutdown
!
crypto pki trustpoint trustpoint_config_created_for_sdm
subject-name e=sdmtest@sdmtest.com
revocation-check crl
!
crypto pki trustpoint TP-self-signed
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-CR
revocation-check none
rsakeypair TP-self-signed-CR
!
crypto pki trustpoint MAIN-R2901
revocation-check crl
rsakeypair MAIN-R2901
!
!

license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
!
!
archive
log config
  logging enable
  hidekeys
username root privilege 15 secret 5 11111111
!
redundancy
!
!
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
track 10 ip sla 1 reachability
!
track 20 ip sla 2 reachability
!
track 30 ip sla 3 reachability
!
track 100 list boolean or
object 10
object 20
object 30
delay down 10 up 5
!
track 110 ip sla 11 reachability
!
track 120 ip sla 12 reachability
!
track 130 ip sla 13 reachability
!
track 200 list boolean or
object 110
object 120
object 130
delay down 10 up 5
!
!
!
!
!
!
!
interface GigabitEthernet0/0
description Spoody Uplink
ip address 2.2.2.150 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
history BPS
no mop enabled
!
interface GigabitEthernet0/0.299
description Mahnet Uplink
encapsulation dot1Q 299
ip address 1.1.1.37 255.255.255.240
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no cdp enable
!
interface GigabitEthernet0/1
description LAN
ip address 11.0.0.1 255.0.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
description CCTV
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
ip access-group 99 out
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
no cdp enable
no routing dynamic
!
interface GigabitEthernet0/1.95
description DefaultWorkLAN
encapsulation dot1Q 95
ip address 192.168.95.1 255.255.255.0
ip accounting output-packets
ip nat inside
ip virtual-reassembly
no cdp enable
!
interface GigabitEthernet0/1.100
description WorkLan
encapsulation dot1Q 100
ip address 172.18.100.1 255.255.0.0
ip accounting output-packets
ip nat inside
ip virtual-reassembly
no cdp enable
!
!
ip local policy route-map Mahnet
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat translation timeout 120
ip nat translation tcp-timeout 3600
ip nat translation udp-timeout 120
ip nat translation finrst-timeout 10
ip nat translation syn-timeout 30
ip nat translation dns-timeout 30
ip nat inside source route-map Mahnet interface GigabitEthernet0/0.299 overload
ip nat inside source route-map Spoody interface GigabitEthernet0/0 overload
ip nat inside source static tcp 172.18.100.10 3389 1.1.1.37 28028 route-map Mahnet extendable
ip nat inside source static tcp 172.18.100.5 35300 1.1.1.37 35300 route-map Mahnet extendable
ip nat inside source static tcp 172.18.100.10 3389 2.2.2.150 28028 route-map Spoody extendable
ip nat inside source static tcp 172.18.100.5 35300 2.2.2.150 35300 route-map Spoody extendable
ip route 0.0.0.0 0.0.0.0 1.1.1.33 track 100
ip route 0.0.0.0 0.0.0.0 2.2.2.254 track 200
ip route 8.8.8.8 255.255.255.255 1.1.1.33
ip route 77.88.8.8 255.255.255.255 1.1.1.33
!
ip access-list extended SLA1_ACL
permit icmp host 1.1.1.37 host 8.8.8.8
permit icmp host 1.1.1.37 host 77.88.8.8
permit icmp host 1.1.1.37 host 4.4.4.4
ip access-list extended SLA2_ACL
permit icmp host 2.2.2.150 host 8.8.8.8
permit icmp host 2.2.2.150 host 77.88.8.8
permit icmp host 2.2.2.150 host 4.4.4.4
ip access-list extended acl_nat
permit ip 192.168.95.0 0.0.0.255 any
permit ip 172.18.100.0 0.0.0.255 any
deny   ip any any
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/0.299
threshold 1000
timeout 1500
frequency 3
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 77.88.8.8 source-interface GigabitEthernet0/0.299
threshold 1000
timeout 1500
frequency 3
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-echo 4.4.4.4 source-interface GigabitEthernet0/0.299
threshold 1000
timeout 1500
frequency 3
ip sla schedule 3 life forever start-time now
ip sla 11
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/0
threshold 1000
timeout 1500
frequency 3
ip sla schedule 11 life forever start-time now
ip sla 12
icmp-echo 77.88.8.8 source-interface GigabitEthernet0/0
threshold 1000
timeout 1500
frequency 3
ip sla schedule 12 life forever start-time now
ip sla 13
icmp-echo 4.4.4.4 source-interface GigabitEthernet0/0
threshold 1000
timeout 1500
frequency 3
ip sla schedule 13 life forever start-time now
access-list 1 permit 172.18.100.0 0.0.0.255
access-list 1 permit 11.0.0.0 0.0.0.255
access-list 1 deny   any
!
!
!
!
route-map Spoody permit 10
match ip address acl_nat
match interface GigabitEthernet0/0
!
route-map Mahnet permit 10
match ip address acl_nat
match interface GigabitEthernet0/0.299
!
route-map PBR_SLA permit 10
match ip address SLA1_ACL
set ip next-hop 1.1.1.33
!
route-map PBR_SLA permit 20
match ip address SLA2_ACL
set ip next-hop 2.2.2.254
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
access-class 1 in
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp authenticate
event manager applet Mahnet_UP
event track 100 state up
action 001 cli command "enable"
action 002 cli command "clear ip nat translation *"
action 003 syslog msg "Mahnet is UP"
event manager applet Mahnet_DOWN
event track 100 state down
action 001 cli command "enable"
action 002 cli command "clear ip nat translation *"
action 003 syslog msg "Mahnet is DOWN"
event manager applet Spoody_UP
event track 200 state up
action 001 cli command "enable"
action 002 cli command "clear ip nat translation *"
action 003 syslog msg "Spoody is UP"
event manager applet Spoody_DOWN
event track 200 state down
action 001 cli command "enable"
action 002 cli command "clear ip nat translation *"
action 003 syslog msg "Spoody is DOWN"
!
end


--Вывод IP SLA Statistics
IPSLAs Latest Operation Statistics

IPSLA operation id: 1
        Latest RTT: 3 milliseconds
Latest operation start time: *16:15:56.504 Moscow Fri Jun 8 2018
Latest operation return code: OK
Number of successes: 1097
Number of failures: 0
Operation time to live: Forever

IPSLA operation id: 2
        Latest RTT: 8 milliseconds
Latest operation start time: *16:15:56.504 Moscow Fri Jun 8 2018
Latest operation return code: OK
Number of successes: 1097
Number of failures: 0
Operation time to live: Forever

IPSLA operation id: 3
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *16:15:56.504 Moscow Fri Jun 8 2018
Latest operation return code: Timeout
Number of successes: 0
Number of failures: 1097
Operation time to live: Forever

IPSLA operation id: 11
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *16:15:56.504 Moscow Fri Jun 8 2018
Latest operation return code: Timeout
Number of successes: 0
Number of failures: 1097
Operation time to live: Forever

IPSLA operation id: 12
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *16:15:56.508 Moscow Fri Jun 8 2018
Latest operation return code: Timeout
Number of successes: 0
Number of failures: 1097
Operation time to live: Forever

IPSLA operation id: 13
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *16:15:56.508 Moscow Fri Jun 8 2018
Latest operation return code: Timeout
Number of successes: 0
Number of failures: 1097
Operation time to live: Forever

-- SHOW ROUTE-MAP all

STATIC routemaps
route-map Spoody, permit, sequence 10
  Match clauses:
    ip address (access-lists): acl_nat
    interface GigabitEthernet0/0
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map Mahnet, permit, sequence 10
  Match clauses:
    ip address (access-lists): acl_nat
    interface GigabitEthernet0/0.299
  Set clauses:
  Policy routing matches: 303 packets, 52062 bytes
route-map PBR_SLA, permit, sequence 10
  Match clauses:
    ip address (access-lists): SLA1_ACL
  Set clauses:
    ip next-hop 5.23.101.33
  Policy routing matches: 0 packets, 0 bytes
route-map PBR_SLA, permit, sequence 20
  Match clauses:
    ip address (access-lists): SLA2_ACL
  Set clauses:
    ip next-hop 10.54.185.254
  Policy routing matches: 0 packets, 0 bytes
DYNAMIC routemaps
Current active dynamic routemaps = 0

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Нужен совет по настройке двух провайдеров на Cisco 2901/K9"  +/
Сообщение от BOJIKA email on 09-Июн-18, 00:39 
трекать нужно только основного провайдера
желательно трекать несколько адресов, и вот когда они все будут недоступны, переключаться на резервный.
Статические маршруты на те адреса, что вы трекаете, должны быть прописаны.

При переключении EEM следует очищать таблицу трансляций...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Нужен совет по настройке двух провайдеров на Cisco 2901/K9"  +/
Сообщение от alsyro (ok) on 09-Июн-18, 09:22 
> трекать нужно только основного провайдера

Сделал, всё равно не робит. sla 11, 12, 13 убрал.

> желательно трекать несколько адресов, и вот когда они все будут недоступны, переключаться
> на резервный.

Для этого созданы sla 1,2,3

> При переключении EEM следует очищать таблицу трансляций...

Так сие и происходит в каждом event - action 002 cli command "clear ip nat translation *"

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Нужен совет по настройке двух провайдеров на Cisco 2901/K9"  +/
Сообщение от ВОЛКА email(ok) on 13-Июн-18, 13:46 
>> трекать нужно только основного провайдера
>  Сделал, всё равно не робит. sla 11, 12, 13 убрал.
>> желательно трекать несколько адресов, и вот когда они все будут недоступны, переключаться
>> на резервный.
> Для этого созданы sla 1,2,3
>> При переключении EEM следует очищать таблицу трансляций...
> Так сие и происходит в каждом event - action 002 cli command
> "clear ip nat translation *"

покажите текущий конфиг, и что именно не работает?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor