The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"vlan между Cisco 3825 и Cisco 871"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 26-Окт-11, 15:44 
Доброго времени суток!
Уважаемые Cisco'воды и гуру, посоветуйте как соединить
есть Cisco 3825

interface GigabitEthernet0/1
ip address 192.168.1.2 255.255.255.252
interface GigabitEthernet0/1.2
encapsulation dot1q 2
!
ip route 192.168.1.4 255.255.255.252 192.168.1.1

и есть Cisco 871 развернутая задом на перед, т.е. WAN порт смотрит в LAN,
встроенный Switch смотрит наружу

interface FastEthernet 3
switchport access vlan 2
interface vlan 2
ip address 192.168.1.6 255.255.255.252
!
ip route 192.168.1.0 255.255.255.252 192.168.1.5

И ВОТ ЧТО-ТО НЕ ВИДЯТ ОНИ ДРУГ ДРУГА! В ЧЕМ ПРОБЛЕМА? ПОДСКАЖИТЕ?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от APach (ok) on 26-Окт-11, 16:50 
switch port mode trunk и access vlan all или те что нужно на GigabitEthernet0/1
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 26-Окт-11, 16:57 
на GigabitEthernet0/1 хочу видеть несколько vlan, т.е. помимо vlan 2 существует
еще несколько vlan и соответственно несколько cisco 871 на других концах.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Николай_kv on 26-Окт-11, 17:09 
Cisco 3825
> interface GigabitEthernet0/1
>  ip address 192.168.1.2 255.255.255.252
> interface GigabitEthernet0/1.2
>  encapsulation dot1q 2
> !
> ip route 192.168.1.4 255.255.255.252 192.168.1.1

Cisco 871
> interface FastEthernet 3
>  switchport access vlan 2
> interface vlan 2
>  ip address 192.168.1.6 255.255.255.252
> !
> ip route 192.168.1.0 255.255.255.252 192.168.1.5

И ВОТ ЧТО-ТО НЕ ВИДЯТ ОНИ ДРУГ ДРУГА! В ЧЕМ ПРОБЛЕМА? ПОДСКАЖИТЕ?

И что мисьё желает увидеть если вы на 3825 создали сабинт на второй влан и не повесили ИП скорее перепутали и повесили его тупо на GigabitEthernet0/1.
может так:
interface GigabitEthernet0/1
  no ip address
interface GigabitEthernet0/1.2
  encapsulation dot1q 2
  ip address 192.168.1.2 255.255.255.252


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 26-Окт-11, 17:14 
да, ip address перевесил на сабинтерфейс, но это не помогло.


Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 26-Окт-11, 17:15 
> да, ip address перевесил на сабинтерфейс, но это не помогло.

только не этот ip address, а адрес из той же подсети что и cisco 871 vlan 2, расширив ее до 255.255.255.248

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Николай_kv on 26-Окт-11, 17:35 
>> да, ip address перевесил на сабинтерфейс, но это не помогло.
> только не этот ip address, а адрес из той же подсети что
> и cisco 871 vlan 2, расширив ее до 255.255.255.248

Конфиг покажите двух железок опять

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 26-Окт-11, 18:01 
Cisco 3825

!
interface GigabitEthernet0/1
no ip address
ip virtual-reassembly
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1.101
encapsulation dot1Q 101
!
interface GigabitEthernet0/1.106
encapsulation dot1Q 106
!
interface GigabitEthernet0/1.107
encapsulation dot1Q 107
ip address 192.168.60.14 255.255.255.248
!
interface GigabitEthernet0/1.111
encapsulation dot1Q 111
!
interface GigabitEthernet0/1.112
encapsulation dot1Q 112
!
interface GigabitEthernet0/1.120
encapsulation dot1Q 120
!

Cisco 871

!
interface FastEthernet3
switchport access vlan 107
!
interface Vlan107
ip address 192.168.60.11 255.255.255.248
ip virtual-reassembly
!

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Николай_kv on 26-Окт-11, 18:12 
>[оверквотинг удален]
> !
> Cisco 871
> !
> interface FastEthernet3
>  switchport access vlan 107
> !
> interface Vlan107
>  ip address 192.168.60.11 255.255.255.248
>  ip virtual-reassembly
> !

возьми пропиши на 871 следующее

interface FastEthernet 2
switchport mode trunk
switchport trunk encapsulation dot1q

воткни кабель 871 в порт FastEthernet 2 на другой стороне воткни 3825 GigabitEthernet0/1 и будет тебе счастье.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 27-Окт-11, 08:55 
Доброго времени суток!

не помогло, совсем пропал, даже шлюз не видит на 871,

может есть необходимость обозначить dot1q на vlan 107 на 871?
там есть возможность добавить команду dot1q tunneling ethertype 0x88A8 или 0x9100

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Аноним (??) on 27-Окт-11, 09:27 
> Доброго времени суток!
> не помогло, совсем пропал, даже шлюз не видит на 871,
> может есть необходимость обозначить dot1q на vlan 107 на 871?
> там есть возможность добавить команду dot1q tunneling ethertype 0x88A8 или 0x9100

Наверное вы забыли создать vlanы на свитче 871. Добавьте вот это:

#vlan database
#vlan 107 name VLAN107
#exit

Посмотреть таблицу вланов свитча:
sh vlan-switch brief

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 27-Окт-11, 11:29 
работает
Cisco 3825
!
no spanning-tree vlan 107
!
interface gigabitethernet0/1
     ip virtual-reassembly
     duplex auto
     speed auto
!
interface gigabitethernet0/1.107
     ip virtual-reaseembly
     ip address 192.168.60.14 255.255.255.248
     encapsulation dot1Q 107
!

Cisco 871
!
no spanning-tree vlan 107
!
interface fastethernet 3
     switchport access vlan 107
!
interface vlan 107
    ip virtual-reassembly
    ip address 192.168.60.11 255.255.255.248
!

причем все заработало само после того как ушел с trunk на access,
может помогла команда switchport trunk encapsulation dot1q ??? ее я не снимал.
    

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "vlan между Cisco 3825 и Cisco 871"  +/
Сообщение от Сережа email on 27-Окт-11, 11:31 
Но тем не менее благодарю всех ответивших!!!

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру