The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"2 ISP +NAT +Route maps"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"2 ISP +NAT +Route maps"  +/
Сообщение от afma (ok) on 20-Ноя-11, 15:37 
Тема обсуждалась уже не один раз. Прочитал кучу топиков, саму идею работы понял.
Проблема в том что настроить это надо на удаленной площадке, и конфигурация не хочет работать. А именно могу пинговать  двух провайдеров, но если отключить одного провайдера (91.98.46.91), пакеты не хотят ходить к другому (192.168.1.1).

Вкратце про конфигурацию:
на рутер приходят пакеты от PIX. на Pix настроен НАТ так что все пакеты которые приходят на рутер имеют source ip 10.10.200.1.

cisco router подключены к двум провайдерам
Один это ADsl модем - 91.98.46.91
другой это WiMAX - 192.168.1.1

вот ниже конфиг с cisco

Current configuration : 2967 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R_INTERNET
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$v4aG$7tOIgrBLrDTLTOO7XDVqx/
!
aaa new-model
!
!
aaa authentication ppp default local
!
aaa session-id common
ip cef table event-log match 192.168.1.2 255.255.255.0
ip cef
!
!
!
!
no ip bootp server
no ip domain lookup
vpdn enable
!
vpdn-group 1
! Default L2TP VPDN group
! Default PPTP VPDN group
accept-dialin
  protocol any
  virtual-template 1
!
!
!
!
username lola privilege 15 secret 5 $1$wUp9$jxSdm6bpGVO6zSI.bSXg01
username rmvpn password 7 08701E1F5B4E5044
username mda password 7 045F1907082E42
username ls password 7 0356095D5757781F
username guest1 password 7 094B5B0C0A1146
username guest2 password 7 121E1012011F5E
username guest3 password 7 070834495D1D4A
username guest4 password 7 110E0C0004065F
username admin password 7 045A0F0B062F
username samad password 7 03175A06070B61
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip accounting output-packets
ip virtual-reassembly
speed auto
half-duplex
!
interface FastEthernet0/1
ip address 91.98.46.92 255.255.255.248
ip access-group 100 in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0/0
switchport access vlan 10
!
interface FastEthernet0/0/1
switchport access vlan 11
!
interface FastEthernet0/0/2
switchport access vlan 11
!
interface FastEthernet0/0/3
switchport access vlan 11
!
interface Virtual-Template1
ip unnumbered Vlan10
peer default ip address pool VPN
ppp authentication pap chap ms-chap ms-chap-v2
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.10.10.2 255.255.255.0
ip nat inside
no ip virtual-reassembly
ip policy route-map isp
!
interface Vlan11
ip address 100.100.100.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
ip policy route-map isp
!
ip local pool VPN 10.10.10.80 10.10.10.90
ip route 0.0.0.0 0.0.0.0 91.98.46.91
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.10.200.1 255.255.255.255 10.10.10.1
!
ip http server
no ip http secure-server
ip nat translation timeout 5
ip nat translation tcp-timeout 5
ip nat translation udp-timeout 5
ip nat translation icmp-timeout 5
ip nat inside source route-map iss2 interface FastEthernet0/1 overload
!
ip access-list standard VOICE
permit 100.100.100.0 0.0.0.255
ip access-list standard is2
permit 91.98.46.91
ip access-list standard isp1
permit 10.10.200.1
!
access-list 10 permit 91.98.46.91
access-list 10 permit 192.168.1.2
snmp-server community IMD RW
snmp-server community public RO
no cdp run
route-map iss2 permit 10
match ip next-hop 10
!
route-map isp permit 10
match ip address name isp1
set ip next-hop 91.98.46.91 192.168.1.1
!
!
!
no cdp run
route-map iss2 permit 10
match ip next-hop 10
!
route-map isp permit 10
match ip address name isp1
set ip next-hop 91.98.46.91 192.168.1.1
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
logging synchronous
!
scheduler allocate 20000 1000
end


Уже руки опускаются, хочется все потереть и настроить с нуля, но это не самый хороший вариант.
Если у кого то есть идеи, буду премного благодарен.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "2 ISP +NAT +Route maps"  +/
Сообщение от j_vw on 20-Ноя-11, 18:28 
> Тема обсуждалась уже не один раз. Прочитал кучу топиков, саму идею работы
> понял.

Похоже, не очень....

> Проблема в том что настроить это надо на удаленной площадке, и конфигурация
> не хочет работать. А именно могу пинговать  двух провайдеров, но
> если отключить одного провайдера (91.98.46.91), пакеты не хотят ходить к другому
> (192.168.1.1).

Ну, так вы сами просите:
route-map isp permit 10
set ip next-hop 91.98.46.91


> Если у кого то есть идеи, буду премного благодарен.

Ну, идеи то две:
1. НЕ ЭКСПЕРИМЕНТИРУЙТЕ на боевом оборудовании, тем более, удаленном. Поставьте себе GNS и откатайте конфиг.

2. Еще раз ВНИМАТЕЛЬНО прочитайте материал о подключении к нескольким ISP, например, этот:
http://anticisco.ru/pubs/DualISPRouter.pdf
А то мухи и котлеты в одной куче...

Удачи...


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "2 ISP +NAT +Route maps"  +/
Сообщение от afma (ok) on 20-Ноя-11, 18:39 
>[оверквотинг удален]
> set ip next-hop 91.98.46.91
>> Если у кого то есть идеи, буду премного благодарен.
> Ну, идеи то две:
> 1. НЕ ЭКСПЕРИМЕНТИРУЙТЕ на боевом оборудовании, тем более, удаленном. Поставьте себе GNS
> и откатайте конфиг.
> 2. Еще раз ВНИМАТЕЛЬНО прочитайте материал о подключении к нескольким ISP, например,
> этот:
> http://anticisco.ru/pubs/DualISPRouter.pdf
> А то мухи и котлеты в одной куче...
> Удачи...

Попытаюсь откатать на GNS.

Вопрос в следующем
Если в route map прописано 2 ip next hop, как будет выбираться решение о выборе маршрута?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "2 ISP +NAT +Route maps"  +/
Сообщение от dmitry (??) on 21-Ноя-11, 07:18 
>[оверквотинг удален]
>> и откатайте конфиг.
>> 2. Еще раз ВНИМАТЕЛЬНО прочитайте материал о подключении к нескольким ISP, например,
>> этот:
>> http://anticisco.ru/pubs/DualISPRouter.pdf
>> А то мухи и котлеты в одной куче...
>> Удачи...
> Попытаюсь откатать на GNS.
> Вопрос в следующем
> Если в route map прописано 2 ip next hop, как будет выбираться
> решение о выборе маршрута?

Будет использоваться первый адрес из списка, для которого связанный интерфейс в состоянии up

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "2 ISP +NAT +Route maps"  +/
Сообщение от afma (ok) on 21-Ноя-11, 08:40 
>[оверквотинг удален]
>>> этот:
>>> http://anticisco.ru/pubs/DualISPRouter.pdf
>>> А то мухи и котлеты в одной куче...
>>> Удачи...
>> Попытаюсь откатать на GNS.
>> Вопрос в следующем
>> Если в route map прописано 2 ip next hop, как будет выбираться
>> решение о выборе маршрута?
> Будет использоваться первый адрес из списка, для которого связанный интерфейс в состоянии
> up

Всем спасибо за советы.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру