The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"cisco ip unnambered + opt82 relay"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]
SWITCH+ROUTE+TSHOOT – курсы Cisco CCNP для администраторов больших сетей
"cisco ip unnambered + opt82 relay"  +/
Сообщение от tvv (??), 01-Сен-20, 16:39 
Всем здравия. Подскажите куда смотреть. есть коммутатор 4948 на нем поднят ip unnamberd vlan per user , встала задача добавлять opt82 для привязки к порту коммутатора. собрал стенд.
cisco на нем создал влан 4001
int vlan 4001
no shut
ip helper-address 172.x.x.x
в циску подключил коммутатор dlink-des 3200-28
на коммутаторе создаю влан управления и пользовательский влан 4001 аплинк порт транк mng vlan+abon vlan
порт пользователя 4001 untag , подключаю роутер в абон порт и на сервере с дхцп почему то даже запросов от роутера не вижу.
на коммутаторе с абонентом делаю вот такие настройки
DES-3200-28:admin#show dhcp_local_relay
Command: show dhcp_local_relay

DHCP/BOOTP Local Relay Status         : Enabled
DHCP/BOOTP Local Relay VID List       : 4001

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "cisco ip unnambered + opt82 relay"  +/
Сообщение от Andrey (??), 02-Сен-20, 08:51 
>[оверквотинг удален]
> mng vlan+abon vlan
> порт пользователя 4001 untag , подключаю роутер в абон порт и на
> сервере с дхцп почему то даже запросов от роутера не вижу.
> на коммутаторе с абонентом делаю вот такие настройки
> DES-3200-28:admin#show dhcp_local_relay
> Command: show dhcp_local_relay
> DHCP/BOOTP Local Relay Status        
> : Enabled
> DHCP/BOOTP Local Relay VID List       :
> 4001

Зачем вы смотрите параметры DHCP на D-Link если ip helper-address на Cisco? Зачем вам вообще на D-Link в этом случае dhcp relay?

Со статическими IP все работает?

Ответить | Правка | Наверх | Cообщить модератору

2. "cisco ip unnambered + opt82 relay"  +/
Сообщение от tvv (??), 02-Сен-20, 11:58 
>[оверквотинг удален]
>> на коммутаторе с абонентом делаю вот такие настройки
>> DES-3200-28:admin#show dhcp_local_relay
>> Command: show dhcp_local_relay
>> DHCP/BOOTP Local Relay Status
>> : Enabled
>> DHCP/BOOTP Local Relay VID List       :
>> 4001
> Зачем вы смотрите параметры DHCP на D-Link если ip helper-address на Cisco?
> Зачем вам вообще на D-Link в этом случае dhcp relay?
> Со статическими IP все работает?

да, что то глупость какую то делаю, если уже есть релей на циске. тогда я понимаю надо на циску на влан интерфейс 4001 навесить ip из подсети в которой находится dhcp сервер, так что ли?

Ответить | Правка | Наверх | Cообщить модератору

3. "cisco ip unnambered + opt82 relay"  +/
Сообщение от Andrey (??), 02-Сен-20, 17:45 
>[оверквотинг удален]
>>> : Enabled
>>> DHCP/BOOTP Local Relay VID List       :
>>> 4001
>> Зачем вы смотрите параметры DHCP на D-Link если ip helper-address на Cisco?
>> Зачем вам вообще на D-Link в этом случае dhcp relay?
>> Со статическими IP все работает?
> да, что то глупость какую то делаю, если уже есть релей на
> циске. тогда я понимаю надо на циску на влан интерфейс 4001
> навесить ip из подсети в которой находится dhcp сервер, так что
> ли?

Нет.
Примерно так
!
vlan 4001
!
vlan 4002
!
int vlan 4001
ip helper-address 172.x.x.x
ip unnumbered lo1          ! или просто ip address 192.168.0.1 255.255.255.0
!
int vlan 4002
ip address 172.x.x.1 255.255.255.0
!

Ответить | Правка | Наверх | Cообщить модератору

4. "cisco ip unnambered + opt82 relay"  +/
Сообщение от tvv (??), 04-Сен-20, 09:20 
>[оверквотинг удален]
> vlan 4002
> !
> int vlan 4001
>  ip helper-address 172.x.x.x
>  ip unnumbered lo1        
>  ! или просто ip address 192.168.0.1 255.255.255.0
> !
> int vlan 4002
>  ip address 172.x.x.1 255.255.255.0
> !

что то не выдается Ip
вот конфиг с циски и dhcp
cat /etc/dhcp/192.168.27.0.conf

    class "inv_sw_192.168.27.2" {
match if (
    binary-to-ascii(16, 8, ":", suffix(option agent.remote-id, 6)) = "e8:cc:18:ce:dc:0"
    and
    binary-to-ascii(10, 8, "", suffix(option agent.circuit-id, 1)) = "2"
);
    }
    pool {
range 192.168.27.2;
allow members of "inv_sw_192.168.27.2";
    }

cisco
interface Loopback5
ip address 192.168.27.1 255.255.255.0
no ip redirects
no ip unreachables
vlan 4001
interface Vlan4001
ip unnumbered Loopback5
ip helper-address 172.10.0.2
на dhcp сервер прилетает
dhcpd: DHCPDISCOVER from 64:ee:b7:14:0a:1e via 192.168.27.1: network: no free leases

Ответить | Правка | Наверх | Cообщить модератору

5. "cisco ip unnambered + opt82 relay"  +/
Сообщение от NetEye (ok), 08-Сен-20, 16:45 
> dhcpd: DHCPDISCOVER from 64:ee:b7:14:0a:1e via 192.168.27.1: network: no free leases

no free leases  как бы намекает , что адрес не выдаётся по причине отсутствия пула IP адресов.

Ответить | Правка | Наверх | Cообщить модератору

6. "cisco ip unnambered + opt82 relay"  +/
Сообщение от tvv (??), 08-Сен-20, 20:20 
>> dhcpd: DHCPDISCOVER from 64:ee:b7:14:0a:1e via 192.168.27.1: network: no free leases
> no free leases  как бы намекает , что адрес не выдаётся
> по причине отсутствия пула IP адресов.

dhcpd.conf

subnet 192.168.27.0 netmask 255.255.255.0 {
            option domain-name-servers 8.8.4.4, 8.8.8.8;
            option subnet-mask 255.255.255.0;
            option routers 192.168.27.1;
            max-lease-time 1296000;
            default-lease-time 604800;
            include "/etc/dhcp/192.168.27.0.conf";
        }

cat /etc/dhcp/192.168.27.0.conf

    class "inv_sw_192.168.27.2" {
match if (
    binary-to-ascii(16, 8, ":", suffix(option agent.remote-id, 6)) = "e8:cc:18:ce:dc:0"
    and
    binary-to-ascii(10, 8, "", suffix(option agent.circuit-id, 1)) = "2"
);
    }
    pool {
range 192.168.27.2;
allow members of "inv_sw_192.168.27.2";
    }
пул есть, подозреваю что опция неправильно как то долетает.
вот настройки dhcp_local_relay с dlink des 3200
Command: show dhcp_local_relay

DHCP/BOOTP Local Relay Status         : Enabled
DHCP/BOOTP Local Relay VID List       : 4001

DHCP Relay Agent Information Option 82 Circuit ID : Default
DHCP Relay Agent Information Option 82 Remote ID : E8-CC-18-CE-DC-00
теперь вообще запросы недолетают (

Ответить | Правка | Наверх | Cообщить модератору

7. "cisco ip unnambered + opt82 relay"  +/
Сообщение от Andrey (??), 09-Сен-20, 08:56 
>[оверквотинг удален]
> пул есть, подозреваю что опция неправильно как то долетает.
> вот настройки dhcp_local_relay с dlink des 3200
> Command: show dhcp_local_relay
> DHCP/BOOTP Local Relay Status        
> : Enabled
> DHCP/BOOTP Local Relay VID List       :
> 4001
> DHCP Relay Agent Information Option 82 Circuit ID : Default
> DHCP Relay Agent Information Option 82 Remote ID : E8-CC-18-CE-DC-00
> теперь вообще запросы недолетают (

Еще раз. Как только включаете DHCP-relay на своем D-Link, то D-Link начинает перехватывать и обрабатывать запросы DHCP и не передает их дальше. А роутером у вас работает не D-Link, а Сisco. Поэтому и не долетает. У вас на D-Link выше L2 вообще никакого включенного функционала не должно быть.

У вас DHCP сервер на каких интерфейсах работает? Сколько интерфейсов на сервере?

Вы сами говорите что "что опция неправильно как то долетает", почему не включаете дебаг на DHCP сервере, а пытаетесь смотерть где-то в другом месте? Вы мазохист?

Ответить | Правка | Наверх | Cообщить модератору

8. "cisco ip unnambered + opt82 relay"  +/
Сообщение от tvv (??), 09-Сен-20, 09:57 
>[оверквотинг удален]
>> теперь вообще запросы недолетают (
> Еще раз. Как только включаете DHCP-relay на своем D-Link, то D-Link начинает
> перехватывать и обрабатывать запросы DHCP и не передает их дальше. А
> роутером у вас работает не D-Link, а Сisco. Поэтому и не
> долетает. У вас на D-Link выше L2 вообще никакого включенного функционала
> не должно быть.
> У вас DHCP сервер на каких интерфейсах работает? Сколько интерфейсов на сервере?
> Вы сами говорите что "что опция неправильно как то долетает", почему не
> включаете дебаг на DHCP сервере, а пытаетесь смотерть где-то в другом
> месте? Вы мазохист?

Andrey, так я включаю же не dhcp relay , a dhcp snooping, только в длинках он обзывается dhcp_local_relay
схема подключения
dhcp server (172.10.0.2)--cisco 4948(172.10.0.1) на циске интерфейс на нижестоящую циску 10.255.255.5---cisco с ip unnambered 10.255.255.6 (тут настроено dhcp snooping, ip helper-address)--абон свич 172.18.2.25 (2 vlana, 1-управленияб 2й абон)

Ответить | Правка | Наверх | Cообщить модератору

9. "cisco ip unnambered + opt82 relay"  +/
Сообщение от NetEye (ok), 11-Сен-20, 08:47 
Измените на время -

pool {
max-lease-time 300;
range 192.168.27.2 192.168.27.5;
allow unknown-clients;
}

И проверьте получение  ip адреса клиентом. Так вы узнаете , если связность к DHCP серверу от клиента.

= я включаю же не dhcp relay , a dhcp snooping, только в длинках он обзывается dhcp_local_relay =
Смысл dhcp snooping -  направить запрос на получение IP адреса конкретному (легитимному) DHCP серверу

Вам точно нужен  dhcp snooping на D-link ?

Ответить | Правка | Наверх | Cообщить модератору

10. "cisco ip unnambered + opt82 relay"  +/
Сообщение от tvv (??), 11-Сен-20, 11:58 
>[оверквотинг удален]
> range 192.168.27.2 192.168.27.5;
> allow unknown-clients;
> }
> И проверьте получение  ip адреса клиентом. Так вы узнаете , если
> связность к DHCP серверу от клиента.
> = я включаю же не dhcp relay , a dhcp snooping, только
> в длинках он обзывается dhcp_local_relay =
> Смысл dhcp snooping -  направить запрос на получение IP адреса конкретному
> (легитимному) DHCP серверу
> Вам точно нужен  dhcp snooping на D-link ?

опишу схему подключения, а то можно подумать что dhcp сервер сбоку циски с unnambered включен.
dhcp(172.10.0.2)<-->cisco 4948(интерфейс в сторону dhcp 172.10.0.1, интерфейс в сторону циски с иннамберед 10.255.255.5)<---> циска 4948 ip unnambered (интерфейс прихода 10.255.255.6, ip unnam)<-->свич доступа. почему делаю не прямой релей? на сети стоит много хуавей quidway 2300 на них нет релеев, только снупинг. какие еще варианты можно попробовать?


Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру