The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"доступность двух ip адресов одновременно"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"доступность двух ip адресов одновременно"  +/
Сообщение от fisher email(ok) on 25-Янв-13, 17:52 
Привет всем!
Есть циско 2800 , два внешних адреса от разных провайдеров (pr1, pr2), настроено ip sla monitor. Все чудесно работает-при падении pr1, работаем через pr2.
Когда pr1 восстанавливается - дефолтный маршрут меняется через pк1 и уже работаем через него.  
Теперь вопрос:
Как мне  настроить роутер чтобы он при рабочем pr1 отвечал на пинги pr2, static route - не предлагать, запросы будут идти с любого внешнего адреса. Пробовал route-map

interface GigabitEthernet0/0  (интерфейс pr2)
ip address dhcp
ip nat outside
no ip virtual-reassembly
ip policy route-map FOR_PING_pr2
duplex auto
speed auto
no cdp enable
crypto map IPSEC


ip access-list extended PING_pr2
permit ip_router_pr2 any
                                                                                              

route-map FOR_PING_pr2 permit 3
match ip address PING_pr2
set ip next-hop to_gataway_for_pr2

но так  даже не матчаться пакеты

Шо подскажете
Спасибо!

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "доступность двух ip адресов одновременно"  +/
Сообщение от vladadm email(ok) on 25-Янв-13, 17:58 
> Как мне  настроить роутер чтобы он при рабочем pr1 отвечал на
> пинги pr2, static route - не предлагать, запросы будут идти с
> любого внешнего адреса. Пробовал route-map

http://www.opennet.ru/openforum/vsluhforumID6/485.html - вот моя тема, там рабочий конфиг по нужной тебе схеме, смотри использование local policy.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "доступность двух ip адресов одновременно"  +/
Сообщение от vladadm email(ok) on 25-Янв-13, 18:03 
ключевые строчки:

! Включаю локал-полиси, чтобы ответы с интерфейса второго провайдера уходили к нему же, а не по дефолту к первому
ip local policy route-map equal-access
!
access-list 2 permit 88.88.88.83
!
route-map equal-access permit 10
match ip address 2
set ip default next-hop 88.88.88.1
!
interface FastEthernet4
ip policy route-map equal-access

И у тебя всё будет убегать нормально, но не будет работать роутинг впн-клиентов на втором интерфейсе, если через второй интерфейс будут коннектится cisco vpn-клиенты :) См. низ моей темы.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "доступность двух ip адресов одновременно"  +/
Сообщение от fisher email(ok) on 25-Янв-13, 18:10 
>[оверквотинг удален]
> !
> route-map equal-access permit 10
> match ip address 2
> set ip default next-hop 88.88.88.1
> !
> interface FastEthernet4
> ip policy route-map equal-access
> И у тебя всё будет убегать нормально, но не будет работать роутинг
> впн-клиентов на втором интерфейсе, если через второй интерфейс будут коннектится cisco
> vpn-клиенты :) См. низ моей темы.

други спасибо за быстрый ответ :)
сейчас проверю


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "доступность двух ip адресов одновременно"  +/
Сообщение от Gromophon (ok) on 31-Янв-13, 09:03 
>[оверквотинг удален]
>  no cdp enable
>  crypto map IPSEC
> ip access-list extended PING_pr2
>  permit ip_router_pr2 any
> route-map FOR_PING_pr2 permit 3
>  match ip address PING_pr2
>  set ip next-hop to_gataway_for_pr2
> но так  даже не матчаться пакеты
> Шо подскажете
> Спасибо!

полноценное решение проблемы доступности и  организации сервисов 2 интерфейса достигается только через vrf

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "доступность двух ip адресов одновременно"  +/
Сообщение от fantom (ok) on 31-Янв-13, 12:11 
>[оверквотинг удален]
>> ip access-list extended PING_pr2
>>  permit ip_router_pr2 any
>> route-map FOR_PING_pr2 permit 3
>>  match ip address PING_pr2
>>  set ip next-hop to_gataway_for_pr2
>> но так  даже не матчаться пакеты
>> Шо подскажете
>> Спасибо!
> полноценное решение проблемы доступности и  организации сервисов 2 интерфейса достигается
> только через vrf

или vrf lite.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру