The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Обновление php до 7 версии на centos 7"
Вариант для распечатки  
Пред. тема | След. тема 
Форум WEB технологии (PHP)
Изначальное сообщение [ Отслеживать ]

"Обновление php до 7 версии на centos 7"  +/
Сообщение от commanderTomemail (ok), 02-Мрт-19, 10:27 
Добрый день.
Зачем-то поставил я на своём сервере древнюю версию пхп - 5.4.16.
Ну было это еще пару лет назад.
А тут обстоятельства и неработающие на этой версии плагины к WP требуют обновления.
В инете в статьях по этому делу пишут, например:

-----------------------
Дальнейшие действия будут зависеть от того, что вы используете на вашем веб сервере. У меня установлен nginx + php-fpm примерно по приведенной статье. Мне необходимо удалить пакеты:

# yum remove php-fpm php-cli php-common

Удаление этих пакетов тянет за собой удаление всех зависимостей. Запишите их куда-нибудь, чтобы потом установить новые версии этих пакетов. В качестве пакета к удалению будет в том числе и phpmyadmin. Впоследствии его можно будет установить только вручную из исходников. Если вы используете apache, то необходимо удалить mod_php, а затем заново установить mod_php70u
------------------

Как узнать, какие зависимости у меня стоят, чтобы их потом обновлять?
Я когда ставил, делал просто

yum -y install httpd
yum -y install php

и всё.
Или достаточно # yum remove php?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Обновление php до 7 версии на centos 7"  +/
Сообщение от stalker37email (ok), 02-Мрт-19, 12:57 
httpd точно не надо удалять
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Обновление php до 7 версии на centos 7"  +/
Сообщение от Аноним (2), 02-Мрт-19, 13:03 
> Мне необходимо удалить пакеты:

Хм. А yum update и update-to - не?

> # yum remove php-fpm php-cli php-common
> Удаление этих пакетов тянет за собой удаление всех зависимостей. Запишите их куда-нибудь,
> чтобы потом установить новые версии этих пакетов. В качестве пакета к
> удалению будет в том числе и phpmyadmin. Впоследствии его можно будет
> установить только вручную из исходников. Если вы используете apache, то необходимо
> удалить mod_php, а затем заново установить mod_php70u
> ------------------
> Как узнать, какие зависимости у меня стоят, чтобы их потом обновлять?

Ну кагбэ насколько я знаю, при удалении юм вывалит список того, что будет покоцано... дальше ctrl+c/ctrl+v...

> Я когда ставил, делал просто
> Или достаточно # yum remove php?

man yum для начала.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Обновление php до 7 версии на centos 7"  +/
Сообщение от Pofigist (?), 02-Мрт-19, 16:56 
так просто не получится - придется для начала подключить remi repo - https://blog.remirepo.net/pages/Config-en
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Обновление php до 7 версии на centos 7"  +/
Сообщение от vg (??), 11-Мрт-19, 10:55 
> так просто не получится - придется для начала подключить remi repo -
> https://blog.remirepo.net/pages/Config-en

Есть SCL - https://www.softwarecollections.org/en/scls/rhscl/rh-php70/

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2019 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor