The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

В GNOME Shell integration for Chrome добавлена поддержка Firefox

26.12.2016 19:08

Более года назад проект Mozilla объявил о решении прекратить поддержку плагинов с интерфейсом NPAPI в Firefox. На текущий момент в ночных сборках Firefox прекращена поддержка NPAPI-плагинов кроме Flash, а версия Firefox 52 станет первой версией браузера, в которой будет запрещён запуск NPAPI плагина GNOME Shell integration, обеспечивающего интеграцию Firefox с GNOME Shell, необходимую для установки расширений из каталога extensions.gnome.org.

Для пользователей расширений GNOME Shell подготовлена замена NPAPI плагина - GNOME Shell integration for Chrome (chrome-gnome-shell). Не стоит думать, что слова "for Chrome" в названии проекта означают поддержку только браузера Google Chrome - chrome-gnome-shell поддерживает все популярные браузеры - Google Chrome/Chromium, Vivaldi, Opera и Firefox. На самом деле, "for Chrome" означает "для браузеров, поддерживающих API расширений Chrome", а в последних версиях Firefox добавлена поддержка собственной реализации API расширений Chrome - Webextensions - достаточной для работы GNOME Shell integration for Chrome.

На текущий момент поддержка Firefox доступна только в master ветке git-репозитория проекта, однако первая версия chrome-gnome-shell с поддержкой Firefox будет опубликована 4 января 2017 года под номером 8. В отличие от плагина NPAPI chrome-gnome-shell состоит из 2 частей: расширения для браузера и приложения, написанного на Python - коннектора.

Расширение для Firefox может быть установлено с сайта addons.mozilla.org. Что касается коннектора – он должен быть установлен отдельно, предпочтительно с помощью менеджера пакетов дистрибутива. Готовые сборки коннектора подготовлены для Arch, Debian, Fedora, Gentoo, Ubuntu. Пакеты с поддержкой Firefox будут доступны вскоре после 4 января 2017 года.

  1. Главная ссылка к новости (https://blogs.gnome.org/ne0sig...)
Автор новости: nE0sIghT
Тип: К сведению
Короткая ссылка: https://opennet.ru/45768-gnome
Ключевые слова: gnome, firefox
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (44) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 20:05, 26/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +29 +/
    Название нужно однозначно менять, GNOME Shell integration for Chrome для Firefox это взрыв мозга. Пока не поздно, переименуйте в что-то более простое для восприятия. Например  GNOME Shell Integration Universal|Multiweb|Plus.
    Или почему бы просто не обозвать GNOME Shell integration 2.0?
     
     
  • 2.3, XXXasd (ok), 20:38, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • +15 +/
    GNOME Shell Integration Professional
     
     
  • 3.4, h31 (ok), 20:43, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • +10 +/
    GNOME Shell Integration Ultimate. Сборка 5 в 1.
     
     
  • 4.13, Аноним (-), 23:57, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    GNOME Shell Integration Ultimate. Сборка 5 в 1. В Вегасе. Начало.
     
  • 3.5, Аноним (-), 20:46, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Advanced Plus
     
  • 2.7, Аноним (-), 21:04, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • +27 +/
    GNOME Shell Zver Edition
     
     
  • 3.16, Аноним (-), 06:40, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Это оно!
     
  • 3.45, alx (??), 13:28, 28/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Popov Shell
     
  • 2.34, Аноним (-), 16:41, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    тебе давно пора понять что фокс плавно превращается в хром. и плохо если ты не поймёшь даже сейчас.
     
     
  • 3.46, Аноним (-), 13:58, 28/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Даже заминусовав не изменишь правды.
     
  • 2.38, trololololo (?), 20:59, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    GNOME Shell epic creator ground zero ultra mega plus for web integration  version two point zero point zero master edition service pack one
     

  • 1.9, Аноним (-), 21:56, 26/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Куда мир катится? Свет клином на Chrome сошелся??
     
     
  • 2.29, Аноним (-), 13:48, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Самый передовой браузер как-никак. ФФ играет чисто догоняющую роль.
     
     
  • 3.31, антончик (?), 14:52, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    "Самый передовой" - это который для старта требует рутовый стики бит (и все прилегающие форки)? Типа настолько "передовой", что стоит впереди всех остальных программ по риску получения дополнительного Pro-версии зонда на уровне ядра.
     
     
  • 4.32, Аноним (-), 15:14, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Привет, коллега! Посоветуй, как мыть голову, не снимая фольгированную шапочку?
     
  • 4.33, nE0sIghT (ok), 15:26, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > для старта требует рутовый стики бит (и все прилегающие форки)?

    Это требуется только со старыми ядрами.
    См. https://chromium.googlesource.com/chromium/src/+/master/docs/linux_sandboxing.

     
  • 3.44, Аноним (-), 07:25, 28/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Скорее самый пропиаренный.
     

  • 1.10, Аноним (-), 22:04, 26/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +9 +/
    А зачем в плагины то пихать? Лучше в СистемД добавить как опцию и готово.
     
     
  • 2.12, Аноним (-), 23:57, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Глупостей-то не пишите. SystemD пока не интегрирован с графической подсистемой, так что добавить "опцию" не получится. Придётся мучаться с этим костылём, пока в SystemD Wayland не перетащат и не удалят из браузеров поддержку устаревшего X11 :(
     
     
  • 3.39, jOKer (ok), 22:47, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >SystemD пока не интегрирован с графической подсистемой
    >пока

    Вектор развития понятен. Майкрософт вам рукоплещет, не сомневайтесь.

     

  • 1.11, Аноним (-), 23:54, 26/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    логичнее было бы сделать десктопную утилиту для поиска и установки плагинов. раз уж у них все равно централизованное хранилище (сайт)
     
  • 1.15, paulus (ok), 04:50, 27/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Насколько смотрю, это в фф добавили возможность, а не в гшелл ;)
     
  • 1.17, Аноним (-), 08:47, 27/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > Не стоит думать, что слова "for Chrome" в названии проекта означают поддержку только браузера Google Chrome

    Звучит как "Не стоит думать, что приставка Win- в слове WinRAR означает поддержку только Windows".

     
  • 1.18, Онаним (?), 08:47, 27/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А как Java-апплеты-то запускать теперь? У моего государства сайт для отчётности в пенсионный фонд Java-плагина требует, а у многих других людей его требуют ещё и банк-клиенты...
     
     
  • 2.19, Аноним (-), 09:05, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Не обновлять браузер. И ждать пока целевые сайты перешагнут через столетие технологий.
     
  • 2.20, proud_anon (?), 09:08, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    веб-подмастерьям которые такие сайты лепят, надо законодательно запретить пользоваться браузерами отличными от netsurf и links. Потому что если у них или заказчиков врожденный ограниченный кругозор отягощенный синдромом дауна, то пусть они в тайге кедровые орешки заготавливают со своими влажными мечтами о js-OS.
     
  • 2.21, abi (?), 09:09, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Вам повезло ещё. У меня личный кабинет в ВТБ24 требует ActiveX, причём 32-разрядного
     
     
  • 3.27, botman (ok), 13:36, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    безопасненько так
     
  • 2.22, X2asd (ok), 09:11, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > а у многих других людей его требуют ещё и банк-клиенты

    Банков много, выбирай любой по вкусу :-)

     
     
  • 3.23, Куяврег (?), 11:11, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    банков-то как конь потрудился, а вот софт клиент-банк раз-два и обчёлся. и тут выбираешь: либо ослик IE-IE с активнымХ, либо жаба. отдельная песня - криптотокен. тоже очень всё интересно, банкам выдать криптотокен "с поддержкой линукса" без поддержки линукса - как моргнуть. может сейчас конечно получше, но лет пять назад я знатно помудохался.
     
     
  • 4.26, Michael Shigorin (ok), 13:18, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    > может сейчас конечно получше

    На всякий: http://altlinux.org/ЭЦП

     
     
  • 5.30, Sluggard (ok), 14:36, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > «обычному пользователю»™

    Что у вас там за клоунада в статье?

    > всем известный html-браузер Firefox

    Что за «html-браузер»?

     
     
  • 6.54, Аноним (-), 22:12, 28/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А вы таки ожидали другого? Это же Мишенька в конце-то концов...
     
     
  • 7.60, Michael Shigorin (ok), 11:36, 30/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > А вы таки ожидали другого? Это же Мишенька в конце-то концов...

    Глупый, это писал человек, до которого мне по разобранной в статье теме примерно как до Луны (а к его оформлению обычно претензиев не имею).

     
  • 6.59, Michael Shigorin (ok), 11:35, 30/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> «обычному пользователю»™
    > Что у вас там за клоунада в статье?
    >> всем известный html-браузер Firefox
    > Что за «html-браузер»?

    Там первой строчкой статьи указан контакт -- переслал сообщение, но вообще резонно багрепорты сразу автору и слать.

     
  • 2.35, Аноним (-), 16:42, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Найти директора и поставить ему динамит в задницу. Чтоб поторопился обновить веб страницу.
     

  • 1.25, Аноним (-), 12:58, 27/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Ну-ну. Хорошо что у меня в бекапах есть 11я опера, в которой я могу запускать silverlight. ФФ уже совсем не торт.
     
  • 1.28, Lain_13 (ok), 13:46, 27/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > поддерживает все популярные браузеры - Google Chrome/Chromium, Vivaldi, Opera и Firefox

    Т.е. Хром/Хром, Хром, Хром и Фокс. Разнообразно-то как.

     
     
  • 2.36, Аноним (-), 19:36, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Идите в попу. Убрали Presto, стало только лучше. Еще и IE бы перешел на webkit. И наступит рай для веб-разработчиков.

    За ваш браузерный плюрализм потом отдуваться веб-разработчикам.

     
     
  • 3.37, proud_anon (?), 20:30, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Идите в попу. Убрали Presto, стало только лучше. Еще и IE бы
    > перешел на webkit. И наступит рай для веб-разработчиков.
    > За ваш браузерный плюрализм потом отдуваться веб-разработчикам.

    Мы туда не пойдем, там ваше место - цветным евангелистам свистоперделок... ой! пусть снежинки на моем сайте падают, ведь скоро новый годик!  тьфу...

     
  • 3.40, Lain_13 (ok), 23:15, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Король умер да здравствует король? Тут ведь какое дело. Если убрать всех конкурентов у Хрома, то получится новый IE6. А потом лет через 10 все будут материться на него точно так же, как на IE6. Presto, конечно, был не сахар, но чем больше разных движков, тем меньше шансов, что сайты будут делать под глюки одного конкретного. И так уже имеем беду в мобильной сфере с префиксом -webkit- в CSS. Благодаря Хрому. -_-

    Так что это будет не рай, хоть по-началу им и покажется. Это будет медленное загнивание.

    Но вообще я пристебался к тому, что в списке перечислили три разные морды одного и того же Хромиума. Можно было с таким же успехом ещё Яндекс-браузер указать и ещё какую-нибудь муть, которая отличается только фронтендом.

     
     
  • 4.41, nE0sIghT (ok), 23:49, 27/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Но вообще я пристебался к тому, что в списке перечислили три разные морды одного и того же Хромиума

    Вы не поверите, но Extensions API Opera отличается в мелочах от API Chrome.
    Настолько отличается, что требуются лишние строки кода, чтобы это все работало везде,  отдельный процесс публикации в отдельном Store и отдельный процесс inline установки на extensions.gnome.org (в планах).

    Vivaldi - да, идентичен Chromium в этой части. Но расскажите пользователям Vivaldi, что это одно и то же с Chromium.

     
     
  • 5.42, Lain_13 (ok), 02:31, 28/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Настолько отличается, что требуются лишние строки кода, чтобы это все работало везде

    Они и это сломали? Талантливые ребята.

    > Но расскажите пользователям Vivaldi, что это одно и то же с Chromium.

    Вообще у меня довольно положительное отношение к Vivaldi, хоть я им и не пользуюсь. Это именно то, чем должна была стать Опера, отказавшись от Presto, но не стала. И это именно то, чем мог бы быть Firefox, будь он создан пару лет назад. Но это всё не отменять того факта, что это Хромиум с альтернативной мордой и не гугловскими сервисами.

     

  • 1.61, Аноним (-), 12:37, 30/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    GNOME Shell integration for web browser
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру