The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

08.08.2018 18:01  Выпуск видеодрайвера AMD Radeon Pro 18.Q3

Компания AMD опубликовала выпуск набора драйверов AMD Radeon Pro 18.Q3 для Linux, основанного на свободном модуле ядра AMDGPU, развиваемого в рамках инициативы по унификации графического стека AMD для проприетарных и открытых видеодрайверов. В рамках AMD Radeon Pro в одном наборе интегрированы открытый и проприетарный стеки драйверов. Драйверы amdgpu-pro и amdgpu-all-open (vulkan-драйвер RADV и OpenGL-драйвер RadeonSE, основанные на коде из Mesa) теперь предлагаются в одном пакете и пользователь на своё усмотрение может выбрать открытые или закрытые драйверы.

Драйвер поддерживает API OpenGL 4.5, GLX 1.4, OpenCL 1.2, Vulkan 1.1 и VDPAU/VAAPI, включает базовые средства для управления экраном и питанием, поддерживает интерфейсы KMS (Kernel Mode Setting) и ADF (Atomic Display Framework), использует совместимый с лицензией GPL модуль ядра, поддерживает возможности FirePro (управление EDID и 30-разрядная цветность), Radeon FreeSync и DirectGMA для OpenGL. В новом выпуске добавлена поддержка Ubuntu 18.04 LTS и RHEL 7.5, а также исправлены накопившиеся ошибки.

  1. Главная ссылка к новости (https://support.amd.com/en-us/...)
  2. OpenNews: Выпуск набора видеодрайверов AMD Radeon 18.20
  3. OpenNews: Выпуск видеодрайвера AMD Radeon Pro 18.Q2
  4. OpenNews: Компания AMD открыла код драйвера с реализацией API Vulkan
  5. OpenNews: Выпуск видеодрайвера AMD Radeon Pro Adrenalin Edition 17.50
  6. OpenNews: Доступен драйвер AMDGPU-PRO 17.40
Лицензия: CC-BY
Тип: Программы
Ключевые слова: amd, firepro, driver
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Ajax/Линейный | Раскрыть все сообщения | RSS
 
  • 1.1, Аноним (1), 18:05, 08/08/2018 [ответить] [показать ветку] [···]    [к модератору]
  • –1 +/
    Если в игрушки под Wine собираетесь играть, НИ В КОЕМ СЛУЧАЕ НЕ СТАВИТЬ!!!
     
     
  • 2.2, Аноним (2), 18:16, 08/08/2018 [^] [ответить]    [к модератору]
  • +/
    А что тогда ставить?
     
     
  • 3.3, Аноним (3), 18:25, 08/08/2018 [^] [ответить]    [к модератору]
  • +/
    Не знаю как насчет вайна, но я играю в стиме в нативный l4d2 на xf86-video-amdgpu -- все отлично.
     
     
  • 4.14, asdasd (?), 21:11, 08/08/2018 [^] [ответить]    [к модератору]
  • –3 +/
    А ничего что новость не про xf86-video-amdgpu?
     
     
  • 5.27, Аноним (27), 00:50, 09/08/2018 [^] [ответить]    [к модератору]
  • +/
    Спросили что ставить для игор, я ответил.
     
  • 4.26, Аноним (26), 00:15, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Наступил тот самый момент, когда открытые драйвера стали намного лучше проприетарных.
     
  • 2.6, Аноним (6), 18:40, 08/08/2018 [^] [ответить]    [к модератору]  
  • +1 +/
    Если wine-nine, а игра DirectX 9, то согласен. А если игра DX10 или 11, то не согласен. Впрочем, лично у меня DX10 и выше игр почти нет.
     
     
  • 3.11, Аноним (11), 20:43, 08/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Например GTAV на dxvk на про версии зависает вместе с системой, вам точно это надо?)
     
     
  • 4.20, Аноним (6), 22:35, 08/08/2018 [^] [ответить]    [к модератору]  
  • +/
    На каком драйвере?
     
     
  • 5.35, Аноним (35), 04:58, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    > На каком драйвере?
    > на про версии
     
     
  • 6.47, Аноним (47), 14:27, 09/08/2018 [^] [ответить]     [к модератору]  
  • +/
    В 2008 или в 2009 в годы актуальности Ubuntu 8 10, я снял видео, как на Катал... весь текст скрыт [показать]
     
  • 3.45, inferrna (ok), 11:28, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    внезапно, если ставить только ядерную часть, то он норм работает с открытой местой и nine.
     
  • 2.7, Аноним (7), 19:18, 08/08/2018 [^] [ответить]    [к модератору]  
  • +/
    а почему? И что ставить тогда?
     
     
  • 3.10, Джон Ленин (?), 20:06, 08/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Есть встроенный AMDGPU, не PRO.

    На нём работает Gallium Nine и DXVK.

    PRO нужен тем, кто использует OpenCL

     
     
  • 4.50, svsd_val (ok), 16:39, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    от про нужна только OpenCL остальное и так работает :)
     
  • 4.63, nexfwall (ok), 10:46, 15/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Мне интересно, можно ли как-нибудь и рыбку съесть, и сами знаете на что сесть?

    Тоесть, завести OpenCL, но при этом пользоваться свободным драйвером для графики?

     
  • 2.25, RotarenegeD (?), 23:08, 08/08/2018 [^] [ответить]     [к модератору]  
  • –3 +/
    кто на карточках для рабочих станций в игрушки то играет это же не amdgpu-pro д... весь текст скрыт [показать]
     
  • 2.32, axredneck (?), 03:57, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    И не только под Wine
     
  • 1.4, vz_2 (?), 18:34, 08/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    открытого на многое хватает
     
  • 1.5, Аноним (5), 18:39, 08/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +3 +/
    AMD вы самые лучшие.
     
     
  • 2.15, Аноним (15), 21:12, 08/08/2018 [^] [ответить]     [к модератору]  
  • +5 +/
    да как завести Radeon HD 7670M на 18 04 чтобы OpenCL было работающим А не C... весь текст скрыт [показать]
     
     
  • 3.16, Аноним (16), 21:19, 08/08/2018 [^] [ответить]    [к модератору]  
  • –4 +/
    https://community.amd.com/community/support-forums
     
  • 3.17, Аноним (17), 21:28, 08/08/2018 [^] [ответить]     [к модератору]  
  • +2 +/
    HD 7670M судя по инфе это Terascale 2, старая VLIW архитекрутра, помоему их подд... весь текст скрыт [показать]
     
     
  • 4.18, Аноним (17), 21:49, 08/08/2018 [^] [ответить]    [к модератору]  
  • +1 +/
    Чтоб не быть голословным, дисскусия на тему VLIW vs GCN в контексте OpenCL https://community.amd.com/thread/168029
     
  • 4.24, Аноним (6), 22:46, 08/08/2018 [^] [ответить]     [к модератору]  
  • +1 +/
    Ну не знаю У меня Radeon 5850 выдавал 412 MH s на предельном разгоне - ни одна ... весь текст скрыт [показать]
     
  • 4.38, Sluggard (ok), 08:07, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    > HD 7670M судя по инфе это Terascale 2, старая VLIW архитекрутра

    Да, это VLIW5.

     
  • 3.33, axredneck (?), 03:59, 09/08/2018 [^] [ответить]    [к модератору]  
  • –2 +/
    В том числе из-за этого я и свалил на Нвидию.
     
     
  • 4.37, Аноним (37), 06:46, 09/08/2018 [^] [ответить]    [к модератору]  
  • +7 +/
    У которой карты старше 5 лет идут в утиль (и нет открытых драйверов)?
     
     
  • 5.42, Аноним (42), 10:11, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    И у которых просто великолепные драйвера Optimus с не менее разрывающим экран кадрами.
    По мне так уж лучше пусть вообще не работает, чем то что было у меня на ноуте с их проприетарщиной.
     
     
  • 6.46, Аноним (47), 13:17, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    На X-Server 1.19 и выше, можно включить PRIME Syncronization. Нет тиринга даже с выключенным композитным менеджером.
     
     
  • 7.54, Аноним (54), 20:59, 09/08/2018 [^] [ответить]    [к модератору]  
  • –1 +/
    А ональные пляски с примусом-то до сих пор остались. А разгадка одна: гибридная графика — убогий выкидыш ущербных лишенцев.
     
     
  • 8.59, Аноним (47), 13:12, 10/08/2018 [^] [ответить]     [к модератору]  
  • +1 +/
    Зачем Примус NVIDIA PRIME Никакого траха, только батарея ноута долго не держит... весь текст скрыт [показать]
     
     
  • 9.64, nexfwall (ok), 10:54, 15/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Они на offloading забили член. Реализовали Optimus на свободном стэке на три четверти (буквально последний рывок остался) и бросили. Типа им не до нас, холопов. Юзайте кривой костыль bumblebee. Сука.

    Я настолько ох@$л с такой наглости, что сплавил ноут с невидией родственнику и купил с дискреткой RX560. Теперь кайфую и смотрю на невидиепроблемы свысока.

     
  • 3.58, nonemo (?), 12:39, 10/08/2018 [^] [ответить]     [к модератору]  
  • +2 +/
    Если ставить OpenCL на Terascale, то более менее производительный вариант только... весь текст скрыт [показать]
     
     
  • 4.60, Аноним (47), 13:15, 10/08/2018 [^] [ответить]     [к модератору]  
  • +/
    А я пользуюсь AMD APP SDK, потому что на странице скачивания дата релиза версии ... весь текст скрыт [показать]
     
  • 4.61, Аноним (47), 13:16, 10/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Вот моя инструкция: http://opennet.ru/openforum/vsluhforumID3/114290.html#67
     
  • 1.8, Анонн (?), 19:40, 08/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Оно дружит с address sanetizer (ASAN)? А то в предыдущих версиях были ошибки.
     
  • 1.9, Аноним (9), 20:02, 08/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +1 +/
    Какой смысл писать параллельно одни и теже жрова, почему разработчики не будут писать в open source, а создадут другую копию? Телеметрия?
     
     
  • 2.12, AnonPlus (?), 20:53, 08/08/2018 [^] [ответить]    [к модератору]  
  • +2 +/
    Поехали вы уже со своей телеметрией. Патенты и сторонний код.
     
  • 2.23, Аноним (6), 22:44, 08/08/2018 [^] [ответить]     [к модератору]  
  • +1 +/
    Почитай вот эту новость https www opennet ru opennews art shtml num 42078 А т... весь текст скрыт [показать]
     
  • 2.34, axredneck (?), 04:03, 09/08/2018 [^] [ответить]    [к модератору]  
  • +2 +/
    Закрытые они пишут в первую очередь под винду (Mesa туда еще не портировали). Но дело к тому и идет, чтобы под их линукс дрова были целиком открытые.
     
  • 1.13, Аноним (17), 20:58, 08/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    А какая версия mesa положена в основу amdgpu all-open из Radeon Pro 18.Q3 ?
     
  • 1.19, getfr (?), 22:01, 08/08/2018 [ответить] [показать ветку] [···]     [к модератору]  
  • –3 +/
    R9 270 поддержки по-прежнему нет АМД Горите в аду Никогда у вас ни за что н... весь текст скрыт [показать]
     
     
  • 2.21, Аноним (6), 22:37, 08/08/2018 [^] [ответить]     [к модератору]  
  • +1 +/
    У меня две R9 290 Tri-X, они прекрасно работают в Ubuntu LTS-версий В 14 04 сра... весь текст скрыт [показать]
     
  • 2.22, Аноним (22), 22:39, 08/08/2018 [^] [ответить]    [к модератору]  
  • +/
    R9 270 с древней архитектура, ставь radeon
     
  • 2.28, Stax (ok), 01:37, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    >  R9 270 поддержки по-прежнему нет.

    Вы что, издеваетесь - требовать от закрытых дров поддержку карт 6-ми летней давности (на архитектуре более чем 7-ми летней давности)? (да, Radeon 7950/7970 вышел в 2011 году, его упрощение 7870 - в начале 2012, а R9 270 это переименованый 7870 с чуть другими частотами)

    Такие старые карты даже в amdgpu официально не поддерживаются, только в старом radeon драйвере.

     
  • 2.29, getfr (?), 01:42, 09/08/2018 [^] [ответить]    [к модератору]  
  • +2 +/
    а ниче, что 7870 поддерживается и R7 260?
     
  • 2.30, Аноним (30), 01:43, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Когда же mali для десктопов выпустят.
     
  • 2.31, corvuscor (ok), 01:45, 09/08/2018 [^] [ответить]    [к модератору]  
  • +2 +/
    >R9 270 поддержки по-прежнему нет.

    Что значит нет?

    Уже год почти на этой карте amdgpu работает не хуже (а местами и получше), чем radeon.
    Единственное что - поддержку UVD в апстрим ядра пока не завезли.

     
  • 2.36, чуваг (?), 04:59, 09/08/2018 [^] [ответить]    [к модератору]  
  • +1 +/
    У Radeon R9 270 начиная с ядра 4.10 была поддержка amdgpu у Ubuntu(но надо было блэклистить radeon), с 4.13 просто загружаем ядро с параметром radeon.si_support=0 amdgpu.si_support=1

    Но ты так не делай, продолжай страдать дальше.

     
     
  • 3.43, Аноним (6), 10:14, 09/08/2018 [^] [ответить]     [к модератору]  
  • +/
    Вот это меня и бесит В начале 10-х, открытый драйвер прекрасно работал - надо б... весь текст скрыт [показать]
     
     
  • 4.48, J.L. (?), 14:56, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    > Вот это меня и бесит. В начале 10-х, открытый драйвер прекрасно работал
    > - надо было только добавить параметры при запуске игры. В лучшем
    > случае два, в худшем - десять.
    > И нигде их не прочитаешь. В сусе хоть в Release Notes такое
    > писали, а в убунте?

    дефолтный драйвер radeon (точнее вроде как radeon_si, не помню точно), прописывать параметры ядру надо только если вы хотите чтоб этот чип запустился на модном и молодёжном amdgpu

     
     
  • 5.49, Аноним (17), 16:23, 09/08/2018 [^] [ответить]     [к модератору]  
  • +1 +/
    Он нужен для RADV, еще были редкие экземпляры карт gcn 1 0 у которых были пробле... весь текст скрыт [показать]
     
  • 5.51, Аноним (6), 18:28, 09/08/2018 [^] [ответить]     [к модератору]  
  • +/
    Не, я не про параметры ядра Я про export HYBERZ 1 export ЕЩЁ_ЧТО_НИБУДЬ true e... весь текст скрыт [показать]
     
  • 3.57, question (??), 08:57, 10/08/2018 [^] [ответить]    [к модератору]  
  • +/
    У кого r5 230 caicos (southern islands) вообще заводится с amdgpu? у меня по ходу от только с открытым radeon работает.
     
  • 2.39, Sluggard (ok), 08:11, 09/08/2018 [^] [ответить]    [к модератору]  
  • +3 +/
    > АМД теперь - жадные мрази и лохотронщики

    Точно! От жадности они спеки открывали в своё время, сотрудники их работали над открытыми дровами вместе с сообществом, а теперь вообще AMD юзает открытые дрова запилиные ими же в ядро. Капец, жмоты, ага.

     
  • 1.40, OS2 (?), 08:58, 09/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    ой ли лучшие? Radeon R7 M265 поддержки по прежнему нет, точнее то что есть и их инструкция по установке как минимум трындежь и провокация.
     
     
  • 2.41, Tihon (??), 09:14, 09/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Radeon R7 M370 - только на словах. На деле - "CGN1.0 будем делать папізже".
    А amdgpu - годно. Завел rx580 - без нареканий (если не считать оными сборку ещё сырого ROCM)
     
  • 1.52, runoverheads (ok), 19:18, 09/08/2018 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    у меня после обновы на ядро 4.17 с опцией DRM_AMDGPU_CIK (amdgpu.cik_support=1) на rx460 на разрешение 2560x1440 лагать перестало в играх
     
     
  • 2.56, чуваг (?), 05:27, 10/08/2018 [^] [ответить]    [к модератору]  
  • +/
    Для RX460 этот параметр бесполезен, она на архитектуре gcn 1.3, изначально работает с модулем amdgpu.
    amdgpu.cik_support=1 для карт на архитектуре gcn 1.2 (7790,260X, 280 и подобных).
     
     
  • 3.62, runoverheads (ok), 01:01, 11/08/2018 [^] [ответить]    [к модератору]  
  • +/
    значит дело не вней.
    до этого стояли ядра 4.14 и ниже и лагало.
    в 4.17 ещё появились опции
    CONFIG_DRM_AMD_DC=y
    CONFIG_DRM_AMD_DC_PRE_VEGA=y
    наверное дело в них
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2018 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor