The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз дистрибутива Red Hat Enterprise Linux 8

07.05.2019 19:47

Компания Red Hat опубликовала релиз дистрибутива Red Hat Enterprise Linux 8. Установочные сборки подготовлены для архитектур x86_64, s390x (IBM System z), ppc64le и Aarch64, но доступны для загрузки только зарегистрированным пользователям Red Hat Customer Portal. Исходные тексты rpm-пакетов Red Hat Enterprise Linux 8 распространяются через Git-репозиторий CentOS. Дистрибутив будет поддерживаться как минимум до 2029 года.

В качестве основы для построения новой ветки использованы технологии, входящие в состав Fedora 28. Новая ветка примечательна переходом по умолчанию на Wayland, заменой iptables на nftables, обновлением базовых компонентов (ядро 4.18, GCC 8), применением пакетного менеджера DNF вместо YUM, использованием модульного репозитория, прекращением поддержки KDE и Btrfs.

Ключевые изменения:

  • Переход на пакетный менеджер DNF с предоставлением прослойки для совместимости с Yum на уровне опций командной строки. По сравнению с Yum, DNF обладает заметно более высокой скоростью работы и низким потреблением памяти, более качественно управляет зависимостями и поддерживает группировку пакетов в модули;
  • Разделение на базовый репозиторий BaseOS и модульный репозиторий AppStream. В BaseOS распространяется минимальный необходимый для работы системы набор пакетов, всё остальное перенесено в репозиторий AppStream. AppStream можно использовать в двух вариантах: как классический RPM-репозиторий и как репозиторий в модульном формате.

    Модульный репозиторий предлагает сгруппированные в модули наборы rpm-пакетов, поддержка которых осуществляется независимо от релизов дистрибутива. Модули можно использовать для установки альтернативных версий определённого приложения (например, можно установить PostgreSQL 9.6 или PostgreSQL 10). Модульная организация позволяет пользователю переходить на новые значительные выпуски приложения не дожидаясь нового релиза дистрибутива и оставаться на старых, но ещё поддерживаемых, версиях после обновления дистрибутива. Модули включают базовое приложение и необходимые для его работы библиотеки (в качестве зависимости могут использоваться другие модули);

  • В качестве рабочего стола по умолчанию предложен GNOME 3.28 с применением по умолчанию дисплейного сервера на базе Wayland. Окружение на базе X.Org Server доступно в качестве опции. Из состава исключены пакеты с рабочим столом KDE, оставлена только поддержка GNOME;
  • Пакет с ядром Linux построен на базе выпуска 4.18. В качестве компилятора по умолчанию задействован GCC 8.2. Системная библиотека Glibc обновлена до выпуска 2.28.
  • В качестве реализации языка программирования Python по умолчанию задействован Python 3.6. Предоставлена ограниченная поддержка Python 2.7. В базовую поставку Python не входит, его нужно устанавливать дополнительно. Обновлены версии Ruby 2.5, PHP 7.2, Perl 5.26, Node.js 10, Java 8 и 11, Clang/LLVM Toolset 6.0, .NET Core 2.1, Git 2.17, Mercurial 4.8, Subversion 1.10. В состав включена система сборки CMake (3.11);
  • В инсталлятор Anaconda добавлена поддержка установки системы на накопители NVDIMM;
  • В инсталлятор и в систему добавлена возможность шифрования дисков с использованием формата LUKS2, который заменил собой ранее применяемый формат LUKS1 (в dm-crypt и cryptsetup LUKS2 теперь предлагается по умолчанию). LUKS2 примечателен упрощённой системой управления ключами, возможностью использования секторов большого размера (4096 вместо 512, снижает нагрузку при расшифровке), символьными идентификаторами разделов (label) и средствами резервирования метаданных с возможностью их автоматического восстановления из копии в случае выявления повреждения.
  • Добавлена новая утилита Composer, предоставляющая инструменты для создания кастомизированных загрузочных системных образов, пригодных для развёртывания в окружениях различных облачных платформ;
  • Удалена поддержка файловой системы Btrfs. В состав больше не входят модуль ядра btrfs.ko, утилиты btrfs-progs и пакет snapper;
  • В состав включён инструментарий Stratis, предоставляющий средства для унификации и упрощения настройки и управления пулом из одного или нескольких локальных накопителей. Stratis реализован в виде слоя (демон stratisd), построенного поверх подсистемы devicemapper и XFS, и позволяет использовать такие возможности как динамическое выделение места в хранилище, снапшоты, обеспечение целостности и создание слоёв для кэширования, без наличия квалификации эксперта по администрированию систем хранения;
  • Реализованы общесистемные политики настройки криптографических подсистем, охватывающие протоколы TLS, IPSec, SSH, DNSSec и Kerberos. При помощи команды update-crypto-policies теперь можно выбрать один из режимов выбора криптоалгоритмов: default, legacy, future и fips. По умолчанию задействован выпуск OpenSSL 1.1.1 с поддержкой TLS 1.3;
  • Обеспечена общесистемная поддержка смарткарт и HSM (Hardware Security Modules) c криптографическими токенами PKCS#11;
  • На смену iptables, ip6tables, arptables и ebtables пришёл пакетный фильтр nftables, который теперь применяется по умолчанию и примечателен унификацией интерфейсов фильтрации пакетов для IPv4, IPv6, ARP и сетевых мостов. Nftables предоставляет на уровне ядра лишь общий интерфейс, не зависящий от конкретного протокола и предоставляющий базовые функции извлечения данных из пакетов, выполнения операций с данными и управления потоком. Непосредственно логика фильтрации и специфичные для протоколов обработчики компилируются в байткод в пространстве пользователя, после чего данный байткод загружается в ядро при помощи интерфейса Netlink и выполняется в специальной виртуальной машине, напоминающей BPF (Berkeley Packet Filters). Демон firewalld переведён на использование nftables в качестве бэкенда по умолчанию. Для преобразования старых правил добавлены утилиты iptables-translate и ip6tables-translate;
  • Для обеспечения сетевой связи между несколькими контейнерами добавлена поддержка драйверов для построения виртуальной сети IPVLAN;
  • В базовую поставку включён http-сервер nginx (1.14). Apache httpd обновлён до версии 2.4.35, а OpenSSH до 7.8p1. Из СУБД в репозиториях доступны MySQL 8.0, MariaDB 10.3, PostgreSQL 9.6/10 и Redis 4.0. СУБД MongoDB не вошла в состав из-за перехода на новую лицензию SSPL, которая пока не признана открытой;
  • Модернизированы компоненты для виртуализации. По умолчанию при создании виртуальных машин используется тип Q35 (эмуляция чипсета ICH9) с поддержкой PCI Express. Для создания и управления виртуальными машинами теперь можно использовать web-интерфейс Cockpit. Интерфейс virt-manager объявлен устаревшим. QEMU обновлён до версии 2.12. В QEMU реализован режим sandbox-изоляции, ограничивающий системные вызовы, которые могут использовать компоненты QEMU;
  • Добавлена поддержка механизмов трассировки на базе eBPF, в том числе при помощи инструментария SystemTap (4.0). В состав включены утилиты для сборки и загрузки BPF-программ;
  • Добавлена экспериментальная поддержка подсистемы XDP (eXpress Data Path), позволяющей в Linux запускать BPF-программы на уровне сетевого драйвера с возможностью прямого доступа к DMA-буферу пакетов и на стадии до выделения буфера skbuff сетевым стеком;
  • В состав добавлена утилита boom для управления настройками загрузчика. Boom упрощает выполнение таких операций как создание новых загрузочных записей, например, при необходимости загрузки с LVM-снапшота. Boom ограничен только добавлением новых загрузочных записей и не может применяться для изменения уже существующих;
  • Интегрирован легковесный инструментарий для управления изолированными контейнерами, использующий для сборки контейнеров Buildah, для запуска - Podman и для поиска готовых образов - Skopeo;
  • Расширены возможности, связанные с кластеризацией. Менеджер кластерных ресурсов Pacemaker обновлён до версии 2.0. В утилите pcs обеспечена полная поддержка Corosync 3, knet и обращения по именам узлов;
  • Объявлены устаревшими и теперь не поставляются по умолчанию классические скрипты для настройки сети (network-scripts). Для обеспечения обратной совместимости вместо скриптов ifup и ifdown добавлены обвязки над NetworkManager, работающие через утилиту nmcli;
  • Удалены пакеты: crypto-utils, cvs, dmraid, empathy, finger, gnote, gstreamer, ImageMagick, mgetty, phonon, pm-utils, rdist, ntp (заменён на chrony), qemu (заменён на qemu-kvm), qt (заменён на qt5-qt), rsh, rt, rubygems (теперь входит в основной пакет ruby), system-config-firewall, tcp_wrappers, wxGTK.
  • Подготовлен универсальный базовый образ (UBI, Universal Base Image) для создания изолированных контейнеров, в том числе позволяющий создавать контейнеры одного приложения. UBI включает в себя минимальное урезанное окружение, runtime-надстройки для поддержки языков программирования (nodejs, ruby, python, php, perl) и набор дополнительных пакетов в репозитории.


  1. Главная ссылка к новости (https://developers.redhat.com/...)
  2. OpenNews: Релиз Red Hat Enterprise Linux 7.6
  3. OpenNews: Релиз Red Hat Enterprise Linux 6
  4. OpenNews: Увидел свет дистрибутив Red Hat Enterprise Linux 7
  5. OpenNews: Разработка Scientific Linux 8 свёрнута в пользу CentOS
Лицензия: CC-BY
Тип: Интересно / Программы
Ключевые слова: rhel, redhat
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (175) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, mikhailnov (ok), 20:00, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    ImageMagick удалили? Без замены?
     
     
  • 2.3, dsdsadasd (?), 20:07, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Заменили на свое свободное время
     

  • 1.2, mikhailnov (ok), 20:01, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Удалили btrfs-progs - стало на одну причину больше не заморачиваться с Red Hat/
     
     
  • 2.12, Аноним (12), 20:31, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Почти уверен что и btrfs.ko, и btrfs-progs, и snapper будут доступны из сторонних репозиториев а-ля ELrepo.
     
  • 2.16, Аноним (16), 20:52, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > стало на одну причину больше

    А что, до сих пор тебе их не хватало?

     
  • 2.40, Z (??), 22:21, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Слава Богу!!!
     
  • 2.145, Аноним (145), 16:36, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    А жаль. btrfs и KDE то единственное чего не хвататет в RHEL.
     

  • 1.4, аннон (?), 20:08, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    А вы в курсе что линукс не следует принципам UNIX?
     
     
  • 2.5, Аноним (5), 20:16, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Чем хорош UNIX?
     
  • 2.6, Аноним (6), 20:22, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +10 +/
    Он и не должен.
     
  • 2.27, Аноним (27), 21:39, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +8 +/
    GNU - is not Unix!
     
     
  • 3.115, Andrey Mitrofanov (?), 10:00, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > GNU - is not Unix!

    Kernel.Org linux is not GNU.   #KOlinG  #sowhatqm

     
  • 2.59, anonymous (??), 23:57, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Linux Is Not UniX
     
     
  • 3.127, Аноним (127), 11:16, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    (LINU)s Torvalds UNI(X)
     
  • 2.61, OpenEcho (?), 00:42, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    беспринципный Unix
     
  • 2.74, leap42 (ok), 05:46, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Принципы UNIX были очень хороши в те времена, когда код был закрытый, количество разработчиков было маленьким, совместной разработки почти не было, а задачи были в 100500 раз легче. Не то, чтобы эти принципы стали плохими, но они объективно устарели.
     
     
  • 3.98, нах (?), 09:38, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    ну так вон вам ваши любимые форточки, не понимаю, зачем ломать то что работает?

    про то что "объективно устарели" нам еще в 87м году рассказывали. И где те рассказчики и их любимый ms-dos?

     
     
  • 4.129, Fyjybv755 (?), 11:53, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Так ms-dos как раз по юниксовым принципам и был построен. И отправился в волшебную страну юниксвея уже много лет назад.
     
     
  • 5.131, й (?), 12:11, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +6 +/
    > ms-dos как раз по юниксовым принципам и был построен

    ага, известная многопользовательская система ms-dos.
    с очень unix-like реализацией fork, например.

     
  • 5.156, йож (?), 21:20, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Так ms-dos как раз по юниксовым принципам и был построен.

    ловите наркомана!!11

     
  • 3.132, Andrey Mitrofanov (?), 12:14, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Кто о чём, а проприертарщик об микрософте Если Вы хорошо попросите и не рань... текст свёрнут, показать
     
  • 2.93, Аноним (93), 09:19, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –5 +/
    UNIX ссаная проприетарщина поэтому и не нужно.
     
  • 2.183, Anonymoustus (ok), 03:39, 27/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > А вы в курсе что линукс не следует принципам UNIX?

    Конечно. Но мы здесь в меньшинстве. А большинство здешнее не знает, что такое Юникс, только такое слово слышало.


    P. S.

    Интеллектуальное большинство не читает ни K&R, ни Реймонда, ни вообще никого из классиков, а сразу переходит на Сраковердоз и прочие кворы, где находит одобрение и понимание в среде себе подобных.

     

  • 1.7, Аноним (7), 20:23, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    А почему ядро 4.18? Это ж не LTS.
     
     
  • 2.15, anonymous (??), 20:42, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Afaik, версии ванильного ядра и того, что наваяла красношапка, не эквивалентны, посему можно не удивляться.
     
  • 2.17, Аноним (16), 20:54, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +11 +/
    Чтобы Оракл страдал, поддерживая свой unbreakable.
     
  • 2.146, Аноним (145), 16:37, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Они, все-равно свои патчи в ядро пихают. Им какая разница.
     
  • 2.151, Аноним (151), 18:25, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Что бы брать ядро от Ubuntu.
     

  • 1.8, Аноним (8), 20:24, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    Внезапно.
    Когда будет CentOS 8?
     
  • 1.9, ОмАр (?), 20:27, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +8 +/
    Отлично! Ждём CentOS!
     
     
  • 2.75, leap42 (ok), 05:48, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Лучще какой-нибудь 8.3-8.4 подождать. Пользуюсь nftables в Fedora, он клевый, удобный, но иногда валится модуль ядра) С сетью начинается странное(
     
     
  • 3.99, нах (?), 09:38, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    ауеть, дайте два.

    типикал линукс - обожаем страдание и обмазывание свежайшим.

     
     
  • 4.184, Anonymoustus (ok), 03:46, 27/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > ауеть, дайте два.
    > типикал линукс - обожаем страдание и обмазывание свежайшим.

    Это же тот, что кричал про устаревший Юникс.

     
  • 3.149, Аноним (149), 17:31, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    nftables патченый https://git.centos.org/rpms/nftables/blob/c8/f/SOURCES
    может быть и в ядре nft_ тоже с патчами, но они неизвестны
     
     
  • 4.174, пох (?), 08:46, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > nftables патченый https://git.centos.org/rpms/nftables/blob/c8/f/SOURCES

    это просто бэкпорты из более модных версий апстрима.
    Ничего особенно интересного в них нет.

    Сырость поделки - да, видна невооруженным глазом, баги в ней исправляются по принципу "где светлее" - большая часть патчей вообще про косметические особенности.

    новый стандарт, как он есть :-(


     

  • 1.10, lucentcode (ok), 20:29, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Дропнуть btrfs из-за NIH, и вместо него воткнуть сырой и стрмный Stratis - это эпик фейл. Надеюсь, другие с них пример брать не будут.
     
     
  • 2.21, Гномик (?), 21:05, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Они Федорук планомерно прикапывают. Видимо все светят на центос
     
  • 2.44, Аноним (44), 22:26, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Я так понимаю, они еще и XFS пилят, планируют добавить туда copy-on-write и снимки.

    Btrfs давно использую на нескольких машинах. Управление разделами, снимки, клонирование файлов, сжатие, дедупликация, send/receive — все это очень удобно и обходиться без этих фич уже не хочется, но вот с производительностью ситуация так себе — ФС деградирует со временем и требует периодической дефрагментации и балансировки, особенно ощутимо на HDD и когда свободного места не много. С надежностью проблем не было, данные не терял.

     
     
  • 3.69, тщт (?), 02:49, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    повезло тебе, а я задолбался синхронизировать зеркало на бтрфс, и решил удалить один винт чтобы на лвм перейте, удалил штатно без проблем, а после перезагрузки фс оказалась нерабочей, так что в то-пку.
     
  • 3.90, Fracta1L (ok), 09:08, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Использовать Btrfs на HDD это само по себе страдание
     
  • 3.95, kvaps (ok), 09:24, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Я так понимаю, они еще и XFS пилят, планируют добавить туда copy-on-write и снимки.

    Уже добавили, поэтому и от btrfs избавиться пытаются

    Хорошая попытка, но нет...

     
  • 2.48, редгад (?), 22:33, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    конечно не будут брать никаких примеров.
    Будут брать и перепаковывать наш пакет - как вы всегда и делали.
    Жрите чо дают, а то и это отберем.

    (ну а вообще-то -stratis всего лишь оберточка над lvm/xfs. Если ЭТИ вам "сырые", то про btrfs у нас и слов-то печатных не найдется. И да, как там у вас в ней с raid?)


     
  • 2.68, mikhailnov (ok), 02:02, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У них нет разработчиков BTRFS, они в Oracle и SUSE. Red Hat не хочет брать обязательства по поддержке того, в чем не разбирается.
     
     
  • 3.70, Васян (?), 04:11, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Логично, брателло! В кедах они тоже не шарят.
     
  • 3.101, нах (?), 09:40, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    наоборот же ж - они разобрались (были вполне внятные статьи их приближенных экспертов на эту тему) и решили - не нанимать. Купив вместо этого разработчиков модного lvm-light с потрохами.

    возможно, ик-сперд как обычно был проплаченный, а истина где-то рядом с "the Truth" ;-)


     

  • 1.13, Аноним (13), 20:35, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Что вы прицепились-то... ой удалили то, ой удалили это, ой удалили ImageMagick, ой удалили btrfs-progs... ОС вообще-то под enterprise нужды. Если что-то выливается значит не особо то и нужно для бизнес подписчиков.
     
     
  • 2.45, anonymous (??), 22:26, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Либо просто решили забить на нужды некоторых подписчиков)

    ImageMagick -- это очень популярный проект. Его немало используют на серверах.

     
     
  • 3.55, Аноним (13), 23:24, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Либо просто решили забить на нужды некоторых подписчиков)
    > ImageMagick -- это очень популярный проект. Его немало используют на серверах.

    Я думаю, что произвольно просто так ничего тут удалять не будут.
    В персональном порядке, учитывая нужды, наверняка могут и поставить кому-нибудь ImageMagick (если уж прямо так нужно!). А что касается общей массы клиентов, то скорее всего ImageMagick был малоиспользуем, вот и выпилили за ненадобностью.

    Достаточно очевидно всё это (как мне кажется).

     
     
  • 4.85, Иван (??), 08:12, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    1С сервер требует ImageMagick для своей работы.
     
     
  • 5.87, Аноним (87), 08:32, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > 1С сервер требует ImageMagick для своей работы.

    Поздравляю вас, но каким образом это касается клиентов редхата?
    Может среди их клиентов нет таких, которые используют 1С, либо полтора подписанта (для которых могут выработать отдельный подход).

    Мало ли что там требуется 1С для своей работы. Речь не об этом. Речь о том, что ImageMagick малоиспользуем среди клиентов и поэтому он был выпилен за ненужностью.

     
  • 4.109, anonymous (??), 09:54, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Звучит сомнительно. Например большинство web-ресурсов используют imagemagick, так как если работаешь с картинками (resize, crop, whatever), то обычно выбор между "какой-то огрызок, а-ля gd" и "imagemagick", и почти всегда выбирают второе.
     
     
  • 5.111, anonymous (??), 09:58, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    P.S.: Для дополнительной наглядности: https://qa.debian.org/popcon.php?package=imagemagick
     
  • 5.150, лютый жабист__ (?), 18:00, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Например большинство web-ресурсов используют imagemagick

    ...большинство php-поделок? В нормальных языках свои средства для этого.

     
     
  • 6.153, anonymous (??), 19:43, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Хм. Типа такого?

    - python, wand: https://github.com/emcconville/wand
    - golang, imagick: https://github.com/gographics/imagick
    - rust, magick: https://github.com/nlfiedler/magick-rust
    - C++, Magick++: https://github.com/ImageMagick/ImageMagick/tree/master/Magick%2B%2B
    и т.п.

     
  • 3.60, anonymous (??), 00:01, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Кому нужно - используют GraphicsMagick т.к.производительность лучше.
     
     
  • 4.102, нах (?), 09:42, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    кому нужно потрахаться с новым отдельным сортом грабель ради сказок о производительности - используют, но прикол в том что в rhel и его тоже нет.

     
     
  • 5.135, anonymous (??), 12:20, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Это не сказки. У меня время обработки изображений сократилось раза в 3-4.
     
     
  • 6.137, Аноним (137), 13:38, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ты мерзкий хипстор! А какже пострадать и потрахаццо? Поныть в энторнетах, наконец.
     
     
  • 7.143, anonymous (??), 16:15, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну, всё же пришлось переписать команды, ибо опции были несовместимы.

    Но это заняло минуты 3 :)

     
     
  • 8.175, нах (?), 09:55, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    нууу, мы ужасов ждали, а он - чижика съел какой ты нафиг хипстер - так, васян-с... текст свёрнут, показать
     
  • 4.110, anonymous (??), 09:55, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    1. Он несовместим с ImageMagick.
    2. Под него тоже есть библиотеки под все популярные языки программирования?

    А вообще да, сам недавно пользовался и был очень доволен производительностью :)

     
  • 2.185, Anonymoustus (ok), 03:52, 27/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Что вы прицепились-то... ой удалили то, ой удалили это, ой удалили ImageMagick,
    > ой удалили btrfs-progs... ОС вообще-то под enterprise нужды. Если что-то выливается
    > значит не особо то и нужно для бизнес подписчиков.

    Так вот почему ынтерпрайзной ОС прокладывают путь катком fd.o!

     

  • 1.14, BlackRot (?), 20:39, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Лично я ждал эту новость и рад её, надеюсь на скорый выход CentOS 8.
     
     
  • 2.24, Аноним (24), 21:11, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Джва года?
     

  • 1.18, Elcanner (?), 21:00, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Никого не смутило прекращение поддержки KDE ?
     
     
  • 2.20, Аноним (20), 21:02, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Все давно разморожены.
     
  • 2.23, Аноним (23), 21:09, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –7 +/
    KDE страшный
    Гном гораздо лучше.
    Использую на домашнем ПК оч доволен
     
     
  • 3.35, Sw00p aka Jerom (?), 21:57, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    кдешная консоль гораздо удобнее чем гномовская
     
     
  • 4.36, Аноним (-), 22:06, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    А использовать кдешную консоль в гноме тебе конечно мамка запрещает?
     
     
  • 5.63, DerRoteBaron (ok), 01:07, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Красная шапка пусть, конечно, и не запрещает, но осложняет, вынуждая либо самостоятельно компилить (вместе с хорошей кучей зависимостей), либо искать тех, кто уже извратился и скомпилил.
     
  • 5.64, Sw00p aka Jerom (?), 01:26, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > А использовать кдешную консоль в гноме тебе конечно мамка запрещает?

    так и делаю, с кучей Г-зависимостей, которые тянутся с консолью

    пс: читай внимательно "Из состава исключены пакеты с рабочим столом KDE, оставлена только поддержка GNOME;"


     
     
  • 6.167, DmA (??), 06:57, 10/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Вообще то они гном начали 15 лет назад, чтобы отказаться от kdе из-за проблем с лицензией на qt. Наконец это свершилось.
     
     
  • 7.186, Anonymoustus (ok), 04:04, 27/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Вообще то они гном начали 15 лет назад, чтобы отказаться от kdе
    > из-за проблем с лицензией на qt. Наконец это свершилось.

     
     
    https://en.wikipedia.org/wiki/GNOME#History
     

     
  • 3.54, Аноне (?), 23:14, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    > Гном гораздо лучше.

    Примерно как квардат Малевича..

     
  • 3.88, Аноним (88), 08:34, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +9 +/
    > Гном гораздо лучше.
    > Использую на домашнем ПК оч доволен

    Моргни дважды, если тебя удерживают.

     
  • 3.128, Anonimus (??), 11:34, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    KDE - наиболее гибко кастомизируемый и сделан для людей. остальное зависит от прослойки между ПК и креслом.
     
     
  • 4.164, Vladjmir (ok), 22:06, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Кедерам придётца сваливать на другие дистры.
     
     
  • 5.171, Anonimus (??), 11:03, 11/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Кедерам придётца сваливать на другие дистры.

    не прийдется если ты и так не используешь RH-based дистрибутив;)

     
  • 2.25, конь в пальто (?), 21:29, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    зачем серверному дистрибутиву DE?
     
     
  • 3.41, хотел спросить (?), 22:21, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Я имея сервер без десктопа, хотал бы себе такую же девелоперскую машину, но с десктопом
     
     
  • 4.84, elcanner (?), 07:33, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Так есть же центос... зачем тратить бабло на дев машину в DЕ, когда можно не тратить бабло на дев машину с DЕ ?
    Видимо мой изначальный пост был слишком тонкий для опеннета :)
     
     
  • 5.86, хотел спросить (?), 08:32, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Так есть же центос... зачем тратить бабло на дев машину в DЕ,
    > когда можно не тратить бабло на дев машину с DЕ ?
    > Видимо мой изначальный пост был слишком тонкий для опеннета :)

    что за фуфло-вброс?

    > зачем серверному дистрибутиву DE?

    это было про то, что KDE выпиливают из RHEL8
    CentOS8 будет полностью копировать RHEL8
    KDE в CentOS8 будет также отсутствовать среди родных RPM.
    так что не надо сча сpaкой елозить на сковородке

     
  • 3.71, Васян (?), 04:15, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Федора серверный дистр? Это оригинальный наброс, как бы лопасти у вентилятора не погнали.
     
     
  • 4.94, Совершенно другой аноним (?), 09:22, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Вроде речь шла про RHEL.
     
  • 3.96, КО (?), 09:31, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Удобно.
    Но вот зачем серверному дистрибутиву Wayland? На это у меня нет очевидного ответа. :)
     
     
  • 4.103, нах (?), 09:43, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    ваш-новый-стандарт, чего тут-то непонятного.
    А то ишь, привыкли что у вас хоть и сервер, а иксовое приложение с него прекрасненько запускается на десктопе. Нахрен не надо того старья - вон, vnc есть!

     
  • 3.105, Аноним (137), 09:46, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    На серверах внезапно иногда бывает нужен GUI. Редко, но бывают такие задачи. DE, конечно, там избыточно, обычно хватает twm стандартного, на крайняк - простенький wm, типа openbox.
     
     
  • 4.138, fi2fi (?), 14:06, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    внезапно!!!  RedHat продает WS пачками по 50 шт., собственно для него gnome и пилят. )))))))
     
     
  • 5.176, нах (?), 09:58, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > внезапно!!!  RedHat продает WS пачками по 50 шт., собственно для него

    это делают для того, чтоб ты, васян, со своим локалхостом, до техподдержки не дое..лся, а вовсе не потому что охрененный спрос, не успевают заворачивать.

    на самом деле нахрен та ws никому не нужна.


     
  • 2.30, BlackRot (?), 21:46, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Консоль, и никаких DE.
     
  • 2.46, Аноним (44), 22:29, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Не думаю, что энтерпрайз-дистрибутиву нужно несколько разных десктопов. Тут главное предоставить цельную хорошо интегрированную систему, а с множеством разных оболочек этого достичь трудно.
     
     
  • 3.65, DerRoteBaron (ok), 01:28, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Другое дело, что третьегном для этого вообще плохо подходит из-за того, что суще... текст свёрнут, показать
     
     
  • 4.97, КО (?), 09:37, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    >Другое дело, что третьегном для этого вообще плохо подходит из-за того, что существенно ломает "опыт использования" рабочего стола,

    Да ладно, зачем по ssh пробрасывать трей?

     
  • 2.147, Аноним (145), 16:41, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Они дропнули четвертую ветку кед. Вопрос в другом, почему не подхватить ей на замену пятые кеды. В общем RHEL не для старых драйверов, не для старой NVIDIA и не для старых AMD и еще не для кучи старого оборудования. А, и в Virtualbox тоже графика скрипит.
     
     
  • 3.165, Vladjmir (ok), 22:11, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Именно, RHEL делают для серверов, где не нужна мощная видеокарта. А старые карты неплохо поддерживаются стандартными видео-драйверами.
     

  • 1.22, Аноним (23), 21:08, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ура лучшему дистрибутиву Линукс и спасибо red hat за продвижение и поддержку open source решений.
     
  • 1.26, Аноним (26), 21:36, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Хороший дистрибутив для энтерпрайз решений. Для дома и "чтобы поиграться" не рекомендую. Пакеты слишком старые и не обновляются. Ещё работает из-за этого слишком стабильно и багов по минимуму, очень скучный дистрибутив для дома.
     
     
  • 2.47, anonymous (??), 22:32, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да ну хватает там нескучности, как собирать всякие окружения, чтобы можно было скомпилить нужные пакеты для ruby, golang (с зависимостями на Сишные библиотеки) и прочего. А так же последние, tex-и и вообще что угодно (что требуется свеженской версии по какой-либо причине).

    А в родных официальных source-пакетах версии зависимостей расставлены на обум, поэтому зачастую нельзя просто взять и собрать то, что тебе нужно.

     
  • 2.139, fi2fi (?), 14:11, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    использую "Для дома" и крайне рекомендую! Если вы конечно не тестер ))))

    Один раз поставил и вся семья на несколько лет спокойно пользуется без геморроя.  

     
     
  • 3.141, Аноним (141), 15:46, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Хороший способ отучить домочадцев залипать за компьютером.
     
     
  • 4.168, DmA (??), 07:02, 10/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Домочадцам обычно нужен интернет и распечатать на принтере, так что линккс вполне хватает
     

  • 1.28, Annoynymous (ok), 21:40, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > В качестве рабочего стола по умолчанию предложен GNOME 3.28 с применением по умолчанию дисплейного сервера на базе Wayland.

    Тот случай, когда в Red Hat нововведения появляются раньше, чем в Ubuntu.

     
     
  • 2.32, BlackRot (?), 21:48, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    А разве на последней бубунте не последний гном 3.34 с вяленым?
    Простите, я шляпник, могу не знать #чтотамубубунты
     
     
  • 3.67, DerRoteBaron (ok), 01:31, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В LTS 18.04 GNOME 3.28, но дефолтный сеанс - иксы (в силу очевидной недопиленности вяленого и, видимо, распространенности невидии).
     
     
  • 4.100, КО (?), 09:40, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    А разве не в силу конструктивных особенностей Вяленого из-за которых надежность работы сеанса и всех приложений зависит от надежности приложения на это ни коим образом не рассчитанного?
     
     
  • 5.104, нах (?), 09:44, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    конечно нет - кого вообще колебет ваша надежность?
     
  • 3.140, iPony (?), 14:13, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Wayland был по умолчанию включён ещё в Ubuntu 17.10.
    В итоге поигрались, и признали неготовым ещё. В Ubuntu 18.04 выключили.
    Хотя в поставке он есть, и его легко включить самому в пару нажатий кнопок, если у тебя не проприетарный драйвер Nvidia
     

  • 1.29, Аноним (29), 21:42, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    удален gstreamer? основной мультимедийный фреймворк для gnome?
     
     
  • 2.72, Аноним (72), 04:18, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    не знаю, что за извращенцы его назначили дефолтным.
     
  • 2.181, Аноним (181), 03:18, 27/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Скорее всего удалили 0.10
     

  • 1.31, Аноним (31), 21:47, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    как это питон в базовую не входит, когда они везде ansible двигают
     
     
  • 2.42, АнонимныйАноним (?), 22:23, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Входит, поищи в libexec
     
  • 2.58, Аноним (58), 23:45, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    То есть то, что у них пакетный менеджер на питоне, тебя не смутило?
     
  • 2.134, asand3r (ok), 12:19, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Скорее всего вторая версия имеется в виду.
     
     
  • 3.160, Анонимус2 (?), 12:49, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну так ансибле на 3 питоне тоже работает.
     
     
  • 4.161, asand3r (ok), 12:53, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ну вот - вторая версия по умолчанию не входит в поставку, а третья входит. Всё нормально.
     

  • 1.33, Аноним (33), 21:48, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Virtual machine snapshots are not properly supported in RHEL 8

    The current mechanism of creating virtual machine (VM) snapshots has been deprecated, as it is not working reliably. As a consequence, it is recommended not to use VM snapshots in RHEL 8.

    Note that a new VM snapshot mechanism is under development and will be fully implemented in a future minor release of RHEL 8.

    https://bugzilla.redhat.com/show_bug.cgi?id=1686057

    кто в курсе, в чем может быть проблема со снапшотами в rhel8, которой нет в rhev? Версии пакетов qemu,libvirt в rhel8 явно не старее rhev.

     
     
  • 2.49, пох (?), 22:36, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > явно не старее rhev.

    может в этом и проблемы, о любитель обмазывания свеженьким? ;-)
    работающую технологию объявили deprecated, а ничего другого индусы к дате анонса, ну надо же, не успели накодить хвостами.

     
  • 2.81, Аноним (81), 07:15, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Virtual machine snapshots are not properly supported in RHEL 8
    > The current mechanism of creating virtual machine (VM) snapshots has been deprecated,

    А что так можно было?!! Кто все эти люди?!! о_О
    Все вопросы к RH по поводу стратегии развития/качества кода в systemd у меня тут же отпали.

     
     
  • 3.177, нах (?), 10:00, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Все вопросы к RH по поводу стратегии развития/качества кода в systemd у
    > меня тут же отпали.

    а чо, были? ну ты лох...


     

  • 1.34, crypt (ok), 21:52, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    много чего старого отменили со времен 6го, добавили всякие хипстерские прокладки для управления... к сожалению, оставили принудительный python network manager на серверах... а раньше релизы редхата ждал с нетерпением.
     
     
  • 2.37, Аноним (37), 22:07, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    ну почему же принудительный? ешё есть networkd!
     
     
  • 3.53, d (??), 23:12, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Час от часу не легче.
     
  • 3.57, Аноним (57), 23:38, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > ну почему же принудительный? ешё есть networkd!

    нет systemd-networkd https://bugzilla.redhat.com/show_bug.cgi?id=1650342

     
     
  • 4.142, Аноним (141), 15:57, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Лёня пилили и тут тебя на, не включили. Так может обидеться и забить
     
  • 2.66, Sw00p aka Jerom (?), 01:30, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > много чего старого отменили со времен 6го, добавили всякие хипстерские прокладки для
    > управления... к сожалению, оставили принудительный python network manager на серверах...
    > а раньше релизы редхата ждал с нетерпением.

    6-ка была одна из лучших

     
     
  • 3.108, Аноним (137), 09:54, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Угу, один апстарт чего стоил.
     
     
  • 4.159, Stamnik (?), 00:35, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вот и зря Вы так. Вполне себе приятная штукенция. Гораздо проще в освоении чем systemd и гораздо гибче initd. Во всяком случае мне понравилась и очень активно использую.
     

  • 1.38, Аноним (44), 22:11, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Зачем *удалять* btrfs, который входит в состав ядра? А как теперь обновляться тем, кто уже на btrfs?
     
     
  • 2.39, BlackRot (?), 22:18, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Видимо поэтому и пишут чейндж логи что бы перед обновлением их читать и думать нужно тебе это обновление или нет.
    Как выйти из вашей ситуации я хз кроме как переносить систему на новую фс
     
     
  • 3.51, пох (?), 22:41, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Как выйти из вашей ситуации я хз

    сменить прокладку между стулом и клавиатурой.
    о том что это произойдет, было написано в changelog'ах (точнее, в release notes) не 8, а 7. За два года не прочухаться - это надо уметь быть слоупоком.

     
  • 2.62, Аноним (62), 00:48, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    С каких пор RH поддерживает обновление между мажорными версиями?
     
     
  • 3.116, RHEL Fan (?), 10:01, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    С RHEL 7 вроде? Правда
    Red Hat currently supports only upgrades from Red Hat Enterprise Linux 6 to Red Hat Enterprise Linux 7 for specific/targeted use cases only.
     
  • 2.119, iFRAME (ok), 10:07, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Поднимаете новый сервер и мигрируете сервисы на новый сервер.
     
     
  • 3.120, Заря (?), 10:29, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Через Убунту и Дебиан, да.
     
  • 2.130, анон (?), 12:08, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Обновление между мажорными версиями не поддерживается. Это вам не убунту/дебиан. Для стабильности приколочено гвоздями.
    Была экспериментальная возможность для обновления с 6 до 7, но уже не работает.
     
  • 2.154, Аноним (154), 19:49, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Затем, что поставляемое ими ядро они обязуются поддерживать и решать проблемы, с ним возникающие. Потому они оставляют при сборке только ту функциональность, поддержку которой готовы обеспечивать.
     

  • 1.43, Аноним (43), 22:26, 07/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    У кого есть,дайте ссылку.Очень хоцца.
     
     
  • 2.50, пох (?), 22:39, 07/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    на тебе ссылку:
    https://www.redhat.com/wapps/ugc/register.html

    (в целом-то и недорого просят)

     
     
  • 3.73, Аноним (72), 04:22, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    та ну, было б за что. Мне для рабочей станции, но за кривой гном платить - нет уж.
     
     
  • 4.80, пох (?), 07:14, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    ты поддельный онаним - тому "очень хоцца". Нет, я понимаю, что ему хотца на халяву и даром - мне соседский гелик тоже хотца, но что-то этот жлобяра не делится.

    и почему за кривой? За единственно-прямой гном - от непосредственного спонсора и идейного вдохновлятеля! (нет, это не redhat ;-)

     
  • 3.118, RHEL Fan (?), 10:04, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да, вроде, за регистрацию не просят? И скачать потом нахаляву можно, и обновлять 60 дней.
     
     
  • 4.121, пох (?), 10:30, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Да, вроде, за регистрацию не просят? И скачать потом нахаляву можно, и обновлять 60 дней.

    ну мне сложно проверить - у меня регистрация столетней давности.

    afair, там были ньюансы из серии скачать-то можно, но пользоваться не для evaluation нини, но это в каждой новой версии чудо-портала и с каждой новой версией самого рхела меняли.

     
  • 3.126, RM (?), 11:15, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Пох,не, можно более нахаляву и законно: https://developers.redhat.com/blog/2016/03/31/no-cost-rhel-developer-subscript
     
     
  • 4.133, пох (?), 12:16, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    где ж тут законно? Ты там подписываешься, что собираешься заниматься _разработкой_ и _только_ разработкой - не берусь утверждать, попадает ли применение опыта, полученного путем ковыряния в локалхосте, под это ограничение, но скорее да чем нет - во всяком случае, разработкой тут и не пахнет.

    Я лично на developer никогда не регистрировался, и особенного смысла не вижу - на поиграть и выбросить хватает и безлицензионной версии, она обычно доступна через обычный логин (а если не, надо подождать неделю-две-четыре, что-нить да выкатят и еще и письмо пришлют элехтрическое - чавой-то ты не бежишь ознакомиться с новым трэшачком, вот же ж, специально для тебя)

    а вот на порыться в багрепортах - иногда и с корпоративным не пускает, типа, это только для наших индусов, а вы обращайтесь, обращайтесь... правда, последние лет пять уже и ни разу не хотелось.

     
     
  • 5.158, RM (?), 23:46, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Законно. Может я rc.local девелоплю.
    >>Can i use this as a student who wants to learn RHEL? i mean self-use only with no commercy.
    >Yes.

    А смысл реги для меня - в доступе к закрытым для общего просмотра KB articles.

     
     
  • 6.182, Аноним (181), 03:23, 27/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Можно не регаться: https://bypass.org.ru/login/redhat.com
     
  • 2.91, Девопс (?), 09:14, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Держи ссылку! https://getfedora.org/en/server/
     

  • 1.76, Дуплик (ok), 05:58, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Отлично, серьёзный дистрибутив для серьёзных людей!
     
     
  • 2.89, Аноним (88), 08:43, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Дуплик, ты определись уже, ты же любитель МС.
     

  • 1.78, Neandertalets (ok), 06:57, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Удалены пакеты: ..., system-config-firewall, tcp_wrappers,

    А что теперь вместо них? Фиг с ним, с firewalld, а вот tcp_wrapper - не ясно: я им достаточно часто пользуюсь и хотел бы иметь в доступных и потом.

     
     
  • 2.79, пох (?), 07:11, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    вместо них systemd-rhel-firewalld, неужели непонятно?

    а этот ваш tcpwrappers мамонтово г-но и портянки, его надо выкинуть-выкинуть.

    вероятно, не осилили совместить с модным интерфейсом cocksuck, или как там его.
    Или может просто перестало собираться модным gcc98, а автор что-то не присылает патчей последние лет 25.

    выкидывание imagemagick и уродливый networkmanager для серверной системы - как бы говорят нам о том, что на one microsoft way нам с редхатом уже совсем не по дороге.

    хотя. да... nginx! "15 лет ждал"!

     
     
  • 3.114, Neandertalets (ok), 10:00, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > а этот ваш tcpwrappers мамонтово г-но и портянки, его надо выкинуть-выкинуть.

       Кому как.

    > выкидывание imagemagick и уродливый networkmanager для серверной системы - как бы говорят
    > нам о том, что на one microsoft way нам с редхатом уже совсем не по дороге.

       NM, на мой взгляд, вполне удобен и юзабелен. Привычка в network играться? :)

     
     
  • 4.124, пох (?), 10:45, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > NM, на мой взгляд, вполне удобен и юзабелен.

    для сервера? С фиксированной адресацией?

    зачем эта уродливая прокладка с нечеловеческим cli (изобретенным не умеющим пользоваться клавиатурой) вообще нужна? А, ну да - "как в винде!"

    В network-scripts, пока, к счастью, все как было - убунтиный netplan видимо отброшен из-за nih-синдрома, а жаль - ведь так прекрасен конфиг, портящийся от лишнего пробела и незаметно добавляющий ipv6 адреса при sysctl'ем заблокированном v6 вообще...

     
  • 3.117, Аноним (137), 10:03, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Или может просто перестало собираться модным gcc98, а автор что-то не присылает патчей последние лет 25.

    Штрадай. Никто не будет поддерживать зоопарк версий компилера ради одной-двух тухлых софтинок, нyжных полутора гикам. И вообсче, или трусы, или крестик. Или ты гик, но тогда будь мужЫком и собери сам, или ты хомяк, и тогда не выпендривайся, и жри что налито.

     
     
  • 4.123, пох (?), 10:42, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Никто не будет поддерживать зоопарк версий компилера ради одной-двух тухлых софтинок, нyжных
    > полутора гикам.

    ну так и не поддерживайте. Зоопарк версий старше 4.7 вообще-то только полутора гикам и был нужен.
    с lto, pgo и прочими вскукареками что щас мы сделаем лучше интела, и поддержкой недописанного недостандарта, каждый день нового.

    а какой софт у вас нужный, какой нет - редхат решил за вас, и жрете и облизываетесь вы любое, что на лопате подают. Пользоваться-то им вы все равно ж не умеете, за вас firewalld пользуется. Чем ему и его разработчикам показалось попроще - тем и пользуется.

    > Или ты гик, но тогда будь мужЫком и собери сам

    я пока занят - сам синтезирую себе препараты для лечения поврежденной спины, сорванной при попытке самостоятельно вскопать поле без трактора (который пока тоже не удалось собрать - лемех-то я выковал, а дизельный двигатель что-то как-то не получилось) чтобы вырастить на нем самостоятельно еду.

     
  • 2.107, КО (?), 09:47, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    system-config-firewall это не про firewalld, это про iptables. :)
     
     
  • 3.112, Neandertalets (ok), 09:59, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > system-config-firewall это не про firewalld, это про iptables. :)

    Упс... Перепутал с firewall-config :-D   Пардоньте...

     
  • 2.170, й (?), 20:52, 10/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > а вот tcp_wrapper - не ясно: я им достаточно часто пользуюсь

    эм, а нафига? tcp wrappers -- это такой контроль доступа к сервисам, которые сами не умеют ограничения, на сервере, на котором нет firewall (да-да, в 90 году это было актуально). вообще изначально работал только в связке с inetd, помните такой?

    как правило, если на сервере есть firewall, в tcp wrappers тупо разрешается всё.

     
     
  • 3.178, нах (?), 10:08, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > (да-да, в 90 году это было актуально). вообще изначально работал только
    > в связке с inetd, помните такой?

    вообще изначально предполагал использование апи, а cli wrapper был last resort (настолько, что некоторые его при сборке умудрялись забыть - годами).
    Да, помним и используем, подальше от ваших новых-стандартов для обезьянки-неосилятора sed.

    > как правило, если на сервере есть firewall, в tcp wrappers тупо разрешается
    > всё.

    тупыми - разрешается. Умные понимают что некоторыми вещами нагружать ядро не стоит, падает производительность, и складывать все яйца в один нечитаемый глазами конфиг и в общий нечитаемый из-за нечеловеческого формата лог, доступные только админу хоста - тем более.

     
     
  • 4.180, й (?), 12:33, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > вообще изначально предполагал использование апи, а cli wrapper был last resort (настолько,
    > что некоторые его при сборке умудрялись забыть - годами).

    ну, ты конечно покажешь пруф, например, вот в этом документе от автора: ftp://ftp.porcupine.org/pub/security/tcp_wrapper.pdf

    > тупыми - разрешается. Умные понимают что некоторыми вещами нагружать ядро не стоит,
    > падает производительность

    tcp_wrappers сливало ядру по производительности ещё во времена ipchains, не надо сказок.

    > и складывать все яйца в один нечитаемый глазами конфиг
    > и в общий нечитаемый из-за нечеловеческого формата лог, доступные только админу
    > хоста - тем более.

    по-моему таки кто-то не осилил файрволл в linux, бывает.

     

  • 1.82, Аноним (82), 07:26, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Поддержку samba ad dc завезли? Или, как обычно, надо Сернету сверху доплачивать?
     
     
  • 2.113, Аноним (58), 09:59, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Ты что? Это же NIH! Только 389 directory server! (или какая там цифирь? по памяти писал)
     

  • 1.83, Аноним (83), 07:26, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Я правильно понимаю, что SCL теперь заменили на некий UBI, что по сути является докером с приватными шапочными registry, и всякие llvm и gcc тулсеты (разные их версии) не будут доступны без красношляпой подписки?
     
  • 1.92, Аноним (93), 09:17, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    IBMd 8.
     
  • 1.122, PnDx (ok), 10:40, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Навскидку вижу сразу 3 проблемы. И пока непонятно, что с этим делать. (Когда нужны специфические штуки вроде shared-lvm особо альтернатив нет, если нет ресурсов на ТП)
    1. network-manager вместо network-scripts — это: Во-первых, единая точка отказа по сети. Во-вторых, проблемы поднять свой софтовый интерфейс. В-третьих, а через что описывать топологии сложнее "просто eth0"?
    2. А chrony точно готов быть stratum 1? Не, последние пару лет он вполне нормально справляется с ролью "sntp на виртуалку".  Но вот так сразу?
    3. tcp_wrappers: добавит работы при конструировании PCI-DSS и т.п. решений.

    * Ну и nftables кому-то доставит, но тут есть ещё почти 5 лет на раскачку.

     
     
  • 2.125, пох (?), 10:55, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > network-manager вместо network-scripts — это

    это модно. Через те же скрипты в том же месте - пока.
    Потом допишут модный-новый гуй. А вообще в эпоху девляпса это и немодно совсем - сервер должен запускаться в виде автоматического инстанса, и ничего кроме dhcp на eth0...зачеркнуто, на угадайчегогокгоикакаятутцифранаконце, ему не полагается - а остальные сети тебе доскер (или доскер немодно, что там сейчас вместо?) сам создаст, по модной-новой технологии ipvlan (vxlan ниасилены и уже забыты) - правда, попутно сп-в адресацию, используемую вашей физичекой сетью, но кого это колебет.

    > А chrony точно готов быть stratum 1?

    а сколько у тебя stratum1 серверов и зачем там редгад?

    > tcp_wrappers: добавит работы при конструировании PCI-DSS и т.п. решений.

    конструируй через firewalld, клик-клик-клик, сейчас все так делают.

    > Ну и nftables кому-то доставит

    по этой же причине и не доставит - их конфиг изначально написан идиотами для идиотов, искренне непонимающих, зачем его руками редактировать, когда есть чудесный firewalld, теперь - ванильный! (ой, в смысле - теперь еще и через web-интерфейс. При поломке - переставишь систему, это быстро.)

    а потом и вовсе будет eBPF, с кривым и неработающим враппером через враппер во враппер.

     
  • 2.155, Аноним (154), 19:55, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    https://www.freedesktop.org/software/systemd/man/systemd.resource-control.html

    Ищи по подстроке "IPAddressAllow"

     
     
  • 3.179, нах (?), 10:15, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Ищи по подстроке "IPAddressAllow"

    интересно, любитель обмазываться свеженьким, как ты потом эту самую строку будешь искать (способ предложенный для вайтлистинга просто прекрасен)? И насколько быстро вообще догадаешься, почему ничего не работает и где источник проблемы.

    отдельно - какова допустимая длинна этой строки (и где это написано).

    но в общем, приятно что я опять угадал. Жаль только, конечно, что с этим вот потом и работать :-(

     

  • 1.144, Пряникё (?), 16:35, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А что теперь делает опция "-Х" у ssh, если там Иксов нету? Как вобще в этом вейленде сеанс экспортировать?
     
     
  • 2.162, Анонимус2 (?), 13:05, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >А что теперь делает опция "-Х" у ssh, если там Иксов нету?

    1. Иксы никуда не делись.
    2. А что по-твоему опция раньше делала если на сервере не было иксов? Пробрасывала 1 сокет и выставляла парочку переменных окружения, не больше.

     

  • 1.148, Ващенаглухо (ok), 16:47, 08/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Когда уже wireguard добавят?
     
     
  • 2.152, scan (??), 19:23, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    да кому он нах нужен
     
     
  • 3.157, Аноним (8), 21:47, 08/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    мне
     
  • 2.163, Аноним (163), 19:26, 09/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    https://www.wireguard.com/install/
    Red Hat Enterprise Linux / CentOS
     

  • 1.166, zo0M (ok), 22:31, 09/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    оч вкусные изменения, поднял у себя виртуалочку на помацать и всё-всё понравилось)
     
  • 1.169, Аноним (169), 17:33, 10/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Из состава исключены пакеты с рабочим столом KDE, оставлена только поддержка GNOME

    Не понимаю, зачем выкидывать самый лучший DE и оставлять убогий Gnome Shell.

     
     
  • 2.172, anonymous (??), 12:38, 11/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Скажу очевидное, но "лучший" и "убогий" -- это субъективные характеристики.
     
     
  • 3.173, ыы (?), 07:34, 12/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Миллион леммингов не может ошибаться! Gnome Hell - шлак :)
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    MIRhosting
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру