The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Решение проблемы с подключением web-камеры к Skype под Linux
Если в Linux дистрибутиве с ядром 2.6.27 или старше локальная web-камера (например, 
камеры серии Logitech Quickcam Communicate работающие через gspca драйверы) в skype 
(или любой другой программе использующей интерфейс v4l1) отображает лишь шум на экране, 
для запуска skype нужно использовать скрипт:

   #!/bin/sh
   export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
   skype 


v4l1compat.so входит в состав пакета libv4l

Проверить в v4l1 ли причина можно так:

   LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so mplayer tv:// -tv driver=v4l2:device=/dev/video0

Для настройки параметров отображения удобно использовать программу v4lucp (http://sourceforge.net/projects/v4l2ucp/)

Создание скрипта для подмены skype:

  mv /usr/bin/skype /usr/bin/skype-bin; echo -e '#!/bin/sh\n\n
   export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so\n\nskype-bin' |
   tee -a /usr/bin/skype; sudo chmod +x /usr/bin/skype
 
Ключи: v4l, linux, video, skype / Лицензия: CC-BY
Раздел:    Корень / Пользователю / Обработка изображений и видео

Обсуждение [ Линейный режим | Показать все | RSS ]
  • 1.2, SwitNJ (??), 00:43, 02/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    начиная с версии libv4l 0.5.8 в описании указано что после установки пакета библиотека уже сама помещается в предзагружаемые модули. так что по идее все вышеописанное уже не нужно.
     
  • 1.3, User294 (ok), 07:30, 02/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Опять у любителей проприетари гемор?Пусть привыкают, так им и надо.Почему-то с проприетарным добром вечно гемор а исправлять приходится не там где надо по уму а там где исправляется :)
     
  • 1.4, Аноним (4), 12:01, 02/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    да, у меня такая проблема после обновления до ubuntu 8.10 возникла

    лечил также

    но на ноуте с 28 ядром все впорядке

     
  • 1.5, SwitNJ (ok), 12:15, 02/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    User294,
    если вы в каменном веке сидите и новости не читаете - специально для вас поясняю:
    Проблема возникла начиная с версии ядра 2.6.27 в связи с тем, что драйверы для вебкамер включили в состав ядра, ане подгружаемыми модулями как ранее. но включив в ядро часть драйвера они выкинули ту ее часть, которая отвечала за бреобразование форматов представления изображения с каждой конкретной камеры к общему стандарту. посему многие камеры просто улетели в трубу, а вот ту функциональность недостающую решили переложить на модуль libv4l. Теперь производители софта сами должны используя эту бибилиотеку переписать свои софтины на "правильное" использование драйверов.
    Так что прежде чем писать что-то там о проприетарщиках и вставлять заумные слова надо бы разобраться в теме сначала.
     
     
  • 2.8, User294 (??), 21:31, 02/03/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >производители софта сами должны используя эту бибилиотеку переписать свои софтины на
    >"правильное" использование драйверов.

    Ну вот я про то и говорю - идите теперь и делайте минет топам из eBay по шустренькому (название у них как раз подходящее) чтоб они вам это переписали, сами то вы это сделать не сможете :P.Иначе будете еще лет пять в обломе куковать и вот так вот дружественно сношаться с ОС при нужде поюзать эту проприетарную байду :)

     

  • 1.6, Georges (ok), 16:51, 02/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    скоро скайп будет в виде opensource плагина к kopete
     
     
  • 2.9, User294 (??), 21:41, 02/03/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >скоро скайп будет в виде opensource плагина к kopete

    А что, кто-то уже нормально распотрошил его протокол и написал рабочую реализациююю?Или опенсорс плагин будет лишь банальным враппером к жирному проприетарному блобу?

    И кстати асечные выкрутки рук некоторых ничему не научили :).Хоть скайп и P2P, у скайпа тоже есть центральные сервера которыми владеет одна шарага.Авторизацией занимаются.В итоге - если eBay решит кому-то что-то навязать, как то например показ рекламы и что там еще - а кто им запретит то? :)

     

  • 1.7, Аноним (4), 21:03, 02/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >> начиная с версии libv4l 0.5.8

    не везде не все и не всегда - если у Вас все ок незначит что это везде сразу подхватывается

     
     
  • 2.11, SwitNJ (??), 14:53, 05/03/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>> начиная с версии libv4l 0.5.8
    >
    >не везде не все и не всегда - если у Вас все
    >ок незначит что это везде сразу подхватывается

    проще говоря не парьте мозги с переписыванием скрипта к каждой программе - достаточно в .profile или в .bashrc прописать ту самую заветную строчку
    export LD_PRELOAD=... и все будет пучком!
    а то с такими темпами как вы предлагаете скрипты писать все юзеры побегут с соплями и стонами обратно на винду

     

  • 1.10, slepnoga (??), 01:12, 04/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    " /usr/bin/skype /usr/bin/skype-bin"
    Уверены в наличии скаипа в /usr/bin/skype в " Linux дистрибутиве с ядром 2.6.27" ?
     
  • 1.12, Николай Попов (?), 15:47, 14/03/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    np@nicolnx ~ $ uname -r ; which skype
    2.6.27-gentoo-r8
    /usr/bin/skype
     
  • 1.13, Balagan (?), 14:49, 20/06/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Автор спасибо огромное всё работает.
     
  • 1.14, Les (??), 02:34, 18/07/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Тема известная. Со скайпом и прочим софтом работает. А вот как все это дело подсунуть Zoneminder'у, чтоб он не выдавал зеленый мусор?
     
  • 1.15, slaine (?), 19:41, 11/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Срасибо.
    работает!
     
  • 1.16, gentleman (?), 11:30, 05/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Огромное спасибо, все заработало
     
  • 1.17, Alexander (??), 21:08, 13/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Спасибо!
     
  • 1.18, kruvalig (?), 12:08, 05/04/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Все работает. Спасибо!
     
  • 1.19, miniboom (?), 13:53, 05/05/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Она живая!!! Спасибо!
     
  • 1.20, istokin (?), 21:56, 14/10/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Скрипт подмены скайпа работает. Но если закрыть скайп то он запустится сам. Теперь выхожу из скайпа - #killall -9 skype-bin
     


     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:




    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру