mailstats - print statistics collected by sendmail
mailstats [-o] [-c ] [-C configfile] [-f statisticsfile] [-p] [-P]
The mailstats utility prints out the statistics collected by the sendmail(1M) program on mailer usage. These statistics are collected if the file indicated by the StatusFile configuration option of sendmail (defined in /etc/mail/sendmail.cf) exists. The default statistics file is /etc/mail/statistics.
To enable mailstats, you must, as root, touch /etc/mail/statistics. See the StatusFile processing option in sendmail(1M).
mailstats first prints the time that the statistics file was created and the last time it was modified. Then, the statistics for each mailer are displayed on a single line, each with the following whitespace-separated fields:
The display of statistics described above is followed by a separation line containing only equal sign (=) characters. After the separation line, a line preceded with a "T" and totaling the values for all of the mailers is displayed. This is followed by another line preceded with a "C" that lists the number of TCP connections.
To reinitialize the statistics file once a night, add an entry to root's crontab(1):
mailstats -p > /dev/null
The following options are supported:
See largefile(5) for the description of the behavior of mailstats when encountering files greater than or equal to 2 Gbyte ( 2^31 bytes).
See attributes(5) for descriptions of the following attributes:
crontab(1), cron(1M), sendmail(1M), attributes(5), largefile(5)
Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру