The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Поиск:  Каталог документации

2. Prerequisites

2.1. What are prerequisites?

Prerequisites are what you, your machine, and your distribution require before you will be able to successfully install or use DB2. The required prerequisites come straight from IBM DB2 Universal Database for UNIX Quick Beginnings. The suggested prerequisites come from experience. For your convenience, I've divided them into hardware and software requirements.

Hardware prerequisites

Processor

x86 compatible (for example, Intel, AMD, or Cyrix). I've successfully installed DB2 Version 7.1 on a Pentium Pro 200 and a Pentium II 350. Your experiences with other x86 processors would be appreciated.

Memory

For application development, I've found 96 MB of RAM is enough to run a small database and test out your applications. Even the Control Center responds acceptably if your processor speed is fast enough. In my case, I was working with a Thinkpad 600 equipped with a Pentium 233 MMX processor and 96 MB of RAM. However, more memory is recommended if you're putting your database into production or running multiple services.

Free disk space

Of course, this depends on the components you install, but for a typical installation of the DB2 Version 7.1 server, the Administration Client, the Application Development Client, the documentation, and the creation of a sample database, you will need about 350 MB of free disk space.

Software prerequisites

glibc

2.1.2 or greater. This can be a tough part of Linux to upgrade on its own, so if your current distribution doesn't meet this requirement, I would strongly suggest upgrading your entire distribution. For example, I tried upgrading only the glibc portion of TurboLinux 4.0 from 2.1.1 to 2.1.3 and ran into a whole world of trouble.

DB2 Version 7.1 should work with glibc 2.1.1. IBM sets prerequisites based on the systems with which they tested.

kernel

2.2.12 or greater. I've upgraded to both 2.2.19 and 2.4.3 and recompiled the kernel for my own purposes, and DB2 seems to work as well as before.

DB2 Version 7.1 should work with a minimum of kernel 2.2.10. IBM sets prerequisites based on the systems with which they tested.

libncurses

4.x. For db2setup to work correctly, this version of the library must be available on your system with the following pathname: /usr/lib/libncurses.so.4.

libstdc++-libc6.1-1.so.2

A file or symbolic link by this exact name is mandatory. On most distributions, this is a symbolic link to libstdc++-2.9.0.so, but on several recent distributions this is a symbolic link to libstdc++-2.10.0.so.

Note

In previous versions of this HOWTO, I stated that the exact version of libstdc++-2.9.0.so was mandatory. I was wrong.

pdksh

5.2 or greater. This is a public domain version of the Korn shell that both the DB2 installer and the DB2 commands require. You cannot do anything with DB2 without installing pdksh.

rpm

3.0 or greater. DB2 for Linux is distributed as a number of RPM packages, so you won't get far without this piece of software. For information on installing DB2 on distributions without using RPM, see Section 5.

Java

The IBM Developer Kit for Java, 1.1.8 or 1.3, is an optional component, but is required to:

  • use the DB2 Control Center to administer your databases using a graphical user interface

  • create or run Java applications, including stored procedures and user-defined functions

As of this writing, the minimum required level of the IBM Developer Kit for Java 1.1.8 is the March 22, 2000 release. You can get the IBM Developer Kit and Runtime Environment for Linux, Java Technology Edition, from the IBM Java Developer Kit downloads web site as follows:

Please note: Other versions of Java, such as the Blackdown or Sun JDKs, have not been tested with DB2 and are not supported by IBM. And no, none of the distributions I have seen so far package the IBM JDK. But do yourself a favour, and get the IBM Developer Kit for Java.

Web browser

DB2 calls the netscape command when you:

  • display the online help for the DB2 Control Center

  • display information using the DB2 Information Center

The easiest approach is to install Netscape Navigator or Communicator on your system. Netscape version 4.72 or above is required to display the Business Intelligence Quick Tour, because of its extreme use of JavaScript.

To use a browser other than Netscape to display online help or information, create a link called netscape to your preferred browser executable. The link must appear in your PATH. For example, to display online help with mozilla, you could create a link in /usr/local/bin with the following command:
bash# ln -s /usr/bin/mozilla-bin /usr/local/bin/netscape

In the following table:




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру