The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Sound в FreeBSD не работает, почему???"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Sound в FreeBSD не работает, почему???"
Сообщение от Azazela emailИскать по авторуВ закладки on 17-Ноя-02, 10:21  (MSK)
Как полагается собрал ядро с поддержкой звука.
Определилась, как pcm:creative emu10k1 ox10e0-0x10ff irq 9 at device 16.0 on pci0."
Запустил конфигуратор:
sh MAKEDEV snd0
sh MAKEDEV snd1
Вобшем как по учебнику, а он только сконфигурил midi, а вот насчет остального audio,dsp,dspW,mixer,music,sequencer,pss не захотел.
Они конечно валяются в /dev...но не как обычные девайсы...

Может кто подскажет как запустить звук.
P.S.
Карточка Creative SB live

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от BSDLamer Искать по авторуВ закладки on 17-Ноя-02, 11:11  (MSK)
>Как полагается собрал ядро с поддержкой звука.
>Определилась, как pcm:creative emu10k1 ox10e0-0x10ff irq 9 at device 16.0 on pci0."
>
>Запустил конфигуратор:
>sh MAKEDEV snd0
>sh MAKEDEV snd1
>Вобшем как по учебнику, а он только сконфигурил midi, а вот насчет
>остального audio,dsp,dspW,mixer,music,sequencer,pss не захотел.
>Они конечно валяются в /dev...но не как обычные девайсы...
>
>Может кто подскажет как запустить звук.
>P.S.
>Карточка Creative SB live

что происходит когда пытаешься послушать чтото ?


  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от Groof emailИскать по авторуВ закладки on 17-Ноя-02, 13:05  (MSK)
У меня KDE да и Gnome кричят что dsp не сконфигурирован...
Я тут еше коечто поискал и вот на что наткнулся:
>Note: The Sound Blaster Live is not supported under FreeBSD 4.0 without >a patch, which this document will not cover.
И где его мне искат, на офицальных только об этом, а самого патьча нет.. хотя у меня 4.7 может поможет всеже ...
Ктонибуть его видел???

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от Azazela emailИскать по авторуВ закладки on 17-Ноя-02, 13:13  (MSK)
Да нечего не происходит, разве что  KDE и GNOME кричат что dsp не сконфигурирован....
Я еще полазил и вот на что наткнулся:
>Note: The Sound Blaster Live is not supported under FreeBSD 4.0 without >a patch, which this document will not cover. It is recommended that you >update to the latest -STABLE before trying to use this card.
И где мне его взять, на фришных сайтах только и говориться о об этом патче, а где его взять нету, хотя у меня версия 4.7 может всетаки поможет..


  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от guns_linger emailИскать по авторуВ закладки on 17-Ноя-02, 15:36  (MSK)
>Как полагается собрал ядро с поддержкой звука.
>Определилась, как pcm:creative emu10k1 ox10e0-0x10ff irq 9 at device 16.0 on pci0."
>
>Запустил конфигуратор:
>sh MAKEDEV snd0
>sh MAKEDEV snd1
>Вобшем как по учебнику, а он только сконфигурил midi, а вот насчет
>остального audio,dsp,dspW,mixer,music,sequencer,pss не захотел.
>Они конечно валяются в /dev...но не как обычные девайсы...
>
>Может кто подскажет как запустить звук.
>P.S.
>Карточка Creative SB live


сделай просто sh MAKEDEV snd0 (без snd1)


  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от guns_linger emailИскать по авторуВ закладки on 17-Ноя-02, 15:38  (MSK)
а,еще ;)
патч для 4.7 не нужен

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от lavr emailИскать по авторуВ закладки on 17-Ноя-02, 18:28  (MSK)
>Как полагается собрал ядро с поддержкой звука.
>Определилась, как pcm:creative emu10k1 ox10e0-0x10ff irq 9 at device 16.0 on pci0."
>
>Запустил конфигуратор:
>sh MAKEDEV snd0
>sh MAKEDEV snd1
>Вобшем как по учебнику, а он только сконфигурил midi, а вот насчет
>остального audio,dsp,dspW,mixer,music,sequencer,pss не захотел.
>Они конечно валяются в /dev...но не как обычные девайсы...
>
>Может кто подскажет как запустить звук.
>P.S.
>Карточка Creative SB live

1. сделать:

dmesg | grep pcm0

если есть такое устройство, тогда:

cd /dev
./MAKEDEV snd0
ls -la /dev/audio*
ls -la /dev/dsp*
ls -la /dev/mixer*
ls -la /dev/dspW*
ls -la /dev/sndstat

если нет, тогда:

dmesg | grep pcm1 и:

cd /dev
./MAKEDEV snd1

2. cat < /dev/sndstat

3. без запуска X11 попробовать проиграть .au, .wav, .mp3 в консольном режиме:

cd /usr/ports/audio/mpg123
make && make install
cd /usr/ports/audio/cdplay
make && make install
...

4. если непонятно:

http://unix1.jinr.ru/~lavr/freebsd_sound.html

если все равно непонятно, смотреть как собраны "несчастные" KDE/GNOME:
esound support, art support

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от Azazela emailИскать по авторуВ закладки on 18-Ноя-02, 09:12  (MSK)
Спасибо за советы, да на ссылки.
А вот как сделать так что бы после команды sh MAKEDEV snd0  и sh MAKEDEV snd1 cконфигурились  все устройства: у меня например при  просмотре mc папки /dev как устройства выглядят
midi0 midi1 mixer0 mixer1 music0 music1 pss0 pss1,  
а вот
@audio, @audio0, @audio1 . @dsp, @dsp0, @dsp1, @dspW @dspW0 @dspW1, @midi, @mixer, @music, @pss
выглядят так со знаком @ и имеют размер когда все остальные нулевые  это нормально???

  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от lavr emailИскать по авторуВ закладки on 18-Ноя-02, 10:18  (MSK)
>Спасибо за советы, да на ссылки.
>А вот как сделать так что бы после команды sh MAKEDEV snd0
> и sh MAKEDEV snd1 cконфигурились  все устройства: у меня
>например при  просмотре mc папки /dev как устройства выглядят
>midi0 midi1 mixer0 mixer1 music0 music1 pss0 pss1,
>а вот
>@audio, @audio0, @audio1 . @dsp, @dsp0, @dsp1, @dspW @dspW0 @dspW1, @midi, @mixer,
>@music, @pss
>выглядят так со знаком @ и имеют размер когда все остальные нулевые
> это нормально???
>

поменьше надо использовать mc и побольше ls если что-то непонятно

в mc для различия файлов используются как цвета, так и спец,символы,
"@" указывает на то что это линк.

команда ./MAKEDEV snd0 создаст все необходимые файлы устройств, если что-то неясно:

[unix1]~ > file /dev/MAKEDEV
/dev/MAKEDEV: Bourne shell script text executable
[unix1]~ >

это означает что MAKEDEV - скрипт, если интересно less /dev/MAKEDEV для
изучения

  Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от Azazela Искать по авторуВ закладки on 18-Ноя-02, 15:03  (MSK)
Может тогда подскажешь что я не так не делаю...
Вот собрал ядрос с поддержкой pci и pcm
Перезагрузился, на каманду dmesg | grep pcm выдал
pcm:creative emu10k1 ox10e0-0x10ff irq 9 at device 16.0 on pci0.
запустил
sh MAKEDEV snd0
sh MAKEDEV snd1
Поставила  mpg123
Запускаю mpg123 а он говорит что не может открыть дивайс....
  Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от lavr emailИскать по авторуВ закладки on 18-Ноя-02, 15:18  (MSK)
>Может тогда подскажешь что я не так не делаю...
>Вот собрал ядрос с поддержкой pci и pcm
>Перезагрузился, на каманду dmesg | grep pcm выдал
>pcm:creative emu10k1 ox10e0-0x10ff irq 9 at device 16.0 on pci0.
>запустил
>sh MAKEDEV snd0
>sh MAKEDEV snd1

ну и зачем оба snd0 и snd1?

>Поставила  mpg123
>Запускаю mpg123 а он говорит что не может открыть дивайс....

если что неясно - все вопросы почтой.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "RE: Sound в FreeBSD не работает, почему???"
Сообщение от Azazela emailИскать по авторуВ закладки on 18-Ноя-02, 09:12  (MSK)
Спасибо за советы, да на ссылки.
А вот как сделать так что бы после команды sh MAKEDEV snd0  и sh MAKEDEV snd1 cконфигурились  все устройства: у меня например при  просмотре mc папки /dev как устройства выглядят
midi0 midi1 mixer0 mixer1 music0 music1 pss0 pss1,  
а вот
@audio, @audio0, @audio1 . @dsp, @dsp0, @dsp1, @dspW @dspW0 @dspW1, @midi, @mixer, @music, @pss
выглядят так со знаком @ и имеют размер когда все остальные нулевые  это нормально???

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру