The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Скажите наконец ! как обновить glibc в linux!!!!"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от Amigo Искать по авторуВ закладки on 22-Сен-03, 02:00  (MSK)
>>>вот чего ругается
>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>ошибка: неудовлетворенные зависимости:
>>>        glibc-common = 2.3-1asp нужен
>>>для glibc-2.3-1asp
>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>ошибка: неудовлетворенные зависимости:
>>>        glibc < 2.3 конфликтует
>>>с glibc-common-2.3-1asp
>>
>>
>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>
>запустил и получилось:
># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>ошибка: неудовлетворенные зависимости:
>        glibc = 2.2.5 нужен
>для glibc-devel-2.2.5-37asp
>
>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?


Это тред из форума выцепил! имею тоже самое.
Абсолютно теже проблемы только на красной шапке!!!
Кто скажет как наконец этот злощасный glibc обновить!!??

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от Amigo Искать по авторуВ закладки on 22-Сен-03, 11:32  (MSK)
>>>>вот чего ругается
>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>ошибка: неудовлетворенные зависимости:
>>>>        glibc-common = 2.3-1asp нужен
>>>>для glibc-2.3-1asp
>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>ошибка: неудовлетворенные зависимости:
>>>>        glibc < 2.3 конфликтует
>>>>с glibc-common-2.3-1asp
>>>
>>>
>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>
>>запустил и получилось:
>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>ошибка: неудовлетворенные зависимости:
>>        glibc = 2.2.5 нужен
>>для glibc-devel-2.2.5-37asp
>>
>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>
>
>Это тред из форума выцепил! имею тоже самое.
>Абсолютно теже проблемы только на красной шапке!!!
>Кто скажет как наконец этот злощасный glibc обновить!!??


Пацаны! ну как там дела!? что скажете?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от lavr emailИскать по авторуВ закладки on 22-Сен-03, 11:54  (MSK)
>>>>>вот чего ругается
>>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>>ошибка: неудовлетворенные зависимости:
>>>>>        glibc-common = 2.3-1asp нужен
>>>>>для glibc-2.3-1asp
>>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>>ошибка: неудовлетворенные зависимости:
>>>>>        glibc < 2.3 конфликтует
>>>>>с glibc-common-2.3-1asp
>>>>
>>>>
>>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>
>>>запустил и получилось:
>>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>ошибка: неудовлетворенные зависимости:
>>>        glibc = 2.2.5 нужен
>>>для glibc-devel-2.2.5-37asp
>>>
>>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>>
>>
>>Это тред из форума выцепил! имею тоже самое.
>>Абсолютно теже проблемы только на красной шапке!!!
>>Кто скажет как наконец этот злощасный glibc обновить!!??
>
>
>Пацаны! ну как там дела!? что скажете?

приблизительно так:


https://rhn.redhat.com/errata/RHBA-2003-136.html

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от davey Искать по авторуВ закладки on 23-Сен-03, 01:30  (MSK)
>>>>>>вот чего ругается
>>>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>        glibc-common = 2.3-1asp нужен
>>>>>>для glibc-2.3-1asp
>>>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>        glibc < 2.3 конфликтует
>>>>>>с glibc-common-2.3-1asp
>>>>>
>>>>>
>>>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>
>>>>запустил и получилось:
>>>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>ошибка: неудовлетворенные зависимости:
>>>>        glibc = 2.2.5 нужен
>>>>для glibc-devel-2.2.5-37asp
>>>>
>>>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>>>
>>>
>>>Это тред из форума выцепил! имею тоже самое.
>>>Абсолютно теже проблемы только на красной шапке!!!
>>>Кто скажет как наконец этот злощасный glibc обновить!!??
>>
>>
>>Пацаны! ну как там дела!? что скажете?
>
>приблизительно так:
>
>
>https://rhn.redhat.com/errata/RHBA-2003-136.html


Никак не обновишься
Ты же хочешь обновиться с glibc2.2 на glibc2.3, а их можно только в пределах одной версии обновлять т.е. 2.2.0 на 2.2.5 например

и это же glibc всетаки, с ней все бинарники связаны

даже если обновить(я делал), то толку мало rpm выдавал segmentation fault
ставь следующий дистр :)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от lavr emailИскать по авторуВ закладки on 23-Сен-03, 10:29  (MSK)
>>>>>>>вот чего ругается
>>>>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>        glibc-common = 2.3-1asp нужен
>>>>>>>для glibc-2.3-1asp
>>>>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>        glibc < 2.3 конфликтует
>>>>>>>с glibc-common-2.3-1asp
>>>>>>
>>>>>>
>>>>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>
>>>>>запустил и получилось:
>>>>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>ошибка: неудовлетворенные зависимости:
>>>>>        glibc = 2.2.5 нужен
>>>>>для glibc-devel-2.2.5-37asp
>>>>>
>>>>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>>>>
>>>>
>>>>Это тред из форума выцепил! имею тоже самое.
>>>>Абсолютно теже проблемы только на красной шапке!!!
>>>>Кто скажет как наконец этот злощасный glibc обновить!!??
>>>
>>>
>>>Пацаны! ну как там дела!? что скажете?
>>
>>приблизительно так:
>>
>>
>>https://rhn.redhat.com/errata/RHBA-2003-136.html
>
>
>Никак не обновишься
>Ты же хочешь обновиться с glibc2.2 на glibc2.3, а их можно только
>в пределах одной версии обновлять т.е. 2.2.0 на 2.2.5 например
>
>и это же glibc всетаки, с ней все бинарники связаны

и что? или опять в Linux'е коренным образом изменили ряд вызовов и
инклюдов?!

>даже если обновить(я делал), то толку мало rpm выдавал segmentation fault
>ставь следующий дистр :)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от davey Искать по авторуВ закладки on 23-Сен-03, 11:54  (MSK)
>>>>>>>>вот чего ругается
>>>>>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>        glibc-common = 2.3-1asp нужен
>>>>>>>>для glibc-2.3-1asp
>>>>>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>>>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>        glibc < 2.3 конфликтует
>>>>>>>>с glibc-common-2.3-1asp
>>>>>>>
>>>>>>>
>>>>>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>>
>>>>>>запустил и получилось:
>>>>>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>        glibc = 2.2.5 нужен
>>>>>>для glibc-devel-2.2.5-37asp
>>>>>>
>>>>>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>>>>>
>>>>>
>>>>>Это тред из форума выцепил! имею тоже самое.
>>>>>Абсолютно теже проблемы только на красной шапке!!!
>>>>>Кто скажет как наконец этот злощасный glibc обновить!!??
>>>>
>>>>
>>>>Пацаны! ну как там дела!? что скажете?
>>>
>>>приблизительно так:
>>>
>>>
>>>https://rhn.redhat.com/errata/RHBA-2003-136.html
>>
>>
>>Никак не обновишься
>>Ты же хочешь обновиться с glibc2.2 на glibc2.3, а их можно только
>>в пределах одной версии обновлять т.е. 2.2.0 на 2.2.5 например
>>
>>и это же glibc всетаки, с ней все бинарники связаны
>
>и что? или опять в Linux'е коренным образом изменили ряд вызовов и
>
>инклюдов?!
>
да не знаю я честно говоря, что они там сделали
но ее можно обновить из исходников, а для этого надо обновить gcc, binutils, modutils может еще чего
и это не относится к линуксу, как к таковому, это относится скорее к самой  glibc. Если хочешь ставь из исходников, но для этого тебе нужен будет какой-нибудь загрузочный линукс(т.е. не тот на котором обновляешь)
в любом случае мне кажется, что стабильность системы будет не та, и ты потеряешь стройность rpm пакетов (у тебя будет что binutils, modutils, glibc стоят как бы из rpm, а на самом деле они "самодельные")и как я уже говорил сама rpm не работает.
>>даже если обновить(я делал), то толку мало rpm выдавал segmentation fault
>>ставь следующий дистр :)


  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от lavr emailИскать по авторуВ закладки on 23-Сен-03, 12:23  (MSK)
>>>>>>>>>вот чего ругается
>>>>>>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>>        glibc-common = 2.3-1asp нужен
>>>>>>>>>для glibc-2.3-1asp
>>>>>>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>>>>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>>        glibc < 2.3 конфликтует
>>>>>>>>>с glibc-common-2.3-1asp
>>>>>>>>
>>>>>>>>
>>>>>>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>>>
>>>>>>>запустил и получилось:
>>>>>>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>        glibc = 2.2.5 нужен
>>>>>>>для glibc-devel-2.2.5-37asp
>>>>>>>
>>>>>>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>>>>>>
>>>>>>
>>>>>>Это тред из форума выцепил! имею тоже самое.
>>>>>>Абсолютно теже проблемы только на красной шапке!!!
>>>>>>Кто скажет как наконец этот злощасный glibc обновить!!??
>>>>>
>>>>>
>>>>>Пацаны! ну как там дела!? что скажете?
>>>>
>>>>приблизительно так:
>>>>
>>>>
>>>>https://rhn.redhat.com/errata/RHBA-2003-136.html
>>>
>>>
>>>Никак не обновишься
>>>Ты же хочешь обновиться с glibc2.2 на glibc2.3, а их можно только
>>>в пределах одной версии обновлять т.е. 2.2.0 на 2.2.5 например
>>>
>>>и это же glibc всетаки, с ней все бинарники связаны
>>
>>и что? или опять в Linux'е коренным образом изменили ряд вызовов и
>>
>>инклюдов?!
>>
>да не знаю я честно говоря, что они там сделали
>но ее можно обновить из исходников, а для этого надо обновить gcc,
>binutils, modutils может еще чего
>и это не относится к линуксу, как к таковому, это относится скорее
>к самой  glibc. Если хочешь ставь из исходников, но для
>этого тебе нужен будет какой-нибудь загрузочный линукс(т.е. не тот на котором
>обновляешь)
>в любом случае мне кажется, что стабильность системы будет не та, и
>ты потеряешь стройность rpm пакетов (у тебя будет что binutils, modutils,
>glibc стоят как бы из rpm, а на самом деле они
>"самодельные")и как я уже говорил сама rpm не работает.
>>>даже если обновить(я делал), то толку мало rpm выдавал segmentation fault
>>>ставь следующий дистр :)

если говорить о *nix'ах, то на *BSD, на Solaris (patches, cluster-patches), я обновляю libc (то что в Linux glibc) без проблем, если
сама библиотека не изменилась коренным образом

если же существенно меняется glibc, как это было при переходе с libc5,
то было соответствующее README, вобщем опять в Линуксе или намудрили или
наделали ошибок в glibc-2.3.x. Похоже намудрили, судя по разным спискам
рассылки разных дистрибутивов линукс, самый простой вариант:

- backup
- install более свежий дистрибутив (красота :)

http://www.linux-sxs.org/upgrading/glibc.html
http://www.linuxmanagers.org/pipermail/linuxmanagers/2003-February/000983.html
http://list.ftech.net/pipermail/gllug/2003-January/031021.html

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Скажите наконец ! как обновить glibc в linux!!!!"
Сообщение от Amigo Искать по авторуВ закладки on 23-Сен-03, 21:24  (MSK)
>>>>>>>>>>вот чего ругается
>>>>>>>>>># rpm -i ./glibc-2.3-1asp.i386.rpm
>>>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>>>        glibc-common = 2.3-1asp нужен
>>>>>>>>>>для glibc-2.3-1asp
>>>>>>>>>>        glibc > 2.2.5 конфликтует с glibc-common-2.2.5-37asp
>>>>>>>>>># rpm -i ./glibc-common-2.3-1asp.i386.rpm
>>>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>>>        glibc < 2.3 конфликтует
>>>>>>>>>>с glibc-common-2.3-1asp
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>>>>
>>>>>>>>запустил и получилось:
>>>>>>>># rpm -U ./glibc-common-2.3-1asp.i386.rpm ./glibc-2.3-1asp.i386.rpm
>>>>>>>>ошибка: неудовлетворенные зависимости:
>>>>>>>>        glibc = 2.2.5 нужен
>>>>>>>>для glibc-devel-2.2.5-37asp
>>>>>>>>
>>>>>>>>glibc-2.2.5-37asp.i386.rpm, glibc-common-2.2.5-37asp.i386.rpm, glibc-devel-2.2.5-37asp установлены, чего делать?
>>>>>>>
>>>>>>>
>>>>>>>Это тред из форума выцепил! имею тоже самое.
>>>>>>>Абсолютно теже проблемы только на красной шапке!!!
>>>>>>>Кто скажет как наконец этот злощасный glibc обновить!!??
>>>>>>
>>>>>>
>>>>>>Пацаны! ну как там дела!? что скажете?
>>>>>
>>>>>приблизительно так:
>>>>>
>>>>>
>>>>>https://rhn.redhat.com/errata/RHBA-2003-136.html
>>>>
>>>>
>>>>Никак не обновишься
>>>>Ты же хочешь обновиться с glibc2.2 на glibc2.3, а их можно только
>>>>в пределах одной версии обновлять т.е. 2.2.0 на 2.2.5 например
>>>>
>>>>и это же glibc всетаки, с ней все бинарники связаны
>>>
>>>и что? или опять в Linux'е коренным образом изменили ряд вызовов и
>>>
>>>инклюдов?!
>>>
>>да не знаю я честно говоря, что они там сделали
>>но ее можно обновить из исходников, а для этого надо обновить gcc,
>>binutils, modutils может еще чего
>>и это не относится к линуксу, как к таковому, это относится скорее
>>к самой  glibc. Если хочешь ставь из исходников, но для
>>этого тебе нужен будет какой-нибудь загрузочный линукс(т.е. не тот на котором
>>обновляешь)
>>в любом случае мне кажется, что стабильность системы будет не та, и
>>ты потеряешь стройность rpm пакетов (у тебя будет что binutils, modutils,
>>glibc стоят как бы из rpm, а на самом деле они
>>"самодельные")и как я уже говорил сама rpm не работает.
>>>>даже если обновить(я делал), то толку мало rpm выдавал segmentation fault
>>>>ставь следующий дистр :)
>
>если говорить о *nix'ах, то на *BSD, на Solaris (patches, cluster-patches), я
>обновляю libc (то что в Linux glibc) без проблем, если
>сама библиотека не изменилась коренным образом
>
>если же существенно меняется glibc, как это было при переходе с libc5,
>
>то было соответствующее README, вобщем опять в Линуксе или намудрили или
>наделали ошибок в glibc-2.3.x. Похоже намудрили, судя по разным спискам
>рассылки разных дистрибутивов линукс, самый простой вариант:
>
>- backup
>- install более свежий дистрибутив (красота :)
>
>http://www.linux-sxs.org/upgrading/glibc.html
>http://www.linuxmanagers.org/pipermail/linuxmanagers/2003-February/000983.html
>http://list.ftech.net/pipermail/gllug/2003-January/031021.html


Да тут все ясно!! Полный Пи3gel]!!! Вчера попробовал обновить!!! хорошо на тестовой машине!!! а хотел сразу на сервак залить!! все либы так перекорежило, вообще гризиться перестал, хорошо бэкап был. а так пиши -пропало!
Видимо чето там пацаны на перекосячили!!

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру