The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от pawko (ok) on 06-Ноя-08, 14:32 
Здравствуйте
Решил попробовать поставить Abills и столкнулся с проблемой...
Не хочет устанавливаться радиус.
С портов тоже... поэтому ставлю с исходников...
что делаю...
#сd freeradius-1.1.7
#./configure
#make

и ловлю ошибку

/home/pahan/abills/freeradius-1.1.7/src/include/modpriv.h:7:18: error: ltdl.h: No such file or directory
In file included from rlm_sqlippool.c:37:
/home/pahan/abills/freeradius-1.1.7/src/include/modpriv.h:16: error: expected specifier-qualifier-list before 'lt_dlhandle'
In file included from rlm_sqlippool.c:39:
/home/pahan/abills/freeradius-1.1.7/src/modules/rlm_sql/rlm_sql.h:15:18: error: ltdl.h: No such file or directory
In file included from rlm_sqlippool.c:39:
/home/pahan/abills/freeradius-1.1.7/src/modules/rlm_sql/rlm_sql.h:68: error: expected specifier-qualifier-list before 'lt_dlhand
rlm_sqlippool.c: In function 'sqlippool_command':
rlm_sqlippool.c:311: error: 'SQL_INST' has no member named 'module'
rlm_sqlippool.c: In function 'sqlippool_query1':
rlm_sqlippool.c:358: error: 'SQL_INST' has no member named 'module'
rlm_sqlippool.c: In function 'sqlippool_postauth':
rlm_sqlippool.c:539: warning: pointer targets in passing argument 2 of 'strNcpy' differ in signedness
rlm_sqlippool.c:526: warning: unused variable 'self'
gmake[5]: *** [rlm_sqlippool.lo] Error 1
gmake[5]: Leaving directory `/home/pahan/abills/freeradius-1.1.7/src/modules/rlm_sqlippool'
gmake[4]: *** [common] Error 2
gmake[4]: Leaving directory `/home/pahan/abills/freeradius-1.1.7/src/modules'
gmake[3]: *** [all] Error 2
gmake[3]: Leaving directory `/home/pahan/abills/freeradius-1.1.7/src/modules'
gmake[2]: *** [common] Error 2
gmake[2]: Leaving directory `/home/pahan/abills/freeradius-1.1.7/src'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory `/home/pahan/abills/freeradius-1.1.7/src'
gmake: *** [common] Error 2
*** Error code 2

Stop in /home/pahan/abills/freeradius-1.1.7.

Ничего не нашел толкового в гугле... помогите...

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от Square (ok) on 06-Ноя-08, 14:54 
>Здравствуйте
>Решил попробовать поставить Abills и столкнулся с проблемой...
>Не хочет устанавливаться радиус.
>С портов тоже... поэтому ставлю с исходников...

а какая ошибка если ставить из портов?

>/home/pahan/abills/freeradius-1.1.7/src/include/modpriv.h:7:18: error: ltdl.h: No such file or directory

нет файла...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от pawko (ok) on 06-Ноя-08, 14:56 

>>/home/pahan/abills/freeradius-1.1.7/src/include/modpriv.h:7:18: error: ltdl.h: No such file or directory
>
>нет файла...

Это я понимаю... вот только где он должен быть?

Если с потров -
kvhoit02# cd /usr/ports/net/freeradius
kvhoit02# make
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/python2.5 - found
===>   freeradius-1.1.7_2 depends on executable: gmake - found
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/perl5.8.8 - found
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/autoconf-2.61 - found
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/libtool - found
===>   freeradius-1.1.7_2 depends on shared library: gdbm.3 - found
===>   freeradius-1.1.7_2 depends on shared library: snmp.4 - not found
===>    Verifying install for snmp.4 in /usr/ports/net-mgmt/net-snmp4
===>  ucd-snmp-4.2.6_7 is marked as broken: Does not compile on FreeBSD >= 7.0.
*** Error code 1

Stop in /usr/ports/net-mgmt/net-snmp4.
*** Error code 1

Stop in /usr/ports/net/freeradius.
*** Error code 1

Stop in /usr/ports/net/freeradius.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от Square (ok) on 06-Ноя-08, 15:01 
>
>>>/home/pahan/abills/freeradius-1.1.7/src/include/modpriv.h:7:18: error: ltdl.h: No such file or directory
>>
>>нет файла...
>
>Это я понимаю... вот только где он должен быть?

поищите в гугле что это за файл и к чему он относится..

>Если с потров -
>kvhoit02# cd /usr/ports/net/freeradius
>kvhoit02# make

=>    Verifying install for snmp.4 in /usr/ports/net-mgmt/net-snmp4
>===>  ucd-snmp-4.2.6_7 is marked as broken: Does not compile on FreeBSD >= 7.0.
>*** Error code 1

фря как всегда жгеть :)

попробуйте сделать make configure и собрать радиус без поддержки snmp

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от pawko (ok) on 06-Ноя-08, 15:19 
kvhoit02# make configure without-snmp
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/python2.5 - found
===>   freeradius-1.1.7_2 depends on executable: gmake - found
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/perl5.8.8 - found
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/autoconf-2.61 - found
===>   freeradius-1.1.7_2 depends on file: /usr/local/bin/libtool - found
===>   freeradius-1.1.7_2 depends on shared library: gdbm.3 - found
===>   freeradius-1.1.7_2 depends on shared library: snmp.4 - not found
===>    Verifying install for snmp.4 in /usr/ports/net-mgmt/net-snmp4
===>  ucd-snmp-4.2.6_7 is marked as broken: Does not compile on FreeBSD >= 7.0.
*** Error code 1

Stop in /usr/ports/net-mgmt/net-snmp4.
*** Error code 1

Stop in /usr/ports/net/freeradius.
*** Error code 1

Stop in /usr/ports/net/freeradius.

Не пошло... или я туплю... уже голова деревянная...

На щет ltdl.h
то он есть во всех положенных ему местах
>> /usr/local/include/ltdl.h
>> /usr/local/share/libtool13/libltdl/ltdl.h
>> /usr/local/share/libtool15/libltdl/ltdl.h

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от pawko (ok) on 06-Ноя-08, 15:39 
пытаюсь поставить из портов этот ucd-snmp-4.2.6
выбрасывает
kvhoit02# make
===>  ucd-snmp-4.2.6_7 is marked as broken: Does not compile on FreeBSD >= 7.0.
*** Error code 1

Stop in /usr/ports/net-mgmt/net-snmp4.

Пытаюсь поставить из tar.gz, пишет

scapi.c: In function 'sc_encrypt':
scapi.c:503: error: 'des_key_schedule' undeclared (first use in this function)
scapi.c:503: error: (Each undeclared identifier is reported only once
scapi.c:503: error: for each function it appears in.)
scapi.c:503: error: expected ';' before 'key_sch'
scapi.c:504: error: 'des_cblock' undeclared (first use in this function)
scapi.c:504: error: expected ';' before 'key_struct'
scapi.c:591: error: 'key_struct' undeclared (first use in this function)
scapi.c:592: error: 'key_sch' undeclared (first use in this function)
scapi.c:597: error: expected expression before ')' token
scapi.c:601: error: expected expression before ')' token
scapi.c: In function 'sc_decrypt':
scapi.c:671: error: 'des_key_schedule' undeclared (first use in this function)
scapi.c:671: error: expected ';' before 'key_sch'
scapi.c:672: error: 'des_cblock' undeclared (first use in this function)
scapi.c:672: error: expected ';' before 'key_struct'
scapi.c:714: error: 'key_struct' undeclared (first use in this function)
scapi.c:715: error: 'key_sch' undeclared (first use in this function)
scapi.c:719: error: expected expression before ')' token
*** Error code 1

Stop in /home/pahan/abills/ucd-snmp-4.2.6/snmplib.
*** Error code 1

Stop in /home/pahan/abills/ucd-snmp-4.2.6.

Версию ucd-snmp-4.2.7.1 - поставил... но толку... нужна то не она
Что это может быть?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от pawko (ok) on 06-Ноя-08, 15:47 
Установил... может у кого-то будет подобная проблема. Решил так...
Взял файл ltdl.h
Втупую скопировал в директорию ..../abills/freeradius-1.1.7/src/include/
И все заработало

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от zim email on 01-Дек-08, 22:09 
А можно поподробнее.А то я только начал знакомство с фрю.Как я понял ты поставил сначала abills копернул туда ltdl.h, а только потом поставил с портов Freeradius.Или  я че-то не так понял?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Проблема с установкой freeradius-1.1.7 на FreeBSD 7.0"  
Сообщение от Square (ok) on 06-Ноя-08, 15:53 

>Версию ucd-snmp-4.2.7.1 - поставил... но толку... нужна то не она

выполнить очистку порта от прежнего конфига

выполнить последовательно:
make clean #прибьет следы прежней недокомпиляции
make configure # позволит если есть возможность указать параметры сборки

и тока после этого  -

make

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру