The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"При формировании автоответа ошибка Exim"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Почта / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"При формировании автоответа ошибка Exim"  +/
Сообщение от bobot email(??) on 29-Мрт-10, 15:43 
Я в роутере exim прописую
 
userautoreply:
driver = autoreply
from = ${local_part}@${domain}
reply_to = ${local_part}@${domain}
to = ${sender_address}
subject = AutoReply Re: ${rfc2047:$h_Subject:}
text = ${lookup mysql{SELECT message FROM autoreply WHERE recipient='${local_part}@${domain}'}}


Транспорт


userautoreply:
driver = accept
condition = ${if eq{} {${lookup mysql{SELECT recipient FROM autoreply \
WHERE recipient='${local_part}@${domain}'}}}{no}{yes}}
senders = " ! ^.*-request@.*:\
! ^owner-.*@.*:\
! ^postmaster@.*:\
! ^listmaster@.*:\
! ^mailer-daemon@.*\
! ^root@.*\
! ^noreply@.*"
no_expn
no_verify
transport = userautoreply
unseen

При рестарте экзима ошибка: cannot find router driver "autoreply"
Может я не туда в роутерах ставлю?
Или у меня экзим собран без поддержки autoreply?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "При формировании автоответа ошибка Exim"  +/
Сообщение от bill (ok) on 29-Мрт-10, 19:37 
>[оверквотинг удален]
>! ^noreply@.*"
>no_expn
>no_verify
>transport = userautoreply
>unseen
>
>
>При рестарте экзима ошибка: cannot find router driver "autoreply"
>Может я не туда в роутерах ставлю?
>Или у меня экзим собран без поддержки autoreply?

эта строка в роутере должна быть.
transport = userautoreply

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "При формировании автоответа ошибка Exim"  +/
Сообщение от bobot email(??) on 30-Мрт-10, 00:02 
>эта строка в роутере должна быть.
>transport = userautoreply

Не понял какая строчка и вместо какой можно уточнить?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "При формировании автоответа ошибка Exim"  +/
Сообщение от bobot email(??) on 30-Мрт-10, 12:04 
>эта строка в роутере должна быть.
>transport = userautoreply

Всё спасибо разобрался работает

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "При формировании автоответа ошибка Exim"  +/
Сообщение от DarkAnge1 (ok) on 09-Июл-10, 12:52 
>>эта строка в роутере должна быть.
>>transport = userautoreply
>
>Всё спасибо разобрался работает

что-то смотрю в книгу вижу фигу.
Автореплай настраивал по той же статье, получил ту же ошибку.
Перенес строку transport = userautoreply из транспорта в роутер, но проблему это не решило.
Подскажите, где я был не прав?

ЗЫ.
в транспорте:

userautoreply:
driver = accept
condition = "user@mydomain.com"
senders = " ! ^.*-request@.*:\
! ^owner-.*@.*:\
! ^postmaster@.*:\
! ^listmaster@.*:\
! ^mailer-daemon@.*\
! ^root@.*\
! ^noreply@.*"
no_expn
no_verify
unseen

в роутере:

userautoreply:
driver = autoreply
from = ${local_part}@${domain}
reply_to = ${local_part}@${domain}
to = ${sender_address}
subject = AutoReply Re: ${rfc2047:$h_Subject:}
text = "test bla bla bla"
transport = userautoreply

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "При формировании автоответа ошибка Exim"  +/
Сообщение от bobot email(ok) on 09-Июл-10, 13:37 
>[оверквотинг удален]
>>
>>Всё спасибо разобрался работает
>
>что-то смотрю в книгу вижу фигу.
>Автореплай настраивал по той же статье, получил ту же ошибку.
>Перенес строку transport = userautoreply из транспорта в роутер, но проблему это
>не решило.
>Подскажите, где я был не прав?
>
>ЗЫ.

Вы перепутали транспорт и роутер надо наоборот

Роутер:  (я в роутере поставилы это перед system_aliases:)

userautoreply:
driver = accept
condition = "user@mydomain.com"
senders = " ! ^.*-request@.*:\
! ^owner-.*@.*:\
! ^postmaster@.*:\
! ^listmaster@.*:\
! ^mailer-daemon@.*\
! ^root@.*\
! ^noreply@.*"
no_expn
no_verify
transport = userautoreply    ------вот тут это надо (вы пропустили)
unseen

Транспорт:  (это поставил в транспорте после remote_smtp:)

userautoreply:
driver = autoreply
from = ${local_part}@${domain}
reply_to = ${local_part}@${domain}
to = ${sender_address}
subject = AutoReply Re: ${rfc2047:$h_Subject:}
text = "test bla bla bla"
transport = userautoreply    -------тут этого не надо


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "При формировании автоответа ошибка Exim"  +/
Сообщение от DarkAnge1 (ok) on 09-Июл-10, 14:47 
>Вы перепутали транспорт и роутер надо наоборот

огромное спасибо!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру