The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Критическая уязвимость, позволяющая выполнить код вне гостев..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от opennews (??) on 13-Май-15, 21:08 
В развиваемом проектом QEMU коде эмуляции контроллера флоппи-дисков (FDC) выявлена (https://securityblog.redhat.com/2015/05/13/venom-dont-get-bi.../) критическая уязвимость (CVE-2015-3456), получившая кодовое имя VENOM (http://venom.crowdstrike.com/). Кроме QEMU драйвер также используется в системах виртуализации Xen и KVM. Уязвимость позволяет выйти за пределы гостевой системы и получить управления над базовым хост-окружением.


Пользователь гостевой системы, имеющий доступ к портам ввода/вывода может отправить эмулятору контроллера FDC специально оформленную команду, которая приведёт к переполнению буфера и выполнению произвольного кода на стороне гостевой системы с правами сопутствующего процесса QEMU. Если данный процесс выполняется с правами root, то пользователь может обойти ограничения виртуализации и из гостевого окружения получить root-доступ к основной системе.


Проблема проявляется во всех гостевых системах на базе архитектуры x86 и x86-64, выполняемых с использованием гипервизора Xen в режиме  полной виртуализации (HVM) и в системах на базе QEMU/KVM. Тип эмулируемого оборудования и настройки запуска QEMU не имеют значения, так как в режимах PIIX и ICH9 создаётся мост для шины ISA, в котором  в любом случае доступен виртуальный контроллер флоппи-дисков.


Обновления с устранением уязвимости уже выпущено для RHEL (https://access.redhat.com/articles/1444903), CentOS (http://lists.centos.org/pipermail/centos-announce/2015-May/0...),  Ubuntu (http://www.ubuntu.com/usn/usn-2608-1/)  и Debian (https://lists.debian.org/debian-security-announce/2015/msg00...). Оценить появление обновлений в других дистрибутивах можно на следующих страницах:  Fedora (https://admin.fedoraproject.org/updates/), openSUSE (http://lists.opensuse.org/opensuse-security-announce/), SLES (https://www.suse.com/support/update/), Slackware (http://www.slackware.com/security/list.php?l=slackware-secur...), Gentoo (http://www.gentoo.org/security/en/index.xml),  FreeBSD (http://www.vuxml.org/freebsd/), NetBSD (http://www.netbsd.org/support/security/). В качестве обходного пути защиты предлагается использовать  sVirt и seccomp для ограничения привилегий процесса QEMU и ограничение доступа к ресурсам.


URL: https://securityblog.redhat.com/2015/05/13/venom-dont-get-bi.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=42223

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +2 +/
Сообщение от Аноним (??) on 13-Май-15, 21:08 
> Тип эмулируемого оборудования и настройки запуска QEMU не имеют значения, так как в режимах PIIX и ICH9 создаётся мост для шины ISA, в котором в любом случае доступен виртуальный контроллер флоппи-дисков.

Ну и зачем так сделали?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

10. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +4 +/
Сообщение от Аноним (??) on 13-Май-15, 22:11 
Я бы спросил иначе. Нафуя в 2015 году вообще таскать драйвер эмулирующий флоповод?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

24. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +3 +/
Сообщение от dalco (ok) on 14-Май-15, 07:45 
Те же античные окошки в принципе ничего кроме флопика не признают во время установки, если драйвера надо поставить.

P.S. И, да, даже в 2015 году вполне актуальны виртуалки с XP/2003/2000 для каких-нибудь античных прог, написанных в 90ые (а современных аналогов нет или они стоят больше годового бюджета твоей конторы :) ).

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

31. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от none7 (ok) on 14-Май-15, 16:33 
В случае виртуалок с XP/2003/2000 эмулируется древний IDE контроллер. Который старые системы понимают без проблем встроенным в систему драйвером.
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

39. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +1 +/
Сообщение от dalco (ok) on 15-Май-15, 03:37 
Вот только virtio-драйвера производительней в разы при существенно меньшем потреблении CPU (тоже в разы). При одной, слабо нагруженной, виртуалке это не столь заметно, а если этих виртуалок у тебя десяток-два на хосте крутится?
Не, можно, конечно, инсталлировать древние окошки под эмулируемый ide-контроллер  и эмулируемый же realtek 8139, а потом все драйвера/виртуальные девайсы менять на правильные, но зачем?

В конце-концов, часть тех самых древних прог желает работать только с флопиком, то есть тот или иной эмулятор флопика в системе таки должен присутствовать.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

32. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +1 +/
Сообщение от Аноним (??) on 14-Май-15, 18:50 
Согласен. А вообще надо заметить что частенько wine тянет эти проги лучше новых версий винды.;-)
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

44. "Критическая уязвимость, позволяющая выполнить код вне..."  +/
Сообщение от arisu (ok) on 22-Май-15, 13:21 
> Я бы спросил иначе. Нафуя в 2015 году вообще таскать драйвер эмулирующий
> флоповод?

может, потому, что виртуалки не только для запихивания в них уебсервисни используются, например?

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –10 +/
Сообщение от еуые on 13-Май-15, 22:14 
К сожалению в ядре всё держится на костылях, а передалать так это надо пол ядра  переписать...
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

33. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +3 +/
Сообщение от Аноним (??) on 14-Май-15, 19:21 
Можно подумать ты в ядре хоть с пол-шишечки понимаешь Ыгспёрд :-D
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

40. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 15-Май-15, 11:42 
Ну не все же такие дегенераты как ты
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

2. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 13-Май-15, 21:09 
жду в тред того анонимуса, который противопоставлял "дырявый" докер "сверхнадежным" квм и пр.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +2 +/
Сообщение от Аноним (??) on 13-Май-15, 21:30 
Я другой ононим. Но факт в том, что в дыркере дыра на дыре, а тут вообще редчайшее явление.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +9 +/
Сообщение от Аноним (??) on 13-Май-15, 21:40 
На солнце обнаружены пятна! Ждём в тред того анонимуса, который противопоставлял "тусклые" лампы накаливания "сверхярким" звёздам и пр.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –3 +/
Сообщение от InventoRs email(ok) on 13-Май-15, 21:31 
Эпично, слов нету.
Еще бы exploit.. и все.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –2 +/
Сообщение от жабабыдлокодер (ok) on 13-Май-15, 21:35 
Программисты на С они такие программисты... Зная, что язык не контролирует переполнение массива, они все равно не контролируют массивы вручную...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –1 +/
Сообщение от Аноним (??) on 13-Май-15, 21:53 
> Программисты на С они такие программисты... Зная, что язык не контролирует переполнение массива, они все равно не контролируют массивы вручную...

Эх, а нужно то всего лишь на Go переписать...

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –2 +/
Сообщение от Gannet email(ok) on 13-Май-15, 21:59 
Зачем такая экзотика? Есть же Java!
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

34. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –1 +/
Сообщение от Аноним (??) on 14-Май-15, 19:24 
> Зачем такая экзотика? Есть же Java!

Javascript же!

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

43. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Анонимус сапиенс on 17-Май-15, 12:30 
Уже
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

9. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –1 +/
Сообщение от жабабыдлокодер (ok) on 13-Май-15, 22:08 
А нужно то всего-то написать маленькую функцию для контроля и кидать данные в массив не напрямую, а через эту функцию. Или несколько таких функций, для разных случаев. Очень сложно, да?
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

14. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 13-Май-15, 22:15 
> функций, для разных случаев. Очень сложно, да?

Виртуализатор который выдаст 30% от скорости bare metal - никто не возьмет, даже если за это приплатить.

Представь себе что на копирование каждого байта (или ворда) делается не только собственно копирование но еще и вызов функции проверки - а можно ли так копировать?! Ну и получится у тебя очередная ЖабаКотораяНеТормозит.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

16. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –1 +/
Сообщение от жабабыдлокодер (ok) on 13-Май-15, 22:21 
Во-первых, такая дырища в безопасности всяко хуже. Во-вторых, то, о чем Вы говорите, было актуально лет этак двадцать назад. Сейчас компилятор сам пересобачивает весь код, вставляя свои оптимизации. И вариант с проверкой может оказаться, в результате, даже быстрей.
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

21. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от ананим.orig on 13-Май-15, 22:57 
> Во-первых, такая дырища в безопасности всяко хуже.

да флопи вставь твою дырищу.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

35. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 14-Май-15, 19:30 
> Во-первых, такая дырища в безопасности всяко хуже.

Хуже когда молчат. Когда увидев орут и фиксят - это ОТЛИЧНО!
> Во-вторых, то, о чем Вы говорите, было актуально лет этак двадцать назад.

Театров не будет ... будет сплошное телевидение! (С)
> Сейчас компилятор сам пересобачивает весь код, вставляя свои оптимизации.

Это - про оптимизацию скорости или размера. Покажи мне хоть один компилятор пересобачивающий код для устранения секурити дыр :) То что новые добавляют stack smash это немного не то ....
> И вариант с проверкой может оказаться, в результате, даже быстрей.

Фантастика! (С)
Впрочем жабщики давно знают что jvm умнее их. Причем не потому что jvm такая умная :)))

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

27. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +2 +/
Сообщение от Michael Shigorin email(ok) on 14-Май-15, 11:45 
> Виртуализатор который выдаст 30% от скорости bare metal

bare metal шустрой 1.44M дискетки выдавал порядка 30 кб/с, помнится.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

18. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +2 +/
Сообщение от Аноним (??) on 13-Май-15, 22:27 
> Эх, а нужно то всего лишь на Go переписать...

Нужно всего лишь иметь внутреннюю дисциплину.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

11. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +4 +/
Сообщение от Аноним (??) on 13-Май-15, 22:12 
> массива, они все равно не контролируют массивы вручную...

Судя по древности бага - про драйвер флоповода, писаный левой пяткой, все просто забыли и забили.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

38. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Hile on 15-Май-15, 00:44 
Будет повод выпилить!)
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

12. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –1 +/
Сообщение от фыва email on 13-Май-15, 22:13 
хм...
а если не создавал в гипервизоре флопик для гостевой?
прокатит?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +2 +/
Сообщение от Аноним (??) on 13-Май-15, 22:16 
> а если не создавал в гипервизоре флопик для гостевой?
> прокатит?

Можно ли сломать спинку у лавочки, если она изначально без спинки? Ну вот то-то и оно - упрощение конструкции иногда дает свои результаты :)

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

17. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –1 +/
Сообщение от фыва email on 13-Май-15, 22:25 
ну мало ли...
сперва решил что, гостевой винде, создаешь эмулятор дискетки, запускаешь сплоит.. и вуаля.. гипервизор порутан..

а так, непритяно канеш, но не так смертельно уж... сми такие сми...

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

19. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +1 +/
Сообщение от sdog (ok) on 13-Май-15, 22:34 
"Также не имеет значение наличие в гостевой системе файла устройства для доступа к флоппи-диску, так как эксплуатация производится через обращение к портам ввода/вывода."

вроде как отсутствие наличия не влияет, или таки да?

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

20. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 13-Май-15, 22:48 
> вроде как отсутствие наличия не влияет, или таки да?

Не влияет поскольку, даже если флопи не будет бага будет работать. Потому что Тип эмулируемого оборудования и настройки запуска QEMU не имеют значения, так как в режимах PIIX и ICH9 создаётся мост для шины ISA, в котором в любом случае доступен виртуальный контроллер флоппи-дисков.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

36. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 14-Май-15, 23:54 
> even guests without floppy disk explicitly enabled in the libvirt or Xen configuration files are affected.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

26. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +1 +/
Сообщение от Аноним (??) on 14-Май-15, 10:21 
В новости же синим по зеленому написано, что нет
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

30. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 14-Май-15, 13:13 
За тебя его создали принудительно.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

37. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 14-Май-15, 23:54 
> even guests without floppy disk explicitly enabled in the libvirt or Xen configuration files are affected.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

23. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +1 +/
Сообщение от Аноним (??) on 14-Май-15, 04:57 
эксплойт опять самому копилировать без техподдержки?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

25. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 14-Май-15, 08:00 
да уже написали не парься
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

28. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –2 +/
Сообщение от Аноним (??) on 14-Май-15, 11:55 
Я мой дискета твой сервер шатал, да!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

29. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –2 +/
Сообщение от фыва email on 14-Май-15, 12:21 
шлюшай... вах, как харашо сказал..красавчеГ
Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

41. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  –2 +/
Сообщение от Гога on 15-Май-15, 11:56 
citrix xen кому он нужен теперь,если с версии 6.5 платным стал?!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

42. "Критическая уязвимость, позволяющая выполнить код вне гостев..."  +/
Сообщение от Аноним (??) on 16-Май-15, 09:15 
> отправить эмулятору контроллера FDC специально оформленную команду, которая приведёт к переполнению буфера и выполнению произвольного кода на стороне гостевой системы с правами сопутствующего процесса QEMU

Поможет всем: https://grsecurity.net/features.php

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру