The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Вышел mod_perl 2.0.5"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Вышел mod_perl 2.0.5"  +/
Сообщение от opennews on 09-Фев-11, 03:44 
Спустя три года с момента прошлого релиза представлена (http://mail-archives.apache.org/mod_mbox/perl-modperl/201102...) новая версия Apache-модуля mod_perl 2.0.5 (http://perl.apache.org/). Новая версия носит (http://perl.apache.org/dist/mod_perl-2.0-current/Changes) в основном корректирующий характер, исправляя накопившиеся ошибки и решая некоторые проблемы совместимости с будущей веткой Perl 5.14. В новой версии добавлена поддержка APR::Socket::fileno,  обеспечен экспорт переменной окружения PROXYREQ_RESPONSE, налажен процесс сборки с использованием не поддерживающего многопоточность APR.

Устранены потенциальные уязвимости, связанные с выходом за границы буфера в Apache2::RequestIO::read, возможностью загрузки сторонних библиотек через APR::XSLoader и Apache2::XSLoader, а также организацией XSS-атаки через запрос к  Apache2::Status.

URL: http://mail-archives.apache.org/mod_mbox/perl-modperl/201102...
Новость: https://www.opennet.ru/opennews/art.shtml?num=29539

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по ответам | RSS]

2. "Вышел mod_perl 2.0.5"  +2 +/
Сообщение от ы on 09-Фев-11, 04:28 
Я год назад пытался прейти на второго апача, выяснил что если в конфе апача указать расположение модулей Perl по пути отличном от системного с помощью PerlSwitches, апач сходил с ума. Выжирал всю память при вервом же запросе и падал. Надеюсь эту фигню пофиксили. Ждем-с в портах фри свежий mod_perl2, а так пока тусим на под старым добрым другом апачем 1.3 и первым mod_perl. :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Вышел mod_perl 2.0.5"  +/
Сообщение от alex_hunt (ok) on 09-Фев-11, 08:55 
Пользую PerlSwitches на апаче 2.2, работает как часы. Да и в рассылке такая бага не гуглится.

Может быть дело в чём-то другом?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Вышел mod_perl 2.0.5"  +/
Сообщение от ы on 09-Фев-11, 12:02 
> Может быть дело в чём-то другом?

Сейчас уже сложно сказать. Появится в портах 2.0.5 попробую повторить эксперимент. Сейчас уже и Perl другой юзаем 5.12. На тот момент был по-моему 5.10. В конфигурации особенного ничего нет, пара самописных модулей и все это под соусом HTML::Mason крутится.

А ругань была по типу: "Deep recursion on subroutine "Compress::Raw::Zlib::AUTOLOAD". Это я у себя в камментах на против опции PerlSwitches оставил на рабочей машине. Подробностей больше не осталось. При чем в наших модулях мы напрямую Zlib и не юзаем сами. Это либо в самом mod_perl касяк, либо в HTML::Mason где-то, либо еще в какой подключаемой либе используется.

Кстати, если не использовать данную опцию, а кинуть модули по системному пути, то все работало. Но на тот момент такой вариант не подошел.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Вышел mod_perl 2.0.5"  +/
Сообщение от Аноним (??) on 09-Фев-11, 17:37 
Не знаю уж... разве еще не все перешли на FCGI или Plack? Или что-то типа HTTP::Server?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Вышел mod_perl 2.0.5"  +/
Сообщение от тоже аноним on 09-Фев-11, 18:55 
а этот переход дает какие-то серьезные преимущества в сравнении с mod_perl ?
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Вышел mod_perl 2.0.5"  +/
Сообщение от KOL (ok) on 09-Фев-11, 20:24 
Отказ от apache, например.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Вышел mod_perl 2.0.5"  +/
Сообщение от Аноним (??) on 10-Фев-11, 09:31 
Да, отказ от толстого и прожорливого апача. :)
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "Вышел mod_perl 2.0.5"  +/
Сообщение от ы on 10-Фев-11, 19:43 
Очень смешно, mod_perl для того и нужен, чтобы все держать в памяти, чтобы максимуму быстро обслужить юзверя, не тратя время на подгрузку и компиляцию либ и прочую ерунду.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Вышел mod_perl 2.0.5"  +/
Сообщение от Name on 12-Фев-11, 01:55 
> Очень смешно, mod_perl для того и нужен, чтобы все держать в памяти,
> чтобы максимуму быстро обслужить юзверя, не тратя время на подгрузку и
> компиляцию либ и прочую ерунду.

Однако он медленнее, чем FastCgi/Nginx.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Вышел mod_perl 2.0.5"  +/
Сообщение от zero (??) on 12-Фев-11, 03:10 
>Однако он медленнее, чем FastCgi/Ngnix.

В общем-то вопрос скорее религиозный и зависим от архитектуры веб-приложения, чем проблема в скорости. Ну и не забываем, что у mod_perl есть такие фичи, которых у FastCGI просто не может быть из-за разных подходов в работе. mod_perl позволяет лазить в самые кишки веб-сервера и вытворять всякие полезности на этапе обработки запроса. FastCGI это фактически классический CGI, но быстрее обычного.

http://kiev.pm.org/?q=node/424 - тут разжевано.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору


Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру