The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Проблема с cisco 2511"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Проблема с cisco 2511"  
Сообщение от argus_k email(ok) on 15-Фев-07, 18:10 
Люди, помогите. Я только не давно столкнулся с цисками, поэтому некоторые проблемы не могу решить.
Есть cisco 2511 с 16 модемами. Впринципе работает нормально, но где-то через сутки, ну можеть чуть позже, начинают появляться ошибки такого плана:
3997: 5d04h: %SYS-2-MALLOCFAIL: Memory allocation of 18180 bytes failed from 0x32341DC, alignment 0
3998: Pool: I/O  Free: 69520  Cause: Memory fragmentation
3999: Alternate Pool: None  Free: 0  Cause: No Alternate pool
4000:
4001: -Process= "IP Input", ipl= 0, pid= 21
4002: -Traceback= 3264650 326545C 32341E4 32344BE 32348DA 32DC9F8 32DC7AE 32DAE32 32DAECA 32DB01A

Внешне ошибка проявляеть, как невозможность у диалапщиков отправить почту. проходит буквально один-два пакета и переда останавливаеться. Перезапуск циски проблему решает.

Выдержки из системы:
> sh version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-P-L), Version 12.1(26), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Sat 16-Oct-04 02:11 by cmong
Image text-base: 0x03041BC4, data-base: 0x00001000

ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTLDR: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)

guard uptime is 49 minutes
System returned to ROM by power-on
System restarted at 14:15:14 UTC Thu Feb 15 2007
System image file is "flash:c2500-p-l.121-26.bin"

cisco 2511 (68030) processor (revision L) with 14336K/2048K bytes of memory.
Processor board ID 05363525, with hardware revision 00000000
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
16 terminal line(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

#sh buffer
Buffer elements
    967 in free list (500 max allowed)
    13734991 hits, 0 misses, 500 created

Public buffer pools
Small buffers, 104 bytes (total 50, permanent 50)
    49 in free list (20 min, 150 max allowed)
    3224680 hits, 4 misses, 18 trims, 18 created
    0 failures (0 no memory)
Middle buffers, 600 bytes (total 25, permanent 25)
    23 in free list (10 min, 150 max allowed)
    489836 hits, 0 misses, 0 trims, 0 created
    0 failures (0 no memory)
Big buffers, 1524 bytes (total 152, permanent 50)
    142 in free list (5 min, 150 max allowed)
    4559746 hits, 18330 misses, 2520 trims, 2622 created
    15442 failures (228652 no memory)
VeryBig buffers, 4520 bytes (total 10, permanent 10)
    10 in free list (0 min, 100 max allowed)
    6216 hits, 647 misses, 1 trims, 1 created
    647 failures (147 no memory)
Large buffers, 5024 bytes (total 1, permanent 0)
    1 in free list (0 min, 10 max allowed)
    168 hits, 479 misses, 3 trims, 4 created
    479 failures (130 no memory)
Huge buffers, 18024 bytes (total 17, permanent 0)
    3 in free list (0 min, 4 max allowed)
    819574 hits, 63719 misses, 111264 trims, 111281 created
    7276 failures (16187 no memory)

> sh mem
               Head    Total           Used         Free     Lowest     Largest
Processor      B4D38    13935304     2454656    11480648    11122552    11220068
     I/O     E00000     2097152     1806864      290288        3160       82456

Из этого я вижу что буфера I/O переполняеться из-за нехватки памяти (Lowest=3160 а запрашивалось 18180).
Как можно увеличить буфер I/O или не в этом проблема?

Подскажите, плиз.
Заранее благодарен за ответы.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Проблема с cisco 2511"  
Сообщение от klincman (ok) on 20-Фев-07, 11:33 
Как на роуторе организуется маршрутизация: динамически или статически?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с cisco 2511"  
Сообщение от argus_k email(??) on 27-Фев-07, 14:24 
>Как на роуторе организуется маршрутизация: динамически или статически?
затрудняюсь ответить.
Мой конфиг:
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname guard
!
aaa new-model
aaa authentication username-prompt login:
aaa authentication login telnet local
aaa authentication login use-radius local group radius
aaa authentication ppp default if-needed none
aaa authentication ppp user-radius if-needed local group radius
aaa authorization exec use-term group radius local none
aaa authorization network use-ppp group radius local none
aaa accounting suppress null-username
aaa accounting update newinfo
aaa accounting network use-radius wait-start group radius
enable secret 5 $$$$$$$$$$$$$$$$$$$$$$$$$$$
!
username stat password 7 XXXXXXXXXX
username stat autocommand ppp
username admin password 7 XXXXXXXXXXX
!
!
!
!
ip subnet-zero
ip domain-name example.domain.ua
ip name-server xx.xx.xx.4
ip name-server xx.xx.xx.3
!
async-bootp gateway xx.xx.xx.197
async-bootp dns-server xx.xx.xx.4
!
!
!
interface Tunnel0
ip address xx.xx.xx.197 255.255.255.0
ntp broadcast
tunnel source 192.168.12.99
tunnel destination 192.168.12.100
!
interface Ethernet0
ip address 192.168.12.99 255.255.255.0
ntp broadcast
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Tunnel0
encapsulation ppp
ip tcp header-compression passive
no ip mroute-cache
no logging event link-status
async dynamic address
async mode interactive
peer default ip address pool setup_pool
ppp authentication pap user-radius
ppp authorization use-ppp
ppp accounting use-radius
group-range 1 16
!
ip local pool setup_pool xx.xx.xx.128 xx.xx.xx.143
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.xx.4
no ip http server
!
logging trap notifications
logging facility local5
logging source-interface Tunnel0
logging xx.xx.xx.3
dialer-list 1 protocol ip permit
radius-server host xx.xx.xx.3 auth-port 1812 acct-port 1813
radius-server retransmit 3
radius-server key 7 $$$$$$$$$$$$$$$
banner login ^welcome^C
!
line con 0
transport input none
line 1 16
autoselect during-login
autoselect ppp
authorization exec use-term
login authentication use-radius
modem Dialin
speed 56700
flowcontrol hardware
line aux 0
line vty 0 4
password 7 XXXXXXXXXXXXX
login authentication telnet
!
ntp clock-period 17179937
ntp server 131.188.3.36
ntp server 140.142.16.34
ntp server 192.5.5.250
end

Что характерно при небольшом числе (до 8-10) активных модемов никаких проблем не возникает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру