The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Callback на 2509"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Callback на 2509"  
Сообщение от amitx email(ok) on 12-Мрт-07, 14:13 
Помогите задолбался ничего не рабоатет вот конфигурация

chat-script offhook "" "ATH1" OK
chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c
....
interface async3
ip unnumbered ethernet0
ip tcp header-compression passive
encapsulatio ppp
ip policy route-map dialin
async mode dedicated
peer default ip address 192.168.80.13
ppp callback initiate
ppp authentication chap

......

line 3
autoselect during-login
autoselect ppp
script modem-off-hook offhook
script callback idc
login local
modem InOut
transport input all
escape-character NONE
callback forced-wait 30
callback nodsr-wait 10000
stopbits 1
rxspeed 57600
txspeed 57600
flowcontrol hardware

звоню на номер с модема ничего не происходит соединение не разрывается циска не перезванивает

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Callback на 2509"  
Сообщение от MoBilka email(ok) on 13-Мрт-07, 19:01 
уже завтра (14го) скину рабочий конфиг. сам парился с callback на такой же cisco (давно настраивал, щас не помню какие были настройки). сразу могу сказать что долго мучался именно с перезвоном а оказалось что проблема была в настройках АТС.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Callback на 2509"  
Сообщение от amitx email(ok) on 14-Мрт-07, 05:46 
куда скинешь?? сообщи


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Callback на 2509"  
Сообщение от VOLAND email(ok) on 14-Мрт-07, 09:12 
>Помогите задолбался ничего не рабоатет вот конфигурация
>
>chat-script offhook "" "ATH1" OK
>chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT
>60 CONNECT \c
>....
>interface async3
>ip unnumbered ethernet0
>ip tcp header-compression passive
>encapsulatio ppp
>ip policy route-map dialin
>async mode dedicated
>peer default ip address 192.168.80.13
>ppp callback initiate
>ppp authentication chap
>
>......
>
>line 3
>autoselect during-login
> autoselect ppp
> script modem-off-hook offhook
> script callback idc
> login local
> modem InOut
> transport input all
> escape-character NONE
> callback forced-wait 30
> callback nodsr-wait 10000
> stopbits 1
> rxspeed 57600
> txspeed 57600
> flowcontrol hardware
>
>звоню на номер с модема ничего не происходит соединение не разрывается циска
>не перезванивает


Месяц назад поднял на своей старушке 2509 callback с freeradius, если интересно можем пообщаться

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Callback на 2509"  
Сообщение от MoBilka email(ok) on 14-Мрт-07, 10:18 
version 12.0  (использовал эту версую потомучто на версию поновей не хватало флеша)
service exec-callback
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname Access
!
aaa new-model
aaa authentication login default local
aaa authentication enable default enable
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default local
enable secret ********************
enable password ***************************
!
username valerab privilege 15 password *********************
username valera nocallback-verify callback-dialstring "" password *********    (callback на номер с запросом номера)
username aronov password *********       (просто диалапный юзер)
username su nopassword
username su autocommand show users
username valerac nocallback-verify callback-dialstring 94564567 password **********  (callback на заранее указанный номер)
ip subnet-zero
ip name-server 192.168.0.2
ip name-server 192.168.0.10
chat-script offhook "" "ATH1" OK
chat-script c ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 45 CONNECT \c
clock timezone UKR 2
clock summer-time UKR-SUMMER recurring last Sun Mar 2:00 last Sun Oct 2:00
!
!
!
interface Ethernet0   (внутренний)
ip address 192.168.0.25 255.255.254.0
no ip directed-broadcast
ip nat outside
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
( ниже 3 Async-порта на которых у меня модемы и 3 линии под них)
interface Async1  
ip unnumbered Ethernet0
no ip directed-broadcast
ip nat inside
encapsulation ppp
autodetect encapsulation ppp
async mode interactive
peer default ip address pool call  (пул выдаваемых ip)
ppp callback accept
ppp authentication chap
!
interface Async2
ip unnumbered Ethernet0
no ip directed-broadcast
ip nat inside
encapsulation ppp
ip tcp header-compression
no ip mroute-cache
autodetect encapsulation ppp
async mode interactive
peer default ip address pool call
no fair-queue
compress mppc       (виндовое сжатие передаваемых данных. без этого у меня было много ошибок в соединении)
ppp callback accept
ppp authentication chap
!
interface Async7
ip unnumbered Ethernet0
no ip directed-broadcast
ip nat inside
encapsulation ppp
ip tcp header-compression
no ip mroute-cache
autodetect encapsulation ppp
async mode interactive
peer default ip address pool call
no fair-queue
compress mppc
ppp callback accept
ppp authentication chap
!
ip local pool call 192.168.10.1 192.168.10.4
ip default-gateway 192.168.0.10
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip nat inside source route-map ROUTE interface Ethernet0 overload
ip http server
ip http port 8080
ip http authentication local
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.10
!
logging source-interface Ethernet0
logging 192.168.0.7
access-list 1 permit 192.168.10.0 0.0.0.248
access-list 101 permit ip any host 192.168.0.111
access-list 101 deny   ip any 192.168.0.0 0.0.255.255
access-list 101 permit ip any any
route-map ROUTE permit 10
!

alias exec ct conf t
alias exec su show users
alias exec sr show running-config
privilege exec level 1 reload
!
line con 0
transport input none
line 1
autoselect during-login
autoselect ppp
script modem-off-hook offhook
script callback c
modem InOut
modem autoconfigure discovery
transport input all
speed 1200
line 2
autoselect during-login
autoselect ppp
script modem-off-hook offhook
script callback c
modem InOut
modem autoconfigure discovery
transport input all
speed 115200
flowcontrol hardware
line 3 6
line 7
autoselect during-login
autoselect ppp
script modem-off-hook offhook
script callback c
modem InOut
modem autoconfigure discovery
transport input all
speed 115200
flowcontrol hardware
line 8
line aux 0
line vty 0 2
password 7 11584B56
line vty 3 4
password 7 040A5955
!
ntp clock-period 17179846
ntp server 193.19.96.9
ntp server 193.19.96.10 prefer
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Callback на 2509"  
Сообщение от amitx email(??) on 14-Мрт-07, 14:21 
а что защито в модемах?? чтобы когда на него звонили он откликался
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Callback на 2509"  
Сообщение от MoBilka email(??) on 14-Мрт-07, 16:57 
>а что защито в модемах?? чтобы когда на него звонили он откликался
>
я с модемами ничего не проделывал - по дефолту всё

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Callback на 2509"  
Сообщение от amitx email(??) on 16-Мрт-07, 05:51 
В принцепе взял твой конфиг все получилось циска начала разрывать звязь и перезванимать , но пришлось изменить ppp callback accept (как я понимаю это означает кто является инициатором разрыва accept - звонящий , initiate - циска) я постаитл initiate rulf звоню на циску она разрывает связь но модем звонящего не переходит в режим ожидания. Если ставить в настройках accept то разрыва связи вообще не происзодит хотя в настройках винды стоит Параметры удаленного вызова-> Ответный вызов-> Всегда отвечать . Кто нибудь знает в чем причина??

P.S. Изначально в модем залил АТН1 в принцепе циска его сама потом заливает

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Callback на 2509"  
Сообщение от Nuri email on 23-Мрт-07, 12:15 
>version 12.0  (использовал эту версую потомучто на версию поновей не хватало


>chat-script offhook "" "ATH1" OK
>chat-script c ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT
>45 CONNECT \c

> script modem-off-hook offhook
> script callback c

На моей циске 2509 (11.2(5)P) почему-то в настройках LINE нет пункта script modem-off-hook.
Проблема та-же, с настройками callback она не перезванивает, а просто пропускает как обычно.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Callback на 2509"  
Сообщение от Nuri email on 23-Мрт-07, 12:30 
>На моей циске 2509 (11.2(5)P) почему-то в настройках LINE нет пункта script
>modem-off-hook.
>Проблема та-же, с настройками callback она не перезванивает, а просто пропускает как
>обычно.
Прописал offhook скрипт, но не изменилось ничего. пускает как обычно, debug callback не показывает никакой активности...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Callback на 2509"  
Сообщение от MoBilka email(??) on 23-Мрт-07, 13:00 
>>На моей циске 2509 (11.2(5)P) почему-то в настройках LINE нет пункта script
>>modem-off-hook.
>>Проблема та-же, с настройками callback она не перезванивает, а просто пропускает как
>>обычно.
>Прописал offhook скрипт, но не изменилось ничего. пускает как обычно, debug callback
>не показывает никакой активности...

обнови IOS

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Callback на 2509"  
Сообщение от Nuri email on 23-Мрт-07, 14:34 
>обнови IOS
Хех... где бы его взять... :(


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Callback на 2509"  
Сообщение от Nuri email on 23-Мрт-07, 16:44 
>>обнови IOS
>Хех... где бы его взять... :(

Ну вот. IOS нашел. Залил (c2500-i-l.120-28a.bin). Самый главный баг теперь - когда делаю debug chat - ios падает :( Вроде стало работать, но почему-то циска номер не набирает, модем на компе ждет до таймаута. Зато перестала запрос винды на callback отшибать :)
chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CON
NECT \c


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Callback на 2509"  
Сообщение от Nuri email on 24-Мрт-07, 14:20 
>>>обнови IOS
Все завелось, спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Callback на 2509"  
Сообщение от Nuri email on 23-Мрт-07, 12:32 
>
>На моей циске 2509 (11.2(5)P) почему-то в настройках LINE нет пункта script
>modem-off-hook.
>Проблема та-же, с настройками callback она не перезванивает, а просто пропускает как
>обычно.

Прописал offhook скрипт, но не изменилось ничего. пускает как обычно, debug callback не показывает никакой активности...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Callback на 2509"  
Сообщение от Aleksey email(??) on 01-Ноя-07, 11:35 
>>

Если у кого остался еще ИОС 12.0 на 2509 киску поделитесь плиз.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Callback на 2509"  
Сообщение от Rootbvn email on 01-Ноя-07, 11:47 
>>>
>
>Если у кого остался еще ИОС 12.0 на 2509 киску поделитесь плиз.
>

http://www.fss.net.ua/c2500-is-l_120-7.bin

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Callback на 2509"  
Сообщение от Алексей email(??) on 02-Ноя-07, 11:09 
>>>>
>>
>>Если у кого остался еще ИОС 12.0 на 2509 киску поделитесь плиз.
>>
>
>http://www.fss.net.ua/c2500-is-l_120-7.bin

Спасибо большое! сразу все заработало :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру