The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"e1 VOIP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"e1 VOIP"  
Сообщение от Serb on 03-Апр-07, 17:22 
Добрый день!

1 - Есть кошка 2801, с платой VWIC2-1MFT-T1/E1.
2 - Есть УАТС Coral с платой 30T

Необходимо их соеденить по e:

version 12.4
service nagle
service pad to-xot
service pad from-xot
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
no service dhcp
!
hostname cisco2801
!
boot-start-marker
boot system flash c2801-adventerprisek9-mz.124-12.bin
boot-end-marker
!
card type e1 0 1
logging buffered 51200 warnings
enable secret 5 IrfhVyTpGCIzBv1cVC/
!
aaa new-model
!
!
aaa authentication login default local-case
aaa authentication login pad none
aaa authentication enable default enable
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization exec pad none
!
aaa session-id common
clock timezone GMT 2
clock summer-time GMT recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 1
network-clock-select 1 E1 0/1/0
no ip source-route
ip cef
!
!
!
!
no ip bootp server
no ip domain lookup
ip domain name yourdomain.com
!
!
voice-card 0
dsp services dspfarm
!
!
!
voice service pots
!
voice service voip
h323
  h225 signal overlap
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 password 7 00081710550E5A57
!
!
controller E1 0/1/0
framing NO-CRC4
ds0-group 0 timeslots 1-8 type r2-digital dtmf dnis
!
class-map match-any VOIP
match ip dscp ef
class-map match-any VOIP-CONTROL
match ip dscp cs3
!
!
policy-map 2xVOIP
class VOIP
  priority 48 400
class VOIP-CONTROL
  bandwidth 8
class class-default
  fair-queue
!
!
!
!
!
!
interface Loopback0
ip address 10.2.244.50 255.255.255.255
ip flow ingress
ip flow egress
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
ip address 10.2.0.254 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 2 range 10.2.0.0 255.255.0.0
network 10.2.0.0 0.0.255.255 area 2
!
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
logging facility local2
logging source-interface Loopback0
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
!
control-plane
!
disable-eadi
!
!
voice-port 0/1/0:0
!
!
!
!
!
dial-peer voice 10 voip
destination-pattern 044T
voice-class source interface Loopback0
session target ipv4:10.0.244.1
playout-delay nominal 250
playout-delay mode fixed
codec g729r8 bytes 40
ip qos dscp cs3 signaling
no vad  
!
dial-peer voice 11 pots
destination-pattern 27....
port 0/1/0:0
forward-digits 4
!
!
banner login ^CC
cisco 2801 for test
^C
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0
exec-timeout 0 0
privilege level 15
transport input telnet
line vty 1 4
!
scheduler allocate 20000 1000
end


Проблема в том что звонки на dial-peer voice 11 pots приходят нормально, а вот исходящие не работают (с АТС позвонить нельзя, на АТС дозваниваются)

Куда собственно копать??

Спасибо

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • e1 VOIP, vit5, 08:49 , 04-Апр-07, (1)  
    • e1 VOIP, nixoz, 12:22 , 04-Апр-07, (2)  
  • e1 VOIP, nixoz, 12:23 , 04-Апр-07, (3)  
    • e1 VOIP, Serb, 12:38 , 04-Апр-07, (5)  
  • e1 VOIP, nixoz, 12:36 , 04-Апр-07, (4)  
    • e1 VOIP, Serb, 13:18 , 04-Апр-07, (6)  
      • e1 VOIP, Alex, 14:19 , 04-Апр-07, (7)  
        • e1 VOIP, Serb, 18:06 , 04-Апр-07, (8)  
          • e1 VOIP, Alex, 16:06 , 05-Апр-07, (9)  

Сообщения по теме [Сортировка по времени, UBB]


1. "e1 VOIP"  
Сообщение от vit5 (ok) on 04-Апр-07, 08:49 
на вскидку конкретно для серии 2800 нескажу нужно смотреть доку
а вот пример на 3661 принцип думаю тотже

!
controller E1 4/0
pri-group timeslots 1-31
!

interface Serial4/0:15
no ip address
no logging event link-status
isdn switch-type primary-net5
isdn overlap-receiving
isdn protocol-emulate network
isdn incoming-voice voice
isdn map address .* plan privacy type unknown
isdn T203 30000
isdn T310 60000
no cdp enable
!
!
voice-port 4/0:15
bearer-cap Speech
!

dial-peer voice 2 pots
destination-pattern 0.T
no digit-strip
direct-inward-dial
port 4/0:15
forward-digits all
!
dial-peer voice 1 pots
destination-pattern 2...
direct-inward-dial
port 4/0:15
forward-digits all
!
!
dial-peer voice 10 voip
description All
destination-pattern .T
session target ras
dtmf-relay h245-alphanumeric
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
ip qos dscp cs5 media
!
!
voice service voip
allow-connections h323 to h323
signaling forward unconditional
h323
  h245 tunnel disable
  h245 caps mode restricted
!
!
isdn switch-type primary-net5
isdn voice-call-failure 0
isdn gateway-max-interworking

как видно при наличае крнтроллера е1
создаем еще под него сериальный интерфейс где указываем все настройки isdn
может у тебя в этом проблема попробуй так потом скажи что получилось

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "e1 VOIP"  
Сообщение от nixoz email on 04-Апр-07, 12:22 
не надо создавать никакие контроллеры.
Д канал сам появится как только поднимится физика Е1..

>на вскидку конкретно для серии 2800 нескажу нужно смотреть доку
>а вот пример на 3661 принцип думаю тотже
>
>!
>controller E1 4/0
> pri-group timeslots 1-31
>!
>
>interface Serial4/0:15
> no ip address
> no logging event link-status
> isdn switch-type primary-net5
> isdn overlap-receiving
> isdn protocol-emulate network
> isdn incoming-voice voice
> isdn map address .* plan privacy type unknown
> isdn T203 30000
> isdn T310 60000
> no cdp enable
>!
>!
>voice-port 4/0:15
> bearer-cap Speech
>!
>
>dial-peer voice 2 pots
> destination-pattern 0.T
> no digit-strip
> direct-inward-dial
> port 4/0:15
> forward-digits all
>!
>dial-peer voice 1 pots
> destination-pattern 2...
> direct-inward-dial
> port 4/0:15
> forward-digits all
>!
>!
>dial-peer voice 10 voip
> description All
> destination-pattern .T
> session target ras
> dtmf-relay h245-alphanumeric
> fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
> ip qos dscp cs5 media
>!
>!
>voice service voip
> allow-connections h323 to h323
> signaling forward unconditional
> h323
>  h245 tunnel disable
>  h245 caps mode restricted
>!
>!
>isdn switch-type primary-net5
>isdn voice-call-failure 0
>isdn gateway-max-interworking
>
>как видно при наличае крнтроллера е1
>создаем еще под него сериальный интерфейс где указываем все настройки isdn
>может у тебя в этом проблема попробуй так потом скажи что получилось
>


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "e1 VOIP"  
Сообщение от nixoz email on 04-Апр-07, 12:23 
Это кто писал конфиг ? )))

у тебя включение по R2 диджитал в АТС ?...
она не поддерживает channelized E1 ?


>Добрый день!
>
>1 - Есть кошка 2801, с платой VWIC2-1MFT-T1/E1.
>2 - Есть УАТС Coral с платой 30T
>
>Необходимо их соеденить по e:
>
>version 12.4
>service nagle
>service pad to-xot
>service pad from-xot
>service tcp-keepalives-in
>service tcp-keepalives-out
>service timestamps debug datetime msec localtime show-timezone
>service timestamps log datetime msec localtime show-timezone
>service password-encryption
>service sequence-numbers
>no service dhcp
>!
>hostname cisco2801
>!
>boot-start-marker
>boot system flash c2801-adventerprisek9-mz.124-12.bin
>boot-end-marker
>!
>card type e1 0 1
>logging buffered 51200 warnings
>enable secret 5 IrfhVyTpGCIzBv1cVC/
>!
>aaa new-model
>!
>!
>aaa authentication login default local-case
>aaa authentication login pad none
>aaa authentication enable default enable
>aaa authentication ppp default local
>aaa authorization exec default local
>aaa authorization exec pad none
>!
>aaa session-id common
>clock timezone GMT 2
>clock summer-time GMT recurring last Sun Mar 2:00 last Sun Oct 3:00
>
>network-clock-participate wic 1
>network-clock-select 1 E1 0/1/0
>no ip source-route
>ip cef
>!
>!
>!
>!
>no ip bootp server
>no ip domain lookup
>ip domain name yourdomain.com
>!
>!
>voice-card 0
> dsp services dspfarm
>!
>!
>!
>voice service pots
>!
>voice service voip
> h323
>  h225 signal overlap
>!
>!
>!
>!
>!
>!
>!
>!
>!
>!
>!
>!
>username admin privilege 15 password 7 00081710550E5A57
>!
>!
>controller E1 0/1/0
> framing NO-CRC4
> ds0-group 0 timeslots 1-8 type r2-digital dtmf dnis
>!
>class-map match-any VOIP
> match ip dscp ef
>class-map match-any VOIP-CONTROL
> match ip dscp cs3
>!
>!
>policy-map 2xVOIP
> class VOIP
>  priority 48 400
> class VOIP-CONTROL
>  bandwidth 8
> class class-default
>  fair-queue
>!
>!
>!
>!
>!
>!
>interface Loopback0
> ip address 10.2.244.50 255.255.255.255
> ip flow ingress
> ip flow egress
>!
>interface FastEthernet0/0
> description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
> ip address 10.2.0.254 255.255.254.0
> duplex auto
> speed auto
>!
>interface FastEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
>!
>router ospf 1
> log-adjacency-changes
> area 2 range 10.2.0.0 255.255.0.0
> network 10.2.0.0 0.0.255.255 area 2
>!
>!
>!
>ip http server
>ip http access-class 23
>ip http authentication local
>no ip http secure-server
>ip http timeout-policy idle 60 life 86400 requests 10000
>!
>logging trap debugging
>logging facility local2
>logging source-interface Loopback0
>access-list 23 permit 10.10.10.0 0.0.0.7
>!
>!
>!
>!
>control-plane
>!
>disable-eadi
>!
>!
>voice-port 0/1/0:0
>!
>!
>!
>!
>!
>dial-peer voice 10 voip
> destination-pattern 044T
> voice-class source interface Loopback0
> session target ipv4:10.0.244.1
> playout-delay nominal 250
> playout-delay mode fixed
> codec g729r8 bytes 40
> ip qos dscp cs3 signaling
> no vad
>!
>dial-peer voice 11 pots
> destination-pattern 27....
> port 0/1/0:0
> forward-digits 4
>!
>!
>banner login ^CC
>cisco 2801 for test
>^C
>!
>line con 0
> exec-timeout 0 0
>line aux 0
>line vty 0
> exec-timeout 0 0
> privilege level 15
> transport input telnet
>line vty 1 4
>!
>scheduler allocate 20000 1000
>end
>
>
>Проблема в том что звонки на dial-peer voice 11 pots приходят нормально,
>а вот исходящие не работают (с АТС позвонить нельзя, на АТС
>дозваниваются)
>
>
>
>Куда собственно копать??
>
>Спасибо


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "e1 VOIP"  
Сообщение от Serb on 04-Апр-07, 12:38 
>Это кто писал конфиг ? )))


Я писал! С E1 первый раз, если сильно смешной конфиг, то подправте
>
>у тебя включение по R2 диджитал в АТС ?...


Именно оно

>она не поддерживает channelized E1 ?

х/з. Из входный данных по АТС есть только тип сигнализации R2D tdmf, никаких ISDN PRI и усе!

Я повторюсь:
При таких настройках звоня с другого маршрутизатора с FXS на этот я звонок получаю!!!
fxs->router->IP->router_e1->atc->phone - работает, а в другую сторону, соответственно нет

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "e1 VOIP"  
Сообщение от nixoz email on 04-Апр-07, 12:36 
дебаги дайлпиров inout в студию..
при звонке с атс

>Добрый день!
>
>1 - Есть кошка 2801, с платой VWIC2-1MFT-T1/E1.
>2 - Есть УАТС Coral с платой 30T
>
>Необходимо их соеденить по e:
>
>version 12.4
>service nagle
>service pad to-xot
>service pad from-xot
>service tcp-keepalives-in
>service tcp-keepalives-out
>service timestamps debug datetime msec localtime show-timezone
>service timestamps log datetime msec localtime show-timezone
>service password-encryption
>service sequence-numbers
>no service dhcp
>!
>hostname cisco2801
>!
>boot-start-marker
>boot system flash c2801-adventerprisek9-mz.124-12.bin
>boot-end-marker
>!
>card type e1 0 1
>logging buffered 51200 warnings
>enable secret 5 IrfhVyTpGCIzBv1cVC/
>!
>aaa new-model
>!
>!
>aaa authentication login default local-case
>aaa authentication login pad none
>aaa authentication enable default enable
>aaa authentication ppp default local
>aaa authorization exec default local
>aaa authorization exec pad none
>!
>aaa session-id common
>clock timezone GMT 2
>clock summer-time GMT recurring last Sun Mar 2:00 last Sun Oct 3:00
>
>network-clock-participate wic 1
>network-clock-select 1 E1 0/1/0
>no ip source-route
>ip cef
>!
>!
>!
>!
>no ip bootp server
>no ip domain lookup
>ip domain name yourdomain.com
>!
>!
>voice-card 0
> dsp services dspfarm
>!
>!
>!
>voice service pots
>!
>voice service voip
> h323
>  h225 signal overlap
>!
>!
>!
>!
>!
>!
>!
>!
>!
>!
>!
>!
>username admin privilege 15 password 7 00081710550E5A57
>!
>!
>controller E1 0/1/0
> framing NO-CRC4
> ds0-group 0 timeslots 1-8 type r2-digital dtmf dnis
>!
>class-map match-any VOIP
> match ip dscp ef
>class-map match-any VOIP-CONTROL
> match ip dscp cs3
>!
>!
>policy-map 2xVOIP
> class VOIP
>  priority 48 400
> class VOIP-CONTROL
>  bandwidth 8
> class class-default
>  fair-queue
>!
>!
>!
>!
>!
>!
>interface Loopback0
> ip address 10.2.244.50 255.255.255.255
> ip flow ingress
> ip flow egress
>!
>interface FastEthernet0/0
> description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
> ip address 10.2.0.254 255.255.254.0
> duplex auto
> speed auto
>!
>interface FastEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
>!
>router ospf 1
> log-adjacency-changes
> area 2 range 10.2.0.0 255.255.0.0
> network 10.2.0.0 0.0.255.255 area 2
>!
>!
>!
>ip http server
>ip http access-class 23
>ip http authentication local
>no ip http secure-server
>ip http timeout-policy idle 60 life 86400 requests 10000
>!
>logging trap debugging
>logging facility local2
>logging source-interface Loopback0
>access-list 23 permit 10.10.10.0 0.0.0.7
>!
>!
>!
>!
>control-plane
>!
>disable-eadi
>!
>!
>voice-port 0/1/0:0
>!
>!
>!
>!
>!
>dial-peer voice 10 voip
> destination-pattern 044T
> voice-class source interface Loopback0
> session target ipv4:10.0.244.1
> playout-delay nominal 250
> playout-delay mode fixed
> codec g729r8 bytes 40
> ip qos dscp cs3 signaling
> no vad
>!
>dial-peer voice 11 pots
> destination-pattern 27....
> port 0/1/0:0
> forward-digits 4
>!
>!
>banner login ^CC
>cisco 2801 for test
>^C
>!
>line con 0
> exec-timeout 0 0
>line aux 0
>line vty 0
> exec-timeout 0 0
> privilege level 15
> transport input telnet
>line vty 1 4
>!
>scheduler allocate 20000 1000
>end
>
>
>Проблема в том что звонки на dial-peer voice 11 pots приходят нормально,
>а вот исходящие не работают (с АТС позвонить нельзя, на АТС
>дозваниваются)
>
>
>
>Куда собственно копать??
>
>Спасибо


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "e1 VOIP"  
Сообщение от Serb on 04-Апр-07, 13:18 
>дебаги дайлпиров inout в студию..
>при звонке с атс


#sh debugging

DIALPEER:
  debug voip dialpeer inout is ON (filter is OFF)

000057: Apr  4 12:01:49.973 GMT:
//-1/EE1395919362/DPM/dpAssociateIncomingPeerCore:
   Calling Number=, Called Number=272550, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search
Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
000058: Apr  4 12:01:49.973 GMT:
//-1/EE1395919362/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
000059: Apr  4 12:01:49.973 GMT:
//-1/EE1395919362/DPM/dpAssociateIncomingPeerCore:
   Calling Number=, Called Number=272550, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search
Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
000060: Apr  4 12:01:49.973 GMT:
//-1/EE1395919362/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
000061: Apr  4 12:01:49.977 GMT: //-1/EE1395919362/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=272550, Peer Info
Type=DIALPEER_INFO_SPEECH
000062: Apr  4 12:01:49.977 GMT: //-1/EE1395919362/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=272550
000063: Apr  4 12:01:49.977 GMT: //-1/EE1395919362/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000064: Apr  4 12:01:49.981 GMT: //-1/EE1395919362/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=11


это при звонке НА АТС

С АТС в дебаг ничего не валится!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "e1 VOIP"  
Сообщение от Alex email(??) on 04-Апр-07, 14:19 
Кажется, для R2 желательно создавать cas-custom
! country param ?
cas-custom <gr #>
reanswer-time <>
dnis-complete
answer-guard-time <>
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "e1 VOIP"  
Сообщение от Serb on 04-Апр-07, 18:06 

при таком конфиге:

controller E1 0/1/0
framing NO-CRC4
ds0-group 0 timeslots 1-4 type r2-digital dtmf dnis
ds0-group 1 timeslots 17-20 type r2-digital dtmf dnis
!

voice-port 0/1/0:1

получаю следующее


2801(config-dial-peer)#
000096: Apr  4 16:46:26.542 GMT: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=, Called Number=, Voice-Interface=0x654DCF74,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
000097: Apr  4 16:46:26.542 GMT: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
2801(config-dial-peer)#
2801(config-dial-peer)#do sh voice port summ
                                          IN       OUT
PORT           CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
============== == ============ ===== ==== ======== ======== ==
0/1/0:0        01  r2-digital  up    dorm idle     idle     y
0/1/0:0        02  r2-digital  up    dorm idle     idle     y
0/1/0:0        03  r2-digital  up    dorm idle     idle     y
0/1/0:0        04  r2-digital  up    dorm idle     idle     y
0/1/0:1        17  r2-digital  up    up   idle     seized   y
0/1/0:1        18  r2-digital  up    dorm idle     idle     y
0/1/0:1        19  r2-digital  up    dorm idle     idle     y
0/1/0:1        20  r2-digital  up    dorm idle     idle     y

PWR FAILOVER PORT        PSTN FAILOVER PORT
=================        ==================

>Кажется, для R2 желательно создавать cas-custom
>! country param ?
в cas-custom <gr #>

только

cas-custom 1
2801(config-ctrl-cas)#?
CAS custom commands:
  alert-wait-time     Time to wait for alert indication for incoming R2 calls
  country             Country Name
  debounce-time       Debounce Timer
  default             Set a command to its defaults
  dtmf                DTMF Inter Digit Timer in MilliSeconds
  exit                Exit from cas custom mode
  invert-abcd         invert the ABCD bits before tx and after rx
  metering            R2 network is sending metering signal
  no                  Negate a command or set its defaults
  proceed-to-send     Suppress proceed-to-send signal for pulsed line signaling
  reanswer-time       Reanswer Timer
  release-ack         Send Release Acknowledgement to Clear Forward
  release-guard-time  Release Guard Timer
  seizure-ack-time    Seizure to Acknowledge timer
  trunk-group         Configure interface to be in a trunk group
  unused-abcd         Unused ABCD bit values

> reanswer-time <>
> dnis-complete
> answer-guard-time <>


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "e1 VOIP"  
Сообщение от Alex email(??) on 05-Апр-07, 16:06 
На 5350 ставил countr - itu.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру