The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"as5400 voip и 2-а диалап пула с разными номерами"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от m_z email(ok) on 19-Апр-07, 10:35 
Народ, кто в кошаках хорошо шарит, помогите пожалуйста решить сабжевый вопрос.
в данный момент конигурация в общем-то типичная, поток с PBX, 2-е платы NM60, войп.
иос 12.3.конфа примерно такая(лишнее вырезал)


...................
resource-pool disable
aaa new-model
!
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa accounting delay-start all
aaa accounting update periodic 1
aaa accounting network default start-stop group radius
aaa accounting connection default start-stop group radius
aaa session-id common
!
controller E1 6/0
framing NO-CRC4
pri-group timeslots 1-31
description VoIP to PSTN link
!
interface FastEthernet0/0
description Management Port
ip address x.x.x.x m.m.m.m
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id OpenH323GK ipaddr x.x.x.x 1719
h323-gateway voip h323-id cisco-gw-1
h323-gateway voip bind srcaddr x.x.x.x
!
interface FastEthernet0/0.111
description Dialup interface(public)
encapsulation dot1Q 111
ip vrf forwarding ppp_dialup_public
ip address x.x.x.x m.m.m.m
no ip redirects
no ip unreachables
no ip mroute-cache
no snmp trap link-status
no cdp enable
!
interface FastEthernet0/0.222
description Dialup interface(private)
encapsulation dot1Q 222
ip vrf forwarding ppp_dialup_private
ip address y.y.y.y m.m.m.m
no ip redirects
no ip unreachables
no ip mroute-cache
no snmp trap link-status
no cdp enable
!
interface Serial6/0:15
no ip address
isdn switch-type primary-net5
isdn not-end-to-end 64
isdn incoming-voice modem 64
isdn map address .* plan unknown type unknown
isdn T310 60000
isdn send-alerting
isdn negotiate-bchan
isdn sending-complete
isdn outgoing ie redirecting-number
no cdp enable
!
interface Virtual-Template2
ip vrf forwarding ppp_dialup_private
ip unnumbered FastEthernet0/0.111
peer default ip address pool dialup_private
ppp ipcp dns x.x.x.x
ppp ipcp wins reject
!
interface Group-Async0
mtu 576
no ip address
encapsulation ppp
no ip route-cache cef
no ip mroute-cache
async mode dedicated
no peer default ip address
no fair-queue
ppp lcp predictive
ppp authentication pap chap ms-chap
ppp timeout idle 3600
group-range 4/00 4/59
!
interface Group-Async1
no ip address
group-range 5/00 5/59
!
ip local pool dialup_public x.x.x.x x.x.x.x
ip local pool dialup_private y.y.y.y y.y.y.y
ip classless
ip route vrf ppp_dialup_public 0.0.0.0 0.0.0.0 x.x.x.x
ip route vrf ppp_dialup_public 0.0.0.0 0.0.0.0 Null0 100
ip route vrf ppp_dialup_private 0.0.0.0 0.0.0.0 y.y.y.y
ip route vrf ppp_dialup_private 0.0.0.0 0.0.0.0 Null0 100
!
voice-port 6/0:D
cptone RU
bearer-cap Speech
!
dial-peer voice 1 voip
tone ringback alert-no-PI
description Peer to H323 gatekeeper
destination-pattern .T
voice-class codec 1000
session target ras
fax rate 9600
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
no vad
!
dial-peer voice 2 pots
tone ringback alert-no-PI
description Peer to PSTN
destination-pattern .T
progress_ind alert enable 8
direct-inward-dial
port 6/0:D
!
dial-peer data 3 pots
description Dialup POTS peer
incoming called-number 1212121
!
...............

то есть сейчас приватная и публичная зона сделаны на одном номере и разбивка идет с помощью радиуса и навешивания темплэйта при авторизации.
Можно ли не прибегая к включению resource-pool'а, сделать разбивку модемного пула на два номера, для примера что вроде этого:


......................
!
interface Group-Async0
mtu 576
ip vrf forwarding ppp_dialup_private
ip unnumbered FastEthernet0/0.222
encapsulation ppp
no ip route-cache cef
no ip mroute-cache
async mode dedicated
peer default ip address pool dialup_private
no fair-queue
ppp lcp predictive
ppp authentication pap chap ms-chap
ppp ipcp dns x.x.x.x
ppp ipcp wins x.x.x.x
ppp timeout idle 3600
group-range 4/00 4/59
!
interface Group-Async1
mtu 576
ip vrf forwarding ppp_dialup_public
ip unnumbered FastEthernet0/0.111
encapsulation ppp
no ip route-cache cef
no ip mroute-cache
async mode dedicated
peer default ip address pool dialup_public
no fair-queue
ppp lcp predictive
ppp authentication pap chap ms-chap
ppp ipcp dns x.x.x.x
ppp ipcp wins reject
ppp timeout idle 3600
group-range 5/00 5/59
!
!
dial-peer data 3 pots
description Dialup POTS peer
incoming called-number 1212121
!
dial-peer data 4 pots
description Dialup POTS peer
incoming called-number 2323232
!
......................................

или, если это невозможно, то подскажите, как через resourse-pool организовать одновременно и работу войпа и dialup'а.....

делая вот так:
resource-pool enable
resource-pool call treatment profile no-answer
!
resource-pool group resource res_modem_public
range port 5/0 5/59
!
resource-pool group resource res_modem_private
range port 4/0 4/59
!
resource-pool profile customer prof_modem_public
limit base-size all
limit overflow-size 0
resource res_modem_public speech
dnis group modem_public
!
resource-pool profile customer prof_modem_private
limit base-size all
limit overflow-size 0
resource res_modem_private speech
dnis group modem_private
!
dialer dnis group modem_public
number 1212121
call-type cas speech
!
dialer dnis group modem_private
number 2323232
call-type cas speech
!

войп отваливается, а где и как его учесть я что-то уже и не знаю -)

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от m_z email(ok) on 19-Апр-07, 18:01 
неужто никто не сталкивался с такой необходимостью?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от test (??) on 23-Янв-09, 05:52 
>неужто никто не сталкивался с такой необходимостью?

Вы решили проблему? Если да, то пожалуйста скиньте конфигурацию.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от m_z (??) on 10-Фев-09, 15:31 
>>неужто никто не сталкивался с такой необходимостью?
>
>Вы решили проблему? Если да, то пожалуйста скиньте конфигурацию.

вух скока времени прошло -)
нет, не получилось, свою задачу решил обходными путями.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от test (??) on 12-Фев-09, 03:17 
>>>неужто никто не сталкивался с такой необходимостью?
>>
>>Вы решили проблему? Если да, то пожалуйста скиньте конфигурацию.
>
>вух скока времени прошло -)
>нет, не получилось, свою задачу решил обходными путями.

Можно пример концфигурации, устал уже воевать ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от m_z (??) on 16-Фев-09, 15:43 
конфу не дам, я в той конторе ужо полгода как не работаю.
но она и не поможет...у меня стояла задача разделить клиентский(инет) и приватный(внтур.сеть конторы + инет) диалапы с одновременным переходом на новый биллинг который не умел темплейты по радиусу навешивать.
так, как я хотел, не получилось(см.выше), потому просто сделал один общий пул(инет) и впн-сервер поднял -)
так что сорри.
попробуй таки с ресур-пулом поигратся....если войп не нужен, то теоретически он должен помочь -))))
но почему у меня не работал диал+войп я хз.
может там иос другой нужен для такой финтифлюшки.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "as5400 voip и 2-а диалап пула с разными номерами"  
Сообщение от test (??) on 18-Фев-09, 08:12 
>[оверквотинг удален]
>но она и не поможет...у меня стояла задача разделить клиентский(инет) и приватный(внтур.сеть
>конторы + инет) диалапы с одновременным переходом на новый биллинг который
>не умел темплейты по радиусу навешивать.
>так, как я хотел, не получилось(см.выше), потому просто сделал один общий пул(инет)
>и впн-сервер поднял -)
>так что сорри.
>попробуй таки с ресур-пулом поигратся....если войп не нужен, то теоретически он должен
>помочь -))))
>но почему у меня не работал диал+войп я хз.
>может там иос другой нужен для такой финтифлюшки.

Спасиб :) буду колупать дальше

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру