The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Очень страная загрузка cisco 2851"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Очень страная загрузка cisco 2851"  
Сообщение от JackK email(ok) on 31-Май-07, 23:59 
имею...:)cisco 2851 pptp-сервер(резанием скорости rate-limit) с натом и сбором статистики(Netflow хотя его отключал).Сидит около 200-300 человек(ip cef включён) и загрузку которая иногда подскакивает до 100% причём вывод sh pr cpu показывает 100%, но по запущенным процессам загрузка от силы 15%
вот вывод sh proc cpu sorted
CPU utilization for five seconds: 74%/63%; one minute: 65%; five minutes: 63%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
239     4931940     54449      90580  3.01%  2.31%  1.60%   0 VTEMPLATE Backgr
  84    35152120  26442232       1329  3.44%  3.45%  3.27%   0 IP Input
229     8727344  11542255        756  1.22%  0.86%  0.74%   0 PPTP Data
232     4212712   1409840       2988  0.57%  1.35%  1.07%   0 IP NAT Ager
236     1023012  10905662         93  0.49%  0.51%  0.49%   0 PPP Events
  75      869576   7110688        122  0.32%  0.31%  0.32%   0 L2X Data Daemon
228      917612   1535740        597  0.24%  0.22%  0.20%   0 PPTP Mgmt
235      283264  10593926         26  0.16%  0.20%  0.21%   0 PPP manager
238      295476  10522749         28  0.16%  0.17%  0.16%   0 RADIUS
  40     1204636    352782       3414  0.16%  0.14%  0.15%   0 Per-Second Jobs
230      400700    922594        434  0.08%  0.10%  0.08%   0 TCP Driver
221      628588     72179       8708  0.08%  0.12%  0.13%   0 Compute load avg
105       74768     33763       2214  0.08%  0.02%  0.00%   0 PPP IP Route
  36       53652    239501        224  0.08%  0.03%  0.01%   0 Net Background
111      183216    542305        337  0.08%  0.08%  0.08%   0 CEF process
106       24352     76443        318  0.08%  0.00%  0.00%   0 PPP IPCP
  25       45684     86835        526  0.08%  0.01%  0.00%   0 HC Counter Timer
не знаю даже что думать... где то вычитал что это внутренние прерывания cisco(стал думать что навреное слишком много пакетов через нее проходит...игрался ip virtual-reassembly,mtu, route-cache,с  вот конфиг интерфейсов
interface Loopback0
ip address 192.168.x.x 255.255.255.0
no ip redirects
no ip unreachables
ip route-cache flow
!
interface GigabitEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$ETH-LAN$$FW_OUTSIDE$
ip address 172.x.x.x 255.255.0.0 lan int
ip access-group 100 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
ip nat inside
ip virtual-reassembly
ip route-cache policy
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/1
description $ES_WAN$$ETH-WAN$$FW_INSIDE$
ip address X.X.X.X 255.255.255.X внешний интерфейс
ip access-group 101 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly
ip route-cache flow
ip policy route-map MAP
duplex auto
speed auto
no mop enabled
service-policy output SDM-Pol-GigabitEthernet0/1
!
interface Virtual-Template1
description $FW_OUTSIDE$
ip address negotiated
ip verify unicast reverse-path
no ip redirects
no ip unreachables
ip mtu 1460
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly max-fragments 16 max-reassemblies 64
ip route-cache policy
ip route-cache flow
ip tcp header-compression
ip tcp adjust-mss 1420
ip mroute-cache
no logging event link-status
autodetect encapsulation ppp
no peer default ip address
ppp authentication ms-chap-v2 chap
Может кто нибудь сталкивался... заранее благодарен
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Очень страная загрузка cisco 2851"  
Сообщение от 123 (??) on 03-Июн-07, 13:00 
>имею...:)cisco 2851 pptp-сервер(резанием скорости rate-limit) с натом и сбором статистики(Netflow хотя его
>отключал).Сидит около 200-300 человек(ip cef включён) и загрузку которая иногда подскакивает
>до 100% причём вывод sh pr cpu показывает 100%, но по
>запущенным процессам загрузка от силы 15%
>вот вывод sh proc cpu sorted
>CPU utilization for five seconds: 74%/63%; one minute: 65%; five minutes: 63%
>
> PID Runtime(ms)   Invoked      uSecs
>  5Sec   1Min   5Min TTY Process
>
> 239     4931940     54449
>     90580  3.01%  2.31%  
>1.60%   0 VTEMPLATE Backgr
>  84    35152120  26442232    
>   1329  3.44%  3.45%  3.27%  
> 0 IP Input
> 229     8727344  11542255    
>    756  1.22%  0.86%  0.74%
>  0 PPTP Data
> 232     4212712   1409840  
>    2988  0.57%  1.35%  1.07%
>  0 IP NAT Ager
> 236     1023012  10905662    
>     93  0.49%  0.51%  
>0.49%   0 PPP Events
>  75      869576   7110688
>       122  0.32%  
>0.31%  0.32%   0 L2X Data Daemon
> 228      917612   1535740  
>      597  0.24%  0.22%
> 0.20%   0 PPTP Mgmt
> 235      283264  10593926  
>      26  0.16%  0.20%
> 0.21%   0 PPP manager
> 238      295476  10522749  
>      28  0.16%  0.17%
> 0.16%   0 RADIUS
>  40     1204636    352782
>      3414  0.16%  0.14%
> 0.15%   0 Per-Second Jobs
> 230      400700    922594
>       434  0.08%  
>0.10%  0.08%   0 TCP Driver
> 221      628588    
>72179       8708  0.08%  
>0.12%  0.13%   0 Compute load avg
> 105       74768    
> 33763       2214  0.08%
> 0.02%  0.00%   0 PPP IP Route
>  36       53652  
> 239501        224  
>0.08%  0.03%  0.01%   0 Net Background
> 111      183216    542305
>       337  0.08%  
>0.08%  0.08%   0 CEF process
> 106       24352    
> 76443        318  
>0.08%  0.00%  0.00%   0 PPP IPCP
>  25       45684  
>  86835        526
> 0.08%  0.01%  0.00%   0 HC Counter
>Timer
>не знаю даже что думать... где то вычитал что это внутренние прерывания
>cisco(стал думать что навреное слишком много пакетов через нее проходит...игрался ip
>virtual-reassembly,mtu, route-cache,с  вот конфиг интерфейсов
>interface Loopback0
> ip address 192.168.x.x 255.255.255.0
> no ip redirects
> no ip unreachables
> ip route-cache flow
>!
>interface GigabitEthernet0/0
> description $ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$ETH-LAN$$FW_OUTSIDE$
> ip address 172.x.x.x 255.255.0.0 lan int
> ip access-group 100 in
> ip verify unicast reverse-path
> no ip redirects
> no ip unreachables
> ip nat inside
> ip virtual-reassembly
> ip route-cache policy
> ip route-cache flow
> duplex auto
> speed auto
> no mop enabled
>!
>interface GigabitEthernet0/1
> description $ES_WAN$$ETH-WAN$$FW_INSIDE$
> ip address X.X.X.X 255.255.255.X внешний интерфейс
> ip access-group 101 in
> ip verify unicast reverse-path
> no ip redirects
> no ip unreachables
> ip nbar protocol-discovery
> ip flow ingress
> ip flow egress
> ip nat outside
> ip virtual-reassembly
> ip route-cache flow
> ip policy route-map MAP
> duplex auto
> speed auto
> no mop enabled
> service-policy output SDM-Pol-GigabitEthernet0/1
>!
>interface Virtual-Template1
> description $FW_OUTSIDE$
> ip address negotiated
> ip verify unicast reverse-path
> no ip redirects
> no ip unreachables
> ip mtu 1460
> ip flow ingress
> ip flow egress
> ip nat inside
> ip virtual-reassembly max-fragments 16 max-reassemblies 64
> ip route-cache policy
> ip route-cache flow
> ip tcp header-compression
> ip tcp adjust-mss 1420
> ip mroute-cache
> no logging event link-status
> autodetect encapsulation ppp
> no peer default ip address
> ppp authentication ms-chap-v2 chap
>Может кто нибудь сталкивался... заранее благодарен

включи flow top-talkers

и смотри sh ip flow top-talkers
валят вири которые создают кратковременный трафик в 20-30к пакетов.
нат убрать на другую железку(комп;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Очень страная загрузка cisco 2851"  
Сообщение от JackK email(??) on 03-Июн-07, 14:07 
>включи flow top-talkers
>
>и смотри sh ip flow top-talkers
>валят вири которые создают кратковременный трафик в 20-30к пакетов.
>нат убрать на другую железку(комп;)
насколько я понял включать надо в configure
ip flow-top-talkers
а дальше что?
cache-timeout  Configure cache timeout
default        Set a command to its defaults
exit           Exit from top talkers configuratio
match          Configure match criteria
no             Negate a command or set its defaul
sort-by        Configure top talker sort criteria
top            Configure number of top talkers
и непонятно Тогда пики ясно или вирусы или особо одаренные люди с большим количеством сессий.. а постоянная нагрузка в 70% при 200 человек. (ведь по обещанием cisco железка может потянуть 1500 vpn-шифрованных ссесий(доп. модуль шифрования стоит,но не используеться за ненадобностью), хотя я согласен что можно поделить 1500 на 2 тоесть около ~700 не шифрованных должны вообще летать), а так если прикинуть то при 500(не шифрованных) будет попка)и без вирей...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Очень страная загрузка cisco 2851"  
Сообщение от КОТ on 03-Июн-07, 14:22 
>>включи flow top-talkers
>>
>>и смотри sh ip flow top-talkers
>>валят вири которые создают кратковременный трафик в 20-30к пакетов.
>>нат убрать на другую железку(комп;)
>насколько я понял включать надо в configure
>ip flow-top-talkers
>а дальше что?
>cache-timeout  Configure cache timeout
>default        Set a command to
>its defaults
>exit           Exit
>from top talkers configuratio
>match          Configure match
>criteria
>no            
> Negate a command or set its defaul
>sort-by        Configure top talker sort
>criteria
>top            
>Configure number of top talkers
>и непонятно Тогда пики ясно или вирусы или особо одаренные люди с
>большим количеством сессий.. а постоянная нагрузка в 70% при 200 человек.
>(ведь по обещанием cisco железка может потянуть 1500 vpn-шифрованных ссесий(доп. модуль
>шифрования стоит,но не используеться за ненадобностью), хотя я согласен что можно
>поделить 1500 на 2 тоесть около ~700 не шифрованных должны вообще
>летать), а так если прикинуть то при 500(не шифрованных) будет попка)и
>без вирей...


там стоит IPSec ускоритель, а не аппаратный ppp терминатор.
Помните, что 2800 это в первую очередь рутер, который пришел на смену 2600/3600 серии.
Смотрите вниматльено поток и пппс, а так же sh ip cache flow или лучше всего анализируйте нетфлоу на том же компе, куда Вам посоветовали НАТ поставить.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Очень страная загрузка cisco 2851"  
Сообщение от Slavon (??) on 03-Июн-07, 14:37 
>вот вывод sh proc cpu sorted
>CPU utilization for five seconds: 74%/63%; one minute: 65%; five minutes: 63%

74%/63%; = значит общая загрузка 74 процента ил них 63 на прерывания... т.е. 11% жрут процессы - остальное прерывание... трафик она гоняет... посмотри сколько пакетов проходит сквозь неё и сравни с таблицей производительности...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Очень страная загрузка cisco 2851"  
Сообщение от JackK email(??) on 03-Июн-07, 15:35 
>>вот вывод sh proc cpu sorted
>>CPU utilization for five seconds: 74%/63%; one minute: 65%; five minutes: 63%
>
>74%/63%; = значит общая загрузка 74 процента ил них 63 на прерывания...
>т.е. 11% жрут процессы - остальное прерывание... трафик она гоняет... посмотри
>сколько пакетов проходит сквозь неё и сравни с таблицей производительности...
конечно глупый вопрос... смотереть show interfaces gigabitEthernet 0/0 к примеру?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Очень страная загрузка cisco 2851"  
Сообщение от JackK email(??) on 03-Июн-07, 19:11 
>>>вот вывод sh proc cpu sorted
>>>CPU utilization for five seconds: 74%/63%; one minute: 65%; five minutes: 63%
>>
>>74%/63%; = значит общая загрузка 74 процента ил них 63 на прерывания...
>>т.е. 11% жрут процессы - остальное прерывание... трафик она гоняет... посмотри
>>сколько пакетов проходит сквозь неё и сравни с таблицей производительности...
>конечно глупый вопрос... смотереть show interfaces gigabitEthernet 0/0 к примеру?
вот вывод show ip cache flow
IP packet size distribution (4415M total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .005 .367 .079 .022 .019 .011 .005 .003 .003 .003 .004 .003 .002 .003 .002

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .003 .002 .023 .024 .407 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 278544 bytes
  4089 active, 7 inactive, 200036698 added
  887836680 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 103560 bytes
  4089 active, 1031 inactive, 199997407 added, 199997407 added to flow
  0 alloc failures, 2527 force free
  5 chunks, 531 chunks added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet       15390      0.0         7   445      0.2       6.0      10.6
TCP-FTP          40102      0.0        11   430      0.7       4.9       8.3
TCP-FTPD          3248      0.0       397   787      2.1      18.3       2.8
TCP-WWW       53693794     91.0        18   696   1684.8       1.5       4.5
TCP-SMTP      27031209     45.8         6   203    297.5       1.8       3.7
TCP-X             9887      0.0        48   741      0.8       9.7       5.2
TCP-BGP              2      0.0         3    40      0.0       0.9      10.6
TCP-NNTP          1728      0.0         6   448      0.0       3.2       5.8
TCP-Frag            13      0.0         1    40      0.0       0.0       3.7
TCP-other     53259274     90.2        44   710   4052.3       8.1       6.0
UDP-DNS        1627478      2.7         3   357      9.4       0.6      10.3
UDP-NTP          89341      0.1         1    76      0.1       0.0      11.7
UDP-TFTP           536      0.0         1   157      0.0       0.2       3.9
UDP-Frag             4      0.0         4    21      0.0       6.8       7.0
UDP-other     61819089    104.7         4   228    490.9       0.5       6.0
ICMP           1061217      1.7        18    51     33.1       3.5       7.3
GRE            1369375      2.3       392   621    911.0      19.8       3.5
IP-other            69      0.0         1   187      0.0       0.0      10.8
Total:       200021756    339.0        22   641   7483.4       3.1       5.3
вот sh int giga 0/0
GigabitEthernet0/0 is up, line protocol is up
  Hardware is MV96340 Ethernet, address is XXXXXX
Description: $ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$ETH-LAN$$FW_OUTSIDE$
  Internet address is X.X.X.X/16
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 5/255, rxload 5/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is T
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/22517/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 19634000 bits/sec, 4043 packets/sec
  5 minute output rate 22611000 bits/sec, 3883 packets/sec
     1331969605 packets input, 419489636 bytes, 1347 no buffer
     Received 76590 broadcasts, 0 runts, 0 giants, 14161 throttles
     12181 input errors, 0 CRC, 0 frame, 711 overrun, 11470 ignored
     0 watchdog, 0 multicast, 98 pause input
     0 input packets with dribble condition detected
     1157335241 packets output, 4072563786 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 19718 pause output
     0 output buffer failures, 0 output buffers swapped out
вот sh int giga 0/1
GigabitEthernet0/1 is up, line protocol is up
  Hardware is MV96340 Ethernet, address is 0016.9d03.fe71 (bia 0016.9d03.fe71)
  Description: $ES_WAN$$ETH-WAN$$FW_INSIDE$
  Internet address is 83.102.220.179/28
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 42/255, rxload 52/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is T
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/51102/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 2/3 (allocated/max allocated)
     Available Bandwidth 34000 kilobits/sec
  5 minute input rate 20749000 bits/sec, 3723 packets/sec
  5 minute output rate 16587000 bits/sec, 3651 packets/sec
     1129895314 packets input, 293078344 bytes, 52006 no buffer
     Received 62382 broadcasts, 0 runts, 0 giants, 41949 throttles
     259 input errors, 1 CRC, 0 frame, 0 overrun, 258 ignored
     0 watchdog, 0 multicast, 1007108 pause input
     0 input packets with dribble condition detected
     1147037097 packets output, 2219190610 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 382 pause output
     0 output buffer failures, 0 output buffers swapped out
При загрузке sh pro cpu sorted
CPU utilization for five seconds: 74%/66%; one minute: 76%; five minutes: 75%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  84    45211176  41542230       1088  4.09%  3.05%  3.97%   0 IP Input
232     6162564   2148168       2868  1.06%  1.20%  1.51%   0 IP NAT Ager
229    11516180  17067191        674  0.98%  1.02%  0.94%   0 PPTP Data
   5     2807652    147268      19064  0.65%  0.36%  0.26%   0 Check heaps
  75     1359000  13037593        104  0.57%  0.51%  0.49%   0 L2X Data Daemon
236     1259696  18522079         68  0.49%  0.48%  0.49%   0 PPP Events
222      336344     10284      32705  0.32%  0.04%  0.00%   0 Per-minute Jobs
235      352448  18135862         19  0.16%  0.21%  0.24%   0 PPP manager
228     1347112   2553101        527  0.16%  0.19%  0.18%   0 PPTP Mgmt
221     1029612    120651       8533  0.16%  0.12%  0.14%   0 Compute load avg
  40     1497784    595114       2516  0.16%  0.13%  0.14%   0 Per-Second Jobs
   2      176728    118046       1497  0.08%  0.03%  0.02%   0 Load Meter
238      368120  18044911         20  0.08%  0.13%  0.14%   0 RADIUS
  54       31292     20527       1524  0.08%  0.00%  0.00%   0 CEF Scanner
111      238468    926544        257  0.08%  0.09%  0.08%   0 CEF process
  14           0         1          0  0.00%  0.00%  0.00%   0 OIR Handler
  15           0         1          0  0.00%  0.00%  0.00%   0 Crash writer
  16        5168     19674        262  0.00%  0.00%  0.00%   0 Environmental mo
и 218 человек подключенных через pptp
это нормально?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Очень страная загрузка cisco 2851"  
Сообщение от demi email(??) on 27-Янв-09, 12:50 
>[оверквотинг удален]
>  15          
> 0         1
>         0  
>0.00%  0.00%  0.00%   0 Crash writer
>  16        5168  
>   19674        
>262  0.00%  0.00%  0.00%   0 Environmental
>mo
>и 218 человек подключенных через pptp
>это нормально?

У нас 2821 и схожая проблема... Удалось ли Вам ее решить?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Очень страная загрузка cisco 2851"  
Сообщение от fantom email(ok) on 27-Янв-09, 14:09 
>[оверквотинг удален]
>>         0  
>>0.00%  0.00%  0.00%   0 Crash writer
>>  16        5168  
>>   19674        
>>262  0.00%  0.00%  0.00%   0 Environmental
>>mo
>>и 218 человек подключенных через pptp
>>это нормально?
>
>У нас 2821 и схожая проблема... Удалось ли Вам ее решить?

2811 до 340 PPPoE+PPtP (280+60) сессий при трафике 40-45Мбит инета.
Нагрузка на проц до 80-85%.
Очень помогло отключение snmp сервера на кошке, до отключения при 35Мбит и 280 сессиях кошка практически "дохла".
Отключение snmp снизило среднюю нагрузку на 9-12%, пиковая не выше 90%.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру